]> git.pld-linux.org Git - packages/rstudio.git/commitdiff
fix build with gcc 11
authorJan Palus <atler@pld-linux.org>
Wed, 11 Aug 2021 08:28:51 +0000 (10:28 +0200)
committerJan Palus <atler@pld-linux.org>
Wed, 11 Aug 2021 08:28:51 +0000 (10:28 +0200)
gcc11.patch [new file with mode: 0644]
rstudio.spec

diff --git a/gcc11.patch b/gcc11.patch
new file mode 100644 (file)
index 0000000..4e60701
--- /dev/null
@@ -0,0 +1,21 @@
+--- rstudio-1.1.143/src/cpp/core/RegexUtils.cpp.orig   2017-04-12 00:42:14.000000000 +0200
++++ rstudio-1.1.143/src/cpp/core/RegexUtils.cpp        2021-08-11 09:33:16.605646831 +0200
+@@ -15,6 +15,7 @@
+ #include <core/RegexUtils.hpp>
++#include <sstream>
+ #include <vector>
+ #include <boost/regex.hpp>
+--- rstudio-1.1.143/CMakeCompiler.txt.orig     2017-04-12 00:42:14.000000000 +0200
++++ rstudio-1.1.143/CMakeCompiler.txt  2021-08-11 09:45:50.402450033 +0200
+@@ -26,6 +26,8 @@
+ endif()
++set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++0x")
++
+ # use Rtools on Windows (mainly for Qt Creator)
+ if(WIN32 AND NOT DEFINED RSTUDIO_PACKAGE_BUILD)
+   set(RTOOLS_PATH "${CMAKE_CURRENT_SOURCE_DIR}/../../dependencies/windows/Rtools33")
index 1a0e07878182becb61a017ddb9ca1426342a035e..afaa6b074fde94d47287e4437c1e3ce0838dd229 100644 (file)
@@ -28,6 +28,7 @@ Patch1:               %{name}-openssl.patch
 Patch2:                %{name}-boost.patch
 Patch3:                websocketpp-boost.patch
 Patch4:                boost1.75.patch
+Patch5:                gcc11.patch
 URL:           http://rstudio.org/
 BuildRequires: Qt5Core-devel >= 5.4.0
 BuildRequires: Qt5DBus-devel >= 5.4.0
@@ -86,6 +87,7 @@ cd src/cpp/ext
 %patch3 -p1
 cd ../../..
 %patch4 -p1
+%patch5 -p1
 
 mkdir -p dependencies/common/dictionaries
 unzip -qq %{SOURCE1} -d dependencies/common/dictionaries
This page took 0.117541 seconds and 4 git commands to generate.