]> git.pld-linux.org Git - packages/rstudio.git/commitdiff
- fix building with boost 1.73
authorJan Rękorajski <baggins@pld-linux.org>
Wed, 12 Aug 2020 07:37:12 +0000 (09:37 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Wed, 12 Aug 2020 07:37:12 +0000 (09:37 +0200)
- rel 4

rstudio-boost.patch
rstudio.spec

index 9e086275ee1e0491b4d61b3188241525fb65ef87..60a220332f7fa4b5447ea28c3789058a5bf048e3 100644 (file)
  
           // get client identity
           core::system::user::UserIdentity userIdentity;
+--- rstudio-1.1.143/src/cpp/core/FilePath.cpp~ 2020-08-12 00:57:08.000000000 +0200
++++ rstudio-1.1.143/src/cpp/core/FilePath.cpp  2020-08-12 00:57:57.852543328 +0200
+@@ -1020,7 +1020,7 @@
+       {
+          // NOTE: The path gets round-tripped through toString/fromString, would
+          //   be nice to have a direct constructor
+-         if (!iterationFunction(itr.level(),
++         if (!iterationFunction(itr.depth(),
+                                 FilePath(BOOST_FS_PATH2STR(itr->path()))))
+          {
+             // end the iteration if requested
+From ea8aa234b48331d34b8002fab58b4b393864e79b Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?I=C3=B1aki=20=C3=9Acar?= <iucar@fedoraproject.org>
+Date: Sat, 30 May 2020 15:33:38 +0200
+Subject: [PATCH] boost-173-global-placeholders
+
+---
+ src/cpp/CMakeLists.txt                           | 1 +
+ src/cpp/core/system/PosixChildProcessTracker.cpp | 1 +
+ src/cpp/core/system/PosixOutputCapture.cpp       | 2 ++
+ src/cpp/core/system/PosixSystem.cpp              | 1 +
+ 4 files changed, 5 insertions(+)
+
+diff --git a/src/cpp/CMakeLists.txt b/src/cpp/CMakeLists.txt
+index af79150..d049524 100644
+--- a/src/cpp/CMakeLists.txt
++++ b/src/cpp/CMakeLists.txt
+@@ -28,6 +28,7 @@ include("${CMAKE_CURRENT_SOURCE_DIR}/../../CMakeGlobals.txt")
+ # global directives
+ add_definitions(-DBOOST_ENABLE_ASSERT_HANDLER)
++add_definitions(-DBOOST_BIND_GLOBAL_PLACEHOLDERS)
+ # explicitly do not use new c++ 11 features for websocketpp
+ # they currently do not work with our source
+diff --git a/src/cpp/core/system/PosixChildProcessTracker.cpp b/src/cpp/core/system/PosixChildProcessTracker.cpp
+index 2ee1a81..976da4f 100644
+--- a/src/cpp/core/system/PosixChildProcessTracker.cpp
++++ b/src/cpp/core/system/PosixChildProcessTracker.cpp
+@@ -18,6 +18,7 @@
+ #include <sys/wait.h>
+ #include <boost/format.hpp>
++#include <boost/bind.hpp>
+ namespace rstudio {
+ namespace core {
+diff --git a/src/cpp/core/system/PosixOutputCapture.cpp b/src/cpp/core/system/PosixOutputCapture.cpp
+index e531e00..01dedd3 100644
+--- a/src/cpp/core/system/PosixOutputCapture.cpp
++++ b/src/cpp/core/system/PosixOutputCapture.cpp
+@@ -28,6 +28,8 @@
+ #include <core/system/System.hpp>
++#include <boost/bind.hpp>
++
+ namespace rstudio {
+ namespace core {
+ namespace system {
+diff --git a/src/cpp/core/system/PosixSystem.cpp b/src/cpp/core/system/PosixSystem.cpp
+index c25cb32..8dae263 100644
+--- a/src/cpp/core/system/PosixSystem.cpp
++++ b/src/cpp/core/system/PosixSystem.cpp
+@@ -23,6 +23,7 @@
+ #include <boost/foreach.hpp>
+ #include <boost/algorithm/string.hpp>
++#include <boost/bind.hpp>
+ #include <signal.h>
+ #include <fcntl.h>
+-- 
+2.25.2
+
index 708e40139c12838477af5c7f8bb7ba1d78b5b510..e8647df08846899de39382551d378bb6dfee9ee0 100644 (file)
@@ -2,7 +2,7 @@ Summary:        IDE for R
 Summary(pl.UTF-8):     IDE dla R
 Name:          rstudio
 Version:       1.1.143
-Release:       3
+Release:       4
 License:       AGPL v3
 Group:         Development/Tools
 Source0:       https://github.com/rstudio/rstudio/archive/v%{version}/%{name}-%{version}.tar.gz
@@ -15,8 +15,6 @@ Source3:      https://s3.amazonaws.com/rstudio-buildtools/gin-1.5.zip
 # Source3-md5: 2409168cc18bf5f341e107e6887fe359
 Source4:       https://s3.amazonaws.com/rstudio-buildtools/mathjax-26.zip
 # Source4-md5: 94fcab0aead8f730cd21e26dcb5a330d
-Source5:       https://s3.amazonaws.com/rstudio-buildtools/pandoc-1.12.4.2.zip
-# Source5-md5: d0f7e3d23b42cb9d26d2783d659040cf
 Source6:       https://s3.amazonaws.com/rstudio-buildtools/libclang-3.5.zip
 # Source6-md5: cf1a43d2d6203a765ef16d7b12382c8a
 Source7:       https://s3.amazonaws.com/rstudio-buildtools/libclang-builtin-headers.zip
@@ -124,6 +122,15 @@ mkdir -p dependencies/common/libclang/3.5/linux/x86_64
 ln -s %{_libdir}/libclang.so dependencies/common/libclang/3.5/linux/x86_64/libclang.so
 %endif
 
+%{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+bash(\s|$),#!/bin/bash\1,' \
+      src/cpp/desktop/rstudio-backtrace.sh.in \
+      src/cpp/session/postback/askpass-passthrough \
+      src/cpp/session/postback/rpostback-askpass \
+      src/cpp/session/postback/rpostback-editfile \
+      src/cpp/session/postback/rpostback-gitssh \
+      src/cpp/session/postback/rpostback-pdfviewer \
+      src/cpp/session/r-ldpath.in
+
 %build
 install -d build
 cd build
This page took 0.118156 seconds and 4 git commands to generate.