]> git.pld-linux.org Git - packages/rpm.git/log
packages/rpm.git
10 years ago- added helperEVR-noassert patch (replace assert by error message;
Jakub Bogusz [Tue, 14 Feb 2012 18:19:57 +0000 (18:19 +0000)]
- added helperEVR-noassert patch (replace assert by error message;
  or maybe the build should fail in such case? but not in such pailfully way)

Changed files:
    rpm-helperEVR-noassert.patch -> 1.1

10 years ago- added __spec_install_post_check_tmpfiles
Jan Rękorajski [Mon, 30 Jan 2012 16:53:36 +0000 (16:53 +0000)]
- added __spec_install_post_check_tmpfiles

Changed files:
    rpm.platform -> 1.10

10 years ago- better description
Jan Rękorajski [Fri, 27 Jan 2012 11:02:18 +0000 (11:02 +0000)]
- better description

Changed files:
    rpm.sysconfig -> 1.8

10 years ago- improved comments
Tomasz Pala [Fri, 27 Jan 2012 10:57:10 +0000 (10:57 +0000)]
- improved comments

Changed files:
    rpm.sysconfig -> 1.7

10 years ago- rel 59
Jan Rękorajski [Thu, 26 Jan 2012 22:54:00 +0000 (22:54 +0000)]
- rel 59
- "enable" is better than "activate" (more consistent with systemd/sysv tools)

Changed files:
    rpm.sysconfig -> 1.6

10 years ago- SysV and systemd service activation settings
Jan Rękorajski [Thu, 26 Jan 2012 18:55:04 +0000 (18:55 +0000)]
- SysV and systemd service activation settings

Changed files:
    rpm.sysconfig -> 1.5

10 years ago- fixed problem with automake.
cieciwa [Thu, 12 Jan 2012 09:15:32 +0000 (09:15 +0000)]
- fixed problem with automake.

Changed files:
    rpm.spec -> 1.935

10 years ago- for fix automake 1.11.2 data variables more strict.
cieciwa [Thu, 12 Jan 2012 09:15:07 +0000 (09:15 +0000)]
- for fix automake 1.11.2 data variables more strict.

Changed files:
    fix-automake-1.11.2.patch -> 1.1

10 years ago- rpm4.5 adopting bug could be useful
Elan Ruusamäe [Tue, 10 Jan 2012 11:18:25 +0000 (11:18 +0000)]
- rpm4.5 adopting bug could be useful

Changed files:
    rpm.spec -> 1.934

10 years ago- package alternative php requires collector (it's a bit buggy so not eanbled default)
Elan Ruusamäe [Mon, 28 Nov 2011 11:34:50 +0000 (11:34 +0000)]
- package alternative php requires collector (it's a bit buggy so not eanbled default)

Changed files:
    macros.php -> 1.3

10 years ago- export PHP_MIN_VERSION via %php_min_version
Elan Ruusamäe [Mon, 28 Nov 2011 11:04:43 +0000 (11:04 +0000)]
- export PHP_MIN_VERSION via %php_min_version

Changed files:
    macros.php -> 1.2

10 years ago- some todo
Elan Ruusamäe [Mon, 28 Nov 2011 11:04:12 +0000 (11:04 +0000)]
- some todo

Changed files:
    rpm-php-requires.php -> 1.21

10 years ago- add macros.php as separate source
Elan Ruusamäe [Mon, 28 Nov 2011 11:03:59 +0000 (11:03 +0000)]
- add macros.php as separate source

Changed files:
    macros.php -> 1.1

10 years ago- up to 5.3.11 rpm-5_3_11-0_1
Elan Ruusamäe [Thu, 6 Oct 2011 15:39:10 +0000 (15:39 +0000)]
- up to 5.3.11

Changed files:
    rpm-configure-autoconf.patch -> 1.5
    rpm-old-fileconflicts-behaviour.patch -> 1.5
    rpm-rpmpopt.patch -> 1.28
    rpm.spec -> 1.933

10 years ago- up to 5.3.5 rpm-5_3_5-0_1
Jan Rękorajski [Wed, 24 Aug 2011 09:03:44 +0000 (09:03 +0000)]
- up to 5.3.5

Changed files:
    openmp.patch -> 1.2
    rpm-configure-autoconf.patch -> 1.4
    rpm-macros.patch -> 1.50
    rpm-rpmpopt.patch -> 1.27
    rpm-scripts-closefds.patch -> 1.4
    rpm.spec -> 1.932

10 years ago- for .la symlinks generate libtool(symlink), not libtool(target) Provides
Jakub Bogusz [Fri, 29 Jul 2011 17:36:37 +0000 (17:36 +0000)]
- for .la symlinks generate libtool(symlink), not libtool(target) Provides

Changed files:
    rpm-libtool-deps.patch -> 1.10

10 years ago- include URL in sourcefile
Elan Ruusamäe [Tue, 8 Feb 2011 07:39:13 +0000 (07:39 +0000)]
- include URL in sourcefile

Changed files:
    rpm-php-requires.php -> 1.20

10 years ago- parse eclipse.xml files
Elan Ruusamäe [Sat, 5 Feb 2011 11:16:59 +0000 (11:16 +0000)]
- parse eclipse.xml files

Changed files:
    rpm-java-requires -> 1.11

10 years ago- rel 48; force glob() to use lstat now; we can avoid using internal copy now + we...
Arkadiusz Miśkiewicz [Sun, 19 Dec 2010 12:27:35 +0000 (12:27 +0000)]
- rel 48; force glob() to use lstat now; we can avoid using internal copy now + we are now sure that dangling symlinks will be properly globbed

Changed files:
    rpm-glob.patch -> 1.9

10 years ago- >= for match equivalent
Elan Ruusamäe [Tue, 16 Nov 2010 19:32:28 +0000 (19:32 +0000)]
- >= for match equivalent

Changed files:
    eclipse-feature.xslt -> 1.7

10 years ago- match also features in requires
Elan Ruusamäe [Tue, 16 Nov 2010 16:00:40 +0000 (16:00 +0000)]
- match also features in requires

Changed files:
    eclipse-feature.xslt -> 1.6

10 years ago- more deps processed
Elan Ruusamäe [Tue, 16 Nov 2010 15:55:26 +0000 (15:55 +0000)]
- more deps processed

Changed files:
    eclipse-feature.xslt -> 1.5

10 years ago- cosmetics
Elan Ruusamäe [Fri, 12 Nov 2010 17:49:10 +0000 (17:49 +0000)]
- cosmetics

Changed files:
    rpm-mimetypedeps -> 1.3

10 years ago- do not output tag, wasn't needed before
Elan Ruusamäe [Fri, 12 Nov 2010 15:40:47 +0000 (15:40 +0000)]
- do not output tag, wasn't needed before

Changed files:
    rpm-java-requires -> 1.10

10 years ago- workflow to process also provides
Elan Ruusamäe [Fri, 12 Nov 2010 12:10:00 +0000 (12:10 +0000)]
- workflow to process also provides

Changed files:
    rpm-java-requires -> 1.9

10 years ago- avoid processing wrong xml files (xml must start with <feature>)
Elan Ruusamäe [Fri, 12 Nov 2010 12:02:44 +0000 (12:02 +0000)]
- avoid processing wrong xml files (xml must start with <feature>)

Changed files:
    eclipse-feature.xslt -> 1.4

10 years ago- indenting
Elan Ruusamäe [Fri, 12 Nov 2010 11:58:33 +0000 (11:58 +0000)]
- indenting

Changed files:
    eclipse-feature.xslt -> 1.3

10 years ago- take $mode (provides | requires)
Elan Ruusamäe [Fri, 12 Nov 2010 11:58:08 +0000 (11:58 +0000)]
- take $mode (provides | requires)

Changed files:
    eclipse-feature.xslt -> 1.2

10 years ago- pass -regextype for find
Elan Ruusamäe [Fri, 12 Nov 2010 11:44:32 +0000 (11:44 +0000)]
- pass -regextype for find

Changed files:
    rpm-java-requires -> 1.8

10 years ago- simplify extension matching
Elan Ruusamäe [Fri, 12 Nov 2010 11:23:18 +0000 (11:23 +0000)]
- simplify extension matching

Changed files:
    rpm-java-requires -> 1.7

10 years ago- rewrite code to handle recursion better
Elan Ruusamäe [Fri, 12 Nov 2010 11:21:38 +0000 (11:21 +0000)]
- rewrite code to handle recursion better

Changed files:
    rpm-java-requires -> 1.6

10 years ago- print out rpm requires/provides from eclipse feature.xml
Elan Ruusamäe [Fri, 12 Nov 2010 09:22:27 +0000 (09:22 +0000)]
- print out rpm requires/provides from eclipse feature.xml

Changed files:
    eclipse-feature.xslt -> 1.1

10 years ago- propagate set -x to functions for verbose debug
Elan Ruusamäe [Thu, 11 Nov 2010 20:13:25 +0000 (20:13 +0000)]
- propagate set -x to functions for verbose debug
- for brief debug set FIND_JAVAREQ_DEBUG=true when building
- recurse into .jars inside .jar to find deps (eclipse plugins do that for example)

Changed files:
    rpm-java-requires -> 1.5

10 years ago- BR: tcl auto/th/rpm-5_3_1-0_1
sparky [Thu, 3 Jun 2010 00:53:05 +0000 (00:53 +0000)]
- BR: tcl

Changed files:
    rpm.spec -> 1.931

10 years agoUpdated to 5.3.1
Artur Frysiak [Tue, 1 Jun 2010 20:34:10 +0000 (20:34 +0000)]
Updated to 5.3.1

Changed files:
    rpm-compress-doc.patch -> 1.9
    rpm-configure-autoconf.patch -> 1.3
    rpm-debuginfo.patch -> 1.21
    rpm-macros-th.patch -> 1.8
    rpm-macros.patch -> 1.49
    rpm-mono.patch -> 1.8
    rpm-perl-macros.patch -> 1.34
    rpm-php-macros.patch -> 1.2

10 years ago- 5.3.1
Artur Frysiak [Tue, 1 Jun 2010 20:33:29 +0000 (20:33 +0000)]
- 5.3.1
NFY - builds but some unpackages files, not tested

Changed files:
    rpm.spec -> 1.930

10 years agoFix linking with libgomp
Artur Frysiak [Tue, 1 Jun 2010 20:31:22 +0000 (20:31 +0000)]
Fix linking with libgomp

Changed files:
    openmp.patch -> 1.1

10 years agoFix building internal BDB
Artur Frysiak [Tue, 1 Jun 2010 20:30:47 +0000 (20:30 +0000)]
Fix building internal BDB

Changed files:
    db.patch -> 1.1

10 years ago- libxml rewrite
Elan Ruusamäe [Thu, 20 May 2010 17:35:56 +0000 (17:35 +0000)]
- libxml rewrite

Changed files:
    rpm-php-requires.php -> 1.19

10 years ago- added lua-exit-chroot-correctly patch
sparky [Sat, 8 May 2010 13:35:12 +0000 (13:35 +0000)]
- added lua-exit-chroot-correctly patch

Changed files:
    rpm.spec -> 1.929

10 years ago- updated for rpm 5.2
sparky [Sat, 8 May 2010 13:34:40 +0000 (13:34 +0000)]
- updated for rpm 5.2

Changed files:
    rpm-lua-exit-chroot-correctly.patch -> 1.2

10 years ago- chroot back to old root, not to old pwd
sparky [Sat, 8 May 2010 12:32:02 +0000 (12:32 +0000)]
- chroot back to old root, not to old pwd

Changed files:
    rpm-lua-exit-chroot-correctly.patch -> 1.1

10 years ago- add librpmconstant to -lib subpackage
Artur Frysiak [Sun, 25 Apr 2010 22:29:59 +0000 (22:29 +0000)]
- add librpmconstant to -lib subpackage

Build and install fine but sig11 on -qa, --rebuilddb and others

Changed files:
    rpm.spec -> 1.928

10 years ago- updated to 5.2.0
Artur Frysiak [Sun, 25 Apr 2010 21:33:51 +0000 (21:33 +0000)]
- updated to 5.2.0

Changed files:
    rpm-configure-autoconf.patch -> 1.2
    rpm-macros.patch -> 1.48
    rpm-old-fileconflicts-behaviour.patch -> 1.4
    rpm.spec -> 1.927

10 years ago- allow setting vendor to PLD
Artur Frysiak [Sun, 25 Apr 2010 21:32:29 +0000 (21:32 +0000)]
- allow setting vendor to PLD

Changed files:
    vendor-pld.patch -> 1.1

10 years ago- rel up
qwiat [Thu, 8 Apr 2010 21:46:25 +0000 (21:46 +0000)]
- rel up

Changed files:
    rpm.spec -> 1.926

10 years ago- added patch: http://rpm5.org/community/rpm-devel/4031.html
qwiat [Thu, 8 Apr 2010 21:45:00 +0000 (21:45 +0000)]
- added patch: rpm5.org/community/rpm-devel/4031.html

Changed files:
    rpm-configure-autoconf.patch -> 1.1
    rpm.spec -> 1.925

10 years ago- more exts need to be lowercased
Elan Ruusamäe [Tue, 23 Mar 2010 11:48:46 +0000 (11:48 +0000)]
- more exts need to be lowercased

Changed files:
    rpm-php-requires.php -> 1.18

10 years ago- remove double slashes, simplify, todos
Elan Ruusamäe [Wed, 10 Mar 2010 23:03:38 +0000 (23:03 +0000)]
- remove double slashes, simplify, todos

Changed files:
    rpm-php-requires.php -> 1.17

10 years ago- avoid deadloops with preg_match
Elan Ruusamäe [Wed, 10 Mar 2010 21:47:17 +0000 (21:47 +0000)]
- avoid deadloops with preg_match

Changed files:
    rpm-php-requires.php -> 1.16

10 years ago- PHP_CompatInfo 1.9.0 says SPL for spl ext
Elan Ruusamäe [Thu, 18 Feb 2010 09:00:23 +0000 (09:00 +0000)]
- PHP_CompatInfo 1.9.0 says SPL for spl ext

Changed files:
    rpm-php-requires.php -> 1.15

10 years ago- dropped unused BR: gettext-autopoint, lzma-devel, rpm-perlprov
sparky [Wed, 3 Feb 2010 02:09:00 +0000 (02:09 +0000)]
- dropped unused BR: gettext-autopoint, lzma-devel, rpm-perlprov

Changed files:
    rpm.spec -> 1.924

10 years ago- add --disable-debuginfo to rpmbuild
Elan Ruusamäe [Tue, 2 Feb 2010 22:40:12 +0000 (22:40 +0000)]
- add --disable-debuginfo to rpmbuild

Changed files:
    rpm-popt-aliases.patch -> 1.4

10 years ago- wrong branch
Elan Ruusamäe [Wed, 27 Jan 2010 17:14:51 +0000 (17:14 +0000)]
- wrong branch

Changed files:
    rpm-rpm5-debugedit.patch -> 1.2

10 years ago- update tools/debugedit.c r2.22 from rpm5 trunk (raw)
Elan Ruusamäe [Wed, 27 Jan 2010 17:12:49 +0000 (17:12 +0000)]
- update tools/debugedit.c r2.22 from rpm5 trunk (raw)

Changed files:
    rpm-rpm5-debugedit.patch -> 1.1

10 years ago- php-<name> only deps for php5
Elan Ruusamäe [Tue, 12 Jan 2010 14:33:50 +0000 (14:33 +0000)]
- php-<name> only deps for php5

Changed files:
    rpm-php-requires.php -> 1.14

10 years ago- allow setting minimum php version
Elan Ruusamäe [Mon, 7 Dec 2009 19:24:20 +0000 (19:24 +0000)]
- allow setting minimum php version

Changed files:
    rpm-php-requires.php -> 1.13

10 years ago- bz2 ext is in php-bzip2 package
Elan Ruusamäe [Mon, 7 Dec 2009 19:15:03 +0000 (19:15 +0000)]
- bz2 ext is in php-bzip2 package

Changed files:
    rpm-php-requires.php -> 1.12

10 years ago- no static mods, all goes in
Elan Ruusamäe [Mon, 7 Dec 2009 19:00:16 +0000 (19:00 +0000)]
- no static mods, all goes in

Changed files:
    rpm-php-requires.php -> 1.11

10 years ago- current ext deps
Elan Ruusamäe [Thu, 3 Dec 2009 08:14:12 +0000 (08:14 +0000)]
- current ext deps

Changed files:
    rpm-php-requires.php -> 1.10

10 years ago- efficent function use
Elan Ruusamäe [Wed, 2 Dec 2009 13:37:53 +0000 (13:37 +0000)]
- efficent function use

Changed files:
    rpm-php-requires.php -> 1.9

10 years ago- missing R and BR for keyutils
Kacper Kornet [Fri, 27 Nov 2009 14:35:21 +0000 (14:35 +0000)]
- missing R and BR for keyutils

Changed files:
    rpm.spec -> 1.923

10 years ago- up to 5.1.9 rel 0.1 some patches to rewrite auto/th/rpm-5_1_9-0_1
Bartłomiej Zimoń [Fri, 23 Oct 2009 20:02:40 +0000 (20:02 +0000)]
- up to 5.1.9 rel 0.1 some patches to rewrite

Changed files:
    rpm-am.patch -> 1.1
    rpm-compress-doc.patch -> 1.8
    rpm.spec -> 1.922

10 years ago- rel 24; add unglobal macro rpm_4_4_9
Arkadiusz Miśkiewicz [Sat, 8 Aug 2009 13:56:40 +0000 (13:56 +0000)]
- rel 24; add unglobal macro

Changed files:
    rpm-unglobal.patch -> 1.1

10 years ago- drop obsolete files
Arkadiusz Miśkiewicz [Sun, 5 Jul 2009 15:49:10 +0000 (15:49 +0000)]
- drop obsolete files

Changed files:
    RPM-GPG-KEY -> 1.2
    adapter.awk -> 1.9
    db-rpm-robustness.patch -> 1.2
    patch.4.5.20.1 -> 1.2
    patch.4.5.20.2 -> 1.2
    patch.4.7.25.1 -> 1.2
    pldnotify.awk -> 1.8
    rpm-bug-146549.patch -> 1.2
    rpm-cpuinfo.patch -> 1.3
    rpm-debugdir.patch -> 1.3
    rpm-debugedit-workaround.patch -> 1.2
    rpm-disable-hkp.patch -> 1.2
    rpm-dontneedutils.patch -> 1.2
    rpm-error-fatal.patch -> 1.3
    rpm-find-lang -> 1.33
    rpm-gid-uucp.patch -> 1.3
    rpm-gstreamer.patch -> 1.3
    rpm-hirmib-ts.patch -> 1.2
    rpm-link-selinux.patch -> 1.2
    rpm-lzma-compress-level.patch -> 1.3
    rpm-lzma-mem.patch -> 1.2
    rpm-lzma-size_t.patch -> 1.2
    rpm-macros-ti.patch -> 1.3
    rpm-macros.gstreamer -> 1.2
    rpm-pl.po.patch -> 1.28
    rpm-po.patch -> 1.19
    rpm-provides-dont-obsolete.patch -> 1.3
    rpm-repackage-wo-lzma.patch -> 1.3
    rpm-rpm2cpio-payload.patch -> 1.2
    rpm-rpm5-patchset-8413.patch -> 1.2
    rpm-rpm5-patchset-8637.patch -> 1.2
    rpm-rpm5-patchset-8784.patch -> 1.2
    rpm-rpmrc-resurrect.patch -> 1.2
    rpm-tar_as_secondary_source.patch -> 1.2
    rpm-v3-support.patch -> 1.2
    rpm.macros -> 1.517

10 years ago- hardcode gid=adm for filesystem; rel 22
Elan Ruusamäe [Fri, 19 Jun 2009 16:37:24 +0000 (16:37 +0000)]
- hardcode gid=adm for filesystem; rel 22

Changed files:
    rpm-gid-uucp.patch -> 1.2

10 years ago- edit listfile earlier
Elan Ruusamäe [Mon, 8 Jun 2009 22:38:17 +0000 (22:38 +0000)]
- edit listfile earlier

Changed files:
    rpm-debugdir.patch -> 1.2

10 years ago- do not package /usr/lib/debug dir in each -debuginfo package
Elan Ruusamäe [Mon, 8 Jun 2009 21:11:44 +0000 (21:11 +0000)]
- do not package /usr/lib/debug dir in each -debuginfo package

Changed files:
    rpm-debugdir.patch -> 1.1

10 years ago- disable hkp://
Elan Ruusamäe [Thu, 4 Jun 2009 22:25:54 +0000 (22:25 +0000)]
- disable hkp://

Changed files:
    rpm-disable-hkp.patch -> 1.1

10 years ago- pldish FHS fixed uid/gids
Elan Ruusamäe [Thu, 4 Jun 2009 21:47:03 +0000 (21:47 +0000)]
- pldish FHS fixed uid/gids

Changed files:
    rpm-gid-uucp.patch -> 1.1

10 years ago- workaround for .jar files with stupid permissions inside
Elan Ruusamäe [Wed, 20 May 2009 00:09:51 +0000 (00:09 +0000)]
- workaround for .jar files with stupid permissions inside

Changed files:
    rpm-java-requires -> 1.4

10 years ago- don't fail when debugedit exits with "canonicalization unexpectedly shrank
Marcin Banasiak [Sun, 12 Apr 2009 13:37:55 +0000 (13:37 +0000)]
- don't fail when debugedit exits with "canonicalization unexpectedly shrank
  by one character" (needed to build openoffice.org.spec)
- added note to rpmbuild manual (from https://bugzilla.redhat.com/show_bug.cgi?id=482903)

Changed files:
    rpm-debugedit-workaround.patch -> 1.1

10 years ago- fix env cleaning auto/ac/rpm-build-macros-1_516-1 auto/th/rpm-build-macros-1_516-1
Arkadiusz Miśkiewicz [Sat, 28 Mar 2009 13:03:36 +0000 (13:03 +0000)]
- fix env cleaning

Changed files:
    rpm.macros -> 1.516

10 years ago- add -q to %addusertogroup (MISSINGOK behaviour) auto/th/rpm-build-macros-1_514-1 auto/th/rpm-build-macros-1_515-1
Elan Ruusamäe [Thu, 26 Mar 2009 11:48:29 +0000 (11:48 +0000)]
- add -q to %addusertogroup (MISSINGOK behaviour)

Changed files:
    rpm.macros -> 1.515

10 years ago- use less global variables (better flow control)
Elan Ruusamäe [Thu, 26 Mar 2009 11:41:23 +0000 (11:41 +0000)]
- use less global variables (better flow control)
- add quiet mode support
- die if uid or gid in target do not exist

Changed files:
    rpm-user_group.sh -> 1.11

10 years ago- %{?macro} epxands already to macro if defined
Elan Ruusamäe [Sat, 21 Mar 2009 22:19:50 +0000 (22:19 +0000)]
- %{?macro} epxands already to macro if defined

Changed files:
    rpm.macros -> 1.514

10 years ago- the spec file does not need to know about preserve_env_base
Elan Ruusamäe [Sat, 21 Mar 2009 22:18:52 +0000 (22:18 +0000)]
- the spec file does not need to know about preserve_env_base

Changed files:
    rpm.macros -> 1.513

10 years ago- preserve SSH_AUTH_SOCK in builds
Elan Ruusamäe [Sat, 21 Mar 2009 22:07:45 +0000 (22:07 +0000)]
- preserve SSH_AUTH_SOCK in builds

Changed files:
    rpm.macros -> 1.512

10 years ago- avoid % expansion in comment auto/th/rpm-build-macros-1_511-1
Jan Rękorajski [Wed, 18 Mar 2009 10:10:17 +0000 (10:10 +0000)]
- avoid % expansion in comment

Changed files:
    rpm.macros -> 1.511

10 years ago- reenable and clean up _smp_mflags, with a comment on how to disable it
Jan Rękorajski [Wed, 18 Mar 2009 10:07:29 +0000 (10:07 +0000)]
- reenable and clean up _smp_mflags, with a comment on how to disable it

Changed files:
    rpm.macros -> 1.510

10 years ago- DO NOT include %{_smp_mflags} for __make/__scons/__waf/__cmake auto/th/rpm-build-macros-1_509-1
Jan Rękorajski [Wed, 18 Mar 2009 09:49:21 +0000 (09:49 +0000)]
- DO NOT include %{_smp_mflags} for __make/__scons/__waf/__cmake
- while it may be good for automated builders, it's just annoying, confusing
  and obfuscating build process

Changed files:
    rpm.macros -> 1.509

10 years ago- added X11/Applications/Accessibility group
Marcin Banasiak [Fri, 13 Mar 2009 22:56:37 +0000 (22:56 +0000)]
- added X11/Applications/Accessibility group

Changed files:
    rpm.groups -> 1.93

10 years ago- oops, print out the deps too (broken 3w, 3d ago, since rpm 4.5-6, 4.4.9-94)
Elan Ruusamäe [Thu, 12 Mar 2009 22:39:22 +0000 (22:39 +0000)]
- oops, print out the deps too (broken 3w, 3d ago, since rpm 4.5-6, 4.4.9-94)

Changed files:
    rpm-java-requires -> 1.3

10 years ago- include %{_smp_mflags} for __make/__scons/__waf/__cmake auto/th/rpm-build-macros-1_508-1 auto/ti/rpm-build-macros-1_508-1
Elan Ruusamäe [Tue, 3 Mar 2009 22:49:29 +0000 (22:49 +0000)]
- include %{_smp_mflags} for __make/__scons/__waf/__cmake

Changed files:
    rpm.macros -> 1.508

10 years agoAdded python3 macros auto/th/rpm-build-macros-1_507-1
Artur Frysiak [Wed, 25 Feb 2009 22:37:11 +0000 (22:37 +0000)]
Added python3 macros

Changed files:
    rpm.macros -> 1.507

10 years ago- more final cosmetics
Tomasz Pala [Sun, 15 Feb 2009 13:14:17 +0000 (13:14 +0000)]
- more final cosmetics

Changed files:
    banner.sh -> 1.11

10 years ago- code cosmetics
Tomasz Pala [Sun, 15 Feb 2009 13:11:42 +0000 (13:11 +0000)]
- code cosmetics

Changed files:
    banner.sh -> 1.10

10 years ago- reflow help screen
Tomasz Pala [Sun, 15 Feb 2009 13:10:02 +0000 (13:10 +0000)]
- reflow help screen

Changed files:
    banner.sh -> 1.9

10 years ago- print help screen when no action specified,
Tomasz Pala [Sun, 15 Feb 2009 13:07:28 +0000 (13:07 +0000)]
- print help screen when no action specified,
- added -d alias to --delete,
- fix en language and typos.

Changed files:
    banner.sh -> 1.8

10 years ago- sh fixes: it's single '=' not '==' test, protect $# vars
Tomasz Pala [Sun, 15 Feb 2009 12:53:10 +0000 (12:53 +0000)]
- sh fixes: it's single '=' not '==' test, protect $# vars

Changed files:
    banner.sh -> 1.7

10 years ago- add _preserve_env_base and a new way of redefining _preserve_env, auto/th/rpm-build-macros-1_506-1
Jan Rękorajski [Thu, 12 Feb 2009 21:57:15 +0000 (21:57 +0000)]
- add _preserve_env_base and a new way of redefining _preserve_env,
  due to rpm problems with %{expand:...} in complicated specs (ex. php.spec)

Changed files:
    rpm.macros -> 1.506

10 years ago- minify
Elan Ruusamäe [Wed, 11 Feb 2009 20:02:47 +0000 (20:02 +0000)]
- minify

Changed files:
    rpm.macros -> 1.505

10 years ago- same rules for requires_releq auto/th/rpm-build-macros-1_504-1
Elan Ruusamäe [Wed, 11 Feb 2009 19:46:19 +0000 (19:46 +0000)]
- same rules for requires_releq

Changed files:
    rpm.macros -> 1.504

10 years ago- requires_eq, requires_eq_to now convert Requires to BuildRequires, making spec...
Elan Ruusamäe [Wed, 11 Feb 2009 19:39:45 +0000 (19:39 +0000)]
- requires_eq, requires_eq_to now convert Requires to BuildRequires, making spec syntax valid if packages are not present
- side effect is that requires_eq now accepts only one paramter, contrary to previous where it accepted long list.

The test results of the new macros:
$ rpm -q xulrunner zlib
package xulrunner is not installed
zlib-1.2.3-7.i686

$ rpm -E '%requires_eq'
ERROR
$ rpm -E '%requires_eq zlib'
Requires: zlib = 0:1.2.3
$ rpm -E '%requires_eq xulrunner'
BuildRequires: xulrunner
$ rpm -E '%requires_eq xulrunner zlib'
ERROR
$ rpm -E '%requires_eq_to'
ERROR
$ rpm -E '%requires_eq_to zlib'
ERROR
$ rpm -E '%requires_eq_to xulrunner zlib'
Requires: xulrunner = 0:1.2.3
$ rpm -E '%requires_eq_to xulrunner zlib zl'
ERROR
$ rpm -E '%requires_eq_to xulrunner xulrunner'
BuildRequires: xulrunner

Changed files:
    rpm.macros -> 1.503

10 years ago- gendiff patch added
Paweł Gołaszewski [Wed, 11 Feb 2009 15:45:02 +0000 (15:45 +0000)]
- gendiff patch added

Changed files:
    rpm.spec -> 1.921

10 years ago- it uses bash syntax, maybe should be rewritten
Paweł Gołaszewski [Wed, 11 Feb 2009 15:44:17 +0000 (15:44 +0000)]
- it uses bash syntax, maybe should be rewritten

Changed files:
    rpm-gendiff.patch -> 1.1

10 years ago- make requires_eq, requires_releq, requires_eq_to return failure if queried package... auto/ac/rpm-build-macros-1_502-1 auto/th/rpm-build-macros-1_502-1
Elan Ruusamäe [Tue, 3 Feb 2009 10:24:47 +0000 (10:24 +0000)]
- make requires_eq, requires_releq, requires_eq_to return failure if queried package is not installed

Changed files:
    rpm.macros -> 1.502

10 years ago- rpm macros required to run gstreamerdeps.sh
Marcin Banasiak [Thu, 22 Jan 2009 17:31:04 +0000 (17:31 +0000)]
- rpm macros required to run gstreamerdeps.sh

Changed files:
    rpm-macros.gstreamer -> 1.1

10 years ago- remove condition. It can be checked in gstreamerdeps.sh
Marcin Banasiak [Wed, 31 Dec 2008 21:28:28 +0000 (21:28 +0000)]
- remove condition. It can be checked in gstreamerdeps.sh

Changed files:
    rpm-gstreamer.patch -> 1.2

10 years ago- adds support for gstreamer codecs provides
Marcin Banasiak [Wed, 31 Dec 2008 20:30:06 +0000 (20:30 +0000)]
- adds support for gstreamer codecs provides

Changed files:
    rpm-gstreamer.patch -> 1.1

This page took 0.175184 seconds and 4 git commands to generate.