]> git.pld-linux.org Git - packages/rpm.git/log
packages/rpm.git
9 years agodrop ruby macros here, duplicate. provided by rpm-build-macros auto/th/rpm-5.4.10-46
Elan Ruusamäe [Fri, 29 Mar 2013 19:43:55 +0000 (21:43 +0200)]
drop ruby macros here, duplicate. provided by rpm-build-macros

9 years ago- rel 45 auto/th/rpm-5.4.10-45
Jan Rękorajski [Mon, 25 Mar 2013 14:30:55 +0000 (15:30 +0100)]
- rel 45

9 years ago- fix path
Jan Rękorajski [Mon, 25 Mar 2013 13:05:38 +0000 (14:05 +0100)]
- fix path

9 years ago- attempt to fix assertions at repackage time cause by xz memory needs
Jan Rękorajski [Mon, 25 Mar 2013 12:51:05 +0000 (13:51 +0100)]
- attempt to fix assertions at repackage time cause by xz memory needs

9 years agoadapter
Elan Ruusamäe [Fri, 22 Mar 2013 10:20:58 +0000 (12:20 +0200)]
adapter

9 years agoadd rpm-rubyprov package
Elan Ruusamäe [Fri, 22 Mar 2013 09:53:19 +0000 (11:53 +0200)]
add rpm-rubyprov package

moved gem_helper.rb and rubygems.rb to there and fill ruby dependencies

9 years ago- don't use hash to truncate inodes to 32 bit because hash collisions auto/th/rpm-5.4.10-44
Jan Rękorajski [Sun, 17 Mar 2013 12:35:37 +0000 (13:35 +0100)]
- don't use hash to truncate inodes to 32 bit because hash collisions
  cause bus errors in rpmbuild
- rel 44

9 years ago- fix for bug LP#1104474 auto/th/rpm-5.4.10-43
Jan Rękorajski [Tue, 12 Mar 2013 17:28:47 +0000 (18:28 +0100)]
- fix for bug LP#1104474
- always use inode hash as generated in build/files.c:genCpioListAndHeader()
  to prevent overflow of 64bit inode numbers
- rel 43

9 years ago- fix spec parsing wrt unknown macros (don't treat them as empty tags) auto/th/rpm-5.4.10-42
Jan Rękorajski [Mon, 25 Feb 2013 13:36:38 +0000 (14:36 +0100)]
- fix spec parsing wrt unknown macros (don't treat them as empty tags)

9 years ago- fix compressing documentation
Jan Rękorajski [Mon, 25 Feb 2013 11:10:57 +0000 (12:10 +0100)]
- fix compressing documentation
- rel 42

9 years agopkgconfig dep solver requires which auto/th/rpm-5.4.10-41
Elan Ruusamäe [Sun, 10 Feb 2013 11:24:10 +0000 (13:24 +0200)]
pkgconfig dep solver requires which

AUTO: -- /usr/lib/rpm/pkgconfigdeps.sh: line 3: which: command not found

9 years agoFix build without python
Marcin Banasiak [Wed, 30 Jan 2013 19:09:17 +0000 (20:09 +0100)]
Fix build without python

9 years agorel 40 to rebuld with pythonegg name transforms auto/th/rpm-5.4.10-40
Elan Ruusamäe [Tue, 29 Jan 2013 13:48:01 +0000 (15:48 +0200)]
rel 40 to rebuld with pythonegg name transforms

see this thread on pld-devel-en:
http://lists.pld-linux.org/mailman/pipermail/pld-devel-en/2013-January/023404.html

9 years ago- transform python eggs versions in form of N.X<a|b>Y into something
Jan Rękorajski [Tue, 29 Jan 2013 12:43:01 +0000 (13:43 +0100)]
- transform python eggs versions in form of N.X<a|b>Y into something
  that rpm can properly compare - N.X-0.<a|b>Y

9 years ago- rel 39 auto/th/rpm-5.4.10-39
Jan Rękorajski [Fri, 25 Jan 2013 13:45:05 +0000 (14:45 +0100)]
- rel 39

9 years ago- work around mksh handling && pipes when -e is in effect
Jan Rękorajski [Fri, 25 Jan 2013 13:05:53 +0000 (14:05 +0100)]
- work around mksh handling && pipes when -e is in effect

9 years ago- apply rpm-DB_CONFIG.patch
Jan Rękorajski [Fri, 25 Jan 2013 11:04:27 +0000 (12:04 +0100)]
- apply rpm-DB_CONFIG.patch

9 years ago- remove _docdir before packaging or fail if something already put
Jan Rękorajski [Thu, 24 Jan 2013 13:28:52 +0000 (14:28 +0100)]
- remove _docdir before packaging or fail if something already put
  unexpected content there

9 years ago- teach rpm dependency generator that we have python stuff also in /usr/share/python* auto/th/rpm-5.4.10-38
Jan Rękorajski [Thu, 24 Jan 2013 11:33:15 +0000 (12:33 +0100)]
- teach rpm dependency generator that we have python stuff also in /usr/share/python*
- rel 38

9 years ago- force upgrade of util-vserver via conflicts auto/th/rpm-5.4.10-37
Jan Rękorajski [Thu, 10 Jan 2013 14:41:19 +0000 (15:41 +0100)]
- force upgrade of util-vserver via conflicts
- rel 37

9 years ago- rel 36 auto/th/rpm-5.4.10-36
Jan Rękorajski [Wed, 12 Dec 2012 07:21:10 +0000 (08:21 +0100)]
- rel 36

9 years ago- removed namespace check in rpmal.c, it was unneccessary as the db52 auto/th/rpm-5.4.10-35.5
Jan Rękorajski [Sun, 2 Dec 2012 13:58:56 +0000 (14:58 +0100)]
- removed namespace check in rpmal.c, it was unneccessary as the
  comparison was on unparsed names and broke name-to-provides check
  during upgrades
- rel .5

9 years ago- rel .4 auto/th/rpm-5.4.10-35.4
Jan Rękorajski [Sat, 1 Dec 2012 20:28:27 +0000 (21:28 +0100)]
- rel .4

9 years ago- merge rpmpopt patch into popt-aliases patch
Jan Rękorajski [Sat, 1 Dec 2012 20:12:11 +0000 (21:12 +0100)]
- merge rpmpopt patch into popt-aliases patch

9 years ago- make triggerin behaviour (args values) comaptible with rpm4,
Jan Rękorajski [Sat, 1 Dec 2012 20:08:13 +0000 (21:08 +0100)]
- make triggerin behaviour (args values) comaptible with rpm4,
  fixes problem with webapp triggers not being run by rpm5

9 years ago- quiet -qa output, we're not interested in it here
Jan Rękorajski [Sat, 1 Dec 2012 10:41:44 +0000 (11:41 +0100)]
- quiet -qa output, we're not interested in it here

9 years agotypo
Elan Ruusamäe [Sat, 1 Dec 2012 10:19:26 +0000 (12:19 +0200)]
typo

9 years ago- fix the root cause behind infinite loop during ntpd install auto/th/rpm-5.4.10-35.3
Jan Rękorajski [Fri, 30 Nov 2012 20:51:07 +0000 (21:51 +0100)]
- fix the root cause behind infinite loop during ntpd install

On Fri, 30 Nov 2012, Jeffrey Johnson wrote:
[...]
> Yes: the iterator loop index on dependency sets is global.
>
> Which means that if something decrements the iterator index
> lower down, then the high level will continuously repeat.

And this exactly happened in lib/rpmal.c:rpmalAllSatisfiesDepend()
for 'provides' set because ntpd provided 'ntp' twice in different
manespaces.

9 years ago- add --initdb alias
Jan Rękorajski [Fri, 30 Nov 2012 20:39:40 +0000 (21:39 +0100)]
- add --initdb alias

9 years ago- kill -fno-strict-aliasing, it's not needed anymore auto/th/rpm-5.4.10-35.2
Jan Rękorajski [Fri, 30 Nov 2012 12:34:19 +0000 (13:34 +0100)]
- kill -fno-strict-aliasing, it's not needed anymore

9 years ago- check namespaces of dependencies in _rpmtsCheck, don't compare strings blindly
Jan Rękorajski [Fri, 30 Nov 2012 12:26:03 +0000 (13:26 +0100)]
- check namespaces of dependencies in _rpmtsCheck, don't compare strings blindly

This patch fixes a bug with ntpd package we encoutered:
- ntpdate has "Conflicts: ntp < 4.2.0-3"
- ntpd has "Provides: ntp = 4.2.4" and "Provides: user(ntp)"
now, if ntpdate is installed then attempt to install ntpd causes
_rpmtsCheck to compare "C: ntp" to both "P: ntp" AND THEN "P: user(ntp)"
due to lack of dependency namespace check. Side effect of this is
infinite loop in _rpmtsCheck due to inner workings of rpm dependency
iterators.

9 years ago- a bit more descriptive message about poldek rpmdb fail after conversion
Jan Rękorajski [Thu, 29 Nov 2012 12:36:49 +0000 (13:36 +0100)]
- a bit more descriptive message about poldek rpmdb fail after conversion

9 years ago- comments cosmetics, ease disabling repackage
Jan Rękorajski [Wed, 28 Nov 2012 13:54:19 +0000 (14:54 +0100)]
- comments cosmetics, ease disabling repackage

9 years agoRevert "add note that repackage (as .xz) needs ram" auto/th/rpm-5.4.10-35.1
Jan Rękorajski [Wed, 28 Nov 2012 12:36:13 +0000 (13:36 +0100)]
Revert "add note that repackage (as .xz) needs ram"

This reverts commit 92e126e5abb15ac331ff2373b6212266c6c5c012.

Binary payload compression level has been changed to 6, which needs
less than 100MB memory to work.

9 years ago- use default lzma/xz compression preset (-6) to avoid memory problems
Jan Rękorajski [Wed, 28 Nov 2012 12:29:28 +0000 (13:29 +0100)]
- use default lzma/xz compression preset (-6) to avoid memory problems
  (see xz man page for detailed memory requirements)

9 years ago- add '-r' option to specify root directory of rpm database,
Jan Rękorajski [Wed, 28 Nov 2012 11:22:40 +0000 (12:22 +0100)]
- add '-r' option to specify root directory of rpm database,
  mainly for use with util-vserver and external package management

9 years ago- require coreutils for postrans and don't check for programs that must
Jan Rękorajski [Tue, 27 Nov 2012 18:10:40 +0000 (19:10 +0100)]
- require coreutils for postrans and don't check for programs that must
  be there after transacion

9 years ago- restore trigger removed by mistake
Jan Rękorajski [Sun, 25 Nov 2012 19:13:21 +0000 (20:13 +0100)]
- restore trigger removed by mistake

9 years ago- use dbupgrade.sh script in posttrans
Jan Rękorajski [Sun, 25 Nov 2012 18:41:21 +0000 (19:41 +0100)]
- use dbupgrade.sh script in posttrans

9 years ago- package dbupgrade.sh
Jan Rękorajski [Sun, 25 Nov 2012 18:38:33 +0000 (19:38 +0100)]
- package dbupgrade.sh

9 years ago- clearer logic
Jan Rękorajski [Sun, 25 Nov 2012 18:37:12 +0000 (19:37 +0100)]
- clearer logic

9 years ago- install rpmdb_reset
Jan Rękorajski [Sun, 25 Nov 2012 18:35:51 +0000 (19:35 +0100)]
- install rpmdb_reset

9 years ago- add tool to reset LSN of rpm database
Jan Rękorajski [Sun, 25 Nov 2012 18:27:55 +0000 (19:27 +0100)]
- add tool to reset LSN of rpm database

9 years ago- add and use simple internal tool to reset LSN of rpm database
Jan Rękorajski [Sun, 25 Nov 2012 18:25:41 +0000 (19:25 +0100)]
- add and use simple internal tool to reset LSN of rpm database

9 years ago- compile rpmdb tool with choosen bdb and check if it's done properly
Jan Rękorajski [Sat, 24 Nov 2012 12:11:41 +0000 (13:11 +0100)]
- compile rpmdb tool with choosen bdb and check if it's done properly

9 years ago- don't continue if conversion failed
Jan Rękorajski [Fri, 23 Nov 2012 18:21:18 +0000 (19:21 +0100)]
- don't continue if conversion failed

9 years ago- add script to automate rpm db upgrade/downgrade
Jan Rękorajski [Fri, 23 Nov 2012 13:41:36 +0000 (14:41 +0100)]
- add script to automate rpm db upgrade/downgrade

9 years ago- leave db5.3 patches but don't apply them
Jan Rękorajski [Fri, 23 Nov 2012 07:15:19 +0000 (08:15 +0100)]
- leave db5.3 patches but don't apply them
- WIP on downgrade/upgrade triggers/posttrans

9 years agoMerge branch 'master' into db52
Jan Rękorajski [Fri, 23 Nov 2012 07:13:45 +0000 (08:13 +0100)]
Merge branch 'master' into db52

Conflicts:
rpm-db5.2.patch
rpm.spec

9 years ago- set bdb 5.2 as rpm database
Jan Rękorajski [Fri, 23 Nov 2012 07:07:18 +0000 (08:07 +0100)]
- set bdb 5.2 as rpm database

9 years ago- set BDB option to keep only active transaction log by default
Jan Rękorajski [Fri, 23 Nov 2012 07:06:18 +0000 (08:06 +0100)]
- set BDB option to keep only active transaction log by default

9 years agosay that it's okay to ignore such scary message that poldek gives after rpmdb upgrade
Elan Ruusamäe [Mon, 19 Nov 2012 10:33:37 +0000 (12:33 +0200)]
say that it's okay to ignore such scary message that poldek gives after rpmdb upgrade

9 years agospec change for 54f5e944a36ab54763126d77f1f29feea1a67867
Elan Ruusamäe [Mon, 19 Nov 2012 10:31:39 +0000 (12:31 +0200)]
spec change for 54f5e944a36ab54763126d77f1f29feea1a67867

9 years agopatching out redhat stuff (our _dependency_whiteout is in rpm-whiteout package)
Elan Ruusamäe [Fri, 16 Nov 2012 22:41:19 +0000 (00:41 +0200)]
patching out redhat stuff (our _dependency_whiteout is in rpm-whiteout package)

9 years ago- add newlines to fprintf auto/th/rpm-5.4.10-35
Jan Rękorajski [Sun, 11 Nov 2012 11:03:53 +0000 (12:03 +0100)]
- add newlines to fprintf

9 years ago- add deps for building xz compressed archives to rpm-build package
Jan Rękorajski [Sun, 11 Nov 2012 10:10:26 +0000 (11:10 +0100)]
- add deps for building xz compressed archives to rpm-build package
- fully replaces default macrofiles list to have proper order of loading
  them: libdir -> sysconfigdir -> homedir
- rel 35

9 years ago- release 34 (by relup.sh) auto/th/rpm-5.4.10-34
Elan Ruusamäe [Thu, 8 Nov 2012 03:01:28 +0000 (05:01 +0200)]
- release 34 (by relup.sh)

9 years ago- netsharedpath sample (probably not complete)
Elan Ruusamäe [Wed, 4 Jan 2012 09:42:07 +0000 (09:42 +0000)]
- netsharedpath sample (probably not complete)
  http://lists.pld-linux.org/mailman/pipermail/pld-devel-en/2010-May/021635.html

Changed files:
    rpm.spec -> 1.837.2.42.2.49.2.110
Conflicts:
rpm.spec

9 years ago- convert rpmdb only if it actually exists (vserver external pkgmanagement)
Elan Ruusamäe [Wed, 31 Oct 2012 07:25:32 +0000 (09:25 +0200)]
- convert rpmdb only if it actually exists (vserver external pkgmanagement)

9 years ago- you need coreutils to cp, and in vserver build coreutils is not there yet
Elan Ruusamäe [Wed, 31 Oct 2012 07:03:41 +0000 (09:03 +0200)]
- you need coreutils to cp, and in vserver build coreutils is not there yet

9 years ago- don't remove "duplicate" descriptions (this is also needed for auto/th/rpm-5.4.10-33
Jan Rękorajski [Thu, 25 Oct 2012 23:03:12 +0000 (01:03 +0200)]
- don't remove "duplicate" descriptions (this is also needed for
  previous fix to work)
- rel 33

9 years ago- proper fix to mdvbz62979 is not copying description and summary to subpackages auto/th/rpm-5.4.10-32
Jan Rękorajski [Thu, 25 Oct 2012 22:43:36 +0000 (00:43 +0200)]
- proper fix to mdvbz62979 is not copying description and summary to subpackages

Copying description to subpackages on they creation time caused
description parser to remove all but the last description translation,
even removed LANG=C default descriptions from subpackages.

9 years ago- looks like epoch0 patch is applied upstream within ifdef VENDOR_PLD
Jan Rękorajski [Thu, 25 Oct 2012 22:17:36 +0000 (00:17 +0200)]
- looks like epoch0 patch is applied upstream within ifdef VENDOR_PLD

9 years ago- rel 31 auto/th/rpm-5.4.10-31
Jan Rękorajski [Thu, 25 Oct 2012 20:50:32 +0000 (22:50 +0200)]
- rel 31
- disable mdvbz62979 (causes duplicate descriptions)

9 years ago- add two more patches from mandriva auto/th/rpm-5.4.10-30
Jan Rękorajski [Thu, 25 Oct 2012 15:21:55 +0000 (17:21 +0200)]
- add two more patches from mandriva
- rel 30

9 years ago- moved __nofsync definition auto/th/rpm-5.4.10-29
Jan Rękorajski [Thu, 25 Oct 2012 09:51:57 +0000 (11:51 +0200)]
- moved __nofsync definition

Rationale:
With %{load:...} being interpreted immediately -- not lazily --
within a macro init file, a failure to load causes immediate
loading  termination silently.

9 years ago- make DB_BUFFER_SMALL workaround loud again, hiding this issue auto/th/rpm-5.4.10-28
Jan Rękorajski [Thu, 25 Oct 2012 06:57:47 +0000 (08:57 +0200)]
- make DB_BUFFER_SMALL workaround loud again, hiding this issue
  won't help us find a reproducer and/or fix it
- rel 28

9 years agoavoid fdatasync syscall flood during database operations, release 27. auto/th/rpm-5.4.10-27
Paweł Sikora [Thu, 25 Oct 2012 05:39:32 +0000 (07:39 +0200)]
avoid fdatasync syscall flood during database operations, release 27.

9 years ago- check to see if rebuilding against db 5.2 fixes some bugs
Jan Rękorajski [Wed, 24 Oct 2012 21:47:33 +0000 (23:47 +0200)]
- check to see if rebuilding against db 5.2 fixes some bugs

9 years ago- always use db version in R and linking
Jan Rękorajski [Wed, 24 Oct 2012 21:45:04 +0000 (23:45 +0200)]
- always use db version in R and linking

9 years ago- rel 26 auto/th/rpm-5.4.10-26
Jan Rękorajski [Wed, 24 Oct 2012 10:02:59 +0000 (12:02 +0200)]
- rel 26

9 years agoMerge branch 'master' of git://git.pld-linux.org/packages/rpm
Jan Rękorajski [Wed, 24 Oct 2012 10:01:36 +0000 (12:01 +0200)]
Merge branch 'master' of git://git.pld-linux.org/packages/rpm

9 years ago- disable l10ndir sqlite database (what's it for?)
Jan Rękorajski [Wed, 24 Oct 2012 10:01:13 +0000 (12:01 +0200)]
- disable l10ndir sqlite database (what's it for?)

9 years ago- renamed patch auto/th/rpm-5.4.10-25
Jan Rękorajski [Tue, 23 Oct 2012 22:25:13 +0000 (00:25 +0200)]
- renamed patch

9 years ago- be noisy about (almost) all queries
Jan Rękorajski [Tue, 23 Oct 2012 22:23:17 +0000 (00:23 +0200)]
- be noisy about (almost) all queries
- rel 25

9 years ago- be noisy about (almost) all queries
Jan Rękorajski [Tue, 23 Oct 2012 22:20:56 +0000 (00:20 +0200)]
- be noisy about (almost) all queries

9 years agoadd note that repackage (as .xz) needs ram
Elan Ruusamäe [Tue, 23 Oct 2012 15:56:30 +0000 (18:56 +0300)]
add note that repackage (as .xz) needs ram

9 years ago- cosmetics
Jan Rękorajski [Mon, 22 Oct 2012 13:22:50 +0000 (15:22 +0200)]
- cosmetics

9 years ago- disable hmac when veryfying file digests auto/th/rpm-5.4.10-24
Jan Rękorajski [Mon, 22 Oct 2012 13:13:23 +0000 (15:13 +0200)]
- disable hmac when veryfying file digests
- rel 24

Disable hmac during digest calculation, since rpm package files
contain plain md5sums, hmac support is useless, see:
http://lists.pld-linux.org/mailman/pipermail/pld-devel-en/2012-October/023193.html

9 years ago- properly generate verify flags at package built time auto/th/rpm-5.4.10-23
Jan Rękorajski [Mon, 22 Oct 2012 11:21:59 +0000 (13:21 +0200)]
- properly generate verify flags at package built time
- rel 23

9 years ago- use plain paths here, not macros
Jan Rękorajski [Mon, 22 Oct 2012 11:19:40 +0000 (13:19 +0200)]
- use plain paths here, not macros

9 years ago- enable _hrmib_path auto/th/rpm-5.4.10-22
Jan Rękorajski [Sun, 14 Oct 2012 18:20:33 +0000 (20:20 +0200)]
- enable _hrmib_path
- rel 22

9 years agomacros: add _netsharedpath sample
Elan Ruusamäe [Sat, 13 Oct 2012 15:44:57 +0000 (18:44 +0300)]
macros: add _netsharedpath sample

9 years ago- rel 21, without neon build fixed auto/th/rpm-5.4.10-21
Jan Rękorajski [Tue, 9 Oct 2012 21:00:25 +0000 (23:00 +0200)]
- rel 21, without neon build fixed

Previous commit 85771a72b1e8e2eceb7df161d81b8f985c418f30 fixed
the following error:

Making all in tests
warning: edos-test-1-0.src.rpm: Header V4 DSA signature: NOKEY, key ID 2039b291
*** glibc detected *** /home/users/builder/rpm/BUILD/rpm-5.4.10/.libs/lt-rpm: free(): invalid size: 0x00000000025df940 ***
*** glibc detected *** /home/users/builder/rpm/BUILD/rpm-5.4.10/.libs/lt-rpm: corrupted double-linked list: 0x00000000025aeca0 ***

If rpm was built without neon, then during build, on PLD builders,
the error shown above manifested itself on random test packages
and then just-built rpm got stuck at a futex.

9 years ago- closer to fixing double-free without neon
Jan Rękorajski [Tue, 9 Oct 2012 20:53:53 +0000 (22:53 +0200)]
- closer to fixing double-free without neon

9 years ago- test no-neon build
Jan Rękorajski [Tue, 9 Oct 2012 20:47:29 +0000 (22:47 +0200)]
- test no-neon build

9 years ago- let's try to skip another test
Jan Rękorajski [Tue, 9 Oct 2012 19:36:23 +0000 (21:36 +0200)]
- let's try to skip another test

9 years ago- fixed condition
Jan Rękorajski [Tue, 9 Oct 2012 19:05:00 +0000 (21:05 +0200)]
- fixed condition

9 years ago- try to workaround tests that fail in mysterious way on builders (and only there)
Jan Rękorajski [Tue, 9 Oct 2012 19:03:20 +0000 (21:03 +0200)]
- try to workaround tests that fail in mysterious way on builders (and only there)

9 years ago- rel 20 auto/th/rpm-5.4.10-20
Elan Ruusamäe [Mon, 8 Oct 2012 21:47:39 +0000 (00:47 +0300)]
- rel 20

9 years agorestore macros.lang file from 4.5 branch (f622fc6)
Elan Ruusamäe [Mon, 8 Oct 2012 21:46:04 +0000 (00:46 +0300)]
restore macros.lang file from 4.5 branch (f622fc6)

9 years ago- release 19 auto/th/rpm-5.4.10-19
Jan Rękorajski [Mon, 8 Oct 2012 21:28:41 +0000 (23:28 +0200)]
- release 19

9 years ago- extend selinux support
Jan Rękorajski [Sun, 7 Oct 2012 20:57:17 +0000 (22:57 +0200)]
- extend selinux support

9 years ago- disable neon/webdav as we always did
Jan Rękorajski [Sun, 7 Oct 2012 20:56:32 +0000 (22:56 +0200)]
- disable neon/webdav as we always did

9 years agoRelease 18 auto/th/rpm-5.4.10-18
Artur Frysiak [Wed, 3 Oct 2012 15:07:21 +0000 (17:07 +0200)]
Release 18

9 years agoEnable posix module in lua
Artur Frysiak [Wed, 3 Oct 2012 15:05:19 +0000 (17:05 +0200)]
Enable posix module in lua

9 years ago- build with internal lua and enable extra lua libs, fixes auto/th/rpm-5.4.10-17
Jan Rękorajski [Wed, 3 Oct 2012 13:03:15 +0000 (15:03 +0200)]
- build with internal lua and enable extra lua libs, fixes
  http://lists.pld-linux.org/mailman/pipermail/pld-devel-en/2012-September/023154.html
- rel 17

9 years ago- properly null-terminate ascii digest string, this fixes upgrade auto/th/rpm-5.4.10-16
Jan Rękorajski [Tue, 2 Oct 2012 20:55:04 +0000 (22:55 +0200)]
- properly null-terminate ascii digest string, this fixes upgrade
  problems with packages built with rpm5 on old rpm-4.5
- rel 16

9 years agouse db package name in deps auto/th/rpm-5.4.10-15
Elan Ruusamäe [Sat, 29 Sep 2012 18:42:39 +0000 (21:42 +0300)]
use db package name in deps

otherwise we end up in funny situation that rpm reqires db > 4.7, but
installs db 5.3 to satisfy it:

Processing dependencies...
db4.7-4.7.25.4-7.i686 obsoleted by db4.7-4.7.25.4-8.i686
db4.7-utils-4.7.25.4-7.i686 obsoleted by db4.7-utils-4.7.25.4-8.i686
  orphaned rpm-lib-4.5-69.i686 marks db5.3-5.3.21.0-1.i686 (cap db >= 4.7.25)

9 years agoGenerate pkgconfig() R for Requires.private auto/th/rpm-5.4.10-14
Artur Frysiak [Sat, 29 Sep 2012 08:16:02 +0000 (10:16 +0200)]
Generate pkgconfig() R for Requires.private

"pkg-config --exists" needs Requires and Requires.private to be
fullfilled.

This page took 0.182971 seconds and 4 git commands to generate.