- improve debuginfo handling: put /usr/lib/.build-id/ in debug packages, auto/th/rpm-4.16.1.3-5
authorJan Rękorajski <baggins@pld-linux.org>
Wed, 24 Mar 2021 09:10:26 +0000 (10:10 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Wed, 24 Mar 2021 09:10:26 +0000 (10:10 +0100)
  enable debug subpackages, enable split debugsource packages
- rel 5

rpm-debuginfo.patch
rpm.spec

index aecf32e7bee27a7964a15296d3369ab20a6fb904..fbe2dfc9e0c07dcce7cb0dbc78f5cc1408e6dd0c 100644 (file)
    chmod 444 "$1" || exit
  }
  
+--- rpm-4.16.1.3/macros.in.orig        2021-03-24 09:50:21.000000000 +0100
++++ rpm-4.16.1.3/macros.in     2021-03-24 10:05:10.129698408 +0100
+@@ -534,7 +534,7 @@
+ #   Same as for "separate" but if the __debug_package global is set then
+ #   the -debuginfo package will have a compatibility link for the main
+ #   ELF /usr/lib/debug/.build-id/xx/yyy -> /usr/lib/.build-id/xx/yyy
+-%_build_id_links compat
++%_build_id_links alldebug
+ # Whether build-ids should be made unique between package version/releases
+ # when generating debuginfo packages. If set to 1 this will pass
+@@ -563,10 +563,10 @@
+ %_unique_debug_srcs   1
+ # Whether rpm should put debug source files into its own subpackage
+-#%_debugsource_packages       1
++%_debugsource_packages        1
+ # Whether rpm should create extra debuginfo packages for each subpackage
+-#%_debuginfo_subpackages 1
++%_debuginfo_subpackages 1
+ #
+ # Use internal dependency generator rather than external helpers?
index 6eb1f96ae7aef944e62c382b4b8150f61b4c53f9..2790aabed4e574e8cf36a0f419cfa88518f2d41f 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -34,7 +34,7 @@ Summary(ru.UTF-8):    Менеджер пакетов от RPM
 Summary(uk.UTF-8):     Менеджер пакетів від RPM
 Name:          rpm
 Version:       4.16.1.3
-Release:       4
+Release:       5
 Epoch:         1
 License:       GPL v2 / LGPL v2.1
 Group:         Base
@@ -136,7 +136,7 @@ BuildRequires:      tetex-pdftex
 Requires(posttrans):   coreutils
 Requires:      %{name}-base = %{epoch}:%{version}-%{release}
 Requires:      %{name}-lib = %{epoch}:%{version}-%{release}
-Requires:      rpm-pld-macros >= 1.744
+Requires:      rpm-pld-macros >= 2.002
 Requires:      FHS >= 3.0-2
 Requires:      libgcrypt
 Requires:      popt >= %{popt_ver}
This page took 0.092124 seconds and 4 git commands to generate.