]> git.pld-linux.org Git - packages/rpm.git/commitdiff
- updated for 4.4.3
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 19 Nov 2005 00:20:32 +0000 (00:20 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    rpm-cleanlibdirs.patch -> 1.2
    rpm-macros.patch -> 1.25
    rpm-mono.patch -> 1.2
    rpm-no-neon.patch -> 1.4
    rpm-no-sqlite.patch -> 1.3
    rpm-requireseq.patch -> 1.2

rpm-cleanlibdirs.patch
rpm-macros.patch
rpm-mono.patch
rpm-no-neon.patch
rpm-no-sqlite.patch
rpm-requireseq.patch

index 344dca75e1734e408ba493d6d329bd923d0303df..e2d693033a72c2f0d71fd748a60564f97233a8f6 100644 (file)
  usrlibdir = $(libdir)@MARK64@
  usrlib_LTLIBRARIES = librpmbuild.la
  librpmbuild_la_SOURCES = \
---- rpm-4.4.2/configure.ac.orig        2005-10-07 13:52:54.000000000 +0200
-+++ rpm-4.4.2/configure.ac     2005-11-08 15:55:31.000000000 +0100
-@@ -350,9 +350,6 @@
- localdone=
- dirs=$prefix
--if test "$cross_compiling" != "yes"; then
--  dirs="$dirs /usr/local"
--fi
- for dir in $dirs
- do
-       case $dir in
index 3257e0de96074ca7b6a8d92ff130c7a4c0bb6a58..f13cfbbb757ae52ae7ea2606883b9fb595c8fe73 100644 (file)
@@ -1,17 +1,17 @@
---- ./macros.in~       2005-10-30 16:24:30.000000000 +0200
-+++ ./macros.in        2005-10-30 16:24:32.000000000 +0200
-@@ -223,7 +223,7 @@
+--- rpm-4.4.3/macros.in.orig   2005-11-19 01:18:44.483914640 +0100
++++ rpm-4.4.3/macros.in        2005-11-19 01:19:50.657854672 +0100
+@@ -219,7 +219,7 @@
  %_tmppath             %{_var}/tmp
  
  #     Path to top of build area.
--%_topdir              %{_usrsrc}/redhat
-+%_topdir         %(echo $HOME)/rpm
+-%_topdir              %{_usrsrc}/rpm
++%_topdir              %(echo $HOME)/rpm
  
  #     The path to the unzip executable (legacy, use %{__unzip} instead).
  %_unzipbin            %{__unzip}
-@@ -1276,5 +1276,18 @@
- #
- %find_lang    @RPMCONFIGDIR@/find-lang.sh %{buildroot}
+@@ -1373,5 +1373,18 @@
+ #%__executable_provides       @RPMCONFIGDIR@/executabledeps.sh --provides
+ #%__executable_requires       @RPMCONFIGDIR@/executabledeps.sh --requires
  
 +# PLD rpm macros
 +%_enable_debug_packages 1
index b6b771df49fb9cbb02bd7ae916ff54a8bb120362..fa4e19bceae99c8071e6098f461641a6d4f907f9 100644 (file)
@@ -1,9 +1,8 @@
-diff -ruN rpm-4.4.2./build/rpmfc.c rpm-4.4.2/build/rpmfc.c
---- rpm-4.4.2./build/rpmfc.c   2005-08-11 13:11:54.000000000 +0200
-+++ rpm-4.4.2/build/rpmfc.c    2005-08-11 15:33:47.000000000 +0200
-@@ -534,6 +534,9 @@
-   /* XXX "python 2.3 byte-compiled" */
-   { "python ",                        RPMFC_PYTHON|RPMFC_INCLUDE },
+--- rpm-4.4.3/build/rpmfc.c.orig       2005-11-19 01:11:00.884392480 +0100
++++ rpm-4.4.3/build/rpmfc.c    2005-11-19 01:13:08.489993480 +0100
+@@ -539,6 +539,9 @@
+   { "Java ",                  RPMFC_JAVA|RPMFC_INCLUDE },
  
 +  /* .NET executables and libraries. file(1) cannot differ it from native win32 executables unfortunatelly */
 +  { "PE executable",          RPMFC_MONO|RPMFC_INCLUDE },
@@ -11,22 +10,15 @@ diff -ruN rpm-4.4.2./build/rpmfc.c rpm-4.4.2/build/rpmfc.c
    { "current ar archive",     RPMFC_STATIC|RPMFC_LIBRARY|RPMFC_ARCHIVE|RPMFC_INCLUDE },
  
    { "Zip archive data",               RPMFC_COMPRESSED|RPMFC_ARCHIVE|RPMFC_INCLUDE },
-@@ -827,6 +830,42 @@
+@@ -900,6 +903,35 @@
  }
  
  /**
 + * Extract .NET dependencies.
 + * @param fc          file classifier
-+ * @param findprov    1 to enable provides
-+ * @param findreq     1 to enable requires
-+ * @param noautoprov  _noautoprov regexps
-+ * @param noautoprov_c        # of _noautoprov regexps
-+ * @param noautoreq   _noautoreq regexps
-+ * @param noautoreq_c # of _noautoreq regexps
 + * @return            0 on success
 + */
-+static int rpmfcMONO(rpmfc fc, int findprov, int findreq,
-+    regex_t *noautoprov, int noautoprov_c, regex_t *noautoreq, int noautoreq_c)
++static int rpmfcMONO(rpmfc fc)
 +      /*@globals rpmGlobalMacroContext, h_errno, fileSystem, internalState @*/
 +      /*@modifies fc, rpmGlobalMacroContext, fileSystem, internalState @*/
 +{
@@ -42,10 +34,10 @@ diff -ruN rpm-4.4.2./build/rpmfc.c rpm-4.4.2/build/rpmfc.c
 +
 +    (void) fclose(fp);
 +
-+    if (findprov)
-+      xx = rpmfcHelper(fc, 'P', "mono", noautoprov, noautoprov_c);
-+    if (findreq)
-+      xx = rpmfcHelper(fc, 'R', "mono", noautoreq, noautoreq_c);
++    if (fc->findprov)
++      xx = rpmfcHelper(fc, 'P', "mono", fc->noautoprov, fc->noautoprov_c);
++    if (fc->findreq)
++      xx = rpmfcHelper(fc, 'R', "mono", fc->noautoreq, fc->noautoreq_c);
 +
 +    return 0;
 +}
@@ -53,11 +45,11 @@ diff -ruN rpm-4.4.2./build/rpmfc.c rpm-4.4.2/build/rpmfc.c
 +/**
   * Extract Elf dependencies.
   * @param fc          file classifier
-  * @param findprov    1 to enable provides
-@@ -1179,6 +1218,7 @@
-     { rpmfcSCRIPT,    (RPMFC_SCRIPT|RPMFC_PERL) },
-     { rpmfcSCRIPT,    (RPMFC_SCRIPT|RPMFC_PYTHON) },
-     { rpmfcSCRIPT,    (RPMFC_SCRIPT|RPMFC_PHP) },
+  * @return            0 on success
+@@ -931,6 +963,7 @@
+ static struct rpmfcApplyTbl_s rpmfcApplyTable[] = {
+     { rpmfcELF,               RPMFC_ELF },
+     { rpmfcSCRIPT,    (RPMFC_SCRIPT|RPMFC_PERL|RPMFC_PYTHON|RPMFC_LIBTOOL|RPMFC_PKGCONFIG|RPMFC_BOURNE|RPMFC_JAVA|RPMFC_PHP) },
 +    { rpmfcMONO,      RPMFC_MONO },
      { NULL, 0 }
  };
index 7a0877da702cb0384aa92a73ef12c08b6172871a..13d3affd8e93607a8713025fe05d0a7ab60ffaf1 100644 (file)
@@ -29,8 +29,8 @@
  AC_SUBST(WITH_NEON_SUBDIR)
  AC_SUBST(WITH_NEON_INCLUDE)
  AC_SUBST(WITH_NEON_LIB)
---- rpm-4.4.2/rpmio/rpmdav.c.orig      2005-02-17 02:07:18.000000000 +0100
-+++ rpm-4.4.2/rpmio/rpmdav.c   2005-07-23 14:11:17.251275568 +0200
+--- rpm-4.4.3/rpmio/rpmdav.c.orig      2005-11-16 01:09:03.000000000 +0100
++++ rpm-4.4.3/rpmio/rpmdav.c   2005-11-19 00:57:53.058160272 +0100
 @@ -9,24 +9,6 @@
  #include <pthread.h>
  #endif
@@ -56,7 +56,7 @@
  #include <rpmio_internal.h>
  
  #define _RPMDAV_INTERNAL
-@@ -62,1315 +44,6 @@
+@@ -62,1326 +44,6 @@
  }
  
  /* =============================================================== */
 -      /* XXX check that neon is ssl enabled. */
 -      if (!strcasecmp(u->scheme, "https"))
 -          ne_ssl_set_verify(u->sess, davVerifyCert, (char *)u->host);
--                                                                                
+-
 -      ne_set_session_private(u->sess, "urlinfo", u);
 -
 -      ne_hook_destroy_session(u->sess, davDestroySession, u);
 -    resr_reference,
 -    resr_error
 -};
--                                                                                
+-
 -struct fetch_resource_s {
+-/*@dependent@*/
 -    struct fetch_resource_s *next;
 -    char *uri;
 -/*@unused@*/
 -
 -/* =============================================================== */
 -struct fetch_context_s {
--/*@relnull@*/
+-/*@relnull@*/ /*@dependent@*/
 -    struct fetch_resource_s **resrock;
 -    const char *uri;
 -    unsigned int include_target; /* Include resource at href */
 -    { "DAV:", "collection", ELM_collection }
 -};
 -
--static int fetch_startelm(void *userdata, int parent, 
+-static int fetch_startelm(void *userdata, int parent,
 -              const char *nspace, const char *name,
 -              /*@unused@*/ const char **atts)
 -      /*@*/
 -    int state = ne_xml_mapid(fetch_idmap, NE_XML_MAPLEN(fetch_idmap),
 -                             nspace, name);
 -
--    if (r == NULL || 
+-    if (r == NULL ||
 -        !((parent == NE_207_STATE_PROP && state == ELM_resourcetype) ||
 -          (parent == ELM_resourcetype && state == ELM_collection)))
 -        return NE_XML_DECLINE;
 -    return state;
 -}
 -
--static int fetch_compare(const struct fetch_resource_s *r1, 
+-static int fetch_compare(const struct fetch_resource_s *r1,
 -                          const struct fetch_resource_s *r2)
 -      /*@*/
 -{
 -
 -if (_dav_debug < 0)
 -fprintf(stderr, "==> %s in uri %s\n", path, ctx->uri);
--    
+-
 -    if (ne_path_compare(ctx->uri, path) == 0 && !ctx->include_target) {
 -      /* This is the target URI */
 -if (_dav_debug < 0)
 -fprintf(stderr, "==> %s skipping target resource.\n", path);
 -      /* Free the private structure. */
+-/*@-dependenttrans -exposetrans@*/
 -      free(newres);
+-/*@=dependenttrans =exposetrans@*/
 -      return;
 -    }
 -
 -    newres->uri = ne_strdup(path);
 -
 -/*@-boundsread@*/
--    clength = ne_propset_value(set, &fetch_props[0]);    
+-    clength = ne_propset_value(set, &fetch_props[0]);
 -    modtime = ne_propset_value(set, &fetch_props[1]);
 -    isexec = ne_propset_value(set, &fetch_props[2]);
 -    checkin = ne_propset_value(set, &fetch_props[4]);
 -    checkout = ne_propset_value(set, &fetch_props[5]);
 -/*@=boundsread@*/
--    
+-
 -/*@-branchstate@*/
 -    if (clength == NULL)
 -      status = ne_propset_status(set, &fetch_props[0]);
 -      newres->is_vcr = 0;
 -    }
 -
--    for (current = *ctx->resrock, previous = NULL; current != NULL; 
+-    for (current = *ctx->resrock, previous = NULL; current != NULL;
 -      previous = current, current = current->next)
 -    {
 -      if (fetch_compare(current, newres) >= 0) {
 -    if (previous) {
 -      previous->next = newres;
 -    } else {
--/*@-boundswrite@*/
+-/*@-boundswrite -dependenttrans @*/
 -      *ctx->resrock = newres;
--/*@=boundswrite@*/
+-/*@=boundswrite =dependenttrans @*/
 -    }
 -    newres->next = current;
 -}
 -    ctx->resrock = resrock;
 -    ctx->include_target = include_target;
 -
--    ne_xml_push_handler(ne_propfind_get_parser(pfh), 
+-    ne_xml_push_handler(ne_propfind_get_parser(pfh),
 -                        fetch_startelm, NULL, NULL, pfh);
 -
 -    ne_propfind_set_private(pfh, fetch_create_item, NULL);
 -}
 -#endif
 -
+-/*@-mustmod@*/
 -static void davAcceptRanges(void * userdata, /*@null@*/ const char * value)
 -      /*@modifies userdata @*/
 -{
 -    urlinfo u = userdata;
 -
--    if (!(u && value)) return;
+-    if (!(u != NULL && value != NULL)) return;
 -if (_dav_debug < 0)
 -fprintf(stderr, "*** u %p Accept-Ranges: %s\n", u, value);
 -    if (!strcmp(value, "bytes"))
 -    if (!strcmp(value, "none"))
 -      u->httpHasRange = 0;
 -}
+-/*@=mustmod@*/
 -
 -#if !defined(HAVE_NEON_NE_GET_RESPONSE_HEADER)
 -static void davAllHeaders(void * userdata, const char * value)
 -{
 -    FD_t ctrl = userdata;
 -
--    if (!(ctrl && value)) return;
+-    if (!(ctrl != NULL && value != NULL)) return;
 -if (_dav_debug)
 -fprintf(stderr, "<- %s\n", value);
 -}
 -#endif
 -
+-/*@-mustmod@*/
 -static void davContentLength(void * userdata, /*@null@*/ const char * value)
 -      /*@modifies userdata @*/
 -{
 -    FD_t ctrl = userdata;
 -
--    if (!(ctrl && value)) return;
+-    if (!(ctrl != NULL && value != NULL)) return;
 -if (_dav_debug < 0)
 -fprintf(stderr, "*** fd %p Content-Length: %s\n", ctrl, value);
 -/*@-unrecog@*/
 -   ctrl->contentLength = strtoll(value, NULL, 10);
 -/*@=unrecog@*/
 -}
+-/*@=mustmod@*/
 -
+-/*@-mustmod@*/
 -static void davConnection(void * userdata, /*@null@*/ const char * value)
 -      /*@modifies userdata @*/
 -{
 -    FD_t ctrl = userdata;
 -
--    if (!(ctrl && value)) return;
+-    if (!(ctrl != NULL && value != NULL)) return;
 -if (_dav_debug < 0)
 -fprintf(stderr, "*** fd %p Connection: %s\n", ctrl, value);
 -    if (!strcasecmp(value, "close"))
 -    else if (!strcasecmp(value, "Keep-Alive"))
 -      ctrl->persist = 1;
 -}
+-/*@=mustmod@*/
 -
 -/*@-mustmod@*/ /* HACK: stash error in *str. */
 -int davResp(urlinfo u, FD_t ctrl, /*@unused@*/ char *const * str)
 -      fd = fdNew("grab ctrl (davOpen)");
 -
 -    if (fd) {
+-      fdSetOpen(fd, url, flags, mode);
 -      fdSetIo(fd, ufdio);
+-
 -      fd->ftpFileDoneNeeded = 0;
 -      fd->rd_timeoutsecs = httpTimeoutSecs;
 -      fd->contentLength = fd->bytesRemain = -1;
 -    ssize_t rc;
 -    int xx;
 -
--#ifndef       NEONBLOWSCHUNKS
+-#if !defined(NEONBLOWSCHUNKS)
 -    ne_session * sess;
 -
 -assert(fd->req != NULL);
 -    /* HACK: include ne_private.h to access sess->socket for now. */
 -    xx = ne_sock_fullwrite(sess->socket, buf, count);
 -#else
--#if defined(HAVE_NEON_NE_SEND_REQUEST_CHUNK)
+-#if defined(HAVE_NEON_NE_SEND_REQUEST_CHUNK) || defined(__LCLINT__)
 -assert(fd->req != NULL);
 -    xx = ne_send_request_chunk(fd->req, buf, count);
 -#else
 -    if (S_ISREG(st->st_mode)) {
 -      st->st_nlink = 1;
 -      st->st_mode |= 0644;
--    } 
+-    }
 -
 -    /* XXX fts(3) needs/uses st_ino, make something up for now. */
 -    if (st->st_ino == 0)
 -    if (S_ISREG(st->st_mode)) {
 -      st->st_nlink = 1;
 -      st->st_mode |= 0644;
--    } 
+-    }
 -
 -    /* XXX fts(3) needs/uses st_ino, make something up for now. */
 -    if (st->st_ino == 0)
  /*@unchecked@*/
  int avmagicdir = 0x3607113;
  
-@@ -1493,172 +166,3 @@
+@@ -1504,172 +166,3 @@
  /*@=kepttrans@*/
  }
  /*@=boundswrite@*/
 -    dp->d_ino = i + 1;                /* W2DO? */
 -    dp->d_reclen = 0;         /* W2DO? */
 -
--#if !defined(hpux) && !defined(sun)
+-#if !(defined(hpux) || defined(__hpux) || defined(sun))
 -#if !defined(__APPLE__)
 -    dp->d_off = 0;            /* W2DO? */
 -#endif
 -    strncpy(dp->d_name, av[i], sizeof(dp->d_name));
 -if (_dav_debug < 0)
 -fprintf(stderr, "*** davReaddir(%p) %p \"%s\"\n", (void *)avdir, dp, dp->d_name);
--    
+-
 -    return dp;
 -}
 -
 -/*@=kepttrans@*/
 -}
 -/*@=modfilesys@*/
-diff -ur rpm-4.4.1/rpmio/rpmdav.h rpm-4.4.1-no-neon/rpmio/rpmdav.h
---- rpm-4.4.1/rpmio/rpmdav.h   2005-01-17 19:46:27.000000000 +0100
-+++ rpm-4.4.1-no-neon/rpmio/rpmdav.h   2005-06-19 20:39:46.034218000 +0200
-@@ -80,131 +80,6 @@
+--- rpm-4.4.3/rpmio/rpmdav.h.orig      2005-10-11 21:13:59.000000000 +0200
++++ rpm-4.4.3/rpmio/rpmdav.h   2005-11-19 01:07:54.224769056 +0100
+@@ -80,133 +80,6 @@
        /*@globals fileSystem, internalState @*/
        /*@modifies fileSystem, internalState @*/;
  
@@ -1570,9 +1580,11 @@ diff -ur rpm-4.4.1/rpmio/rpmdav.h rpm-4.4.1-no-neon/rpmio/rpmdav.h
 - * @retval *str               error msg               
 - * @returns           0 on success
 - */
+-/*@-exportlocal@*/
 -int davResp(urlinfo u, FD_t ctrl, /*@out@*/ /*@null@*/ char *const * str)
 -      /*@globals fileSystem, internalState @*/
 -      /*@modifies ctrl, *str, fileSystem, internalState @*/;
+-/*@=exportlocal@*/
 -
 -/**
 - */
@@ -1680,22 +1692,9 @@ diff -ur rpm-4.4.1/rpmio/rpmdav.h rpm-4.4.1-no-neon/rpmio/rpmdav.h
  #ifdef __cplusplus
  }
  #endif
-diff -ur rpm-4.4.1/rpmio/rpmio.c rpm-4.4.1-no-neon/rpmio/rpmio.c
---- rpm-4.4.1/rpmio/rpmio.c    2005-01-26 04:39:58.000000000 +0100
-+++ rpm-4.4.1-no-neon/rpmio/rpmio.c    2005-06-19 20:34:07.005758160 +0200
-@@ -104,11 +104,6 @@
- /**
-  */
- /*@unchecked@*/
--static int httpTimeoutSecs = TIMEOUT_SECS;
--
--/**
-- */
--/*@unchecked@*/
- int _rpmio_debug = 0;
- /**
-@@ -369,13 +364,6 @@
+--- rpm-4.4.3/rpmio/rpmio.c.orig       2005-11-16 01:05:39.000000000 +0100
++++ rpm-4.4.3/rpmio/rpmio.c    2005-11-19 01:03:10.769860752 +0100
+@@ -371,13 +371,6 @@
  
      fdstat_enter(fd, FDSTAT_READ);
  /*@-boundswrite@*/
@@ -1709,7 +1708,7 @@ diff -ur rpm-4.4.1/rpmio/rpmio.c rpm-4.4.1-no-neon/rpmio/rpmio.c
        rc = read(fdFileno(fd), buf, (count > fd->bytesRemain ? fd->bytesRemain : count));
  /*@=boundswrite@*/
      fdstat_exit(fd, FDSTAT_READ, rc);
-@@ -403,10 +391,6 @@
+@@ -405,10 +398,6 @@
  
      fdstat_enter(fd, FDSTAT_WRITE);
  /*@-boundsread@*/
@@ -1720,7 +1719,7 @@ diff -ur rpm-4.4.1/rpmio/rpmio.c rpm-4.4.1-no-neon/rpmio/rpmio.c
        rc = write(fdno, buf, (count > fd->bytesRemain ? fd->bytesRemain : count));
  /*@=boundsread@*/
      fdstat_exit(fd, FDSTAT_WRITE, rc);
-@@ -453,11 +437,6 @@
+@@ -455,11 +444,6 @@
      fdSetFdno(fd, -1);
  
      fdstat_enter(fd, FDSTAT_CLOSE);
@@ -1732,7 +1731,7 @@ diff -ur rpm-4.4.1/rpmio/rpmio.c rpm-4.4.1-no-neon/rpmio/rpmio.c
        rc = ((fdno >= 0) ? close(fdno) : -2);
  /*@=branchstate@*/
      fdstat_exit(fd, FDSTAT_CLOSE, rc);
-@@ -509,10 +488,6 @@
+@@ -512,10 +496,6 @@
      FD_ZERO(&wrfds);
  #endif
        
@@ -1743,7 +1742,7 @@ diff -ur rpm-4.4.1/rpmio/rpmio.c rpm-4.4.1-no-neon/rpmio/rpmio.c
      if ((fdno = fdFileno(fd)) < 0)
        return -1;      /* XXX W2DO? */
        
-@@ -564,10 +539,6 @@
+@@ -567,10 +547,6 @@
      FD_ZERO(&rdfds);
  #endif
  
@@ -1754,10 +1753,11 @@ diff -ur rpm-4.4.1/rpmio/rpmio.c rpm-4.4.1-no-neon/rpmio/rpmio.c
      if ((fdno = fdFileno(fd)) < 0)
        return -1;      /* XXX W2DO? */
        
-@@ -1562,152 +1533,6 @@
+@@ -1566,154 +1542,6 @@
      return rc;
  }
  
+-#ifdef DEAD
 -static int httpResp(urlinfo u, FD_t ctrl, /*@out@*/ char ** str)
 -      /*@globals fileSystem @*/
 -      /*@modifies ctrl, *str, fileSystem @*/
@@ -1903,11 +1903,12 @@ diff -ur rpm-4.4.1/rpmio/rpmio.c rpm-4.4.1-no-neon/rpmio/rpmio.c
 -    return rc;
 -/*@=usereleased@*/
 -}
+-#endif
 -
  /* XXX DYING: unused */
  void * ufdGetUrlinfo(FD_t fd)
  {
-@@ -2064,29 +1889,6 @@
+@@ -2071,29 +1899,6 @@
            fd->wr_chunked = 0;
        }
        break;
@@ -1937,19 +1938,19 @@ diff -ur rpm-4.4.1/rpmio/rpmio.c rpm-4.4.1-no-neon/rpmio/rpmio.c
      case URL_IS_DASH:
        assert(!(flags & O_RDWR));
        fd = fdDup( ((flags & O_WRONLY) ? STDOUT_FILENO : STDIN_FILENO) );
-@@ -2703,10 +2505,8 @@
+@@ -2711,10 +2516,8 @@
            if (fd->nfps > 0 && fpno == -1 &&
                fd->fps[fd->nfps-1].io == ufdio &&
                fd->fps[fd->nfps-1].fp == fp &&
 -              (fd->fps[fd->nfps-1].fdno >= 0 || fd->req != NULL))
-+              fd->fps[fd->nfps-1].fdno >= 0)
++              (fd->fps[fd->nfps-1].fdno >= 0))
            {
 -              int hadreqpersist = (fd->req != NULL);
 -
                if (fp)
                    rc = fflush(fp);
                fd->nfps--;
-@@ -2716,26 +2516,9 @@
+@@ -2724,26 +2527,9 @@
  /*@-usereleased@*/
                if (fdGetFdno(fd) >= 0)
                    break;
@@ -1976,14 +1977,14 @@ diff -ur rpm-4.4.1/rpmio/rpmio.c rpm-4.4.1-no-neon/rpmio/rpmio.c
                        rc = fclose(fp);
                }
                fdPop(fd);
-@@ -2984,18 +2767,9 @@
+@@ -2992,18 +2778,10 @@
            return NULL;
        }
      } else {
 -      FILE *fp;
 -      int fdno;
 -      int isHTTP = 0;
--
        /* XXX gzdio and bzdio here too */
  
        switch (urlIsURL(path)) {
@@ -1995,7 +1996,7 @@ diff -ur rpm-4.4.1/rpmio/rpmio.c rpm-4.4.1-no-neon/rpmio/rpmio.c
        case URL_IS_PATH:
        case URL_IS_DASH:
        case URL_IS_FTP:
-@@ -3003,7 +2777,7 @@
+@@ -3011,7 +2789,7 @@
  if (_rpmio_debug)
  fprintf(stderr, "*** Fopen ufdio path %s fmode %s\n", path, fmode);
            fd = ufdOpen(path, flags, perms);
@@ -2004,7 +2005,7 @@ diff -ur rpm-4.4.1/rpmio/rpmio.c rpm-4.4.1-no-neon/rpmio/rpmio.c
                return fd;
            break;
        default:
-@@ -3012,15 +2786,6 @@
+@@ -3020,15 +2798,6 @@
            return NULL;
            /*@notreached@*/ break;
        }
@@ -2020,7 +2021,7 @@ diff -ur rpm-4.4.1/rpmio/rpmio.c rpm-4.4.1-no-neon/rpmio/rpmio.c
      }
      /*@=branchstate@*/
  
-@@ -3056,10 +2821,6 @@
+@@ -3064,10 +2833,6 @@
      int i, rc = 0;
  
      if (fd == NULL) return -1;
@@ -2031,7 +2032,7 @@ diff -ur rpm-4.4.1/rpmio/rpmio.c rpm-4.4.1-no-neon/rpmio/rpmio.c
      for (i = fd->nfps; rc == 0 && i >= 0; i--) {
  /*@-boundsread@*/
        FDSTACK_t * fps = &fd->fps[i];
-@@ -3094,9 +2855,6 @@
+@@ -3102,9 +2867,6 @@
  {
      int i, rc = -1;
  
index 572303e052372f9fa410e7d056909d2fc7ac0fed..c6d0d50fa133b115e9692f84701ccfcfecfc1df3 100644 (file)
@@ -1,6 +1,6 @@
---- rpm-4.4.2/configure.ac.orig        2005-07-23 14:12:39.097833000 +0200
-+++ rpm-4.4.2/configure.ac     2005-07-23 14:14:23.972889568 +0200
-@@ -588,24 +588,6 @@
+--- rpm-4.4.3/configure.ac.orig        2005-11-19 01:08:41.529577632 +0100
++++ rpm-4.4.3/configure.ac     2005-11-19 01:09:44.521001480 +0100
+@@ -618,24 +596,6 @@
  WITH_SQLITE3_INCLUDE=
  WITH_SQLITE3_LIB=
  
@@ -16,7 +16,7 @@
 -  if test -d sqlite ; then
 -    AC_DEFINE(HAVE_SQLITE3_H, 1, [Define if you have the <sqlite3.h> header file])
 -    WITH_SQLITE3_SUBDIR=sqlite
--    WITH_SQLITE3_INCLUDE="-I\${top_srcdir}/${WITH_SQLITE3_SUBDIR}/src"
+-    WITH_SQLITE3_INCLUDE="-I\${top_srcdir}/${WITH_SQLITE3_SUBDIR} -I\${top_srcdir}/${WITH_SQLITE3_SUBDIR}/src"
 -    WITH_SQLITE3_LIB="\${top_builddir}/${WITH_SQLITE3_SUBDIR}/libsqlite3.la"
 -    DBLIBSRCS="$DBLIBSRCS sqlite.c"
 -  fi
index e30cf2da8a02df4ff98adf664e9c2a60a47c2e55..65fb81ff70709b7c8f1a5892365e3ec7d2fa47d3 100644 (file)
@@ -1,12 +1,11 @@
-diff -urBb rpm-4.4.2.org/macros.in rpm-4.4.2/macros.in
---- rpm-4.4.2.org/macros.in    2005-10-08 13:38:33.470982000 +0200
-+++ rpm-4.4.2/macros.in        2005-10-08 13:39:51.327848250 +0200
-@@ -1249,7 +1249,7 @@
- #     %{perl_sitearch}/Image
+--- rpm-4.4.3/macros.in.orig   2005-11-19 01:16:40.317790760 +0100
++++ rpm-4.4.3/macros.in        2005-11-19 01:17:48.254462816 +0100
+@@ -1298,7 +1298,7 @@
  #     %dir %{perl_sitearch}/auto/Image
  #
 -%requires_eq()        %(LC_ALL="C" echo '%*' | xargs -r rpm -q --qf 'Requires: %%{name} = %%{epoch}:%%{version}\\n' | sed -e 's/ (none):/ /' -e 's/ 0:/ /' | grep -v "is not")
 +%requires_eq()        %(echo '%*' | LC_ALL="C" xargs -r rpm -q --qf 'Requires: %%{name} = %%{epoch}:%%{version}\\n' | sed -e 's/ (none):/ /' -e 's/ 0:/ /' | grep -v "is not")
  %perl_sitearch        %(eval "`%{__perl} -V:installsitearch`"; echo $installsitearch)
  %perl_sitelib %(eval "`%{__perl} -V:installsitelib`"; echo $installsitelib)
- %perl_vendorarch %(eval "`%{__perl} -V:installvendorarch`"; echo $installvendorarch)
This page took 0.075369 seconds and 4 git commands to generate.