]> git.pld-linux.org Git - packages/rpm.git/commitdiff
- added nosetproctitle patch (disable setproctitle as internal function or external...
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 6 Apr 2013 19:56:24 +0000 (21:56 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sat, 6 Apr 2013 19:56:24 +0000 (21:56 +0200)
rpm-nosetproctitle.patch [new file with mode: 0644]
rpm.spec

diff --git a/rpm-nosetproctitle.patch b/rpm-nosetproctitle.patch
new file mode 100644 (file)
index 0000000..1dd0f55
--- /dev/null
@@ -0,0 +1,47 @@
+--- rpm-5.4.10/misc/librpmmisc.c.orig  2009-05-29 21:04:21.000000000 +0200
++++ rpm-5.4.10/misc/librpmmisc.c       2013-04-06 21:52:32.825238309 +0200
+@@ -33,7 +33,7 @@
+ #endif
+ /* XXX limit the fiddle up to linux for now. */
+-#if !defined(HAVE_SETPROCTITLE) && defined(__linux__)
++#if 0 && !defined(HAVE_SETPROCTITLE) && defined(__linux__)
+ #include "setproctitle.c"
+ #endif
+--- rpm-5.4.10/configure.ac.orig       2013-04-06 15:51:42.965689560 +0200
++++ rpm-5.4.10/configure.ac    2013-04-06 21:52:57.755237789 +0200
+@@ -945,13 +945,6 @@ if test $ac_cv_func_syslog = no; then
+   done
+ fi
+-AC_CHECK_FUNCS(setproctitle)
+-if test $ac_cv_func_setproctitle = no; then
+-  # setproctitle is not in the default libraries.  See if it's in some other.
+-  AC_CHECK_LIB(setproctitle, setproctitle, [AC_DEFINE(HAVE_SETPROCTITLE)
+-  LIBS="$LIBS -lsetproctitle"])
+-fi
+-
+ dnl # Check how to find out the amount of physical memory in the system. The
+ dnl # xz command line tool uses this to automatically limit its memory usage.
+ dnl # - sysconf() gives all the needed info on GNU+Linux and Solaris.
+--- rpm-5.4.10/rpmqv.c.orig    2012-07-06 17:39:16.000000000 +0200
++++ rpm-5.4.10/rpmqv.c 2013-04-06 21:52:12.351905402 +0200
+@@ -450,7 +450,7 @@ int main(int argc, const char ** argv)
+     environ = envp;
+ #else
+ /* XXX limit the fiddle up to linux for now. */
+-#if !defined(HAVE_SETPROCTITLE) && defined(__linux__)
++#if 0 && !defined(HAVE_SETPROCTITLE) && defined(__linux__)
+     (void) initproctitle(argc, (char **)argv, environ);
+ #endif
+ #endif  
+@@ -1117,7 +1117,7 @@ exit:
+     optCon = rpmcliFini(optCon);
+ /* XXX limit the fiddle up to linux for now. */
+-#if !defined(HAVE_SETPROCTITLE) && defined(__linux__)
++#if 0 && !defined(HAVE_SETPROCTITLE) && defined(__linux__)
+     (void) finiproctitle();
+ #endif
index 23ff1ddf60d984085097bb7fc67bd80efea21ae3..f110832b24977000093c4f28b5c02d8503487958 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -94,6 +94,7 @@ Source29:     dbupgrade.sh
 Patch0:                %{name}-branch.patch
 Patch1:                %{name}-man_pl.patch
 Patch2:                %{name}-popt-aliases.patch
+Patch3:                %{name}-nosetproctitle.patch
 Patch4:                %{name}-perl-macros.patch
 Patch5:                %{name}-perl-req-perlfile.patch
 Patch6:                %{name}-scripts-closefds.patch
@@ -813,6 +814,7 @@ Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
 #patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 %patch4 -p1
 %patch5 -p1
 %patch6 -p1
This page took 0.112851 seconds and 4 git commands to generate.