]> git.pld-linux.org Git - packages/rpm.git/commitdiff
- rel 43; use types directly (fixes rpm build and header files when used on glibc... auto/th/rpm-5.4.15-43
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Sat, 11 Aug 2018 10:44:58 +0000 (12:44 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Sat, 11 Aug 2018 10:44:58 +0000 (12:44 +0200)
glibc.patch [new file with mode: 0644]
rpm.spec

diff --git a/glibc.patch b/glibc.patch
new file mode 100644 (file)
index 0000000..4e0f552
--- /dev/null
@@ -0,0 +1,45 @@
+diff -upr rpm-5.4.15.org/rpmio/gzdio.c rpm-5.4.15/rpmio/gzdio.c
+--- rpm-5.4.15.org/rpmio/gzdio.c       2012-04-16 05:21:22.000000000 +0200
++++ rpm-5.4.15/rpmio/gzdio.c   2018-08-11 12:36:48.761296851 +0200
+@@ -380,7 +380,7 @@ static int gzdSeek(void * cookie, _libio
+     int rc;
+ #if defined(HAVE_GZSEEK)
+ #ifdef USE_COOKIE_SEEK_POINTER
+-    _IO_off64_t p = *pos;
++    off64_t p = *pos;
+ #else
+     off_t p = pos;
+ #endif
+diff -upr rpm-5.4.15.org/rpmio/rpmio.c rpm-5.4.15/rpmio/rpmio.c
+--- rpm-5.4.15.org/rpmio/rpmio.c       2014-08-05 00:47:16.000000000 +0200
++++ rpm-5.4.15/rpmio/rpmio.c   2018-08-11 12:36:48.757963417 +0200
+@@ -481,7 +481,7 @@ static int fdSeek(void * cookie, _libio_
+       /*@modifies fileSystem, internalState @*/
+ {
+ #ifdef USE_COOKIE_SEEK_POINTER
+-    _IO_off64_t p = *pos;
++    off64_t p = *pos;
+ #else
+     off_t p = pos;
+ #endif
+@@ -2458,7 +2458,7 @@ int Fseek(FD_t fd, _libio_off_t offset,
+ {
+     fdio_seek_function_t _seek;
+ #ifdef USE_COOKIE_SEEK_POINTER
+-    _IO_off64_t o64 = offset;
++    off64_t o64 = offset;
+     _libio_pos_t pos = &o64;
+ #else
+     _libio_pos_t pos = offset;
+diff -upr rpm-5.4.15.org/rpmio/rpmio.h rpm-5.4.15/rpmio/rpmio.h
+--- rpm-5.4.15.org/rpmio/rpmio.h       2014-07-20 01:01:26.000000000 +0200
++++ rpm-5.4.15/rpmio/rpmio.h   2018-08-11 12:36:48.761296851 +0200
+@@ -25,7 +25,7 @@
+ #if !defined(__LCLINT__) && !defined(__UCLIBC__) && defined(__GLIBC__) && \
+       (__GLIBC__ > 2 || (__GLIBC__ == 2 && __GLIBC_MINOR__ >= 2))
+ #define USE_COOKIE_SEEK_POINTER 1
+-typedef _IO_off64_t   _libio_off_t;
++typedef off64_t       _libio_off_t;
+ typedef _libio_off_t *        _libio_pos_t;
+ #else
+ typedef off_t                 _libio_off_t;
index ba43cb013589a99167019e7c15080921fe8a5ba0..769a5047f8e44dab86a23d4cb26367dc64ade25e 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -47,7 +47,7 @@ Summary(ru.UTF-8):    Менеджер пакетов от RPM
 Summary(uk.UTF-8):     Менеджер пакетів від RPM
 Name:          rpm
 Version:       5.4.15
-Release:       42
+Release:       43
 License:       LGPL v2.1
 Group:         Base
 # http://rpm5.org/files/rpm/rpm-5.4/rpm-5.4.15-0.20140824.src.rpm
@@ -181,6 +181,7 @@ Patch93:    python2_explicit.patch
 Patch94:       do_not_write_before_macro_buffer.patch
 Patch95:       rpm-python-spec-header.patch
 Patch96:       skip-ldconfig-optimization.patch
+Patch97:       glibc.patch
 
 # Patches imported from Mandriva
 
@@ -1013,6 +1014,7 @@ cd -
 %patch94 -p1
 %patch95 -p1
 %patch96 -p1
+%patch97 -p1
 
 %patch1050 -p1
 
This page took 0.040424 seconds and 4 git commands to generate.