]> git.pld-linux.org Git - packages/rpm.git/commitdiff
- added rpm-apidocs subpackage with rpm api documentation generated by
authortwittner <twittner@pld-linux.org>
Sun, 22 Aug 2004 21:19:09 +0000 (21:19 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
  doxygen
- added -doxygen_hack.patch
- changed bcond name: docs -> apidocs

Changed files:
    rpm.spec -> 1.580

rpm.spec

index 32b1d6ac604eb2386a2403031f88899bbe63a45a..39a50fe8734c41b89c1273db2e1474dadeec2df5 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -8,7 +8,7 @@
 # Conditional build:
 %bcond_with    static  # build static rpmi (not supported at the moment)
 %bcond_without pkgnameinautoreq        # don't put package name in autogenerated dependancy
-%bcond_without doc     # don't generate documentation with doxygen
+%bcond_without apidocs # don't generate documentation with doxygen
 %bcond_without python  # don't build python bindings
 %bcond_without selinux # dont enable selinux support
 # force_cc             - force using __cc other than "%{_target_cpu}-pld-linux-gcc"
@@ -97,6 +97,7 @@ Patch41:      %{name}-file-readelf-fix.patch
 Patch43:       %{name}-perl_req-INC_dirs.patch
 Patch44:       %{name}-debuginfo.patch
 Patch45:       %{name}-beecrypt4.patch
+Patch46:       %{name}-doxygen_hack.patch
 Patch100:      %{name}-pl.po.patch
 URL:           http://www.rpm.org/
 Icon:          rpm.gif
@@ -554,6 +555,15 @@ construir pacotes usando o RPM.
 ò¦ÚÎÏÍÁΦÔΦ ÄÏÐÏͦÖΦ ÓËÒÉÐÔÉ ÔÁ ÕÔÉ̦ÔÉ, Ñ˦ ×ÉËÏÒÉÓÔÏ×ÕÀÔØÓÑ ÄÌÑ
 ÐÏÂÕÄÏ×É RPM'¦×.
 
+%if %{with apidocs}
+%package apidocs
+Summary: apidocs
+Group:  Documentation  
+
+%description apidocs
+rpm apidocs generated by doxygen.
+%endif
+
 %prep
 %setup -q -n %{name}
 %patch1 -p1
@@ -612,6 +622,7 @@ cat %{SOURCE11} >> macros.in
 %patch43 -p0
 %patch44 -p1
 %patch45 -p1
+%patch46 -p1
 %patch100 -p1
 %patch3 -p1
 
@@ -685,6 +696,7 @@ mv -f macros.tmp macros.in
        debugedit_LDADD="\$(WITH_LIBELF_LIB) -lpopt"
 
 #      %{!?with_static:rpm_LDFLAGS="\$(myLDFLAGS)"} \
+%{?with_docs:%{__make} doxygen}
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -1036,3 +1048,9 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 %attr(755,root,root) %{_bindir}/builder
 %attr(755,root,root) %{_bindir}/adapter.awk
 %attr(755,root,root) %{_bindir}/pldnotify.awk
+
+%if %{with apidocs}
+%files apidocs
+%defattr(644,root,root,755)
+%doc apidocs
+%endif
This page took 0.049552 seconds and 4 git commands to generate.