]> git.pld-linux.org Git - packages/rpm.git/commitdiff
fix autoreq for elf without exe bit during %install; rel 14 auto/th/rpm-4.16.1.3-14
authorJan Palus <atler@pld-linux.org>
Wed, 23 Mar 2022 10:52:33 +0000 (11:52 +0100)
committerJan Palus <atler@pld-linux.org>
Wed, 23 Mar 2022 10:52:33 +0000 (11:52 +0100)
no-exe-for-elf-req.patch [new file with mode: 0644]
rpm.spec

diff --git a/no-exe-for-elf-req.patch b/no-exe-for-elf-req.patch
new file mode 100644 (file)
index 0000000..3aa7b0f
--- /dev/null
@@ -0,0 +1,12 @@
+--- rpm-4.16.1.3/tools/elfdeps.c.orig  2020-05-28 12:04:25.084136944 +0200
++++ rpm-4.16.1.3/tools/elfdeps.c       2022-03-23 11:19:01.656202339 +0100
+@@ -300,7 +300,8 @@
+     if (ehdr->e_type == ET_DYN || ehdr->e_type == ET_EXEC) {
+       ei->marker = mkmarker(ehdr);
+       ei->isDSO = (ehdr->e_type == ET_DYN);
+-      ei->isExec = (st.st_mode & (S_IXUSR|S_IXGRP|S_IXOTH));
++      //ei->isExec = (st.st_mode & (S_IXUSR|S_IXGRP|S_IXOTH));
++      ei->isExec = 1;
+       processProgHeaders(ei, ehdr);
+       processSections(ei);
index 8b1631e2f7ae5328acc50fd099e9c1c0668fcf58..7f624d8c3befaacb93e2a49197c7f084b66e8703 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -34,7 +34,7 @@ Summary(ru.UTF-8):    Менеджер пакетов от RPM
 Summary(uk.UTF-8):     Менеджер пакетів від RPM
 Name:          rpm
 Version:       4.16.1.3
-Release:       13
+Release:       14
 Epoch:         1
 License:       GPL v2 / LGPL v2.1
 Group:         Base
@@ -95,6 +95,7 @@ Patch35:      pl-po.patch
 Patch36:       build-locale.patch
 Patch37:       %{name}-pl.po-update.patch
 Patch38:       no-exe-for-elf-debuginfo.patch
+Patch39:       no-exe-for-elf-req.patch
 URL:           https://rpm.org/
 BuildRequires: acl-devel
 %{?with_audit:BuildRequires:   audit-libs-devel}
@@ -636,6 +637,7 @@ Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
 %patch36 -p1
 %patch37 -p1
 %patch38 -p1
+%patch39 -p1
 
 %{__rm} po/*.gmo
 
This page took 0.118003 seconds and 4 git commands to generate.