]> git.pld-linux.org Git - packages/rpm.git/commitdiff
- fix spec parsing wrt unknown macros (don't treat them as empty tags) auto/th/rpm-5.4.10-42
authorJan Rękorajski <baggins@pld-linux.org>
Mon, 25 Feb 2013 13:36:38 +0000 (14:36 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Mon, 25 Feb 2013 13:36:38 +0000 (14:36 +0100)
rpm-parseSpec-skip-empty-tags.patch [new file with mode: 0644]
rpm.spec

diff --git a/rpm-parseSpec-skip-empty-tags.patch b/rpm-parseSpec-skip-empty-tags.patch
new file mode 100644 (file)
index 0000000..119cbed
--- /dev/null
@@ -0,0 +1,11 @@
+--- rpm-5.4.10/build/parseSpec.c.orig  2013-02-25 14:29:07.874848468 +0100
++++ rpm-5.4.10/build/parseSpec.c       2013-02-25 14:29:25.661698897 +0100
+@@ -92,6 +92,8 @@
+         if (aTags != NULL && aTags[0] != NULL) {
+             ARGV_t av;
+             s = tagCanonicalize(line+1);      /* XXX +1 to skip leading '%' */
++          if (strlen(s) == 0) /* not a tag, just unknown macro */
++                  goto exit;
+ #if defined(RPM_VENDOR_OPENPKG) /* wildcard-matching-arbitrary-tagnames */
+             av = argvSearchLinear(aTags, s, argvFnmatchCasefold);
+ #else
index ec2f8b667a58d7bc14c8f93e0a5697d800c7ad22..00b591a7c99e199d7215bce6bff013249d370532 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -155,6 +155,7 @@ Patch61:    %{name}-clean-docdir.patch
 Patch62:       %{name}-DB_CONFIG.patch
 Patch63:       %{name}-pythoneggs.patch
 Patch64:       %{name}-fix-compress-doc.patch
+Patch65:       %{name}-parseSpec-skip-empty-tags.patch
 
 # Patches imported from Mandriva
 
@@ -860,6 +861,7 @@ Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
 %patch62 -p1
 %patch63 -p1
 %patch64 -p1
+%patch65 -p1
 
 %patch1000 -p1
 %patch1001 -p1
This page took 0.04485 seconds and 4 git commands to generate.