]> git.pld-linux.org Git - packages/rpm.git/commitdiff
drop ruby macros here, duplicate. provided by rpm-build-macros auto/th/rpm-5.4.10-46
authorElan Ruusamäe <glen@delfi.ee>
Fri, 29 Mar 2013 19:43:55 +0000 (21:43 +0200)
committerElan Ruusamäe <glen@delfi.ee>
Fri, 29 Mar 2013 19:43:55 +0000 (21:43 +0200)
rpm.spec

index 1559c2f53078916e76822683519c7fb3e25ae348..23ff1ddf60d984085097bb7fc67bd80efea21ae3 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -52,7 +52,7 @@ Summary(ru.UTF-8):    Менеджер пакетов от RPM
 Summary(uk.UTF-8):     Менеджер пакетів від RPM
 Name:          rpm
 Version:       5.4.10
 Summary(uk.UTF-8):     Менеджер пакетів від RPM
 Name:          rpm
 Version:       5.4.10
-Release:       45
+Release:       46
 License:       LGPL
 Group:         Base
 # http://rpm5.org/files/rpm/rpm-5.4/rpm-5.4.10-0.20120706.src.rpm
 License:       LGPL
 Group:         Base
 # http://rpm5.org/files/rpm/rpm-5.4/rpm-5.4.10-0.20120706.src.rpm
@@ -621,7 +621,7 @@ Summary(ru.UTF-8):  Скрипты и утилиты, необходимые дл
 Summary(uk.UTF-8):     Скрипти та утиліти, необхідні для побудови пакетів
 Group:         Applications/File
 Requires(pre): findutils
 Summary(uk.UTF-8):     Скрипти та утиліти, необхідні для побудови пакетів
 Group:         Applications/File
 Requires(pre): findutils
-Requires:      %{name}-build-macros >= 1.653
+Requires:      %{name}-build-macros >= 1.656
 Requires:      %{name}-utils = %{version}-%{release}
 Requires:      /bin/id
 Requires:      awk
 Requires:      %{name}-utils = %{version}-%{release}
 Requires:      /bin/id
 Requires:      awk
@@ -1137,6 +1137,13 @@ rm $RPM_BUILD_ROOT%{_rpmlibdir}/vpkg-provides*
 rm $RPM_BUILD_ROOT%{_rpmlibdir}/find-{prov,req}.pl
 rm $RPM_BUILD_ROOT%{_rpmlibdir}/find-{provides,requires}.perl
 rm $RPM_BUILD_ROOT%{_rpmlibdir}/find-lang.sh
 rm $RPM_BUILD_ROOT%{_rpmlibdir}/find-{prov,req}.pl
 rm $RPM_BUILD_ROOT%{_rpmlibdir}/find-{provides,requires}.perl
 rm $RPM_BUILD_ROOT%{_rpmlibdir}/find-lang.sh
+rm $RPM_BUILD_ROOT%{_rpmlibdir}/macros.d/ruby
+rm $RPM_BUILD_ROOT%{_rpmlibdir}/lib/liblua.a
+rm $RPM_BUILD_ROOT%{_rpmlibdir}/lib/liblua.la
+rm $RPM_BUILD_ROOT%{_rpmlibdir}/mono-find-provides
+rm $RPM_BUILD_ROOT%{_rpmlibdir}/mono-find-requires
+
+%{__sed} -i -e '/macros.d\/ruby/ s/^/#/' $RPM_BUILD_ROOT%{_rpmlibdir}/macros
 
 # not installed since 4.4.8 (-tools-perl subpackage)
 install scripts/rpmdiff scripts/rpmdiff.cgi $RPM_BUILD_ROOT%{_rpmlibdir}
 
 # not installed since 4.4.8 (-tools-perl subpackage)
 install scripts/rpmdiff scripts/rpmdiff.cgi $RPM_BUILD_ROOT%{_rpmlibdir}
@@ -1471,7 +1478,6 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 %{_rpmlibdir}/macros.d/php
 %{_rpmlibdir}/macros.d/pkgconfig
 %{_rpmlibdir}/macros.d/python
 %{_rpmlibdir}/macros.d/php
 %{_rpmlibdir}/macros.d/pkgconfig
 %{_rpmlibdir}/macros.d/python
-%{_rpmlibdir}/macros.d/ruby
 %{_rpmlibdir}/macros.d/selinux
 %{_rpmlibdir}/macros.d/tcl
 %{_rpmlibdir}/macros.rpmbuild
 %{_rpmlibdir}/macros.d/selinux
 %{_rpmlibdir}/macros.d/tcl
 %{_rpmlibdir}/macros.rpmbuild
This page took 0.059906 seconds and 4 git commands to generate.