]> git.pld-linux.org Git - packages/rpm.git/commitdiff
- requires lua 5.3
authorJan Rękorajski <baggins@pld-linux.org>
Thu, 26 Dec 2019 15:42:07 +0000 (00:42 +0900)
committerJan Rękorajski <baggins@pld-linux.org>
Thu, 26 Dec 2019 15:42:07 +0000 (00:42 +0900)
rpm-lua.patch
rpm.spec

index e253eb678f4fbf1b3fd887150fc5bfcc018f85eb..4e92e7b88d561cd93ad8c966526ebd0f8bf51895 100644 (file)
@@ -5,7 +5,7 @@
  AS_IF([test "$with_lua" != no],[
    PKG_CHECK_MODULES([LUA],
 -    [lua >= 5.1],
-+    [lua51 >= 5.1],
++    [lua5.3 >= 5.3],
      [AC_DEFINE(WITH_LUA, 1, [Build with lua support?])],
      [AC_MSG_ERROR([lua not present (--without-lua to disable)])])
    AC_SUBST(LUA_CFLAGS)
index fb7b77059b4619f5864cb85d56a7cf2162868ef0..3c079d92e6e7c6b47a7d67e8c54e4e1b384fc62e 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -136,7 +136,7 @@ BuildRequires:      libtool >= 1:1.4.2-9
 BuildRequires: libxml2-devel
 BuildRequires: neon-devel >= 0.25.5
 %endif
-BuildRequires: lua52-devel >= 5.2.2
+BuildRequires: lua53-devel >= 5.3.5
 BuildRequires: ossp-uuid-devel
 BuildRequires: patch >= 2.2
 BuildRequires: popt-devel >= %{reqpopt_ver}
@@ -730,7 +730,7 @@ sed -i \
        -e 's|@host_os@|%{_target_os}|' \
        macros.in
 
-CPPFLAGS="-I/usr/include/lua51 %{rpmcppflags}"
+CPPFLAGS="-I/usr/include/lua53 %{rpmcppflags}"
 %configure \
        WITH_PERL_VERSION=no \
        __GST_INSPECT=%{_bindir}/gst-inspect-1.0 \
@@ -765,9 +765,7 @@ CPPFLAGS="-I/usr/include/lua51 %{rpmcppflags}"
        --with-xz=external \
        --with-zlib=external
 
-%{__make} -j1
-
-%{?with_apidocs:%{__make} apidocs}
+%{__make}
 
 %{__cc} %{rpmcflags} -I/usr/include/db%{reqdb_ver} tools/rpmdb_checkversion.c \
        -o tools/rpmdb_checkversion -ldb-%{reqdb_ver}
@@ -926,7 +924,6 @@ EOF
 # Squash Extra Blank Lines
 %{__sed} -i -e '/./,/^$/!d' $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
 
-%{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/vpkg-provides*
 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/find-{prov,req}.pl
 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/find-{provides,requires}.perl
 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/find-lang.sh
This page took 0.047397 seconds and 4 git commands to generate.