]> git.pld-linux.org Git - packages/rpm.git/commitdiff
- added 4.1-branch-po-updates (updates for message changed by 4.1-branch patch)
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 24 Nov 2002 19:26:43 +0000 (19:26 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- link patch - add dependencies to lib*_LIBADD instead of hacking lib*.la
- beecrypt-opt patch - don't override optflags in libbeecrypt on x86
- changes in rpm.macros:
  - more heuristics in %%__gettextize (allow non-external gt 0.11 and external
    gt without po/Makevars)
  - new %%__autopoint macro (=autopoint --force)
- avoid build trap - define __gettextize to not require very fresh rpm to build
- release 5 (beecrypt rel. 2)

Changed files:
    rpm-4.1-branch-po-updates.patch -> 1.1
    rpm-beecrypt-opt.patch -> 1.1
    rpm-link.patch -> 1.1
    rpm.macros -> 1.94
    rpm.spec -> 1.368

rpm-4.1-branch-po-updates.patch [new file with mode: 0644]
rpm-beecrypt-opt.patch [new file with mode: 0644]
rpm-link.patch [new file with mode: 0644]
rpm.macros
rpm.spec

diff --git a/rpm-4.1-branch-po-updates.patch b/rpm-4.1-branch-po-updates.patch
new file mode 100644 (file)
index 0000000..20e7dc3
--- /dev/null
@@ -0,0 +1,36 @@
+diff -Nur rpm-4.1/po.orig/pl.po rpm-4.1/po/pl.po
+--- rpm-4.1/po.orig/pl.po      Sun Nov 24 18:56:42 2002
++++ rpm-4.1/po/pl.po   Sun Nov 24 18:58:25 2002
+@@ -3055,7 +3055,7 @@
+ #.
+ #: lib/transaction.c:1021
+ #, c-format
+-msgid "sanity checking %d elments\n"
++msgid "sanity checking %d elements\n"
+ msgstr "sprawdzanie poprawno¶ci %d elementów\n"
+ #. ===============================================
+diff -Nur rpm-4.1/po.orig/ru.po rpm-4.1/po/ru.po
+--- rpm-4.1/po.orig/ru.po      Tue Sep 17 21:38:06 2002
++++ rpm-4.1/po/ru.po   Sun Nov 24 18:58:34 2002
+@@ -3065,7 +3065,7 @@
+ #.
+ #: lib/transaction.c:1021
+ #, c-format
+-msgid "sanity checking %d elments\n"
++msgid "sanity checking %d elements\n"
+ msgstr "ÐÒÏ×eÒÑÅÔÓÑ %d ÜÌÅÍÅÎÔÏ×\n"
+ #. ===============================================
+diff -Nur rpm-4.1/po.orig/sv.po rpm-4.1/po/sv.po
+--- rpm-4.1/po.orig/sv.po      Tue Sep 17 21:38:08 2002
++++ rpm-4.1/po/sv.po   Sun Nov 24 18:58:42 2002
+@@ -3048,7 +3048,7 @@
+ #.
+ #: lib/transaction.c:1021
+ #, c-format
+-msgid "sanity checking %d elments\n"
++msgid "sanity checking %d elements\n"
+ msgstr "rimlighetskontrollerar %d element\n"
+ #. ===============================================
diff --git a/rpm-beecrypt-opt.patch b/rpm-beecrypt-opt.patch
new file mode 100644 (file)
index 0000000..14b7df1
--- /dev/null
@@ -0,0 +1,52 @@
+--- rpm-4.1/beecrypt/configure.ac.orig Sat Jun 15 20:49:02 2002
++++ rpm-4.1/beecrypt/configure.ac      Sun Nov 24 19:51:39 2002
+@@ -82,11 +82,6 @@
+ AC_PROG_CXX
+ AC_PROG_LIBTOOL
+-# Initialize tool flags
+-CFLAGS=""
+-CPPFLAGS=""
+-LDFLAGS=""
+-
+ # Checks for compiler characteristics and flags
+ if test "$ac_cv_prog_gcc" != yes; then
+   AC_CACHE_CHECK([whether we are using Sun Workshop C], ac_cv_prog_SUNPRO_CC, [
+@@ -706,7 +697,6 @@
+   fi
+ else
+   if test "$ac_cv_prog_gcc" = yes; then
+-    CFLAGS="$CFLAGS -O3 -g"
+     if test "$ac_enable_optimized" = yes; then
+       case $target_cpu in
+ # This switch makes the mp32 routines slower by about 10%, so it's disabled
+@@ -717,16 +707,16 @@
+         CFLAGS="$CFLAGS -fomit-frame-pointer"
+         ;;
+       i386)
+-        CFLAGS="$CFLAGS -march=i386 -mcpu=i686 -fomit-frame-pointer"
++        CFLAGS="$CFLAGS -fomit-frame-pointer"
+         ;;
+       i486)
+-        CFLAGS="$CFLAGS -march=i386 -mcpu=i686 -fomit-frame-pointer"
++        CFLAGS="$CFLAGS -fomit-frame-pointer"
+         ;;
+       i586)
+-        CFLAGS="$CFLAGS -march=i386 -mcpu=i686 -fomit-frame-pointer"
++        CFLAGS="$CFLAGS -fomit-frame-pointer"
+         ;;
+       i686)
+-      CFLAGS="$CFLAGS -march=i386  -mcpu=i686 -fomit-frame-pointer"
++      CFLAGS="$CFLAGS -fomit-frame-pointer"
+         ;;
+       sparc)
+         CFLAGS="$CFLAGS -m32 -mtune=ultrasparc"
+@@ -787,8 +777,6 @@
+     if test "$ac_enable_threads" = yes; then
+       CFLAGS="$CFLAGS -pthread"
+     fi
+-  else
+-    CFLAGS="$CFLAGS -O2"
+   fi
+ fi
diff --git a/rpm-link.patch b/rpm-link.patch
new file mode 100644 (file)
index 0000000..350fd2f
--- /dev/null
@@ -0,0 +1,73 @@
+--- rpm-4.1/build/Makefile.am.orig     Mon Jul 22 00:06:19 2002
++++ rpm-4.1/build/Makefile.am  Sun Nov 24 19:25:53 2002
+@@ -23,12 +23,7 @@
+       parseFiles.c parsePreamble.c parsePrep.c parseReqs.c parseScript.c \
+       parseSpec.c poptBT.c reqprov.c spec.c
+ librpmbuild_la_LDFLAGS = -release @VERSION@
+-
+-# XXX Add internal libtool dependence
+-install-data-local:
+-      @cd $(DESTDIR)/$(libdir) && \
+-      sed -e "s|^dependency_libs='|& -lrpm-@VERSION@|" < librpmbuild.la > .librpmbuild.la && \
+-      mv .librpmbuild.la librpmbuild.la
++librpmbuild_la_LIBADD = ../lib/librpm.la
+ #BUILT_SOURCES = rpmbuild.lcd
+--- rpm-4.1/lib/Makefile.am.orig       Fri Aug 30 13:41:54 2002
++++ rpm-4.1/lib/Makefile.am    Sun Nov 24 19:29:23 2002
+@@ -38,12 +38,7 @@
+       signature.c stringbuf.c transaction.c \
+       verify.c
+ librpm_la_LDFLAGS = -release @VERSION@
+-
+-# XXX Add internal libtool dependence
+-install-data-local:
+-      @cd $(DESTDIR)/$(libdir) && \
+-      sed -e "s|^dependency_libs='|& -lrpmdb-@VERSION@ -lrpmio-@VERSION@ -lpopt|" < librpm.la > .librpm.la && \
+-      mv .librpm.la librpm.la
++librpm_la_LIBADD = ../rpmdb/librpmdb.la ../rpmio/librpmio.la -lpopt
+ getdate.c: getdate.y
+       @echo expect 10 shift/reduce conflicts
+--- rpm-4.1/rpmdb/Makefile.am.orig     Fri Aug 30 15:12:01 2002
++++ rpm-4.1/rpmdb/Makefile.am  Sun Nov 24 19:30:41 2002
+@@ -40,18 +40,12 @@
+       poptDB.c rpmhash.c rpmdb.c \
+       tagname.c tagtbl.c
+ librpmdb_la_LDFLAGS = -release @VERSION@ @libdb3@
+-librpmdb_la_LIBADD = $(DBLIBOBJS) $(DB3LOBJS) @WITH_LIBELF_LIB@
++librpmdb_la_LIBADD = ../rpmio/librpmio.la $(DBLIBOBJS) $(DB3LOBJS) @WITH_LIBELF_LIB@
+ librpmdb_la_DEPENDENCIES = $(DBLIBOBJS) .created
+ # XXX make sure that db.h symlink is generated
+ dbconfig.c: db.h
+-# XXX Add internal libtool dependence
+-install-data-local:
+-      @cd $(DESTDIR)/$(libdir) && \
+-      sed -e "s|^dependency_libs='|& -lrpmio-@VERSION@|" < librpmdb.la > .librpmdb.la && \
+-      mv .librpmdb.la librpmdb.la
+-
+ tagtbl.c: Makefile.am $(top_srcdir)/lib/rpmlib.h 
+       @echo '/*@-bounds@*/' > $@
+       @echo '#include "system.h"' >> $@
+--- rpm-4.1/rpmio/Makefile.am.orig     Sun Nov 24 19:22:06 2002
++++ rpm-4.1/rpmio/Makefile.am  Sun Nov 24 19:31:18 2002
+@@ -26,15 +26,9 @@
+       rpmio.c rpmlog.c rpmmalloc.c \
+       rpmpgp.c rpmrpc.c strcasecmp.c stubs.c url.c ugid.c
+ librpmio_la_LDFLAGS = -release @VERSION@ @WITH_ZLIB_LIB@ -lrt -lpthread
+-librpmio_la_LIBADD = $(BEECRYPTLOBJS)
++librpmio_la_LIBADD = -lpopt $(BEECRYPTLOBJS)
+ librpmio_la_DEPENDENCIES = .created
+-# XXX Add internal libtool dependence
+-install-data-local:
+-      @cd $(DESTDIR)/$(libdir) && \
+-      sed -e "s|^dependency_libs='|& -lpopt|" < librpmio.la > .librpmio.la && \
+-      mv .librpmio.la librpmio.la
+-
+ $(top_builddir)/beecrypt/listobjs:
+       ${MAKE} -C $(top_builddir)/beecrypt listobjs
index 36d079a72f15fdd2904a7af6bcc7eb5c96e20005..e5b4b7dc0a08898eec175f0857ddc982f2cc18bd 100644 (file)
 %__libtoolize           libtoolize --copy --force
 %__gettextize { \
     if ! gettextize --version | grep -q '0\.10\.' ; then \
-       if [ -f po/Makevars ]; then \
-           gettextize --copy --force --no-changelog; \
-       else \
-           gettextize --copy --force --no-changelog --intl; \
-              cp -f po/Makevars{.template,}; \
-          fi; \
+       if grep -qs 'AM_GNU_GETTEXT.*external' configure.{ac,in} ; then \
+           gettextize --copy --force --no-changelog; \
        else \
-               gettextize --copy --force; \
+           gettextize --copy --force --no-changelog --intl; \
+       fi; \
+       if [ ! -f po/Makevars ]; then \
+           cp -f po/Makevars{.template,}; \
+       fi; \
+    else \
+       gettextize --copy --force; \
     fi; \
-}              
+}
+%__autopoint            autopoint --force
 %__automake             automake -a -c -f --foreign
 %__autoconf             autoconf %{?debug:-Wall}
 
index 8fa9f53a7ca234605d2330d1f24e7af2b7eeedfb..298c2ab38f497a853da89839ede06dcb7c9c739a 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -1,6 +1,6 @@
 %include        /usr/lib/rpm/macros.python
 %define        beecrypt_ver    2.2.0
-%define        beecrypt_rel    1.5
+%define        beecrypt_rel    2
 Summary:       RPM Package Manager
 Summary(de):   RPM Packet-Manager
 Summary(es):   Gestor de paquetes RPM
@@ -8,7 +8,7 @@ Summary(pl):    Aplikacja do zarz
 Summary(pt_BR):        Gerenciador de pacotes RPM
 Name:          rpm
 Version:       4.1
-Release:       4
+Release:       5
 License:       GPL
 Group:         Base
 Source0:       ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.1.x/%{name}-%{version}.tar.gz
@@ -58,6 +58,9 @@ Patch22:      %{name}-build.patch
 Patch23:       %{name}-python-link.patch
 Patch24:       %{name}-system_libs.patch
 Patch25:       %{name}-bb-and-short-circuit.patch
+Patch26:       %{name}-4.1-branch-po-updates.patch
+Patch27:       %{name}-link.patch
+Patch28:       %{name}-beecrypt-opt.patch
 URL:           http://www.rpm.org/
 Icon:          rpm.gif
 BuildRequires: autoconf >= 2.52
@@ -89,6 +92,9 @@ Conflicts:    glibc < 2.2.92
 %define                __find_provides %{SOURCE4}
 %define                _binary_payload w9.gzdio
 
+# don't require very fresh rpm.macros to build
+%define                __gettextize gettextize --copy --force --intl ; cp -f po/Makevars{.template,}
+
 %description
 RPM is a powerful package manager, which can be used to build,
 install, query, verify, update, and uninstall individual software
@@ -416,6 +422,9 @@ Statyczna wersja biblioteki kryptograficznej.
 %patch23 -p1
 %patch24 -p1
 %patch25 -p1
+%patch26 -p1
+%patch27 -p1
+%patch28 -p1
 
 sed -e 's/^/@pld@/' %{SOURCE2} >>platform.in
 cp -f platform.in macros.pld.in
@@ -459,8 +468,7 @@ rm -f missing
 %{__libtoolize}
 %{__gettextize}
 %{__aclocal}
-autoupdate
-%{__autoheader} || :
+%{__autoheader}
 %{__autoconf}
 %{__automake}
 
This page took 0.060391 seconds and 4 git commands to generate.