]> git.pld-linux.org Git - packages/rpm.git/commitdiff
ruby: generate abi deps also for ruby *.so files
authorElan Ruusamäe <glen@delfi.ee>
Thu, 25 Apr 2013 22:12:08 +0000 (01:12 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Thu, 25 Apr 2013 22:12:08 +0000 (01:12 +0300)
rpm.spec
rubyprov-archdirs.patch [new file with mode: 0644]

index f307ceb10e03377b1a51f292303956e31b2ddd07..704719156b606553224efe04cc4f3317a45635c5 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -159,6 +159,7 @@ Patch64:    %{name}-fix-compress-doc.patch
 Patch65:       %{name}-parseSpec-skip-empty-tags.patch
 Patch66:       %{name}-payload-use-hashed-inode.patch
 Patch67:       rpm-repackage-dont-force-max-compression.patch
+Patch68:       rubyprov-archdirs.patch
 
 # Patches imported from Mandriva
 
@@ -928,6 +929,7 @@ Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
 %patch1040 -p1
 %patch1041 -p1
 %patch1042 -p1
+%patch68 -p1
 
 install %{SOURCE2} macros/pld.in
 install %{SOURCE8} scripts/php.prov.in
diff --git a/rubyprov-archdirs.patch b/rubyprov-archdirs.patch
new file mode 100644 (file)
index 0000000..1e0036b
--- /dev/null
@@ -0,0 +1,19 @@
+--- rpm-5.4.10/scripts/rubygems.rb~    2013-04-26 00:28:59.955288629 +0300
++++ rpm-5.4.10/scripts/rubygems.rb     2013-04-26 00:43:35.122569376 +0300
+@@ -51,10 +51,16 @@
+   elsif not ruby_versioned
+     if path.match(RbConfig::CONFIG["rubylibdir"])
+       ruby_versioned = true
++    elsif path.match(RbConfig::CONFIG["archdir"])
++      ruby_versioned = true
+     elsif path.match(RbConfig::CONFIG["sitelibdir"])
+       ruby_versioned = true
++    elsif path.match(RbConfig::CONFIG["sitearchdir"])
++      ruby_versioned = true
+     elsif path.match(RbConfig::CONFIG["vendorlibdir"])
+       ruby_versioned = true
++    elsif path.match(RbConfig::CONFIG["vendorarchdir"])
++      ruby_versioned = true
+     end
+   end
+ end
This page took 0.035186 seconds and 4 git commands to generate.