]> git.pld-linux.org Git - packages/rpm.git/commitdiff
- use internal glob(). auto/th/rpm-4_4_1-1_99
authorPaweł Sikora <pluto@pld-linux.org>
Fri, 15 Jul 2005 21:02:26 +0000 (21:02 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    rpm-glob.patch -> 1.4
    rpm.spec -> 1.675

rpm-glob.patch [new file with mode: 0644]
rpm.spec

diff --git a/rpm-glob.patch b/rpm-glob.patch
new file mode 100644 (file)
index 0000000..9ece1e8
--- /dev/null
@@ -0,0 +1,59 @@
+--- rpm-4.4.1/configure.ac.orig        2005-07-15 20:06:31.000000000 +0000
++++ rpm-4.4.1/configure.ac     2005-07-15 20:22:45.000000000 +0000
+@@ -619,7 +619,6 @@
+ dnl popt w float/double needs.
+ AC_CHECK_HEADERS(float.h)
+-AC_CHECK_HEADERS(glob.h)
+ dnl statfs portability fiddles.
+ dnl
+@@ -843,10 +842,10 @@
+ dnl XXX Glob is "fixed" in glibc-2.3.3-61, but the cost is that
+ dnl dangling symlinks are no longer globbed. Always use the internal glob.
+ dnl
+-#AC_ARG_WITH(glob, [  --with-glob             use the internal GNU glob ],
+-#    [rpm_cv_glob=yes],
+-#    [AC_CHECK_FUNCS(glob, rpm_cv_glob=no, rpm_cv_glob=yes)])
+-#
++AC_ARG_WITH(glob, [  --with-glob             use the internal GNU glob ],
++    [rpm_cv_glob=yes],
++    [AC_CHECK_FUNCS(glob, rpm_cv_glob=no, rpm_cv_glob=yes)])
++
+ #if test $rpm_cv_glob = no ; then
+ #    AC_CACHE_CHECK([for GNU extensions to glob], rpm_cv_glob_ext, [
+ #    rm -f t
+@@ -870,11 +869,11 @@
+ #    fi
+ #fi
+ #
+-#if test "$rpm_cv_glob" = yes; then
++if test "$rpm_cv_glob" = yes; then
+     AC_DEFINE(USE_GNU_GLOB, 1, [Use the included glob.c?])
+     AC_LIBOBJ(glob)
+     AC_LIBOBJ(fnmatch)
+-#fi
++fi
+ dnl
+ dnl Auto-detect which python bindings should be built.
+ dnl
+--- rpm-4.4.1/misc/glob.c.orig 2005-01-28 06:19:54.000000000 +0000
++++ rpm-4.4.1/misc/glob.c      2005-07-15 20:35:31.000000000 +0000
+@@ -130,7 +130,7 @@
+    If memory cannot be allocated for PGLOB, GLOB_NOSPACE is returned.
+    Otherwise, `glob' returns zero.  */
+ int
+-glob (const char *pattern, int flags,
++rpm_glob (const char *pattern, int flags,
+       int (*errfunc) __P ((const char *, int)), glob_t *pglob)
+ {
+   const char *filename;
+@@ -831,7 +831,7 @@
+ /* Free storage allocated in PGLOB by a previous `glob' call.  */
+ void
+-globfree (glob_t *pglob)
++rpm_globfree (glob_t *pglob)
+ {
+   if (pglob->gl_pathv != NULL)
+     {
index c03e8d03612c492c7ac39c67738e6ec6a6bc4245..e2d937c4e5b9cb0d166d90b843812ad416da11a2 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -30,7 +30,7 @@ Summary(uk):  
 Name:          rpm
 %define        sover   4.4
 Version:       4.4.1
-Release:       1.12
+Release:       1.99
 License:       GPL
 Group:         Base
 Source0:       ftp://jbj.org/pub/rpm-4.4.x/%{name}-%{version}.tar.gz
@@ -96,6 +96,7 @@ Patch38:      %{name}-gcc4.patch
 Patch39:       %{name}-pythondeps.patch
 Patch40:       %{name}-print-requires.patch
 Patch41:       %{name}-reduce-stack-usage.patch
+Patch42:       %{name}-glob.patch
 URL:           http://www.rpm.org/
 Icon:          rpm.gif
 BuildRequires: autoconf >= 2.52
@@ -622,6 +623,7 @@ cat %{SOURCE11} >> macros.in
 %patch39 -p1
 %patch40 -p1
 %patch41 -p1
+%patch42 -p1
 %patch0 -p1
 %patch3 -p1
 
@@ -680,6 +682,7 @@ CPPFLAGS="-Dglob=rpm_glob -Dglobfree=rpm_globfree"; export CPPFLAGS
        %{?with_python:--with-python=auto} \
        %{!?with_python:--without-python} \
        %{!?with_selinux:--without-selinux} \
+       --with-glob \
        --without-db
 
 # file_LDFLAGS, debugedit_LDADD - no need to link "file" and "debugedit" statically
This page took 0.043236 seconds and 4 git commands to generate.