]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm.spec
- fixed (finally?) GConf scripts, rel 0.6
[packages/rpm.git] / rpm.spec
index cf3ffe35a8cc9208c73b8e5879feda52f9e23e23..fbe1b0cb7e65365933316e92ed9971b4d104e08c 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -1,24 +1,28 @@
 #
 # TODO:
-# - use system libmagic not internal libfmagic
-# - when really needed: _noauto{req,prov} for non-helper-generated deps
-#
+# - detected Requires lists are not printed at the end of build (Provides etc. are)
+# - fix pythondeps detection (*.py[co] should belong to python class; autodetect P(abi))
+# - consider using system libmagic not internal libfmagic
+#   (but internal has different method of passing output)
+# - after ac drop amd64 patch and make x86_64 generic arch + subarchs amd64 and ia32e
+# 
 # Conditional build:
+%bcond_with    distver # build with distversion field
 %bcond_with    static  # build static rpmi (not supported at the moment)
-%bcond_without doc     # don't generate documentation with doxygen
+%bcond_without apidocs # don't generate documentation with doxygen
+%bcond_with    pkgnameinautoreq        # don't put package name in autogenerated dependancy
 %bcond_without python  # don't build python bindings
 %bcond_without selinux # dont enable selinux support
 # force_cc             - force using __cc other than "%{_target_cpu}-pld-linux-gcc"
 # force_cxx            - force using __cxx other than "%{_target_cpu}-pld-linux-g++"
 # force_cpp            - force using __cpp other than "%{_target_cpu}-pld-linux-gcc -E"
 
-%include        /usr/lib/rpm/macros.python
-%define snap   20040107
+%define        snap    20041121
 # versions of required libraries
-%define        reqdb_ver       4.2.50-1
-%define        reqpopt_ver     1.9
-%define        beecrypt_ver    3.0.0-0.20030610.1
-%define rpm_macros_rev 1.145
+%define        reqdb_ver       4.3.27-1
+%define        reqpopt_ver     1.10.1
+%define        beecrypt_ver    2:4.1.0
+%define        rpm_macros_rev  1.196
 Summary:       RPM Package Manager
 Summary(de):   RPM Packet-Manager
 Summary(es):   Gestor de paquetes RPM
@@ -27,14 +31,15 @@ Summary(pt_BR):     Gerenciador de pacotes RPM
 Summary(ru):   íÅÎÅÄÖÅÒ ÐÁËÅÔÏ× ÏÔ RPM
 Summary(uk):   íÅÎÅÄÖÅÒ ÐÁËÅԦנצĠRPM
 Name:          rpm
-%define        ver     4.3
-Version:       %{ver}
-Release:       0.%{snap}.17
+%define        sover   4.4
+Version:       4.4.1
+Release:       0.6
 License:       GPL
 Group:         Base
 #Source0:      ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.2.x/%{name}-%{version}.%{snap}.tar.gz
-Source0:       ftp://distfiles.pld-linux.org/src/%{name}-%{version}.%{snap}.tar.bz2
-# Source0-md5: c1bc4a2ae441fbd4da8dd90149bab2f2
+# Snap tarball is generated from rpm-4_4 branch
+Source0:       ftp://jbj.org/pub/rpm-4.4.x/%{name}-%{version}.tar.gz
+# Source0-md5: 90ded9047b1b69d918c6c7c7b56fd7a9
 Source1:       %{name}.groups
 Source2:       %{name}.platform
 Source3:       %{name}-install-tree
@@ -47,53 +52,54 @@ Source9:    %{name}-php-provides
 Source10:      %{name}-php-requires
 Source11:      %{name}.macros
 Source12:      perl.prov
+Source13:      %{name}-user_group.sh
+Source14:      %{name}.sysconfig
 Source30:      builder
 Source31:      adapter.awk
 Source32:      pldnotify.awk
+# http://svn.pld-linux.org/banner.sh/
+Source33:      banner.sh
 Patch0:                %{name}-pl.po.patch
 Patch1:                %{name}-rpmrc.patch
 Patch2:                %{name}-arch.patch
 Patch3:                %{name}-rpmpopt.patch
 Patch4:                %{name}-perl-macros.patch
 Patch5:                %{name}-perl-req-perlfile.patch
-Patch6:                %{name}-glob.patch
-Patch7:                %{name}-noexpand.patch
-Patch8:                %{name}-scripts-closefds.patch
-Patch9:                %{name}-python-macros.patch
-Patch10:       %{name}-gettext-in-header.patch
-Patch11:       %{name}-compress-doc.patch
-Patch12:       %{name}-build.patch
-Patch13:       %{name}-system_libs.patch
-Patch14:       %{name}-bb-and-short-circuit.patch
-Patch15:       %{name}-etc_dir.patch
-Patch16:       %{name}-system_libs-more.patch
-Patch17:       %{name}-php-deps.patch
-Patch18:       %{name}-python-fix.patch
-Patch19:       %{name}-ldconfig-always.patch
-Patch20:       %{name}-perl_req.patch
-Patch21:       %{name}-no-bin-env.patch
-Patch22:       %{name}-magic-usesystem.patch
-Patch23:       %{name}-dontneedutils.patch
-Patch24:       %{name}-provides-dont-obsolete.patch
-Patch25:       %{name}-examplesaredoc.patch
-Patch26:       %{name}-po.patch
-Patch27:       %{name}-amd64.patch
-Patch28:       %{name}-notsc.patch
-Patch29:       %{name}-hack-norpmlibdep.patch
-Patch30:       %{name}-makefile-no_myLDADD_deps.patch
-Patch31:       %{name}-libdir64.patch
-Patch32:       %{name}-libdir-links.patch
-Patch33:       %{name}-context.patch
-Patch34:       %{name}-nls-fixes.patch
-Patch35:       %{name}-missing-prototypes.patch
-Patch36:       %{name}-pld-autodep.patch
-Patch37:       %{name}-rpmsq.patch
-Patch38:       %{name}-file-readelf.patch
-Patch39:       %{name}-pentiumX.patch
-Patch40:       %{name}-epoch0.patch
-Patch41:       %{name}-file-readelf-fix.patch
-Patch42:       %{name}-cpuid.patch
-Patch43:       %{name}-perl_req-INC_dirs.patch
+Patch6:                %{name}-noexpand.patch
+Patch7:                %{name}-scripts-closefds.patch
+Patch8:                %{name}-python-macros.patch
+Patch9:                %{name}-gettext-in-header.patch
+Patch10:       %{name}-compress-doc.patch
+Patch11:       %{name}-build.patch
+Patch12:       %{name}-system_libs.patch
+Patch13:       %{name}-bb-and-short-circuit.patch
+Patch14:       %{name}-etc_dir.patch
+Patch15:       %{name}-system_libs-more.patch
+Patch16:       %{name}-php-deps.patch
+Patch17:       %{name}-ldconfig-always.patch
+Patch18:       %{name}-perl_req.patch
+Patch19:       %{name}-no-bin-env.patch
+Patch20:       %{name}-magic-usesystem.patch
+Patch21:       %{name}-dontneedutils.patch
+Patch22:       %{name}-provides-dont-obsolete.patch
+Patch23:       %{name}-examplesaredoc.patch
+Patch24:       %{name}-po.patch
+Patch25:       %{name}-amd64.patch
+Patch26:       %{name}-notsc.patch
+Patch27:       %{name}-hack-norpmlibdep.patch
+Patch28:       %{name}-makefile-no_myLDADD_deps.patch
+Patch29:       %{name}-libdir64.patch
+Patch30:       %{name}-libdir-links.patch
+Patch31:       %{name}-missing-prototypes.patch
+Patch32:       %{name}-pld-autodep.patch
+Patch33:       %{name}-rpmsq.patch
+Patch34:       %{name}-epoch0.patch
+Patch35:       %{name}-perl_req-INC_dirs.patch
+Patch36:       %{name}-debuginfo.patch
+Patch37:       %{name}-doxygen_hack.patch
+Patch38:       %{name}-distver.patch
+Patch39:       %{name}-gcc4.patch
+Patch40:       %{name}-pythondeps.patch
 URL:           http://www.rpm.org/
 Icon:          rpm.gif
 BuildRequires: autoconf >= 2.52
@@ -101,18 +107,23 @@ BuildRequires:    automake
 BuildRequires: beecrypt-devel >= %{beecrypt_ver}
 BuildRequires: bzip2-devel >= 1.0.1
 BuildRequires: db-devel >= %{reqdb_ver}
-%{?with_doc:BuildRequires:     doxygen}
-BuildRequires: gettext-devel >= 0.11.4-2
+%{?with_apidocs:BuildRequires: doxygen}
 BuildRequires: elfutils-devel
+BuildRequires: findutils
+BuildRequires: gettext-devel >= 0.11.4-2
 #BuildRequires:        libmagic-devel
-%{?with_selinux:BuildRequires: libselinux-devel}
+%{?with_selinux:BuildRequires: libselinux-devel >= 1.18}
+# needed only for AM_PROG_CXX used for CXX substitution in rpm.macros
+BuildRequires: libstdc++-devel
 BuildRequires: libtool
+BuildRequires: libxml2-devel
+BuildRequires: neon-devel >= 0.24.7-3
 BuildRequires: patch >= 2.2
 BuildRequires: popt-devel >= %{reqpopt_ver}
 %{?with_python:BuildRequires:  python-devel >= 2.2}
 BuildRequires: python-modules >= 2.2
+BuildRequires: readline-devel
 BuildRequires: rpm-perlprov
-BuildRequires: rpm-pythonprov
 BuildRequires: zlib-devel
 %if %{with static}
 # Require static library only for static build
@@ -122,10 +133,11 @@ BuildRequires:    db-static >= %{reqdb_ver}
 BuildRequires: glibc-static >= 2.2.94
 BuildRequires: elfutils-static
 #BuildRequires:        libmagic-static
-%{?with_selinux:BuildRequires: libselinux-static}
+%{?with_selinux:BuildRequires: libselinux-static >= 1.18}
 BuildRequires: popt-static >= %{reqpopt_ver}
 BuildRequires: zlib-static
 %endif
+Requires:      beecrypt >= %{beecrypt_ver}
 Requires:      popt >= %{reqpopt_ver}
 Requires:      %{name}-lib = %{version}-%{release}
 %{!?with_static:Obsoletes:     rpm-utils-static}
@@ -139,11 +151,12 @@ BuildRoot:        %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 # don't require very fresh rpm.macros to build
 %define                __gettextize gettextize --copy --force --intl ; cp -f po/Makevars{.template,}
+%define                ix86 i386 i486 i586 i686 athlon pentium3 pentium4
 
 # stabilize new build environment
-%define                __cc %{?force_cc}%{!?force_cc:%{_target_cpu}-pld-linux-gcc}
-%define                __cxx %{?force_cxx}%{!?force_cxx:%{_target_cpu}-pld-linux-g++}
-%define                __cpp %{?force_cpp}%{!?force_cpp:%{_target_cpu}-pld-linux-gcc -E}
+%define                __newcc %{?force_cc}%{!?force_cc:%{_target_cpu}-pld-linux-gcc}
+%define                __newcxx %{?force_cxx}%{!?force_cxx:%{_target_cpu}-pld-linux-g++}
+%define                __newcpp %{?force_cpp}%{!?force_cpp:%{_target_cpu}-pld-linux-gcc -E}
 
 %define                _rpmlibdir /usr/lib/rpm
 
@@ -196,6 +209,23 @@ RPM - 
 ÓÌÕÖÂÏ×ϧ ¦ÎÆÏÒÍÁæ§, ÝϠͦÓÔÉÔØ ÎÁÚ×Õ, ×ÅÒÓ¦À, ÏÐÉÓ ÔÁ ¦ÎÛÕ
 ¦ÎÆÏÒÍÁæÀ ÐÒÏ ÐÁËÅÔ.
 
+%package lib
+Summary:       RPMs library
+Summary(pl):   Biblioteki RPM-a
+Group:         Libraries
+Requires:      db >= %{reqdb_ver}
+%{?with_selinux:BuildRequires: libselinux >= 1.18}
+Requires:      popt >= %{reqpopt_ver}
+%{?with_distver:Provides:      rpm-lib(distver)}
+# avoid SEGV caused by mixed db versions
+Conflicts:     poldek < 0.18.1-16
+
+%description lib
+RPMs library.
+
+%description lib -l pl
+Biblioteki RPM-a.
+
 %package devel
 Summary:       Header files for rpm libraries
 Summary(de):   Header-Dateien für rpm Libraries
@@ -350,102 +380,6 @@ Aktualnie pakiet zawiera binark
 uaktualniania lub usuwania pakietów bez udzia³u bibliotek statycznych
 (z wyj±tkiem modu³ów NSS).
 
-%package perlprov
-Summary:       Additional utilities for checking perl provides/requires in rpm packages
-Summary(de):   Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
-Summary(pl):   Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów perla w pakietach rpm
-Group:         Applications/File
-Requires:      %{name} = %{version}-%{release}
-Requires:      perl-devel
-Requires:      perl-modules
-
-%description perlprov
-Additional utilities for checking perl provides/requires in rpm
-packages.
-
-%description perlprov -l de
-Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
-
-%description perlprov -l pl
-Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów perla w
-pakietach rpm.
-
-%package pythonprov
-Summary:       Python macros, which simplifies creation of rpm packages with Python software
-Summary(pl):   Makra u³atwiaj±ce tworzenie pakietów rpm z programami napisanymi w Pythonie
-Group:         Applications/File
-Requires:      %{name} = %{version}-%{release}
-Requires:      python-modules
-
-%description pythonprov
-Python macros, which simplifies creation of rpm packages with Python
-software.
-
-%description pythonprov -l pl
-Makra u³atwiaj±ce tworzenie pakietów rpm z programami napisanymi w
-Pythonie.
-
-%package php-pearprov
-Summary:       Additional utilities for managing rpm packages and database
-Summary(pl):   Dodatkowe narzêdzia do sprawdzania zale¿no¶ci skryptów php w rpm
-Group:         Applications/File
-Requires:      %{name} = %{version}-%{release}
-
-%description php-pearprov
-Additional utilities for checking php pear provides/requires in rpm
-packages.
-
-%description php-pearprov -l pl
-Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów php pear w
-pakietach rpm.
-
-%package -n python-rpm
-Summary:       Python interface to RPM library
-Summary(pl):   Pythonowy interfejs do biblioteki RPM-a
-Summary(pt_BR):        Módulo Python para aplicativos que manipulam pacotes RPM
-Group:         Development/Languages/Python
-Requires:      %{name} = %{version}-%{release}
-%pyrequires_eq python
-Obsoletes:     rpm-python
-
-%description -n python-rpm
-The rpm-python package contains a module which permits applications
-written in the Python programming language to use the interface
-supplied by RPM (RPM Package Manager) libraries.
-
-This package should be installed if you want to develop Python
-programs that will manipulate RPM packages and databases.
-
-%description -n python-rpm -l pl
-Pakiet rpm-python zawiera modu³, który pozwala aplikacjom napisanym w
-Pythonie na u¿ywanie interfejsu dostarczanego przez biblioteki RPM-a.
-
-Pakiet ten powinien zostaæ zainstalowany, je¶li chcesz pisaæ w
-Pythonie programy manipuluj±ce pakietami i bazami danych rpm.
-
-%description -n python-rpm -l pt_BR
-O pacote rpm-python contém um módulo que permite que aplicações
-escritas em Python utilizem a interface fornecida pelas bibliotecas
-RPM (RPM Package Manager).
-
-Esse pacote deve ser instalado se você quiser desenvolver programas em
-Python para manipular pacotes e bancos de dados RPM.
-
-%package lib
-Summary:       RPMs library
-Summary(pl):   Biblioteki RPM-a
-Group:         Libraries
-Requires:      db >= %{reqdb_ver}
-Requires:      popt >= %{reqpopt_ver}
-# avoid SEGV caused by mixed db versions
-Conflicts:     poldek < 0.18.1-16
-
-%description lib
-RPMs library.
-
-%description lib -l pl
-Biblioteki RPM-a.
-
 %package build
 Summary:       Scripts for building binary RPM packages
 Summary(de):   Scripts fürs Bauen binärer RPM-Pakete
@@ -459,19 +393,23 @@ Requires: %{name}-utils = %{version}-%{release}
 Requires:      /bin/id
 Requires:      awk
 Requires:      binutils
+Requires:      bzip2
 Requires:      chrpath >= 0.10-4
+Requires:      cpio
 Requires:      diffutils
+Requires:      elfutils
 Requires:      file >= 4.01
 Requires:      fileutils
 Requires:      findutils
 %ifarch athlon
 Requires:      gcc >= 3.0.3
 %else
+%ifarch i686
+# because of -mtune in rpmrc
+Requires:      gcc >= 5:3.4
+%else
 Requires:      gcc
 %endif
-%ifarch amd64
-Conflicts:     automake < 1:1.7.9-2
-Conflicts:     libtool < 2:1.5-13
 %endif
 Requires:      glibc-devel
 Requires:      grep
@@ -484,6 +422,13 @@ Requires:  sh-utils
 Requires:      tar
 Requires:      textutils
 Provides:      rpmbuild(macros) = %{rpm_macros_rev}
+Provides:      rpmbuild(noauto) = 3
+# because of -fvisibility-inlines-hidden in rpm.macros
+Conflicts:     gcc-c++ < 5:3.4
+%ifarch amd64
+Conflicts:     automake < 1:1.7.9-2
+Conflicts:     libtool < 2:1.5-13
+%endif
 
 %description build
 Scripts for building binary RPM packages.
@@ -540,12 +485,106 @@ construir pacotes usando o RPM.
 ò¦ÚÎÏÍÁΦÔΦ ÄÏÐÏͦÖΦ ÓËÒÉÐÔÉ ÔÁ ÕÔÉ̦ÔÉ, Ñ˦ ×ÉËÏÒÉÓÔÏ×ÕÀÔØÓÑ ÄÌÑ
 ÐÏÂÕÄÏ×É RPM'¦×.
 
+%package perlprov
+Summary:       Additional utilities for checking perl provides/requires in rpm packages
+Summary(de):   Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
+Summary(pl):   Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów perla w pakietach rpm
+Group:         Applications/File
+Requires:      %{name} = %{version}-%{release}
+Requires:      perl-devel
+Requires:      perl-modules
+
+%description perlprov
+Additional utilities for checking perl provides/requires in rpm
+packages.
+
+%description perlprov -l de
+Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
+
+%description perlprov -l pl
+Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów perla w
+pakietach rpm.
+
+%package pythonprov
+Summary:       Python macros, which simplifies creation of rpm packages with Python software
+Summary(pl):   Makra u³atwiaj±ce tworzenie pakietów rpm z programami napisanymi w Pythonie
+Group:         Applications/File
+Requires:      %{name} = %{version}-%{release}
+Requires:      python-modules
+
+%description pythonprov
+Python macros, which simplifies creation of rpm packages with Python
+software.
+
+%description pythonprov -l pl
+Makra u³atwiaj±ce tworzenie pakietów rpm z programami napisanymi w
+Pythonie.
+
+%package php-pearprov
+Summary:       Additional utilities for managing rpm packages and database
+Summary(pl):   Dodatkowe narzêdzia do sprawdzania zale¿no¶ci skryptów php w rpm
+Group:         Applications/File
+Requires:      %{name} = %{version}-%{release}
+
+%description php-pearprov
+Additional utilities for checking php pear provides/requires in rpm
+packages.
+
+%description php-pearprov -l pl
+Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów php pear w
+pakietach rpm.
+
+%package -n python-rpm
+Summary:       Python interface to RPM library
+Summary(pl):   Pythonowy interfejs do biblioteki RPM-a
+Summary(pt_BR):        Módulo Python para aplicativos que manipulam pacotes RPM
+Group:         Development/Languages/Python
+Requires:      %{name} = %{version}-%{release}
+%pyrequires_eq python
+Obsoletes:     rpm-python
+
+%description -n python-rpm
+The rpm-python package contains a module which permits applications
+written in the Python programming language to use the interface
+supplied by RPM (RPM Package Manager) libraries.
+
+This package should be installed if you want to develop Python
+programs that will manipulate RPM packages and databases.
+
+%description -n python-rpm -l pl
+Pakiet rpm-python zawiera modu³, który pozwala aplikacjom napisanym w
+Pythonie na u¿ywanie interfejsu dostarczanego przez biblioteki RPM-a.
+
+Pakiet ten powinien zostaæ zainstalowany, je¶li chcesz pisaæ w
+Pythonie programy manipuluj±ce pakietami i bazami danych rpm.
+
+%description -n python-rpm -l pt_BR
+O pacote rpm-python contém um módulo que permite que aplicações
+escritas em Python utilizem a interface fornecida pelas bibliotecas
+RPM (RPM Package Manager).
+
+Esse pacote deve ser instalado se você quiser desenvolver programas em
+Python para manipular pacotes e bancos de dados RPM.
+
+%package apidocs
+Summary:       RPM API documentation and guides
+Summary(pl):   Documentacja API RPM-a i przewodniki
+Group:         Documentation   
+
+%description apidocs
+Documentation for RPM API and guides in HTML format generated
+from rpm sources by doxygen.
+
+%description apidocs -l pl
+Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane
+ze ¼rode³ RPM-a przez doxygen.
+
 %prep
 %setup -q
-%patch0 -p1
 %patch1 -p1
 %patch2 -p1
-%patch3 -p1
+# temporarily moved after patch0 - messes too much in pl.po
+#%patch3 -p1
 %patch4 -p1
 %patch5 -p1
 %patch6 -p1
@@ -556,14 +595,13 @@ construir pacotes usando o RPM.
 %patch11 -p1
 %patch12 -p1
 %patch13 -p1
-%patch14 -p1
+# home-etc FIXME
+#%patch14 -p1
 %patch15 -p1
 %patch16 -p1
 %patch17 -p1
 %patch18 -p1
 %patch19 -p1
-%patch20 -p1
-%patch21 -p1
 sed -e 's/^/@pld@/' %{SOURCE2} >>platform.in
 cp -f platform.in macros.pld.in
 echo '%%define __perl_provides %%{__perl} /usr/lib/rpm/perl.prov' > macros.perl
@@ -576,6 +614,8 @@ install %{SOURCE9} scripts/php.prov.in
 install %{SOURCE10} scripts/php.req.in
 install %{SOURCE12} scripts/perl.prov
 cat %{SOURCE11} >> macros.in
+%patch20 -p1
+%patch21 -p1
 %patch22 -p1
 %patch23 -p1
 %patch24 -p1
@@ -589,15 +629,14 @@ cat %{SOURCE11} >> macros.in
 %patch32 -p1
 %patch33 -p1
 %patch34 -p1
-%patch35 -p1
+%patch35 -p0
 %patch36 -p1
 %patch37 -p1
-%patch38 -p1
+%{?with_distver:%patch38 -p1}
 %patch39 -p1
 %patch40 -p1
-%patch41 -p1
-%patch42 -p1
-%patch43 -p0
+%patch0 -p1
+%patch3 -p1
 
 cd scripts;
 mv -f perl.req perl.req.in
@@ -607,7 +646,7 @@ cd ..
 mv -f po/{no,nb}.po
 mv -f po/{sr,sr@Latn}.po
 
-rm -rf zlib libelf db db3 popt rpmdb/db.h
+rm -rf neon zlib libelf db db3 popt rpmdb/db.h
 
 # generate Group translations to *.po
 awk -f %{SOURCE6} %{SOURCE1}
@@ -618,6 +657,10 @@ for f in doc{,/ja,/pl}/rpm.8 doc{,/ja,/pl}/rpmbuild.8 ; do
        mv -f ${f}.tmp $f
 done
 
+# ... and make some cleanings
+rm -fr $(find ./ -type d -name CVS )
+rm -f  $(find ./ -type f -name ".cvsignore" )
+
 %build
 cd file
 %{__libtoolize}
@@ -636,18 +679,19 @@ cd ..
 
 # config.guess doesn't handle athlon, so we have to change it by hand.
 # rpm checks for CPU type at runtime, but it looks better
-sed -e 's|@host@|%{_target_cpu}-%{_target_vendor}-linux-gnu|'  \
-       -e 's|@host_cpu@|%{_target_cpu}|'  macros.in  > macros.tmp
+sed -e 's|@host@|%{_target_cpu}-%{_target_vendor}-linux-gnu|' \
+       -e 's|@host_cpu@|%{_target_cpu}|' macros.in > macros.tmp
 mv -f macros.tmp macros.in
 
 # pass CC and CXX too in case of building with some older configure macro
 %configure \
-       CC="%{__cc}" \
-       CXX="%{__cxx}" \
-       CPP="%{__cpp}" \
+       CC="%{__newcc}" \
+       CXX="%{__newcxx}" \
+       CPP="%{__newcpp}" \
        --enable-shared \
        --enable-static \
-       %{?with_doc:--with-apidocs} \
+       %{?with_apidoc:--with-apidocs} \
+       %{?with_pkgnameinautoreq:--enable-adding-packages-names-in-autogenerated-dependancies} \
        %{?with_python:--with-python=auto} \
        %{!?with_python:--without-python} \
        %{!?with_selinux:--without-selinux} \
@@ -655,16 +699,20 @@ mv -f macros.tmp macros.in
 
 # file_LDFLAGS, debugedit_LDADD - no need to link "file" and "debugedit" statically
 %{__make} \
+       CC="%{__cc}" \
+       CXX="%{__cxx}" \
+       CPP="%{__cpp}" \
        pylibdir=%{py_libdir} \
        myLDFLAGS="%{rpmldflags}" \
        file_LDFLAGS= \
        debugedit_LDADD="\$(WITH_LIBELF_LIB) -lpopt"
 
 #      %{!?with_static:rpm_LDFLAGS="\$(myLDFLAGS)"} \
+%{?with_apidocs:%{__make} doxygen}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT/%{_lib}
+install -d $RPM_BUILD_ROOT{/%{_lib},/etc/sysconfig,%{_sysconfdir}/rpm}
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT \
@@ -684,17 +732,18 @@ install %{SOURCE3} $RPM_BUILD_ROOT%{_rpmlibdir}/install-build-tree
 install %{SOURCE4} $RPM_BUILD_ROOT%{_rpmlibdir}/find-spec-bcond
 install %{SOURCE7} $RPM_BUILD_ROOT%{_rpmlibdir}/compress-doc
 install %{SOURCE8} $RPM_BUILD_ROOT%{_rpmlibdir}/check-files
+install %{SOURCE13} $RPM_BUILD_ROOT%{_rpmlibdir}/user_group.sh
 install scripts/find-php*      $RPM_BUILD_ROOT%{_rpmlibdir}
 install scripts/php.{prov,req} $RPM_BUILD_ROOT%{_rpmlibdir}
+install %{SOURCE14} $RPM_BUILD_ROOT/etc/sysconfig/rpm
 
 install %{SOURCE30} $RPM_BUILD_ROOT%{_bindir}/builder
 install %{SOURCE31} $RPM_BUILD_ROOT%{_bindir}/adapter.awk
 install %{SOURCE32} $RPM_BUILD_ROOT%{_bindir}/pldnotify.awk
+install %{SOURCE33} $RPM_BUILD_ROOT%{_bindir}/banner.sh
 
 install rpmio/ugid.h $RPM_BUILD_ROOT%{_includedir}/rpm
 
-install -d $RPM_BUILD_ROOT%{_sysconfdir}/rpm
-
 %ifarch %{ix86}
 ix86re=$(echo "(%{ix86})"|sed 's/ /|/g')
 perl -p -i -e 's/^(buildarchtranslate: '"$ix86re"': ).*/\1%{_target_cpu}/' \
@@ -721,8 +770,8 @@ cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprov <<EOF
 EOF
 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqfiles <<EOF
 # global list of files (regexps) which don't generate Requires
-/usr/src/examples/.*
-/usr/share/doc/.*
+^/usr/src/examples/
+^/usr/share/doc/
 EOF
 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreq <<EOF
 # global list of script capabilities (regexps) not to be used in Requires
@@ -730,27 +779,76 @@ EOF
 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqdep <<EOF
 # global list of capabilities (SONAME, perl(module), php(module) regexps)
 # which don't generate dependencies on package NAMES
-libGL.so.1
-libGLU.so.1
-libOSMesa.so.4
-libglide3.so.3
-libgtkmozembed.so
-libgtksuperwin.so
-libxpcom.so
+# -- OpenGL implementation
+^libGL.so.1
+^libGLU.so.1
+^libOSMesa.so
+# -- Glide
+^libglide3.so.3
+# -- mozilla
+^libgtkmozembed.so
+^libgtksuperwin.so
+^libxpcom.so
+# -- X11 implementation
+^libFS.so
+^libI810XvMC.so
+^libICE.so
+^libSM.so
+^libX11.so
+^libXRes.so
+^libXTrap.so
+^libXaw.so
+^libXcomposite.so
+^libXcursor.so
+^libXdamage.so
+^libXdmcp.so
+^libXevie.so
+^libXext.so
+^libXfixes.so
+^libXfont.so
+^libXfontcache.so
+^libXft.so
+^libXi.so
+^libXinerama.so
+^libXmu.so
+^libXmuu.so
+^libXp.so
+^libXpm.so
+^libXrandr.so
+^libXrender.so
+^libXss.so
+^libXt.so
+^libXtst.so
+^libXv.so
+^libXvMC.so
+^libXxf86dga.so
+^libXxf86misc.so
+^libXxf86rush.so
+^libXxf86vm.so
+^libdps.so
+^libdpstk.so
+^libfontenc.so
+^libpsres.so
+^libxkbfile.so
+^libxkbui.so
 EOF
 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautocompressdoc <<EOF
 # global list of file masks not to be compressed in DOCDIR
 EOF
 
 # for rpm -e|-U --repackage
-install -d $RPM_BUILD_ROOT/var/spool/repackage
+install -d $RPM_BUILD_ROOT/var/{spool/repackage,lock/rpm}
+touch $RPM_BUILD_ROOT/var/lock/rpm/transaction
 
 # move libs to /lib
-for a in librpm-%{ver}.so librpmdb-%{ver}.so librpmio-%{ver}.so ; do
+for a in librpm-%{sover}.so librpmdb-%{sover}.so librpmio-%{sover}.so ; do
        mv -f $RPM_BUILD_ROOT%{_libdir}/$a $RPM_BUILD_ROOT/%{_lib}
        ln -s /%{_lib}/$a $RPM_BUILD_ROOT%{_libdir}/$a
 done
 
+%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
+%py_comp $RPM_BUILD_ROOT%{py_sitedir}
+
 for f in $RPM_BUILD_ROOT%{_datadir}/locale/{en_RN,eu_ES,gl,hu,ro,wa,zh,zh_CN.GB2312}/LC_MESSAGES/rpm.mo ; do
        [ "`file $f | sed -e 's/.*,//' -e 's/message.*//'`" -le 1 ] && rm -f $f
 done
@@ -781,6 +879,7 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 
 %dir %{_sysconfdir}/rpm
 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/rpm/macros
+%config(noreplace) %verify(not size mtime md5) /etc/sysconfig/rpm
 
 %{_mandir}/man8/rpm.8*
 %lang(fr) %{_mandir}/fr/man8/rpm.8*
@@ -792,6 +891,8 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 
 %dir /var/lib/rpm
 %dir %attr(700,root,root) /var/spool/repackage
+%dir /var/lock/rpm
+/var/lock/rpm/transaction
 
 %dir %{_rpmlibdir}
 #%attr(755,root,root) %{_rpmlibdir}/rpmd
@@ -800,6 +901,9 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 #%attr(755,root,root) %{_rpmlibdir}/rpm[qv]
 
 %doc %attr(755,root,root) %{_rpmlibdir}/convertrpmrc.sh
+%attr(755,root,root) %{_rpmlibdir}/user_group.sh
+
+%attr(755,root,root) %{_bindir}/banner.sh
 
 %{_rpmlibdir}/rpmrc
 %{_rpmlibdir}/rpmpopt*
@@ -810,6 +914,63 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 %attr(755,root,root) /%{_lib}/librpm*-*.so
 %attr(755,root,root) %{_libdir}/librpm*-*.so
 
+%files devel
+%defattr(644,root,root,755)
+%{_includedir}/rpm
+%{_libdir}/librpm*.la
+%attr(755,root,root) %{_libdir}/librpm.so
+%attr(755,root,root) %{_libdir}/librpm-%{sover}.so
+%attr(755,root,root) %{_libdir}/librpmio.so
+%attr(755,root,root) %{_libdir}/librpmio-%{sover}.so
+%attr(755,root,root) %{_libdir}/librpmdb.so
+%attr(755,root,root) %{_libdir}/librpmdb-%{sover}.so
+%attr(755,root,root) %{_libdir}/librpmbuild.so
+
+%files static
+%defattr(644,root,root,755)
+%{_libdir}/librpm*.a
+
+%files utils
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/debugedit
+%attr(755,root,root) %{_bindir}/rpm2cpio
+%attr(755,root,root) %{_bindir}/rpmcache
+%attr(755,root,root) %{_bindir}/rpmdeps
+%attr(755,root,root) %{_bindir}/rpmgraph
+%attr(755,root,root) %{_bindir}/rpmfile
+%attr(755,root,root) %{_rpmlibdir}/find-debuginfo.sh
+%attr(755,root,root) %{_rpmlibdir}/rpm2cpio.sh
+%attr(755,root,root) %{_rpmlibdir}/tgpg
+%attr(755,root,root) %{_rpmlibdir}/rpmdb_loadcvt
+%{_mandir}/man8/rpm2cpio.8*
+%{_mandir}/man8/rpmdeps.8*
+%{_mandir}/man8/rpmcache.8*
+%{_mandir}/man8/rpmgraph.8*
+%lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
+%lang(ja) %{_mandir}/ja/man8/rpmcache.8*
+%lang(ja) %{_mandir}/ja/man8/rpmgraph.8*
+%lang(ko) %{_mandir}/ko/man8/rpm2cpio.8*
+%lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
+%lang(pl) %{_mandir}/pl/man8/rpmdeps.8*
+%lang(pl) %{_mandir}/pl/man8/rpmcache.8*
+%lang(pl) %{_mandir}/pl/man8/rpmgraph.8*
+%lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
+
+%files utils-perl
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_rpmlibdir}/rpmdiff*
+# not here
+#%%{_rpmlibdir}/rpm.daily
+#%%{_rpmlibdir}/rpm.log
+#%%{_rpmlibdir}/rpm.xinetd
+
+%if %{with static}
+%files utils-static
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/rpm[ieu]
+%attr(755,root,root) %{_rpmlibdir}/rpm[ieu]
+%endif
+
 %files build
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/rpm/noauto*
@@ -832,9 +993,6 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 #%attr(755,root,root) %{_rpmlibdir}/cpanflute
 #%attr(755,root,root) %{_rpmlibdir}/cpanflute2
 #%attr(755,root,root) %{_rpmlibdir}/Specfile.pm
-%attr(755,root,root) %{_rpmlibdir}/http.req
-%attr(755,root,root) %{_rpmlibdir}/magic.prov
-%attr(755,root,root) %{_rpmlibdir}/magic.req
 %attr(755,root,root) %{_rpmlibdir}/u_pkg.sh
 #%attr(755,root,root) %{_rpmlibdir}/vpkg-provides.sh
 #%attr(755,root,root) %{_rpmlibdir}/vpkg-provides2.sh
@@ -846,26 +1004,34 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 %{_rpmlibdir}/pentium*
 %{_rpmlibdir}/athlon*
 %endif
+%ifarch alpha
+%{_rpmlibdir}/alpha*
+%endif
 %ifarch amd64
 %{_rpmlibdir}/amd64*
-%{_rpmlibdir}/x86_64*
 %endif
-%ifarch sparc sparc64
-%{_rpmlibdir}/sparc*
+%ifarch ia64
+%{_rpmlibdir}/ia64*
 %endif
-%ifarch alpha
-%{_rpmlibdir}/alpha*
+%ifarch mips mipsel mips64 mips64el
+%{_rpmlibdir}/mips*
 %endif
 %ifarch ppc
 %{_rpmlibdir}/ppc*
 %endif
+%ifarch sparc sparc64
+%{_rpmlibdir}/sparc*
+%endif
 # must be here for "Requires: rpm-*prov" to work
 %{_rpmlibdir}/macros.perl
 %{_rpmlibdir}/macros.php
-# not used yet ...
-%{_rpmlibdir}/sql.prov
-%{_rpmlibdir}/sql.req
-%{_rpmlibdir}/tcl.req
+# not used yet ... these six depend on perl
+#%attr(755,root,root) %{_rpmlibdir}/http.req
+#%attr(755,root,root) %{_rpmlibdir}/magic.prov
+#%attr(755,root,root) %{_rpmlibdir}/magic.req
+#%{_rpmlibdir}/sql.prov
+#%{_rpmlibdir}/sql.req
+#%{_rpmlibdir}/tcl.req
 %{_rpmlibdir}/trpm
 
 %attr(755,root,root) %{_bindir}/javadeps
@@ -878,60 +1044,11 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 %lang(pl) %{_mandir}/pl/man1/gendiff.1*
 %lang(pl) %{_mandir}/pl/man8/rpmbuild.8*
 
-%files devel
-%defattr(644,root,root,755)
-%{_includedir}/rpm
-%{_libdir}/librpm*.la
-%attr(755,root,root) %{_libdir}/librpm.so
-%attr(755,root,root) %{_libdir}/librpmio.so
-%attr(755,root,root) %{_libdir}/librpmdb.so
-%attr(755,root,root) %{_libdir}/librpmbuild.so
-
-%files static
-%defattr(644,root,root,755)
-%{_libdir}/librpm*.a
-
-%files utils
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/debugedit
-%attr(755,root,root) %{_bindir}/rpm2cpio
-%attr(755,root,root) %{_bindir}/rpmcache
-%attr(755,root,root) %{_bindir}/rpmdeps
-%attr(755,root,root) %{_bindir}/rpmgraph
-%attr(755,root,root) %{_bindir}/rpmfile
-%attr(755,root,root) %{_rpmlibdir}/find-debuginfo.sh
-%attr(755,root,root) %{_rpmlibdir}/rpm2cpio.sh
-%attr(755,root,root) %{_rpmlibdir}/tgpg
-%attr(755,root,root) %{_rpmlibdir}/rpmdb_loadcvt
-
-%files utils-perl
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_rpmlibdir}/rpmdiff*
-# not here
-#%%{_rpmlibdir}/rpm.daily
-#%%{_rpmlibdir}/rpm.log
-#%%{_rpmlibdir}/rpm.xinetd
-
-%{_mandir}/man8/rpm2cpio.8*
-%{_mandir}/man8/rpmdeps.8*
-%{_mandir}/man8/rpmcache.8*
-%{_mandir}/man8/rpmgraph.8*
-%lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
-%lang(ja) %{_mandir}/ja/man8/rpmcache.8*
-%lang(ja) %{_mandir}/ja/man8/rpmgraph.8*
-%lang(ko) %{_mandir}/ko/man8/rpm2cpio.8*
-%lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
-%lang(pl) %{_mandir}/pl/man8/rpmdeps.8*
-%lang(pl) %{_mandir}/pl/man8/rpmcache.8*
-%lang(pl) %{_mandir}/pl/man8/rpmgraph.8*
-%lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
-
-%if %{with static}
-%files utils-static
+%files build-tools
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/rpm[ieu]
-%attr(755,root,root) %{_rpmlibdir}/rpm[ieu]
-%endif
+%attr(755,root,root) %{_bindir}/builder
+%attr(755,root,root) %{_bindir}/adapter.awk
+%attr(755,root,root) %{_bindir}/pldnotify.awk
 
 %files perlprov
 %defattr(644,root,root,755)
@@ -946,6 +1063,7 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 %files pythonprov
 %defattr(644,root,root,755)
 %{_rpmlibdir}/macros.python
+%attr(755,root,root) %{_rpmlibdir}/pythondeps.sh
 
 %files php-pearprov
 %defattr(644,root,root,755)
@@ -956,12 +1074,14 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 %files -n python-rpm
 %defattr(644,root,root,755)
 %attr(755,root,root) %{py_sitedir}/*.so
+%attr(755,root,root) %{py_sitedir}/rpm/*.so
+%attr(755,root,root) %{py_sitedir}/rpm/*.py[co]
 %attr(755,root,root) %{py_sitedir}/rpmdb/*.so
 %{py_sitedir}/rpmdb/*.py*
 %endif
 
-%files build-tools
+%if %{with apidocs}
+%files apidocs
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/builder
-%attr(755,root,root) %{_bindir}/adapter.awk
-%attr(755,root,root) %{_bindir}/pldnotify.awk
+%doc apidocs
+%endif
This page took 0.059287 seconds and 4 git commands to generate.