]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm.spec
- fixed (finally?) GConf scripts, rel 0.6
[packages/rpm.git] / rpm.spec
index a30607645edc6136633aa8e4803f13521f76fed9..fbe1b0cb7e65365933316e92ed9971b4d104e08c 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -1,5 +1,7 @@
 #
 # TODO:
+# - detected Requires lists are not printed at the end of build (Provides etc. are)
+# - fix pythondeps detection (*.py[co] should belong to python class; autodetect P(abi))
 # - consider using system libmagic not internal libfmagic
 #   (but internal has different method of passing output)
 # - after ac drop amd64 patch and make x86_64 generic arch + subarchs amd64 and ia32e
@@ -8,7 +10,7 @@
 %bcond_with    distver # build with distversion field
 %bcond_with    static  # build static rpmi (not supported at the moment)
 %bcond_without apidocs # don't generate documentation with doxygen
-%bcond_without pkgnameinautoreq        # don't put package name in autogenerated dependancy
+%bcond_with    pkgnameinautoreq        # don't put package name in autogenerated dependancy
 %bcond_without python  # don't build python bindings
 %bcond_without selinux # dont enable selinux support
 # force_cc             - force using __cc other than "%{_target_cpu}-pld-linux-gcc"
 
 %define        snap    20041121
 # versions of required libraries
-%define        reqdb_ver       4.2.50-1
+%define        reqdb_ver       4.3.27-1
 %define        reqpopt_ver     1.10.1
 %define        beecrypt_ver    2:4.1.0
-%define        rpm_macros_rev  1.188
+%define        rpm_macros_rev  1.196
 Summary:       RPM Package Manager
 Summary(de):   RPM Packet-Manager
 Summary(es):   Gestor de paquetes RPM
@@ -31,7 +33,7 @@ Summary(uk):  
 Name:          rpm
 %define        sover   4.4
 Version:       4.4.1
-Release:       0.1
+Release:       0.6
 License:       GPL
 Group:         Base
 #Source0:      ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.2.x/%{name}-%{version}.%{snap}.tar.gz
@@ -97,6 +99,7 @@ Patch36:      %{name}-debuginfo.patch
 Patch37:       %{name}-doxygen_hack.patch
 Patch38:       %{name}-distver.patch
 Patch39:       %{name}-gcc4.patch
+Patch40:       %{name}-pythondeps.patch
 URL:           http://www.rpm.org/
 Icon:          rpm.gif
 BuildRequires: autoconf >= 2.52
@@ -121,7 +124,6 @@ BuildRequires:      popt-devel >= %{reqpopt_ver}
 BuildRequires: python-modules >= 2.2
 BuildRequires: readline-devel
 BuildRequires: rpm-perlprov
-BuildRequires: rpm-pythonprov
 BuildRequires: zlib-devel
 %if %{with static}
 # Require static library only for static build
@@ -632,6 +634,7 @@ cat %{SOURCE11} >> macros.in
 %patch37 -p1
 %{?with_distver:%patch38 -p1}
 %patch39 -p1
+%patch40 -p1
 %patch0 -p1
 %patch3 -p1
 
@@ -1060,7 +1063,7 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 %files pythonprov
 %defattr(644,root,root,755)
 %{_rpmlibdir}/macros.python
-%{_rpmlibdir}/pythondeps.sh
+%attr(755,root,root) %{_rpmlibdir}/pythondeps.sh
 
 %files php-pearprov
 %defattr(644,root,root,755)
This page took 0.038206 seconds and 4 git commands to generate.