]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm.spec
- use sql support from db-sql instead of sqlite
[packages/rpm.git] / rpm.spec
index c5a40ae8ab3d20433177fa1e1d254b5f7b858a77..f327736d6baf582a0af0a016f62ef5ef1ca67533 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
 %bcond_without selinux         # build without selinux support
 %bcond_without suggest_tags    # build without Suggest tag (bootstrapping)
 %bcond_with    neon            # build with HTTP/WebDAV support (neon library)
-%bcond_without db              # BerkeleyDB
-%bcond_without sqlite          # build with SQLite support
-%bcond_with    sqlite_dbapi    # default database backend is sqlite
+%bcond_with    sqlite          # build with SQLite support
 %bcond_with    system_lua      # use system lua
 %bcond_with    keyutils        # build with keyutils support
 # force_cc             - force using __cc other than "%{_target_cpu}-pld-linux-gcc"
 # force_cxx            - force using __cxx other than "%{_target_cpu}-pld-linux-g++"
 # force_cpp            - force using __cpp other than "%{_target_cpu}-pld-linux-gcc -E"
 #
-%if %{with sqlite_dbapi}
-%define        with_sqlite     1
-%endif
-
-%if %{without db} && %{without sqlite}
-%{error:Need db or sqlite}
-ERROR
-%endif
 
 %if %{with sqlite}
 # Error: /lib64/librpmio-5.4.so: undefined symbol: sqlite3_enable_load_extension
@@ -38,7 +28,7 @@ ERROR
 
 # versions of required libraries
 %define                reqdb_pkg       db5.2
-%define                reqdb_ver       5.2
+%define                reqdb_ver       5.2.36.0-4
 %define                reqpopt_ver     1.15
 %define                beecrypt_ver    2:4.1.2-4
 %define                sover           5.4
@@ -52,8 +42,8 @@ Summary(ru.UTF-8):    Менеджер пакетов от RPM
 Summary(uk.UTF-8):     Менеджер пакетів від RPM
 Name:          rpm
 Version:       5.4.10
-Release:       50
-License:       LGPL
+Release:       53
+License:       LGPL v2.1
 Group:         Base
 # http://rpm5.org/files/rpm/rpm-5.4/rpm-5.4.10-0.20120706.src.rpm
 Source0:       %{name}-%{version}.tar.gz
@@ -158,10 +148,12 @@ Patch63:  %{name}-pythoneggs.patch
 Patch64:       %{name}-fix-compress-doc.patch
 Patch65:       %{name}-parseSpec-skip-empty-tags.patch
 Patch66:       %{name}-payload-use-hashed-inode.patch
-Patch67:       rpm-repackage-dont-force-max-compression.patch
+Patch67:       %{name}-repackage-dont-force-max-compression.patch
 Patch68:       rubyprov-archdirs.patch
 Patch69:       rubyprov-abi-versioned.patch
-Patch70:       python-rpmsense-missingok.patch
+Patch70:       python-%{name}sense-missingok.patch
+Patch71:       %{name}-changelog-encoding.patch
+Patch72:       %{name}-preserve-tag-type.patch
 
 # Patches imported from Mandriva
 
@@ -275,7 +267,12 @@ Patch1041: %{name}-5.4.9-disable-l10ndir.patch
 Patch1042:     %{name}-5.4.9-fix-rpm_qa-pattern.patch
 
 URL:           http://rpm5.org/
-%{?with_db:BuildRequires:      %{reqdb_pkg}-devel >= %{reqdb_ver}}
+BuildRequires: %{reqdb_pkg}-devel >= %{reqdb_ver}
+%if %{with sqlite}
+BuildRequires: sqlite3-devel
+%else
+BuildRequires: %{reqdb_pkg}-sql-devel >= %{reqdb_ver}
+%endif
 BuildRequires: autoconf >= 2.60
 BuildRequires: automake >= 1.4
 BuildRequires: beecrypt-devel >= %{beecrypt_ver}
@@ -304,7 +301,6 @@ BuildRequires:      popt-devel >= %{reqpopt_ver}
 %{?with_python:BuildRequires:  python-devel >= 1:2.3}
 BuildRequires: python-modules >= 1:2.3
 %{?with_python:BuildRequires:  rpm-pythonprov}
-%{?with_sqlite:BuildRequires:  sqlite3-devel}
 BuildRequires: tcl
 BuildRequires: xz-devel
 BuildRequires: zlib-devel
@@ -316,7 +312,7 @@ BuildRequires:      tetex-pdftex
 %endif
 %if %{with static}
 # Require static library only for static build
-%{?with_db:BuildRequires:      %{reqdb_pkg}-static >= %{reqdb_ver}}
+BuildRequires: %{reqdb_pkg}-static >= %{reqdb_ver}
 BuildRequires: beecrypt-static >= %{beecrypt_ver}
 BuildRequires: bzip2-static >= 1.0.2-17
 BuildRequires: elfutils-static
@@ -437,12 +433,16 @@ Zawiera on:
 Summary:       RPMs library
 Summary(pl.UTF-8):     Biblioteki RPM-a
 Group:         Libraries
-%{?with_db:Requires:   %{reqdb_pkg} >= %{reqdb_ver}}
+Requires:      %{reqdb_pkg} >= %{reqdb_ver}
+%if %{with sqlite}
+Requires:      sqlite3 >= %{sqlite_build_version}
+%else
+Requires:      %{reqdb_pkg}-sql >= %{reqdb_ver}
+%endif
 Requires:      beecrypt >= %{beecrypt_ver}
 Requires:      libmagic >= 1.15-2
 %{?with_selinux:Requires:      libselinux >= 2.1.0}
 Requires:      popt >= %{reqpopt_ver}
-%{?with_sqlite:Requires:       sqlite3 >= %{sqlite_build_version}}
 Obsoletes:     rpm-libs
 # avoid SEGV caused by mixed db versions
 Conflicts:     poldek < 0.18.1-16
@@ -463,7 +463,7 @@ Summary(ru.UTF-8):  Хедеры и библиотеки для программ,
 Summary(uk.UTF-8):     Хедери та бібліотеки для програм, що працюють з пакетами rpm
 Group:         Development/Libraries
 Requires:      %{name}-lib = %{version}-%{release}
-%{?with_db:Requires:   %{reqdb_pkg}-devel >= %{reqdb_ver}}
+Requires:      %{reqdb_pkg}-devel >= %{reqdb_ver}
 Requires:      beecrypt-devel >= %{beecrypt_ver}
 Requires:      bzip2-devel
 Requires:      elfutils-devel
@@ -527,7 +527,7 @@ Summary(ru.UTF-8):  Статическая библиотека для прогр
 Summary(uk.UTF-8):     Статична бібліотека для програм, що працюють з пакетами rpm
 Group:         Development/Libraries
 Requires:      %{name}-devel = %{version}-%{release}
-%{?with_db:Requires:   %{reqdb_pkg}-static >= %{reqdb_ver}}
+Requires:      %{reqdb_pkg}-static >= %{reqdb_ver}
 Requires:      beecrypt-static >= %{beecrypt_ver}
 Requires:      bzip2-static
 Requires:      elfutils-static
@@ -742,6 +742,7 @@ Summary(pl.UTF-8):  Dodatkowe narzędzia do sprawdzania zależności skryptów ph
 Group:         Applications/File
 Requires:      %{name} = %{version}-%{release}
 Requires:      sed >= 4.0
+Suggests:      php-pear-PHP_CompatInfo
 
 %description php-pearprov
 Additional utilities for checking PHP PEAR provides/requires in RPM
@@ -888,6 +889,8 @@ Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
 %patch66 -p1
 %patch67 -p1
 %patch70 -p1
+%patch71 -p1
+%patch72 -p1
 
 %patch1000 -p1
 %patch1001 -p1
@@ -988,9 +991,9 @@ sed -i \
        --with-neon=%{?with_neon:external}%{!?with_neon:no} \
        --with-file=external \
        --with-popt=external \
-       --with-db=%{?with_db:external}%{!?with_db:no} \
+       --with-db=external \
+       --with-dbapi=db \
        --with-sqlite=%{?with_sqlite:yes}%{!?with_sqlite:no} \
-       --with-dbapi=%{!?with_sqlite_dbapi:db}%{?with_sqlite_dbapi:sqlite} \
        --with-lua=%{!?with_system_lua:internal}%{?with_system_lua:external} \
        --with-pcre=external \
        --with-keyutils=%{?with_keyutils:external}%{!?with_keyutils:no} \
This page took 0.090582 seconds and 4 git commands to generate.