]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm.spec
- convert rpmdb only if it actually exists (vserver external pkgmanagement)
[packages/rpm.git] / rpm.spec
index df189f91f19ad22bfd5d1fc6f4b16a4410fa9aa7..efdb5a17c3d9e483897f419cafe87253ef79156e 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -52,7 +52,7 @@ Summary(ru.UTF-8):    Менеджер пакетов от RPM
 Summary(uk.UTF-8):     Менеджер пакетів від RPM
 Name:          rpm
 Version:       5.4.10
-Release:       24
+Release:       33
 License:       LGPL
 Group:         Base
 # http://rpm5.org/files/rpm/rpm-5.4/rpm-5.4.10-0.20120706.src.rpm
@@ -102,7 +102,7 @@ Patch9:             %{name}-lua.patch
 Patch10:       %{name}-php-deps.patch
 Patch11:       %{name}-notsc.patch
 Patch12:       %{name}-hack-norpmlibdep.patch
-Patch13:       %{name}-epoch0.patch
+Patch13:       %{name}-dont-copy-descriptive-tags.patch
 Patch14:       %{name}-perl_req-INC_dirs.patch
 Patch15:       %{name}-debuginfo.patch
 Patch16:       vendor-pld.patch
@@ -136,7 +136,7 @@ Patch43:    %{name}-fix-___build_pre-macro.patch
 Patch44:       %{name}-missing-patch-file-fails-build.patch
 Patch45:       %{name}-remove-misleading-missing-patch-message.patch
 Patch46:       %{name}-file-magic-can-be-mixed-case.patch
-Patch47:       %{name}-query-file-always-noisy.patch
+Patch47:       %{name}-query-always-noisy.patch
 Patch48:       %{name}-verify-ghosts-broken-logic.patch
 Patch49:       %{name}-python-enable-compat-RPMSENSE.patch
 Patch50:       %{name}-dont-treat-gstreamer-modules-as-font.patch
@@ -250,13 +250,19 @@ Patch1038:        rpm-5.4.10-support-ignore-arch-and-os-again.patch
 Patch1039:     rpm-5.4.4-fix-same-package-with-epoch-possible-to-upgrade.patch
 # we want that patch too, a bit of builder infrastructure relies on NOSIGNATURES
 Patch1040:     rpm-5.4.9-support-signatures-and-digest-disablers.patch
+# lack insight on actual functionality, which anyways seems broken, so let's
+# disable it to avoid errors from berkeley db..
+# status: keep locally
+Patch1041:     rpm-5.4.9-disable-l10ndir.patch
+# status: ready for merge
+Patch1042:     rpm-5.4.9-fix-rpm_qa-pattern.patch
 
 URL:           http://rpm5.org/
 BuildRequires: autoconf >= 2.60
 BuildRequires: automake >= 1.4
 BuildRequires: beecrypt-devel >= %{beecrypt_ver}
 BuildRequires: bzip2-devel >= 1.0.2-17
-%{?with_db:BuildRequires:      db-devel >= %{reqdb_ver}}
+%{?with_db:BuildRequires:      %{reqdb_pkg}-devel >= %{reqdb_ver}}
 BuildRequires: elfutils-devel >= 0.108
 #BuildRequires:        gettext-autopoint >= 0.11.4-2
 BuildRequires: gettext-devel >= 0.11.4-2
@@ -876,6 +882,8 @@ Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
 %patch1038 -p1
 %patch1039 -p1
 %patch1040 -p1
+%patch1041 -p1
+%patch1042 -p1
 
 install %{SOURCE2} macros/pld.in
 install %{SOURCE8} scripts/php.prov.in
@@ -948,7 +956,7 @@ sed -i \
 
 %{?with_apidocs:%{__make} apidocs}
 
-%{__cc} %{rpmcflags} tools/rpmdb_checkversion.c -o tools/rpmdb_checkversion -ldb
+%{__cc} %{rpmcflags} tools/rpmdb_checkversion.c -o tools/rpmdb_checkversion -ldb-%{reqdb_ver}
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -1165,16 +1173,16 @@ if [ -f %{_sysconfdir}/rpm/sysinfo ]; then
 fi
 
 %posttrans
-if [ -x %{_rpmlibdir}/bin/rpmdb_checkversion ] && \
-               ! %{_rpmlibdir}/bin/rpmdb_checkversion -h /var/lib/rpm -d /var/lib/rpm ; then
-       if [ ! -e /var/lib/rpm.rpmbackup-%{version}-%{release} ] && \
-                       /bin/cp -a /var/lib/rpm /var/lib/rpm.rpmbackup-%{version}-%{release} ; then
+if [ -e /var/lib/rpm/Packages ] && [ -x %{_rpmlibdir}/bin/rpmdb_checkversion ] && \
+               ! %{_rpmlibdir}/bin/rpmdb_checkversion -h /var/lib/rpm -d /var/lib/rpm; then
+       if [ ! -e /var/lib/rpm.rpmbackup-%{version}-%{release} ] && [ -x /bin/cp ] && \
+                       /bin/cp -a /var/lib/rpm /var/lib/rpm.rpmbackup-%{version}-%{release}; then
                echo
                echo "Backup of the rpm database has been created in /var/lib/rpm.rpmbackup-%{version}-%{release}"
                echo
        fi
        if [ -x %{_rpmlibdir}/bin/dbconvert ]; then
-               if ! %{_rpmlibdir}/bin/dbconvert --rebuilddb ; then
+               if ! %{_rpmlibdir}/bin/dbconvert --rebuilddb; then
                        echo
                        echo "rpm database conversion failed!"
                        echo "You have to run  %{_rpmlibdir}/bin/dbconvert manually"
This page took 0.179637 seconds and 4 git commands to generate.