]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm.spec
- check-files cleanup
[packages/rpm.git] / rpm.spec
index d4ae0e6f24e61967ccd8d3ab0e791eea91409250..e5b4267a3b0e52f7296e3962cf63599e0fbe590c 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
 %bcond_without python          # don't build python bindings
 %bcond_without selinux         # build without selinux support
 %bcond_without suggest_tags    # build without Suggest tag (bootstrapping)
-%bcond_with    db60            # use DB 6.0 instead of 5.2
+%bcond_with    db61            # use DB 6.1 instead of 5.2
 %bcond_with    neon            # build with HTTP/WebDAV support (neon library)
 %bcond_with    sqlite          # build with SQLite support
 %bcond_with    system_lua      # use system lua
+%bcond_without system_pcre     # use system pcre
 %bcond_with    keyutils        # build with keyutils support
 # force_cc             - force using __cc other than "%{_target_cpu}-pld-linux-gcc"
 # force_cxx            - force using __cxx other than "%{_target_cpu}-pld-linux-g++"
 %endif
 
 # versions of required libraries
-%if %{with db60}
-%define                reqdb_pkg       db6.0
-%define                reqdb_ver       6.0
-%define                reqdb_pkgver    6.0.20
+%if %{with db61}
+%define                reqdb_pkg       db6.1
+%define                reqdb_ver       6.1
+%define                reqdb_pkgver    6.1.19
 %else
 %define                reqdb_pkg       db5.2
 %define                reqdb_ver       5.2
@@ -49,13 +50,13 @@ Summary(pt_BR.UTF-8):       Gerenciador de pacotes RPM
 Summary(ru.UTF-8):     Менеджер пакетов от RPM
 Summary(uk.UTF-8):     Менеджер пакетів від RPM
 Name:          rpm
-Version:       5.4.14
-Release:       6
+Version:       5.4.15
+Release:       7
 License:       LGPL v2.1
 Group:         Base
-# http://rpm5.org/files/rpm/rpm-5.4/rpm-5.4.14-0.20131024.src.rpm
+# http://rpm5.org/files/rpm/rpm-5.4/rpm-5.4.15-0.20140824.src.rpm
 Source0:       %{name}-%{version}.tar.gz
-# Source0-md5: 9bd3fef1170f26a223a149dc1113c23c
+# Source0-md5: 4067f83ca8b5bf1a21e443c0cff3efa0
 Source100:     cpu-os-macros.tar.gz
 # Source100-md5:       928034a5bdceb398881bc14b5f29973b
 Source1:       %{name}.groups
@@ -89,6 +90,7 @@ Source27:     macros.lang
 Source28:      %{name}db_reset.c
 Source29:      dbupgrade.sh
 Source30:      rubygems.rb
+Source31:      gem_helper.rb
 Patch0:                %{name}-branch.patch
 Patch1:                %{name}-man_pl.patch
 Patch2:                %{name}-popt-aliases.patch
@@ -158,7 +160,6 @@ Patch67:    %{name}-repackage-dont-force-max-compression.patch
 Patch70:       python-%{name}sense-missingok.patch
 Patch71:       %{name}-changelog-encoding.patch
 Patch72:       %{name}-preserve-tag-type.patch
-Patch73:       gem_helper-spec-arg.patch
 Patch74:       %{name}-fix-internal-lua-build.patch
 Patch75:       %{name}-double_check_file_deps.patch
 Patch77:       %{name}-lua-expat.patch
@@ -166,6 +167,8 @@ Patch78:    %{name}-double_check_unpackaged_subdirs.patch
 Patch79:       %{name}-rpmspec.patch
 Patch80:       %{name}-revert-gpg-argv-parsing.patch
 Patch81:       %{name}-perl-magic.patch
+Patch82:       %{name}-5.4.15-use-DSA-sig.patch
+Patch83:       %{name}-ignore-missing-macro-files.patch
 
 # Patches imported from Mandriva
 
@@ -275,6 +278,15 @@ Patch1044: %{name}-5.4.12-fix-rpmlua-print.patch
 Patch1045:     %{name}-5.4.12-fix-rpmpython-module-import-init.patch
 Patch1046:     %{name}-5.4.12-truncate-output-buffer-after-use.patch
 Patch1047:     %{name}-5.4.13-perl-bindings-do-not-use-xmalloc.patch
+# proyvind:
+# there's a rpmdbchk tool I wrote a while back, which might help you. although
+# the incidents it's able to deal with is rather limited ATM... it might help
+# you out, if not and you'll be able to solve yer problem, you could take a
+# stab at adding support for fixing your specific problem to the util ;)
+# https://abf.io/openmandriva/rpm/raw/master/rpm-5.4.14-rpmdbchk.patch
+Patch1048:     %{name}-5.4.14-rpmdbchk.patch
+# https://abf.io/openmandriva/rpm/raw/master/rpm-5.4.14-no-assert-abort-with-broken-headers.patch
+Patch1049:     %{name}-5.4.14-no-assert-abort-with-broken-headers.patch
 
 URL:           http://rpm5.org/
 BuildRequires: %{reqdb_pkg}-devel >= %{reqdb_pkgver}
@@ -283,13 +295,12 @@ BuildRequires:    sqlite3-devel
 %else
 BuildRequires: %{reqdb_pkg}-sql-devel >= %{reqdb_pkgver}
 %endif
-BuildRequires: autoconf >= 2.60
+BuildRequires: autoconf >= 2.63
 BuildRequires: automake >= 1.4
 BuildRequires: beecrypt-devel >= %{beecrypt_ver}
 BuildRequires: bzip2-devel >= 1.0.2-17
 BuildRequires: elfutils-devel >= 0.108
-#BuildRequires:        gettext-autopoint >= 0.11.4-2
-BuildRequires: gettext-devel >= 0.11.4-2
+BuildRequires: gettext-tools >= 0.19.2
 %{?with_keyutils:BuildRequires:        keyutils-devel}
 BuildRequires: libmagic-devel
 %if %{with selinux}
@@ -645,7 +656,7 @@ Summary(uk.UTF-8):  Скрипти та утиліти, необхідні для
 Group:         Applications/File
 Requires(pretrans):    coreutils
 Requires(pretrans):    findutils
-Requires:      %{name}-build-macros >= 1.656
+Requires:      %{name}-build-macros >= 1.699
 Requires:      %{name}-utils = %{version}-%{release}
 Requires:      /bin/id
 Requires:      awk
@@ -885,7 +896,7 @@ Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
 %patch38 -p1
 %patch39 -p1
 %patch40 -p1
-%{?with_db60:%patch41 -p1}
+%{?with_db61:%patch41 -p1}
 %patch42 -p1
 %patch43 -p1
 %patch44 -p1
@@ -901,7 +912,7 @@ Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
 %patch54 -p1
 %patch55 -p1
 %patch56 -p1
-%{!?with_db60:%patch57 -p1}
+%{!?with_db61:%patch57 -p1}
 %patch58 -p1
 %patch60 -p1
 %patch61 -p1
@@ -914,7 +925,6 @@ Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
 %patch70 -p1
 %patch71 -p1
 %patch72 -p1
-%patch73 -p1
 %patch74 -p1
 %patch75 -p1
 %patch77 -p0
@@ -922,6 +932,7 @@ Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
 %patch79 -p1
 %patch80 -p1
 %patch81 -p0
+%patch82 -p1
 
 %patch1000 -p1
 %patch1001 -p1
@@ -960,19 +971,25 @@ Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
 %patch1038 -p1
 %patch1039 -p1
 %patch1040 -p1
-%patch1041 -p1
+# don't delete, may be usefull if jbj descides to enable this again
+#%patch1041 -p1
 %patch1042 -p1
 %patch1043 -p1
 %patch1044 -p1
 %patch1045 -p1
 %patch1046 -p1
 %patch1047 -p1
+%patch1048 -p1
+%patch1049 -p1
+
+%patch83 -p1
 
 install %{SOURCE2} macros/pld.in
 install %{SOURCE8} scripts/php.prov.in
 install %{SOURCE9} scripts/php.req.in
 install %{SOURCE11} scripts/perl.prov.in
 cp -p %{SOURCE30} scripts/rubygems.rb
+cp -p %{SOURCE31} scripts/gem_helper.rb
 
 %{__mv} -f scripts/perl.req{,.in}
 
@@ -982,7 +999,7 @@ awk -f %{SOURCE6} %{SOURCE1}
 install %{SOURCE26} tools/rpmdb_checkversion.c
 install %{SOURCE28} tools/rpmdb_reset.c
 
-for extlib in beecrypt neon pcre popt; do
+for extlib in beecrypt neon %{?with_system_pcre:pcre} popt; do
        [ -d $extlib ] && %{__rm} -r $extlib
 done
 
@@ -1026,7 +1043,7 @@ sed -i \
        --with-neon=%{?with_neon:external}%{!?with_neon:no} \
        --with-path-macros='%{_rpmlibdir}/macros:%{_rpmlibdir}/%%{_target}/macros:%{_rpmlibdir}/macros.d/pld:%{_rpmlibdir}/macros.build:%{_sysconfdir}/rpm/macros.*:%{_sysconfdir}/rpm/macros:%{_sysconfdir}/rpm/%%{_target}/macros:%{_sysconfdir}/rpm/macros.d/*.macros:~/etc/.rpmmacros:~/.rpmmacros' \
        --without-path-versioned \
-       --with-pcre=external \
+       --with-pcre=%{!?with_system_pcre:internal}%{?with_system_pcre:external} \
        --with-popt=external \
        %{?with_python:--with-python=%{py_ver} --with-python-lib-dir=%{py_sitedir}} \
        %{!?with_python:--without-python} \
@@ -1233,6 +1250,9 @@ for m in gstreamer java mono perl php python; do
        echo "%%{load:%{_rpmlibdir}/macros.d/$m}" >$RPM_BUILD_ROOT%{_rpmlibdir}/macros.$m
 done
 
+# moved to rpm-build-macros 1.699
+%{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/macros.d/kernel
+
 # for rpm -e|-U --repackage
 install -d $RPM_BUILD_ROOT/var/{spool/repackage,lock/rpm}
 touch $RPM_BUILD_ROOT/var/lock/rpm/transaction
@@ -1257,8 +1277,6 @@ mv $RPM_BUILD_ROOT{%{_rpmlibdir},%{_bindir}}/rpm2cpio
 
 # wrong location, not used anyway
 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/rpm.{daily,log,xinetd}
-# utils dropped in 4.4.8 -- their manuals
-%{__rm} $RPM_BUILD_ROOT%{_mandir}/*/man8/rpmgraph.8
 # utils dropped in 5.4 -- their manuals
 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/rpmgrep.1
 # script obsoleted by /usr/lib/rpm/bin/dbconvert binary
@@ -1325,7 +1343,6 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 %{_mandir}/man8/rpm.8*
 %lang(fr) %{_mandir}/fr/man8/rpm.8*
 %lang(ja) %{_mandir}/ja/man8/rpm.8*
-%lang(ko) %{_mandir}/ko/man8/rpm.8*
 %lang(pl) %{_mandir}/pl/man8/rpm.8*
 %lang(ru) %{_mandir}/ru/man8/rpm.8*
 %lang(sk) %{_mandir}/sk/man8/rpm.8*
@@ -1382,6 +1399,7 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 %attr(755,root,root) %{_rpmlibdir}/bin/dbupgrade.sh
 %attr(755,root,root) %{_rpmlibdir}/bin/rpmdb_checkversion
 %attr(755,root,root) %{_rpmlibdir}/bin/rpmdb_reset
+%attr(755,root,root) %{_rpmlibdir}/bin/rpmdbchk
 
 %files base
 %defattr(644,root,root,755)
@@ -1389,7 +1407,6 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rpm
 %dir %{_rpmlibdir}
 %attr(755,root,root) %{_bindir}/banner.sh
-%attr(755,root,root) %{_bindir}/multiarch-dispatch
 %attr(755,root,root) %{_rpmlibdir}/user_group.sh
 %dir /var/lib/banner
 
@@ -1418,7 +1435,6 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 %attr(755,root,root) %{_libdir}/librpmmisc-%{sover}.so
 %{_libdir}/librpm*.la
 %{_includedir}/rpm
-%{_includedir}/multiarch-dispatch.h
 %{_pkgconfigdir}/*.pc
 
 %files static
@@ -1455,15 +1471,11 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 %{?with_keyutils:%attr(755,root,root) %{_rpmlibdir}/bin/rpmkey}
 %attr(755,root,root) %{_rpmlibdir}/bin/rpmrepo
 %{_mandir}/man8/rpm2cpio.8*
-%{_mandir}/man8/rpmcache.8*
 %{_mandir}/man8/rpmconstant.8*
 %{_mandir}/man8/rpmdeps.8*
 %{_mandir}/man8/rpmmtree.8*
 %lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
-%lang(ja) %{_mandir}/ja/man8/rpmcache.8*
-%lang(ko) %{_mandir}/ko/man8/rpm2cpio.8*
 %lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
-%lang(pl) %{_mandir}/pl/man8/rpmcache.8*
 %lang(pl) %{_mandir}/pl/man8/rpmdeps.8*
 %lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
 
@@ -1516,7 +1528,6 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 %{_rpmlibdir}/macros.d/cmake
 %{_rpmlibdir}/macros.d/gstreamer
 %{_rpmlibdir}/macros.d/java
-%{_rpmlibdir}/macros.d/kernel
 %{_rpmlibdir}/macros.d/libtool
 %{_rpmlibdir}/macros.d/mono
 %{_rpmlibdir}/macros.d/perl
@@ -1535,13 +1546,10 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 %{_rpmlibdir}/macros.php
 %{_rpmlibdir}/macros.python
 
-%attr(755,root,root) %{_rpmlibdir}/check-multiarch-files
 %attr(755,root,root) %{_rpmlibdir}/gstreamer.sh
 %attr(755,root,root) %{_rpmlibdir}/kmod-deps.sh
-%attr(755,root,root) %{_rpmlibdir}/mkmultiarch
 
 %attr(755,root,root) %{_bindir}/gendiff
-%attr(755,root,root) %{_bindir}/multiarch-platform
 %attr(755,root,root) %{_bindir}/rpmbuild
 
 %dir %{_rpmlibdir}/helpers
This page took 0.038508 seconds and 4 git commands to generate.