]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm.spec
- check-files cleanup
[packages/rpm.git] / rpm.spec
index 9d64e419df9c083a029443038f247a44b43bb29c..e5b4267a3b0e52f7296e3962cf63599e0fbe590c 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -51,7 +51,7 @@ Summary(ru.UTF-8):    Менеджер пакетов от RPM
 Summary(uk.UTF-8):     Менеджер пакетів від RPM
 Name:          rpm
 Version:       5.4.15
-Release:       5
+Release:       7
 License:       LGPL v2.1
 Group:         Base
 # http://rpm5.org/files/rpm/rpm-5.4/rpm-5.4.15-0.20140824.src.rpm
@@ -90,6 +90,7 @@ Source27:     macros.lang
 Source28:      %{name}db_reset.c
 Source29:      dbupgrade.sh
 Source30:      rubygems.rb
+Source31:      gem_helper.rb
 Patch0:                %{name}-branch.patch
 Patch1:                %{name}-man_pl.patch
 Patch2:                %{name}-popt-aliases.patch
@@ -159,7 +160,6 @@ Patch67:    %{name}-repackage-dont-force-max-compression.patch
 Patch70:       python-%{name}sense-missingok.patch
 Patch71:       %{name}-changelog-encoding.patch
 Patch72:       %{name}-preserve-tag-type.patch
-Patch73:       gem_helper-spec-arg.patch
 Patch74:       %{name}-fix-internal-lua-build.patch
 Patch75:       %{name}-double_check_file_deps.patch
 Patch77:       %{name}-lua-expat.patch
@@ -278,6 +278,15 @@ Patch1044: %{name}-5.4.12-fix-rpmlua-print.patch
 Patch1045:     %{name}-5.4.12-fix-rpmpython-module-import-init.patch
 Patch1046:     %{name}-5.4.12-truncate-output-buffer-after-use.patch
 Patch1047:     %{name}-5.4.13-perl-bindings-do-not-use-xmalloc.patch
+# proyvind:
+# there's a rpmdbchk tool I wrote a while back, which might help you. although
+# the incidents it's able to deal with is rather limited ATM... it might help
+# you out, if not and you'll be able to solve yer problem, you could take a
+# stab at adding support for fixing your specific problem to the util ;)
+# https://abf.io/openmandriva/rpm/raw/master/rpm-5.4.14-rpmdbchk.patch
+Patch1048:     %{name}-5.4.14-rpmdbchk.patch
+# https://abf.io/openmandriva/rpm/raw/master/rpm-5.4.14-no-assert-abort-with-broken-headers.patch
+Patch1049:     %{name}-5.4.14-no-assert-abort-with-broken-headers.patch
 
 URL:           http://rpm5.org/
 BuildRequires: %{reqdb_pkg}-devel >= %{reqdb_pkgver}
@@ -291,7 +300,7 @@ BuildRequires:      automake >= 1.4
 BuildRequires: beecrypt-devel >= %{beecrypt_ver}
 BuildRequires: bzip2-devel >= 1.0.2-17
 BuildRequires: elfutils-devel >= 0.108
-BuildRequires: gettext-devel >= 0.19.2
+BuildRequires: gettext-tools >= 0.19.2
 %{?with_keyutils:BuildRequires:        keyutils-devel}
 BuildRequires: libmagic-devel
 %if %{with selinux}
@@ -647,7 +656,7 @@ Summary(uk.UTF-8):  Скрипти та утиліти, необхідні для
 Group:         Applications/File
 Requires(pretrans):    coreutils
 Requires(pretrans):    findutils
-Requires:      %{name}-build-macros >= 1.656
+Requires:      %{name}-build-macros >= 1.699
 Requires:      %{name}-utils = %{version}-%{release}
 Requires:      /bin/id
 Requires:      awk
@@ -916,7 +925,6 @@ Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
 %patch70 -p1
 %patch71 -p1
 %patch72 -p1
-%patch73 -p1
 %patch74 -p1
 %patch75 -p1
 %patch77 -p0
@@ -971,6 +979,8 @@ Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
 %patch1045 -p1
 %patch1046 -p1
 %patch1047 -p1
+%patch1048 -p1
+%patch1049 -p1
 
 %patch83 -p1
 
@@ -979,6 +989,7 @@ install %{SOURCE8} scripts/php.prov.in
 install %{SOURCE9} scripts/php.req.in
 install %{SOURCE11} scripts/perl.prov.in
 cp -p %{SOURCE30} scripts/rubygems.rb
+cp -p %{SOURCE31} scripts/gem_helper.rb
 
 %{__mv} -f scripts/perl.req{,.in}
 
@@ -1239,6 +1250,9 @@ for m in gstreamer java mono perl php python; do
        echo "%%{load:%{_rpmlibdir}/macros.d/$m}" >$RPM_BUILD_ROOT%{_rpmlibdir}/macros.$m
 done
 
+# moved to rpm-build-macros 1.699
+%{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/macros.d/kernel
+
 # for rpm -e|-U --repackage
 install -d $RPM_BUILD_ROOT/var/{spool/repackage,lock/rpm}
 touch $RPM_BUILD_ROOT/var/lock/rpm/transaction
@@ -1385,6 +1399,7 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 %attr(755,root,root) %{_rpmlibdir}/bin/dbupgrade.sh
 %attr(755,root,root) %{_rpmlibdir}/bin/rpmdb_checkversion
 %attr(755,root,root) %{_rpmlibdir}/bin/rpmdb_reset
+%attr(755,root,root) %{_rpmlibdir}/bin/rpmdbchk
 
 %files base
 %defattr(644,root,root,755)
@@ -1513,7 +1528,6 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 %{_rpmlibdir}/macros.d/cmake
 %{_rpmlibdir}/macros.d/gstreamer
 %{_rpmlibdir}/macros.d/java
-%{_rpmlibdir}/macros.d/kernel
 %{_rpmlibdir}/macros.d/libtool
 %{_rpmlibdir}/macros.d/mono
 %{_rpmlibdir}/macros.d/perl
This page took 0.026379 seconds and 4 git commands to generate.