]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm.spec
- internal file update (for compatibility with *.mgc generated by file-4.14)
[packages/rpm.git] / rpm.spec
index 9cf8936deb4610f9123e9c0ee8347485191793b7..e2d937c4e5b9cb0d166d90b843812ad416da11a2 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -19,7 +19,7 @@
 %define        reqdb_ver       4.3.27-1
 %define        reqpopt_ver     1.10.1
 %define        beecrypt_ver    2:4.1.0
-%define        rpm_macros_rev  1.213
+%define        rpm_macros_rev  1.231
 Summary:       RPM Package Manager
 Summary(de):   RPM Packet-Manager
 Summary(es):   Gestor de paquetes RPM
@@ -30,7 +30,7 @@ Summary(uk):  
 Name:          rpm
 %define        sover   4.4
 Version:       4.4.1
-Release:       1.9
+Release:       1.99
 License:       GPL
 Group:         Base
 Source0:       ftp://jbj.org/pub/rpm-4.4.x/%{name}-%{version}.tar.gz
@@ -96,6 +96,7 @@ Patch38:      %{name}-gcc4.patch
 Patch39:       %{name}-pythondeps.patch
 Patch40:       %{name}-print-requires.patch
 Patch41:       %{name}-reduce-stack-usage.patch
+Patch42:       %{name}-glob.patch
 URL:           http://www.rpm.org/
 Icon:          rpm.gif
 BuildRequires: autoconf >= 2.52
@@ -397,16 +398,8 @@ Requires:  elfutils
 Requires:      file >= 4.13-2
 Requires:      fileutils
 Requires:      findutils
-%ifarch athlon
-Requires:      gcc >= 3.0.3
-%else
-%ifarch i686
-# because of -mtune in rpmrc
-Requires:      gcc >= 5:3.4
-%else
-Requires:      gcc
-%endif
-%endif
+# because of -fvisibility... related fixes
+Requires:      gcc >= 5:4.0.1-0.20050514.2
 Requires:      glibc-devel
 Requires:      grep
 Requires:      gzip
@@ -419,8 +412,6 @@ Requires:   tar
 Requires:      textutils
 Provides:      rpmbuild(macros) = %{rpm_macros_rev}
 Provides:      rpmbuild(noauto) = 3
-# because of -fvisibility-inlines-hidden in rpm.macros
-Conflicts:     gcc-c++ < 5:3.4
 %ifarch %{x8664}
 Conflicts:     automake < 1:1.7.9-2
 Conflicts:     libtool < 2:1.5-13
@@ -506,7 +497,7 @@ Summary:    Python macros, which simplifies creation of rpm packages with Python so
 Summary(pl):   Makra u³atwiaj±ce tworzenie pakietów rpm z programami napisanymi w Pythonie
 Group:         Applications/File
 Requires:      %{name} = %{version}-%{release}
-Requires:      python-modules
+Requires:      python
 
 %description pythonprov
 Python macros, which simplifies creation of rpm packages with Python
@@ -632,6 +623,7 @@ cat %{SOURCE11} >> macros.in
 %patch39 -p1
 %patch40 -p1
 %patch41 -p1
+%patch42 -p1
 %patch0 -p1
 %patch3 -p1
 
@@ -654,10 +646,6 @@ for f in doc{,/ja,/pl}/rpm.8 doc{,/ja,/pl}/rpmbuild.8 ; do
        mv -f ${f}.tmp $f
 done
 
-# ... and make some cleanings
-rm -fr $(find ./ -type d -name CVS )
-rm -f  $(find ./ -type f -name ".cvsignore" )
-
 %build
 cd file
 %{__libtoolize}
@@ -680,6 +668,8 @@ sed -e 's|@host@|%{_target_cpu}-%{_target_vendor}-linux-gnu|' \
        -e 's|@host_cpu@|%{_target_cpu}|' macros.in > macros.tmp
 mv -f macros.tmp macros.in
 
+CPPFLAGS="-Dglob=rpm_glob -Dglobfree=rpm_globfree"; export CPPFLAGS
+
 # pass CC and CXX too in case of building with some older configure macro
 %configure \
        CC="%{__newcc}" \
@@ -692,6 +682,7 @@ mv -f macros.tmp macros.in
        %{?with_python:--with-python=auto} \
        %{!?with_python:--without-python} \
        %{!?with_selinux:--without-selinux} \
+       --with-glob \
        --without-db
 
 # file_LDFLAGS, debugedit_LDADD - no need to link "file" and "debugedit" statically
This page took 0.051595 seconds and 4 git commands to generate.