]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm.spec
- internal file update (for compatibility with *.mgc generated by file-4.14)
[packages/rpm.git] / rpm.spec
index 784f75d688086d7fd6f3addeec604d261c971190..e2d937c4e5b9cb0d166d90b843812ad416da11a2 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -1,26 +1,25 @@
 #
 # TODO:
+# - python(abi) cap is not provided automatically (because /usr/bin/python matches
+#   ELF first; it should be provided by python-libs not binary anyway)
 # - consider using system libmagic not internal libfmagic
 #   (but internal has different method of passing output)
-# - after ac drop amd64 patch and make x86_64 generic arch + subarchs amd64 and ia32e
 # 
 # Conditional build:
-%bcond_with    distver # build with distversion field
-%bcond_with    static  # build static rpmi (not supported at the moment)
-%bcond_without apidocs # don't generate documentation with doxygen
-%bcond_without pkgnameinautoreq        # don't put package name in autogenerated dependancy
-%bcond_without python  # don't build python bindings
-%bcond_without selinux # dont enable selinux support
+%bcond_with    static          # build static rpmi (not supported at the moment)
+%bcond_without apidocs         # don't generate documentation with doxygen
+%bcond_with    autoreqdep      # autogenerate package name deps in addition to sonames/perl(X)
+%bcond_without python          # don't build python bindings
+%bcond_without selinux         # build without selinux support
 # force_cc             - force using __cc other than "%{_target_cpu}-pld-linux-gcc"
 # force_cxx            - force using __cxx other than "%{_target_cpu}-pld-linux-g++"
 # force_cpp            - force using __cpp other than "%{_target_cpu}-pld-linux-gcc -E"
 
-%define        snap    20041121
 # versions of required libraries
-%define        reqdb_ver       4.2.50-1
-%define        reqpopt_ver     1.9
+%define        reqdb_ver       4.3.27-1
+%define        reqpopt_ver     1.10.1
 %define        beecrypt_ver    2:4.1.0
-%define        rpm_macros_rev  1.183
+%define        rpm_macros_rev  1.231
 Summary:       RPM Package Manager
 Summary(de):   RPM Packet-Manager
 Summary(es):   Gestor de paquetes RPM
@@ -29,16 +28,13 @@ Summary(pt_BR):     Gerenciador de pacotes RPM
 Summary(ru):   íÅÎÅÄÖÅÒ ÐÁËÅÔÏ× ÏÔ RPM
 Summary(uk):   íÅÎÅÄÖÅÒ ÐÁËÅԦנצĠRPM
 Name:          rpm
-%define        ver     4.4
 %define        sover   4.4
-Version:       %{ver}
-Release:       0.%{snap}.0.7
+Version:       4.4.1
+Release:       1.99
 License:       GPL
 Group:         Base
-#Source0:      ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.2.x/%{name}-%{version}.%{snap}.tar.gz
-# Snap tarball is generated from rpm-4_4 branch
-Source0:       ftp://distfiles.pld-linux.org/src/%{name}-%{version}.%{snap}.tar.bz2
-# Source0-md5: 9960ab3e3023b49b42c1e85acef33de5
+Source0:       ftp://jbj.org/pub/rpm-4.4.x/%{name}-%{version}.tar.gz
+# Source0-md5: 90ded9047b1b69d918c6c7c7b56fd7a9
 Source1:       %{name}.groups
 Source2:       %{name}.platform
 Source3:       %{name}-install-tree
@@ -83,7 +79,7 @@ Patch21:      %{name}-dontneedutils.patch
 Patch22:       %{name}-provides-dont-obsolete.patch
 Patch23:       %{name}-examplesaredoc.patch
 Patch24:       %{name}-po.patch
-Patch25:       %{name}-amd64.patch
+Patch25:       %{name}-getcwd.patch
 Patch26:       %{name}-notsc.patch
 Patch27:       %{name}-hack-norpmlibdep.patch
 Patch28:       %{name}-makefile-no_myLDADD_deps.patch
@@ -96,8 +92,11 @@ Patch34:     %{name}-epoch0.patch
 Patch35:       %{name}-perl_req-INC_dirs.patch
 Patch36:       %{name}-debuginfo.patch
 Patch37:       %{name}-doxygen_hack.patch
-Patch38:       %{name}-distver.patch
-Patch39:       %{name}-gcc4.patch
+Patch38:       %{name}-gcc4.patch
+Patch39:       %{name}-pythondeps.patch
+Patch40:       %{name}-print-requires.patch
+Patch41:       %{name}-reduce-stack-usage.patch
+Patch42:       %{name}-glob.patch
 URL:           http://www.rpm.org/
 Icon:          rpm.gif
 BuildRequires: autoconf >= 2.52
@@ -110,7 +109,7 @@ BuildRequires:      elfutils-devel
 BuildRequires: findutils
 BuildRequires: gettext-devel >= 0.11.4-2
 #BuildRequires:        libmagic-devel
-%{?with_selinux:BuildRequires: libselinux-devel}
+%{?with_selinux:BuildRequires: libselinux-devel >= 1.18}
 # needed only for AM_PROG_CXX used for CXX substitution in rpm.macros
 BuildRequires: libstdc++-devel
 BuildRequires: libtool
@@ -122,7 +121,6 @@ BuildRequires:      popt-devel >= %{reqpopt_ver}
 BuildRequires: python-modules >= 2.2
 BuildRequires: readline-devel
 BuildRequires: rpm-perlprov
-BuildRequires: rpm-pythonprov
 BuildRequires: zlib-devel
 %if %{with static}
 # Require static library only for static build
@@ -132,7 +130,7 @@ BuildRequires:      db-static >= %{reqdb_ver}
 BuildRequires: glibc-static >= 2.2.94
 BuildRequires: elfutils-static
 #BuildRequires:        libmagic-static
-%{?with_selinux:BuildRequires: libselinux-static}
+%{?with_selinux:BuildRequires: libselinux-static >= 1.18}
 BuildRequires: popt-static >= %{reqpopt_ver}
 BuildRequires: zlib-static
 %endif
@@ -150,7 +148,8 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 # don't require very fresh rpm.macros to build
 %define                __gettextize gettextize --copy --force --intl ; cp -f po/Makevars{.template,}
-%define                ix86 i386 i486 i586 i686 athlon pentium3 pentium4
+%define                ix86    i386 i486 i586 i686 athlon pentium3 pentium4
+%define                x8664   amd64 ia32e x86_64
 
 # stabilize new build environment
 %define                __newcc %{?force_cc}%{!?force_cc:%{_target_cpu}-pld-linux-gcc}
@@ -208,6 +207,22 @@ RPM - 
 ÓÌÕÖÂÏ×ϧ ¦ÎÆÏÒÍÁæ§, ÝϠͦÓÔÉÔØ ÎÁÚ×Õ, ×ÅÒÓ¦À, ÏÐÉÓ ÔÁ ¦ÎÛÕ
 ¦ÎÆÏÒÍÁæÀ ÐÒÏ ÐÁËÅÔ.
 
+%package lib
+Summary:       RPMs library
+Summary(pl):   Biblioteki RPM-a
+Group:         Libraries
+Requires:      db >= %{reqdb_ver}
+%{?with_selinux:BuildRequires: libselinux >= 1.18}
+Requires:      popt >= %{reqpopt_ver}
+# avoid SEGV caused by mixed db versions
+Conflicts:     poldek < 0.18.1-16
+
+%description lib
+RPMs library.
+
+%description lib -l pl
+Biblioteki RPM-a.
+
 %package devel
 Summary:       Header files for rpm libraries
 Summary(de):   Header-Dateien für rpm Libraries
@@ -362,103 +377,6 @@ Aktualnie pakiet zawiera binark
 uaktualniania lub usuwania pakietów bez udzia³u bibliotek statycznych
 (z wyj±tkiem modu³ów NSS).
 
-%package perlprov
-Summary:       Additional utilities for checking perl provides/requires in rpm packages
-Summary(de):   Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
-Summary(pl):   Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów perla w pakietach rpm
-Group:         Applications/File
-Requires:      %{name} = %{version}-%{release}
-Requires:      perl-devel
-Requires:      perl-modules
-
-%description perlprov
-Additional utilities for checking perl provides/requires in rpm
-packages.
-
-%description perlprov -l de
-Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
-
-%description perlprov -l pl
-Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów perla w
-pakietach rpm.
-
-%package pythonprov
-Summary:       Python macros, which simplifies creation of rpm packages with Python software
-Summary(pl):   Makra u³atwiaj±ce tworzenie pakietów rpm z programami napisanymi w Pythonie
-Group:         Applications/File
-Requires:      %{name} = %{version}-%{release}
-Requires:      python-modules
-
-%description pythonprov
-Python macros, which simplifies creation of rpm packages with Python
-software.
-
-%description pythonprov -l pl
-Makra u³atwiaj±ce tworzenie pakietów rpm z programami napisanymi w
-Pythonie.
-
-%package php-pearprov
-Summary:       Additional utilities for managing rpm packages and database
-Summary(pl):   Dodatkowe narzêdzia do sprawdzania zale¿no¶ci skryptów php w rpm
-Group:         Applications/File
-Requires:      %{name} = %{version}-%{release}
-
-%description php-pearprov
-Additional utilities for checking php pear provides/requires in rpm
-packages.
-
-%description php-pearprov -l pl
-Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów php pear w
-pakietach rpm.
-
-%package -n python-rpm
-Summary:       Python interface to RPM library
-Summary(pl):   Pythonowy interfejs do biblioteki RPM-a
-Summary(pt_BR):        Módulo Python para aplicativos que manipulam pacotes RPM
-Group:         Development/Languages/Python
-Requires:      %{name} = %{version}-%{release}
-%pyrequires_eq python
-Obsoletes:     rpm-python
-
-%description -n python-rpm
-The rpm-python package contains a module which permits applications
-written in the Python programming language to use the interface
-supplied by RPM (RPM Package Manager) libraries.
-
-This package should be installed if you want to develop Python
-programs that will manipulate RPM packages and databases.
-
-%description -n python-rpm -l pl
-Pakiet rpm-python zawiera modu³, który pozwala aplikacjom napisanym w
-Pythonie na u¿ywanie interfejsu dostarczanego przez biblioteki RPM-a.
-
-Pakiet ten powinien zostaæ zainstalowany, je¶li chcesz pisaæ w
-Pythonie programy manipuluj±ce pakietami i bazami danych rpm.
-
-%description -n python-rpm -l pt_BR
-O pacote rpm-python contém um módulo que permite que aplicações
-escritas em Python utilizem a interface fornecida pelas bibliotecas
-RPM (RPM Package Manager).
-
-Esse pacote deve ser instalado se você quiser desenvolver programas em
-Python para manipular pacotes e bancos de dados RPM.
-
-%package lib
-Summary:       RPMs library
-Summary(pl):   Biblioteki RPM-a
-Group:         Libraries
-Requires:      db >= %{reqdb_ver}
-Requires:      popt >= %{reqpopt_ver}
-%{?with_distver:Provides:      rpm-lib(distver)}
-# avoid SEGV caused by mixed db versions
-Conflicts:     poldek < 0.18.1-16
-
-%description lib
-RPMs library.
-
-%description lib -l pl
-Biblioteki RPM-a.
-
 %package build
 Summary:       Scripts for building binary RPM packages
 Summary(de):   Scripts fürs Bauen binärer RPM-Pakete
@@ -477,14 +395,11 @@ Requires: chrpath >= 0.10-4
 Requires:      cpio
 Requires:      diffutils
 Requires:      elfutils
-Requires:      file >= 4.01
+Requires:      file >= 4.13-2
 Requires:      fileutils
 Requires:      findutils
-%ifarch athlon
-Requires:      gcc >= 3.0.3
-%else
-Requires:      gcc
-%endif
+# because of -fvisibility... related fixes
+Requires:      gcc >= 5:4.0.1-0.20050514.2
 Requires:      glibc-devel
 Requires:      grep
 Requires:      gzip
@@ -497,7 +412,7 @@ Requires:   tar
 Requires:      textutils
 Provides:      rpmbuild(macros) = %{rpm_macros_rev}
 Provides:      rpmbuild(noauto) = 3
-%ifarch amd64
+%ifarch %{x8664}
 Conflicts:     automake < 1:1.7.9-2
 Conflicts:     libtool < 2:1.5-13
 %endif
@@ -557,6 +472,87 @@ construir pacotes usando o RPM.
 ò¦ÚÎÏÍÁΦÔΦ ÄÏÐÏͦÖΦ ÓËÒÉÐÔÉ ÔÁ ÕÔÉ̦ÔÉ, Ñ˦ ×ÉËÏÒÉÓÔÏ×ÕÀÔØÓÑ ÄÌÑ
 ÐÏÂÕÄÏ×É RPM'¦×.
 
+%package perlprov
+Summary:       Additional utilities for checking perl provides/requires in rpm packages
+Summary(de):   Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
+Summary(pl):   Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów perla w pakietach rpm
+Group:         Applications/File
+Requires:      %{name} = %{version}-%{release}
+Requires:      perl-devel
+Requires:      perl-modules
+
+%description perlprov
+Additional utilities for checking perl provides/requires in rpm
+packages.
+
+%description perlprov -l de
+Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
+
+%description perlprov -l pl
+Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów perla w
+pakietach rpm.
+
+%package pythonprov
+Summary:       Python macros, which simplifies creation of rpm packages with Python software
+Summary(pl):   Makra u³atwiaj±ce tworzenie pakietów rpm z programami napisanymi w Pythonie
+Group:         Applications/File
+Requires:      %{name} = %{version}-%{release}
+Requires:      python
+
+%description pythonprov
+Python macros, which simplifies creation of rpm packages with Python
+software.
+
+%description pythonprov -l pl
+Makra u³atwiaj±ce tworzenie pakietów rpm z programami napisanymi w
+Pythonie.
+
+%package php-pearprov
+Summary:       Additional utilities for managing rpm packages and database
+Summary(pl):   Dodatkowe narzêdzia do sprawdzania zale¿no¶ci skryptów php w rpm
+Group:         Applications/File
+Requires:      %{name} = %{version}-%{release}
+
+%description php-pearprov
+Additional utilities for checking php pear provides/requires in rpm
+packages.
+
+%description php-pearprov -l pl
+Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów php pear w
+pakietach rpm.
+
+%package -n python-rpm
+Summary:       Python interface to RPM library
+Summary(pl):   Pythonowy interfejs do biblioteki RPM-a
+Summary(pt_BR):        Módulo Python para aplicativos que manipulam pacotes RPM
+Group:         Development/Languages/Python
+Requires:      %{name} = %{version}-%{release}
+%pyrequires_eq python
+Obsoletes:     rpm-python
+
+%description -n python-rpm
+The rpm-python package contains a module which permits applications
+written in the Python programming language to use the interface
+supplied by RPM (RPM Package Manager) libraries.
+
+This package should be installed if you want to develop Python
+programs that will manipulate RPM packages and databases.
+
+%description -n python-rpm -l pl
+Pakiet rpm-python zawiera modu³, który pozwala aplikacjom napisanym w
+Pythonie na u¿ywanie interfejsu dostarczanego przez biblioteki RPM-a.
+
+Pakiet ten powinien zostaæ zainstalowany, je¶li chcesz pisaæ w
+Pythonie programy manipuluj±ce pakietami i bazami danych rpm.
+
+%description -n python-rpm -l pt_BR
+O pacote rpm-python contém um módulo que permite que aplicações
+escritas em Python utilizem a interface fornecida pelas bibliotecas
+RPM (RPM Package Manager).
+
+Esse pacote deve ser instalado se você quiser desenvolver programas em
+Python para manipular pacotes e bancos de dados RPM.
+
 %package apidocs
 Summary:       RPM API documentation and guides
 Summary(pl):   Documentacja API RPM-a i przewodniki
@@ -571,7 +567,7 @@ Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane
 ze ¼rode³ RPM-a przez doxygen.
 
 %prep
-%setup -q -n %{name}
+%setup -q
 %patch1 -p1
 %patch2 -p1
 # temporarily moved after patch0 - messes too much in pl.po
@@ -623,8 +619,11 @@ cat %{SOURCE11} >> macros.in
 %patch35 -p0
 %patch36 -p1
 %patch37 -p1
-%{?with_distver:%patch38 -p1}
+%patch38 -p1
 %patch39 -p1
+%patch40 -p1
+%patch41 -p1
+%patch42 -p1
 %patch0 -p1
 %patch3 -p1
 
@@ -647,10 +646,6 @@ for f in doc{,/ja,/pl}/rpm.8 doc{,/ja,/pl}/rpmbuild.8 ; do
        mv -f ${f}.tmp $f
 done
 
-# ... and make some cleanings
-rm -fr $(find ./ -type d -name CVS )
-rm -f  $(find ./ -type f -name ".cvsignore" )
-
 %build
 cd file
 %{__libtoolize}
@@ -673,6 +668,8 @@ sed -e 's|@host@|%{_target_cpu}-%{_target_vendor}-linux-gnu|' \
        -e 's|@host_cpu@|%{_target_cpu}|' macros.in > macros.tmp
 mv -f macros.tmp macros.in
 
+CPPFLAGS="-Dglob=rpm_glob -Dglobfree=rpm_globfree"; export CPPFLAGS
+
 # pass CC and CXX too in case of building with some older configure macro
 %configure \
        CC="%{__newcc}" \
@@ -685,6 +682,7 @@ mv -f macros.tmp macros.in
        %{?with_python:--with-python=auto} \
        %{!?with_python:--without-python} \
        %{!?with_selinux:--without-selinux} \
+       --with-glob \
        --without-db
 
 # file_LDFLAGS, debugedit_LDADD - no need to link "file" and "debugedit" statically
@@ -770,15 +768,15 @@ cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqdep <<EOF
 # global list of capabilities (SONAME, perl(module), php(module) regexps)
 # which don't generate dependencies on package NAMES
 # -- OpenGL implementation
-^libGL.so.1$
-^libGLU.so.1$
+^libGL.so.1
+^libGLU.so.1
 ^libOSMesa.so
 # -- Glide
-^libglide3.so.3$
+^libglide3.so.3
 # -- mozilla
-^libgtkmozembed.so$
-^libgtksuperwin.so$
-^libxpcom.so$
+^libgtkmozembed.so
+^libgtksuperwin.so
+^libxpcom.so
 # -- X11 implementation
 ^libFS.so
 ^libI810XvMC.so
@@ -904,6 +902,63 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 %attr(755,root,root) /%{_lib}/librpm*-*.so
 %attr(755,root,root) %{_libdir}/librpm*-*.so
 
+%files devel
+%defattr(644,root,root,755)
+%{_includedir}/rpm
+%{_libdir}/librpm*.la
+%attr(755,root,root) %{_libdir}/librpm.so
+%attr(755,root,root) %{_libdir}/librpm-%{sover}.so
+%attr(755,root,root) %{_libdir}/librpmio.so
+%attr(755,root,root) %{_libdir}/librpmio-%{sover}.so
+%attr(755,root,root) %{_libdir}/librpmdb.so
+%attr(755,root,root) %{_libdir}/librpmdb-%{sover}.so
+%attr(755,root,root) %{_libdir}/librpmbuild.so
+
+%files static
+%defattr(644,root,root,755)
+%{_libdir}/librpm*.a
+
+%files utils
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/debugedit
+%attr(755,root,root) %{_bindir}/rpm2cpio
+%attr(755,root,root) %{_bindir}/rpmcache
+%attr(755,root,root) %{_bindir}/rpmdeps
+%attr(755,root,root) %{_bindir}/rpmgraph
+%attr(755,root,root) %{_bindir}/rpmfile
+%attr(755,root,root) %{_rpmlibdir}/find-debuginfo.sh
+%attr(755,root,root) %{_rpmlibdir}/rpm2cpio.sh
+%attr(755,root,root) %{_rpmlibdir}/tgpg
+%attr(755,root,root) %{_rpmlibdir}/rpmdb_loadcvt
+%{_mandir}/man8/rpm2cpio.8*
+%{_mandir}/man8/rpmdeps.8*
+%{_mandir}/man8/rpmcache.8*
+%{_mandir}/man8/rpmgraph.8*
+%lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
+%lang(ja) %{_mandir}/ja/man8/rpmcache.8*
+%lang(ja) %{_mandir}/ja/man8/rpmgraph.8*
+%lang(ko) %{_mandir}/ko/man8/rpm2cpio.8*
+%lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
+%lang(pl) %{_mandir}/pl/man8/rpmdeps.8*
+%lang(pl) %{_mandir}/pl/man8/rpmcache.8*
+%lang(pl) %{_mandir}/pl/man8/rpmgraph.8*
+%lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
+
+%files utils-perl
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_rpmlibdir}/rpmdiff*
+# not here
+#%%{_rpmlibdir}/rpm.daily
+#%%{_rpmlibdir}/rpm.log
+#%%{_rpmlibdir}/rpm.xinetd
+
+%if %{with static}
+%files utils-static
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/rpm[ieu]
+%attr(755,root,root) %{_rpmlibdir}/rpm[ieu]
+%endif
+
 %files build
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/rpm/noauto*
@@ -940,9 +995,6 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 %ifarch alpha
 %{_rpmlibdir}/alpha*
 %endif
-%ifarch amd64
-%{_rpmlibdir}/amd64*
-%endif
 %ifarch ia64
 %{_rpmlibdir}/ia64*
 %endif
@@ -955,6 +1007,9 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 %ifarch sparc sparc64
 %{_rpmlibdir}/sparc*
 %endif
+%ifarch %{x8664}
+%{_rpmlibdir}/x86_64*
+%endif
 # must be here for "Requires: rpm-*prov" to work
 %{_rpmlibdir}/macros.perl
 %{_rpmlibdir}/macros.php
@@ -977,63 +1032,11 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 %lang(pl) %{_mandir}/pl/man1/gendiff.1*
 %lang(pl) %{_mandir}/pl/man8/rpmbuild.8*
 
-%files devel
-%defattr(644,root,root,755)
-%{_includedir}/rpm
-%{_libdir}/librpm*.la
-%attr(755,root,root) %{_libdir}/librpm.so
-%attr(755,root,root) %{_libdir}/librpm-%{sover}.so
-%attr(755,root,root) %{_libdir}/librpmio.so
-%attr(755,root,root) %{_libdir}/librpmio-%{sover}.so
-%attr(755,root,root) %{_libdir}/librpmdb.so
-%attr(755,root,root) %{_libdir}/librpmdb-%{sover}.so
-%attr(755,root,root) %{_libdir}/librpmbuild.so
-
-%files static
-%defattr(644,root,root,755)
-%{_libdir}/librpm*.a
-
-%files utils
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/debugedit
-%attr(755,root,root) %{_bindir}/rpm2cpio
-%attr(755,root,root) %{_bindir}/rpmcache
-%attr(755,root,root) %{_bindir}/rpmdeps
-%attr(755,root,root) %{_bindir}/rpmgraph
-%attr(755,root,root) %{_bindir}/rpmfile
-%attr(755,root,root) %{_rpmlibdir}/find-debuginfo.sh
-%attr(755,root,root) %{_rpmlibdir}/rpm2cpio.sh
-%attr(755,root,root) %{_rpmlibdir}/tgpg
-%attr(755,root,root) %{_rpmlibdir}/rpmdb_loadcvt
-%{_mandir}/man8/rpm2cpio.8*
-%{_mandir}/man8/rpmdeps.8*
-%{_mandir}/man8/rpmcache.8*
-%{_mandir}/man8/rpmgraph.8*
-%lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
-%lang(ja) %{_mandir}/ja/man8/rpmcache.8*
-%lang(ja) %{_mandir}/ja/man8/rpmgraph.8*
-%lang(ko) %{_mandir}/ko/man8/rpm2cpio.8*
-%lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
-%lang(pl) %{_mandir}/pl/man8/rpmdeps.8*
-%lang(pl) %{_mandir}/pl/man8/rpmcache.8*
-%lang(pl) %{_mandir}/pl/man8/rpmgraph.8*
-%lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
-
-%files utils-perl
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_rpmlibdir}/rpmdiff*
-# not here
-#%%{_rpmlibdir}/rpm.daily
-#%%{_rpmlibdir}/rpm.log
-#%%{_rpmlibdir}/rpm.xinetd
-
-
-%if %{with static}
-%files utils-static
+%files build-tools
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/rpm[ieu]
-%attr(755,root,root) %{_rpmlibdir}/rpm[ieu]
-%endif
+%attr(755,root,root) %{_bindir}/builder
+%attr(755,root,root) %{_bindir}/adapter.awk
+%attr(755,root,root) %{_bindir}/pldnotify.awk
 
 %files perlprov
 %defattr(644,root,root,755)
@@ -1048,6 +1051,7 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 %files pythonprov
 %defattr(644,root,root,755)
 %{_rpmlibdir}/macros.python
+%attr(755,root,root) %{_rpmlibdir}/pythondeps.sh
 
 %files php-pearprov
 %defattr(644,root,root,755)
@@ -1064,12 +1068,6 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 %{py_sitedir}/rpmdb/*.py*
 %endif
 
-%files build-tools
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/builder
-%attr(755,root,root) %{_bindir}/adapter.awk
-%attr(755,root,root) %{_bindir}/pldnotify.awk
-
 %if %{with apidocs}
 %files apidocs
 %defattr(644,root,root,755)
This page took 0.045108 seconds and 4 git commands to generate.