]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm.spec
- rel 58
[packages/rpm.git] / rpm.spec
index 2b3e494d4dfcbe731b51e0f4c506efabadfdf767..cf2b555cb9ed6a0c18233c832f572aaec73bc6fd 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
 # Conditional build:
 %bcond_with    static          # build static rpm+rpmi
 %bcond_without apidocs         # don't generate documentation with doxygen
-%bcond_with            internal_db             # internal db (db 4.5.20)
+%bcond_with    internal_db     # internal db (db 4.5.20)
 %if "%{pld_release}" == "ac"
 %bcond_without autoreqdep      # autogenerate package name deps in addition to sonames/perl(X)
-%bcond_with            nptl                    # internal db: don't use process-shared POSIX mutexes (NPTL provides full interface)
+%bcond_with    nptl            # internal db: don't use process-shared POSIX mutexes (NPTL provides full interface)
 %else
-%bcond_with            autoreqdep      # autogenerate package name deps in addition to sonames/perl(X)
-%bcond_without nptl                    # internal db: don't use process-shared POSIX mutexes (NPTL provides full interface)
+%bcond_with    autoreqdep      # autogenerate package name deps in addition to sonames/perl(X)
+%bcond_without nptl            # internal db: don't use process-shared POSIX mutexes (NPTL provides full interface)
 %endif
 %bcond_without python          # don't build python bindings
 %bcond_without selinux         # build without selinux support
@@ -57,7 +57,7 @@ Summary(ru.UTF-8):    Менеджер пакетов от RPM
 Summary(uk.UTF-8):     Менеджер пакетів від RPM
 Name:          rpm
 Version:       4.5
-Release:       43
+Release:       58
 License:       LGPL
 Group:         Base
 Source0:       %{name}-%{version}.tar.gz
@@ -84,6 +84,8 @@ Source17:     %{name}-java-requires
 # http://svn.pld-linux.org/banner.sh/
 Source18:      banner.sh
 Source19:      %{name}-macros.gstreamer
+Source20:      macros.php
+Source21:      %{name}-php-requires.php
 Patch1000:     %{name}-new-debuginfo.patch
 Patch1067:     %{name}-disable-features.patch
 Patch1070:     %{name}-rpmrc-ac.patch
@@ -102,6 +104,7 @@ Patch12:    %{name}-system_libs.patch
 Patch13:       %{name}-unglobal.patch
 Patch14:       %{name}-etc_dir.patch
 Patch15:       %{name}-system_libs-more.patch
+Patch16:       %{name}-libmagic-locale.patch
 Patch17:       %{name}-ldconfig-always.patch
 Patch18:       %{name}-macros-ac.patch
 Patch19:       %{name}-macros-th.patch
@@ -180,6 +183,7 @@ Patch100:   %{name}-rpm5-debugedit.patch
 Patch101:      %{name}-builddir-readlink.patch
 Patch102:      pythondeps-speedup.patch
 Patch103:      %{name}-lua-exit-chroot-correctly.patch
+Patch104:      %{name}-glob.patch
 URL:           http://rpm5.org/
 BuildRequires: autoconf >= 2.57
 BuildRequires: automake >= 1.4
@@ -198,7 +202,7 @@ BuildRequires:      libtool >= 1:1.4.2-9
 BuildRequires: libxml2-devel
 BuildRequires: neon-devel >= 0.25.5
 %endif
-BuildRequires: ossp-uuid-devel >= 1.6.2-6
+BuildRequires: ossp-uuid-devel >= 1.6.2-8
 BuildRequires: patch >= 2.2
 BuildRequires: popt-devel >= %{reqpopt_ver}
 %{?with_python:BuildRequires:  python-devel >= 1:2.3}
@@ -370,6 +374,7 @@ Requires:   elfutils-devel
 Requires:      keyutils-devel
 %{?with_system_libmagic:Requires:      libmagic-devel}
 %{?with_selinux:Requires:      libselinux-devel}
+Requires:      ossp-uuid-devel >= 1.6.2-6
 Requires:      popt-devel >= %{reqpopt_ver}
 Requires:      zlib-devel >= 1.2.3.3
 
@@ -550,13 +555,13 @@ Requires: gcc >= 5:3.4
 Requires:      glibc-devel
 Requires:      grep
 Requires:      gzip
-Requires:      xz
 Requires:      make
 Requires:      patch
 Requires:      sed
 Requires:      sh-utils
 Requires:      tar
 Requires:      textutils
+Requires:      xz
 Provides:      rpmbuild(monoautodeps)
 Provides:      rpmbuild(noauto) = 3
 %ifarch %{x8664}
@@ -716,13 +721,13 @@ Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
 %patch12 -p1
 %patch13 -p1
 %patch14 -p1
+%patch16 -p1
 %patch17 -p1
 sed -e 's/^/@pld@/' %{SOURCE2} >>platform.in
 echo '%%define __perl_provides %%{__perl} /usr/lib/rpm/perl.prov' > macros.perl
 echo '%%define __perl_requires %%{__perl} /usr/lib/rpm/perl.req' >> macros.perl
 echo '# obsoleted file' > macros.python
-echo '%%define __php_provides  /usr/lib/rpm/php.prov' > macros.php
-echo '%%define __php_requires  /usr/lib/rpm/php.req' >> macros.php
+cp -p %{SOURCE20} macros.php
 echo '%%define __mono_provides /usr/lib/rpm/mono-find-provides' > macros.mono
 echo '%%define __mono_requires /usr/lib/rpm/mono-find-requires' >> macros.mono
 install %{SOURCE10} scripts/php.prov
@@ -809,6 +814,7 @@ install %{SOURCE13} scripts/perl.prov
 %patch101 -p1
 %patch102 -p1
 %patch103 -p1
+%patch104 -p1
 
 mv -f po/{sr,sr@Latn}.po
 rm -rf sqlite zlib popt
@@ -882,7 +888,7 @@ sed -i \
 
 # pass CC and CXX too in case of building with some older configure macro
 # disable perl-RPM2 build, we have it in separate spec
-CPPFLAGS=-I/usr/include/oosp-uuid
+CPPFLAGS="%{rpmcppflags} -I/usr/include/ossp-uuid"
 %configure \
        CC="%{__newcc}" \
        CXX="%{__newcxx}" \
@@ -1043,6 +1049,7 @@ install -p %{SOURCE7} $RPM_BUILD_ROOT%{_rpmlibdir}/compress-doc
 install -p %{SOURCE14} $RPM_BUILD_ROOT%{_rpmlibdir}/user_group.sh
 install -p %{SOURCE17} $RPM_BUILD_ROOT%{_rpmlibdir}/java-find-requires
 install -p scripts/php.{prov,req}      $RPM_BUILD_ROOT%{_rpmlibdir}
+cp -p %{SOURCE21} $RPM_BUILD_ROOT%{_rpmlibdir}/php.req.php
 install -p %{SOURCE5} $RPM_BUILD_ROOT%{_rpmlibdir}/hrmib-cache
 install -p %{SOURCE18} $RPM_BUILD_ROOT%{_bindir}/banner.sh
 cp -a %{SOURCE15} $RPM_BUILD_ROOT/etc/sysconfig/rpm
@@ -1078,6 +1085,9 @@ cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros <<EOF
 # Boolean (i.e. 1 == "yes", 0 == "no") that controls whether files
 # marked as %doc should be installed.
 #%%_excludedocs   1
+
+# For static /dev not to update perms if upgraded and tmpfs mounted
+#%%_netsharedpath /dev/shm
 EOF
 
 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.lang <<EOF
This page took 0.110789 seconds and 4 git commands to generate.