]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm.spec
- new
[packages/rpm.git] / rpm.spec
index b64ee31e34ca3969141f7817e31832b515e2f973..c8ad9d6c51670d75fd1f7e7713f9c902378a87d0 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -2,6 +2,7 @@
 # TODO:
 # - python(abi) cap is not provided automatically (because /usr/bin/python matches
 #   ELF first; it should be provided by python-libs not binary anyway)
+# - repackaging when lzma is not installed (todo: fix digest signature of header)
 #
 # Conditional build:
 %bcond_with    static          # build static rpm+rpmi
@@ -28,12 +29,12 @@ Summary(pt_BR):     Gerenciador de pacotes RPM
 Summary(ru):   íÅÎÅÄÖÅÒ ÐÁËÅÔÏ× ÏÔ RPM
 Summary(uk):   íÅÎÅÄÖÅÒ ÐÁËÅԦנצĠRPM
 Name:          rpm
-Version:       4.4.6
-Release:       1.1
+Version:       4.4.7
+Release:       0.2
 License:       GPL
 Group:         Base
 Source0:       ftp://jbj.org/pub/rpm-4.4.x/%{name}-%{version}.tar.gz
-# Source0-md5: baa6f371446c65b4080d1cd1f194a7ae
+# Source0-md5: d012c81b5169f7377ea4a36607e1445e
 Source1:       %{name}.groups
 Source2:       %{name}.platform
 Source3:       %{name}-install-tree
@@ -53,7 +54,6 @@ Source31:     adapter.awk
 Source32:      pldnotify.awk
 # http://svn.pld-linux.org/banner.sh/
 Source33:      banner.sh
-Source34:      php-pear-build-macros
 Patch0:                %{name}-pl.po.patch
 Patch1:                %{name}-rpmrc.patch
 Patch2:                %{name}-arch.patch
@@ -87,7 +87,7 @@ Patch29:      %{name}-libdir64.patch
 Patch30:       %{name}-libdir-links.patch
 Patch31:       %{name}-missing-prototypes.patch
 Patch32:       %{name}-pld-autodep.patch
-
+Patch33:       %{name}-arch-x86_64.patch
 Patch34:       %{name}-epoch0.patch
 Patch35:       %{name}-perl_req-INC_dirs.patch
 Patch36:       %{name}-debuginfo.patch
@@ -101,7 +101,7 @@ Patch43:    %{name}-patch-quote.patch
 Patch44:       %{name}-no-neon.patch
 Patch45:       %{name}-no-sqlite.patch
 Patch46:       %{name}-mono.patch
-
+Patch47:       %{name}-rpmrc-resurrect.patch
 Patch48:       %{name}-requireseq.patch
 Patch49:       %{name}-p4.patch
 Patch50:       %{name}-macros.patch
@@ -111,13 +111,14 @@ Patch53:  %{name}-lzma.patch
 Patch54:       %{name}-lzma2.patch
 Patch55:       %{name}-truncate-cvslog.patch
 Patch56:       %{name}-skip-backups.patch
+Patch57:       %{name}-as_needed-fix.patch
+Patch58:       %{name}-repackage-wo-lzma.patch
 URL:           http://wraptastic.org/
 BuildRequires: autoconf >= 2.57
 BuildRequires: automake
 BuildRequires: beecrypt-devel >= %{beecrypt_ver}
 BuildRequires: bzip2-devel >= 1.0.2-17
 BuildRequires: db-devel >= %{reqdb_ver}
-%{?with_apidocs:BuildRequires: doxygen}
 BuildRequires: elfutils-devel >= 0.108
 BuildRequires: gettext-devel >= 0.11.4-2
 %{?with_system_libmagic:BuildRequires: libmagic-devel}
@@ -131,11 +132,17 @@ BuildRequires:    neon-devel >= 0.25.5
 %endif
 BuildRequires: patch >= 2.2
 BuildRequires: popt-devel >= %{reqpopt_ver}
-%{?with_python:BuildRequires:  python-devel >= 1:2.3}
-BuildRequires: python-modules >= 1:2.3
+%{?with_python:BuildRequires:  python-devel >= 1:2.5}
+BuildRequires: python-modules >= 1:2.5
 BuildRequires: rpm-perlprov
 %{?with_python:BuildRequires:  rpm-pythonprov}
 BuildRequires: zlib-devel
+%if %{with apidocs}
+BuildRequires: doxygen
+BuildRequires: ghostscript
+BuildRequires: graphviz
+BuildRequires: tetex-pdftex
+%endif
 %if %{with static}
 # Require static library only for static build
 BuildRequires: beecrypt-static >= %{beecrypt_ver}
@@ -229,6 +236,7 @@ RPM - 
 Summary:       RPM base package - scripts used by rpm packages themselves
 Summary(pl):   Podstawowy pakiet RPM - skrypty u¿ywane przez same pakiety rpm
 Group:         Base
+Requires:      filesystem
 Obsoletes:     vserver-rpm
 
 %description base
@@ -256,6 +264,7 @@ Requires:   popt >= %{reqpopt_ver}
 Obsoletes:     rpm-libs
 # avoid SEGV caused by mixed db versions
 Conflicts:     poldek < 0.18.1-16
+Suggests:      lzma
 
 %description lib
 RPMs library.
@@ -428,11 +437,12 @@ Summary(ru):      
 Summary(uk):   óËÒÉÐÔÉ ÔÁ ÕÔÉ̦ÔÉ, ÎÅÏÂȦÄΦ ÄÌÑ ÐÏÂÕÄÏ×É ÐÁËÅÔ¦×
 Group:         Applications/File
 Requires(pre): findutils
-Requires:      %{name}-build-macros >= 1.284
+Requires:      %{name}-build-macros >= 1.314
 Requires:      %{name}-utils = %{version}-%{release}
 Requires:      /bin/id
 Requires:      awk
-Requires:      binutils
+# we need fixed binutils for -feliminate-dwarf2-dups
+Requires:      binutils >= 3:2.17.50.0.3-2
 Requires:      bzip2
 Requires:      chrpath >= 0.10-4
 Requires:      cpio
@@ -561,16 +571,10 @@ Requires: sed >= 4.0
 Additional utilities for checking php pear provides/requires in rpm
 packages.
 
-This package provides rpm macros and dependencies to help building
-PEAR packages.
-
 %description php-pearprov -l pl
 Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów php pear w
 pakietach rpm.
 
-Ten pakiet dostarcza makra rpm-a i zale¿no¶ci pomagaj±ce przy
-budowaniu pakietów PEAR-a.
-
 %package -n python-rpm
 Summary:       Python interface to RPM library
 Summary(pl):   Pythonowy interfejs do biblioteki RPM-a
@@ -642,7 +646,8 @@ sed -e 's/^/@pld@/' %{SOURCE2} >>platform.in
 echo '%%define __perl_provides %%{__perl} /usr/lib/rpm/perl.prov' > macros.perl
 echo '%%define __perl_requires %%{__perl} /usr/lib/rpm/perl.req' >> macros.perl
 echo '# obsoleted file' > macros.python
-install %{SOURCE34} macros.php
+echo '%%define __php_provides  /usr/lib/rpm/php.prov' > macros.php
+echo '%%define __php_requires  /usr/lib/rpm/php.req' >> macros.php
 echo '%%define __mono_provides /usr/lib/rpm/mono-find-provides' > macros.mono
 echo '%%define __mono_requires /usr/lib/rpm/mono-find-requires' >> macros.mono
 install %{SOURCE5} scripts/find-lang.sh
@@ -663,7 +668,7 @@ install %{SOURCE12} scripts/perl.prov
 %patch30 -p1
 %patch31 -p1
 %patch32 -p1
-
+%patch33 -p1
 %patch34 -p1
 %patch35 -p0
 %patch36 -p1
@@ -677,7 +682,7 @@ install %{SOURCE12} scripts/perl.prov
 %{!?with_neon:%patch44 -p1}
 %patch45 -p1
 %patch46 -p1
-
+%patch47 -p1
 %patch48 -p1
 %patch49 -p1
 %patch50 -p1
@@ -687,6 +692,8 @@ install %{SOURCE12} scripts/perl.prov
 %patch54 -p1
 %patch55 -p1
 %patch56 -p1
+%patch57 -p1
+%patch58 -p1
 
 cd scripts
 mv -f perl.req perl.req.in
@@ -745,8 +752,8 @@ CPPFLAGS="-Dglob=rpm_glob -Dglobfree=rpm_globfree"; export CPPFLAGS
        %{?with_autoreqdep:--enable-adding-packages-names-in-autogenerated-dependancies} \
        --enable-shared \
        --enable-static \
-       %{?with_apidocs:--with-apidocs} \
-       %{?with_python:--with-python=auto} \
+       %{!?with_apidocs:--without-apidocs} \
+       %{?with_python:--with-python=2.5} \
        %{!?with_python:--without-python} \
        %{!?with_selinux:--without-selinux} \
        --without-db
@@ -975,7 +982,7 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 #%attr(755,root,root) %{_rpmlibdir}/rpmk
 #%attr(755,root,root) %{_rpmlibdir}/rpm[qv]
 
-%doc %attr(755,root,root) %{_rpmlibdir}/convertrpmrc.sh
+#%doc %attr(755,root,root) %{_rpmlibdir}/convertrpmrc.sh
 
 %{_rpmlibdir}/rpmrc
 %{_rpmlibdir}/rpmpopt*
@@ -1016,6 +1023,7 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 %attr(755,root,root) %{_bindir}/rpm2cpio
 %attr(755,root,root) %{_bindir}/rpmcache
 %attr(755,root,root) %{_bindir}/rpmdeps
+%attr(755,root,root) %{_bindir}/rpmdigest
 %attr(755,root,root) %{_bindir}/rpmgraph
 %{!?with_system_libmagic:%attr(755,root,root) %{_bindir}/rpmfile}
 %attr(755,root,root) %{_rpmlibdir}/find-debuginfo.sh
@@ -1052,7 +1060,7 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/noauto*
 %attr(755,root,root) %{_rpmlibdir}/brp-*
 %attr(755,root,root) %{_rpmlibdir}/check-files
-%attr(755,root,root) %{_rpmlibdir}/check-prereqs
+%attr(755,root,root) %{_rpmlibdir}/check-prereqs
 %attr(755,root,root) %{_rpmlibdir}/compress-doc
 %attr(755,root,root) %{_rpmlibdir}/config.*
 %attr(755,root,root) %{_rpmlibdir}/cross-build
@@ -1131,7 +1139,7 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 #%attr(755,root,root) %{_rpmlibdir}/find-*.perl
 #%attr(755,root,root) %{_rpmlibdir}/find-prov.pl
 #%attr(755,root,root) %{_rpmlibdir}/find-req.pl
-%attr(755,root,root) %{_rpmlibdir}/get_magic.pl
+#%attr(755,root,root) %{_rpmlibdir}/get_magic.pl
 
 %files pythonprov
 %defattr(644,root,root,755)
This page took 0.035903 seconds and 4 git commands to generate.