]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm.spec
- Allow to disable '__debug_install_post'
[packages/rpm.git] / rpm.spec
index 9d4214494cd743e4fe92b3d6c8d8d595bc6e608e..c31428a3498423c9b769a0547294177c3bb4d6aa 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -1,7 +1,7 @@
 #
 # TODO:
-# - use system libmagic not internal libfmagic
-# - when really needed: _noauto{req,prov} for non-helper-generated deps
+# - consider using system libmagic not internal libfmagic
+#   (but internal has different method of passing output)
 #
 # Conditional build:
 %bcond_with    static  # build static rpmi (not supported at the moment)
 # force_cxx            - force using __cxx other than "%{_target_cpu}-pld-linux-g++"
 # force_cpp            - force using __cpp other than "%{_target_cpu}-pld-linux-gcc -E"
 
-%include        /usr/lib/rpm/macros.python
-%define snap   20040107
+%include       /usr/lib/rpm/macros.python
+%define        snap    20040107
 # versions of required libraries
 %define        reqdb_ver       4.2.50-1
 %define        reqpopt_ver     1.9
 %define        beecrypt_ver    3.0.0-0.20030610.1
-%define rpm_macros_rev 1.145
+%define        rpm_macros_rev  1.153
 Summary:       RPM Package Manager
 Summary(de):   RPM Packet-Manager
 Summary(es):   Gestor de paquetes RPM
@@ -29,7 +29,7 @@ Summary(uk):  
 Name:          rpm
 %define        ver     4.3
 Version:       %{ver}
-Release:       0.%{snap}.19
+Release:       0.%{snap}.23
 License:       GPL
 Group:         Base
 #Source0:      ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.2.x/%{name}-%{version}.%{snap}.tar.gz
@@ -94,6 +94,7 @@ Patch40:      %{name}-epoch0.patch
 Patch41:       %{name}-file-readelf-fix.patch
 Patch42:       %{name}-cpuid.patch
 Patch43:       %{name}-perl_req-INC_dirs.patch
+Patch44:       %{name}-debuginfo.patch
 URL:           http://www.rpm.org/
 Icon:          rpm.gif
 BuildRequires: autoconf >= 2.52
@@ -106,6 +107,8 @@ BuildRequires:      gettext-devel >= 0.11.4-2
 BuildRequires: elfutils-devel
 #BuildRequires:        libmagic-devel
 %{?with_selinux:BuildRequires: libselinux-devel}
+# needed only for AM_PROG_CXX used for CXX substitution in rpm.macros
+BuildRequires: libstdc++-devel
 BuildRequires: libtool
 BuildRequires: patch >= 2.2
 BuildRequires: popt-devel >= %{reqpopt_ver}
@@ -575,7 +578,6 @@ install %{SOURCE5} scripts/find-lang.sh
 install %{SOURCE9} scripts/php.prov.in
 install %{SOURCE10} scripts/php.req.in
 install %{SOURCE12} scripts/perl.prov
-sed -i -e 's#%%package debug#%%package debuginfo#g' macros.in
 cat %{SOURCE11} >> macros.in
 %patch22 -p1
 %patch23 -p1
@@ -599,6 +601,7 @@ cat %{SOURCE11} >> macros.in
 %patch41 -p1
 %patch42 -p1
 %patch43 -p0
+%patch44 -p1
 
 cd scripts;
 mv -f perl.req perl.req.in
@@ -637,8 +640,8 @@ cd ..
 
 # config.guess doesn't handle athlon, so we have to change it by hand.
 # rpm checks for CPU type at runtime, but it looks better
-sed -e 's|@host@|%{_target_cpu}-%{_target_vendor}-linux-gnu|'  \
-       -e 's|@host_cpu@|%{_target_cpu}|'  macros.in  > macros.tmp
+sed -e 's|@host@|%{_target_cpu}-%{_target_vendor}-linux-gnu|' \
+       -e 's|@host_cpu@|%{_target_cpu}|' macros.in > macros.tmp
 mv -f macros.tmp macros.in
 
 # pass CC and CXX too in case of building with some older configure macro
@@ -752,9 +755,6 @@ for a in librpm-%{ver}.so librpmdb-%{ver}.so librpmio-%{ver}.so ; do
        ln -s /%{_lib}/$a $RPM_BUILD_ROOT%{_libdir}/$a
 done
 
-# fix debug script
-perl -pi -e 's#/.*/debugedit#%{_bindir}/debugedit#g' $RPM_BUILD_ROOT%{_rpmlibdir}/find-debuginfo.sh
-
 for f in $RPM_BUILD_ROOT%{_datadir}/locale/{en_RN,eu_ES,gl,hu,ro,wa,zh,zh_CN.GB2312}/LC_MESSAGES/rpm.mo ; do
        [ "`file $f | sed -e 's/.*,//' -e 's/message.*//'`" -le 1 ] && rm -f $f
 done
This page took 0.037204 seconds and 4 git commands to generate.