]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm.spec
- Allow to disable '__debug_install_post'
[packages/rpm.git] / rpm.spec
index 317183da53e7bf2df0058c5ba4bbc9074fd3e8cd..c31428a3498423c9b769a0547294177c3bb4d6aa 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -1,23 +1,24 @@
 #
 # TODO:
-# - use system libmagic not internal libfmagic
-# - when really needed: _noauto{req,prov} for non-helper-generated deps
+# - consider using system libmagic not internal libfmagic
+#   (but internal has different method of passing output)
 #
 # Conditional build:
 %bcond_with    static  # build static rpmi (not supported at the moment)
 %bcond_without doc     # don't generate documentation with doxygen
 %bcond_without python  # don't build python bindings
+%bcond_without selinux # dont enable selinux support
 # force_cc             - force using __cc other than "%{_target_cpu}-pld-linux-gcc"
 # force_cxx            - force using __cxx other than "%{_target_cpu}-pld-linux-g++"
 # force_cpp            - force using __cpp other than "%{_target_cpu}-pld-linux-gcc -E"
 
-%include        /usr/lib/rpm/macros.python
-%define snap   20040107
+%include       /usr/lib/rpm/macros.python
+%define        snap    20040107
 # versions of required libraries
 %define        reqdb_ver       4.2.50-1
 %define        reqpopt_ver     1.9
 %define        beecrypt_ver    3.0.0-0.20030610.1
-%define rpm_macros_rev 1.145
+%define        rpm_macros_rev  1.153
 Summary:       RPM Package Manager
 Summary(de):   RPM Packet-Manager
 Summary(es):   Gestor de paquetes RPM
@@ -28,7 +29,7 @@ Summary(uk):  
 Name:          rpm
 %define        ver     4.3
 Version:       %{ver}
-Release:       0.%{snap}.15
+Release:       0.%{snap}.23
 License:       GPL
 Group:         Base
 #Source0:      ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.2.x/%{name}-%{version}.%{snap}.tar.gz
@@ -92,6 +93,8 @@ Patch39:      %{name}-pentiumX.patch
 Patch40:       %{name}-epoch0.patch
 Patch41:       %{name}-file-readelf-fix.patch
 Patch42:       %{name}-cpuid.patch
+Patch43:       %{name}-perl_req-INC_dirs.patch
+Patch44:       %{name}-debuginfo.patch
 URL:           http://www.rpm.org/
 Icon:          rpm.gif
 BuildRequires: autoconf >= 2.52
@@ -103,7 +106,9 @@ BuildRequires:      db-devel >= %{reqdb_ver}
 BuildRequires: gettext-devel >= 0.11.4-2
 BuildRequires: elfutils-devel
 #BuildRequires:        libmagic-devel
-BuildRequires: libselinux-devel
+%{?with_selinux:BuildRequires: libselinux-devel}
+# needed only for AM_PROG_CXX used for CXX substitution in rpm.macros
+BuildRequires: libstdc++-devel
 BuildRequires: libtool
 BuildRequires: patch >= 2.2
 BuildRequires: popt-devel >= %{reqpopt_ver}
@@ -120,7 +125,7 @@ BuildRequires:      db-static >= %{reqdb_ver}
 BuildRequires: glibc-static >= 2.2.94
 BuildRequires: elfutils-static
 #BuildRequires:        libmagic-static
-BuildRequires: libselinux-static
+%{?with_selinux:BuildRequires: libselinux-static}
 BuildRequires: popt-static >= %{reqpopt_ver}
 BuildRequires: zlib-static
 %endif
@@ -208,7 +213,7 @@ Requires:   beecrypt-devel >= %{beecrypt_ver}
 Requires:      bzip2-devel
 Requires:      db-devel >= %{reqdb_ver}
 Requires:      elfutils-devel
-Requires:      libselinux-devel
+%{?with_selinux:Requires:      libselinux-devel}
 Requires:      popt-devel >= %{reqpopt_ver}
 Requires:      zlib-devel
 
@@ -595,6 +600,8 @@ cat %{SOURCE11} >> macros.in
 %patch40 -p1
 %patch41 -p1
 %patch42 -p1
+%patch43 -p0
+%patch44 -p1
 
 cd scripts;
 mv -f perl.req perl.req.in
@@ -633,8 +640,8 @@ cd ..
 
 # config.guess doesn't handle athlon, so we have to change it by hand.
 # rpm checks for CPU type at runtime, but it looks better
-sed -e 's|@host@|%{_target_cpu}-%{_target_vendor}-linux-gnu|'  \
-       -e 's|@host_cpu@|%{_target_cpu}|'  macros.in  > macros.tmp
+sed -e 's|@host@|%{_target_cpu}-%{_target_vendor}-linux-gnu|' \
+       -e 's|@host_cpu@|%{_target_cpu}|' macros.in > macros.tmp
 mv -f macros.tmp macros.in
 
 # pass CC and CXX too in case of building with some older configure macro
@@ -647,6 +654,7 @@ mv -f macros.tmp macros.in
        %{?with_doc:--with-apidocs} \
        %{?with_python:--with-python=auto} \
        %{!?with_python:--without-python} \
+       %{!?with_selinux:--without-selinux} \
        --without-db
 
 # file_LDFLAGS, debugedit_LDADD - no need to link "file" and "debugedit" statically
This page took 0.030478 seconds and 4 git commands to generate.