]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm.spec
- don't install and package some useless scripts
[packages/rpm.git] / rpm.spec
index 2db85595fd087de5ccf14747dc1d6e8ac3a8a048..c06e8f4b4add85d40255bd5f4464d1c5e33af919 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -47,7 +47,7 @@ Summary(ru.UTF-8):    Менеджер пакетов от RPM
 Summary(uk.UTF-8):     Менеджер пакетів від RPM
 Name:          rpm
 Version:       5.4.15
-Release:       51
+Release:       58
 License:       LGPL v2.1
 Group:         Base
 # http://rpm5.org/files/rpm/rpm-5.4/rpm-5.4.15-0.20140824.src.rpm
@@ -59,10 +59,8 @@ Source101:   README.cpu-os-macros
 Source1:       %{name}.groups
 Source2:       macros.pld.in
 Source3:       %{name}-install-tree
-Source4:       %{name}-find-spec-bcond
 Source5:       %{name}-hrmib-cache
 Source6:       %{name}-groups-po.awk
-Source7:       %{name}-compress-doc
 Source10:      %{name}.sysinfo
 Source11:      perl.prov
 Source12:      %{name}-user_group.sh
@@ -71,7 +69,6 @@ Source13:     %{name}.sysconfig
 Source15:      banner.sh
 Source16:      ftp://ftp.pld-linux.org/dists/th/PLD-3.0-Th-GPG-key.asc
 # Source16-md5:        23914bb49fafe7153cee87126d966461
-Source17:      %{name}-mimetypedeps
 Source18:      macros.local
 Source19:      %{name}.noautocompressdoc
 Source20:      %{name}.noautoprov
@@ -128,7 +125,7 @@ Patch42:    %{name}-pattern_Release.patch
 Patch43:       %{name}-fix-___build_pre-macro.patch
 Patch44:       %{name}-missing-patch-file-fails-build.patch
 Patch45:       %{name}-remove-misleading-missing-patch-message.patch
-Patch46:       %{name}-file-magic-can-be-mixed-case.patch
+Patch46:       %{name}-rpm2cpio.patch
 Patch47:       %{name}-query-always-noisy.patch
 Patch48:       %{name}-verify-ghosts-broken-logic.patch
 Patch49:       %{name}-python-enable-compat-RPMSENSE.patch
@@ -179,6 +176,7 @@ Patch96:    skip-ldconfig-optimization.patch
 Patch97:       glibc.patch
 Patch98:       extension-based-compression-detection.patch
 Patch99:       %{name}-gpg-pinentry.patch
+Patch100:      dont-install-useless-scripts.patch
 
 # Patches imported from Mandriva
 
@@ -363,7 +361,6 @@ Requires:   %{name}-base = %{version}-%{release}
 Requires:      %{name}-lib = %{version}-%{release}
 Requires:      beecrypt >= %{beecrypt_ver}
 Requires:      popt >= %{reqpopt_ver}
-Provides:      rpm-db-ver = %{reqdb_ver}
 Obsoletes:     rpm-getdeps
 %{!?with_static:Obsoletes:     rpm-utils-static}
 Conflicts:     glibc < 2.2.92
@@ -470,6 +467,7 @@ Requires:   beecrypt >= %{beecrypt_ver}
 Requires:      libmagic >= 1.15-2
 %{?with_selinux:Requires:      libselinux >= 2.1.0}
 Requires:      popt >= %{reqpopt_ver}
+Provides:      rpm-db-ver = %{reqdb_ver}
 Obsoletes:     rpm-libs
 # avoid SEGV caused by mixed db versions
 Conflicts:     poldek < 0.18.1-16
@@ -662,7 +660,7 @@ Summary(uk.UTF-8):  Скрипти та утиліти, необхідні для
 Group:         Applications/File
 Requires(pretrans):    coreutils
 Requires(pretrans):    findutils
-Requires:      %{name}-build-macros >= 1.744-3
+Requires:      %{name}-pld-macros-build >= 1.744-3
 Requires:      %{name}-utils = %{version}-%{release}
 Requires:      /bin/id
 Requires:      awk
@@ -960,6 +958,7 @@ cd -
 %patch96 -p1
 %patch97 -p1
 %patch98 -p1
+%patch100 -p1
 
 %patch1050 -p1
 
@@ -1015,7 +1014,7 @@ sed -i \
        --with-lua=%{!?with_system_lua:internal}%{?with_system_lua:external} \
        --with-lzma=external \
        --with-neon=%{?with_neon:external}%{!?with_neon:no} \
-       --with-path-macros='%{_rpmlibdir}/macros:%{_rpmlibdir}/macros.d/pld:%{_rpmlibdir}/%%{_target}/macros:%{_rpmlibdir}/macros.build:%{_sysconfdir}/rpm/macros.*:%{_sysconfdir}/rpm/macros:%{_sysconfdir}/rpm/%%{_target}/macros:%{_sysconfdir}/rpm/macros.d/*.macros:~/etc/.rpmmacros:~/.rpmmacros' \
+       --with-path-macros='%{_rpmlibdir}/macros:%{_rpmlibdir}/macros.d/pld:%{_rpmlibdir}/pld/macros:%{_rpmlibdir}/%%{_target}/macros:%{_rpmlibdir}/macros.build:%{_sysconfdir}/rpm/macros.*:%{_sysconfdir}/rpm/macros:%{_sysconfdir}/rpm/%%{_target}/macros:%{_sysconfdir}/rpm/macros.d/*.macros:~/etc/.rpmmacros:~/.rpmmacros' \
        --without-path-versioned \
        --with-pcre=%{!?with_system_pcre:internal}%{?with_system_pcre:external} \
        --with-popt=external \
@@ -1030,7 +1029,7 @@ sed -i \
        --with-xz=external \
        --with-zlib=external
 
-%{__make} -j1
+%{__make}
 
 %{?with_apidocs:%{__make} apidocs}
 
@@ -1051,11 +1050,11 @@ fi
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{/bin,/%{_lib},/etc/sysconfig,%{_sysconfdir}/rpm} \
-       $RPM_BUILD_ROOT{/var/lib/banner,/var/cache/hrmib,/etc/pki/rpm-gpg}
+       $RPM_BUILD_ROOT{/var/lib/banner,/var/cache/hrmib,/etc/pki/rpm-gpg,%{_rpmlibdir}/pld}
 
 install %{SOURCE16} $RPM_BUILD_ROOT%{_sysconfdir}/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
 
-%{__make} -j1 install \
+%{__make} install \
        pkgconfigdir=%{_pkgconfigdir} \
        DESTDIR=$RPM_BUILD_ROOT
 
@@ -1205,10 +1204,7 @@ install scripts/rpmdiff scripts/rpmdiff.cgi $RPM_BUILD_ROOT%{_rpmlibdir}
 
 install %{SOURCE1} doc/manual/groups
 install %{SOURCE3} $RPM_BUILD_ROOT%{_rpmlibdir}/install-build-tree
-install %{SOURCE4} $RPM_BUILD_ROOT%{_rpmlibdir}/find-spec-bcond
-install %{SOURCE7} $RPM_BUILD_ROOT%{_rpmlibdir}/compress-doc
 install %{SOURCE12} $RPM_BUILD_ROOT%{_rpmlibdir}/user_group.sh
-install %{SOURCE17} $RPM_BUILD_ROOT%{_rpmlibdir}/mimetypedeps.sh
 install %{SOURCE5} $RPM_BUILD_ROOT%{_rpmlibdir}/hrmib-cache
 install %{SOURCE13} $RPM_BUILD_ROOT/etc/sysconfig/rpm
 
@@ -1236,15 +1232,15 @@ install tools/rpmdb_reset $RPM_BUILD_ROOT%{_rpmlibdir}/bin
 install %{SOURCE29} $RPM_BUILD_ROOT%{_rpmlibdir}/bin/dbupgrade.sh
 
 # create macro loading wrappers for backward compatibility
-for m in gstreamer mono; do
-       echo "%%{load:%{_rpmlibdir}/macros.d/$m}" >$RPM_BUILD_ROOT%{_rpmlibdir}/macros.$m
+for m in gstreamer libtool mono pkgconfig selinux; do
+       %{__mv} $RPM_BUILD_ROOT%{_rpmlibdir}/macros.d/{$m,macros.$m}
 done
 
-install %{SOURCE30} $RPM_BUILD_ROOT%{_rpmlibdir}/macros.d/prov-req
+install %{SOURCE30} $RPM_BUILD_ROOT%{_rpmlibdir}/macros.d/macros.prov-req
 
-# moved to rpm-build-macros 1.699
+# moved to rpm-pld-macros-macros 1.699
 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/macros.d/kernel
-# moved to rpm-build-macros 1.744
+# moved to rpm-pld-macros-build 1.744
 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/javadeps.sh
 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/{gem_helper,rubygems}.rb
 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/php.{prov,req}
@@ -1361,6 +1357,7 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 %{_rpmlibdir}/macros
 %dir %{_rpmlibdir}/macros.d
 %{_rpmlibdir}/macros.d/pld
+%dir %{_rpmlibdir}/pld
 %{_rpmlibdir}/cpuinfo.yaml
 %{_rpmlibdir}/noarch-*
 %ifarch %{ix86} %{x8664} x32
@@ -1450,7 +1447,6 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 %attr(755,root,root) %{_rpmlibdir}/bin/cp
 %attr(755,root,root) %{_rpmlibdir}/bin/debugedit
 %attr(755,root,root) %{_rpmlibdir}/bin/find
-%attr(755,root,root) %{_rpmlibdir}/bin/mgo
 %attr(755,root,root) %{_rpmlibdir}/bin/mtree
 %attr(755,root,root) %{_rpmlibdir}/bin/rpmcache
 %attr(755,root,root) %{_rpmlibdir}/bin/rpmcmp
@@ -1493,46 +1489,34 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/noauto*
 %attr(755,root,root) %{_rpmlibdir}/brp-*
 %attr(755,root,root) %{_rpmlibdir}/check-files
-%attr(755,root,root) %{_rpmlibdir}/compress-doc
 %attr(755,root,root) %{_rpmlibdir}/cross-build
-%attr(755,root,root) %{_rpmlibdir}/find-spec-bcond
 %attr(755,root,root) %{_rpmlibdir}/getpo.sh
 %attr(755,root,root) %{_rpmlibdir}/install-build-tree
 %attr(755,root,root) %{_rpmlibdir}/u_pkg.sh
 %attr(755,root,root) %{_rpmlibdir}/executabledeps.sh
 %attr(755,root,root) %{_rpmlibdir}/libtooldeps.sh
-%attr(755,root,root) %{_rpmlibdir}/mimetypedeps.sh
 # needs hacked pkg-config to return anything
 %attr(755,root,root) %{_rpmlibdir}/pkgconfigdeps.sh
-%attr(755,root,root) %{_rpmlibdir}/bin/api-sanity-autotest.pl
-%attr(755,root,root) %{_rpmlibdir}/bin/api-sanity-checker.pl
 %{!?with_sqlite:%attr(755,root,root) %{_rpmlibdir}/bin/dbsql}
 %attr(755,root,root) %{_rpmlibdir}/bin/install-sh
 %attr(755,root,root) %{_rpmlibdir}/bin/mkinstalldirs
-%attr(755,root,root) %{_rpmlibdir}/bin/pom2spec
 %attr(755,root,root) %{_rpmlibdir}/bin/rpmspec
 %attr(755,root,root) %{_rpmlibdir}/bin/rpmspecdump
 %attr(755,root,root) %{_rpmlibdir}/bin/sqlite3
 %attr(755,root,root) %{_rpmlibdir}/bin/wget
 %attr(755,root,root) %{_rpmlibdir}/vcheck
-# not used yet ... these six depend on perl
-%attr(755,root,root) %{_rpmlibdir}/http.req
 # we always used scripts provided by mono-devel, maybe move them here
 #%attr(755,root,root) %{_rpmlibdir}/mono-find-provides
 #%attr(755,root,root) %{_rpmlibdir}/mono-find-requires
 
 %attr(755,root,root) %{_rpmlibdir}/fontconfig.prov
-# must be here for "Requires: rpm-*prov" to work
-%{_rpmlibdir}/macros.d/gstreamer
-%{_rpmlibdir}/macros.d/libtool
-%{_rpmlibdir}/macros.d/mono
-%{_rpmlibdir}/macros.d/pkgconfig
-%{_rpmlibdir}/macros.d/prov-req
-%{_rpmlibdir}/macros.d/selinux
+%{_rpmlibdir}/macros.d/macros.gstreamer
+%{_rpmlibdir}/macros.d/macros.libtool
+%{_rpmlibdir}/macros.d/macros.mono
+%{_rpmlibdir}/macros.d/macros.pkgconfig
+%{_rpmlibdir}/macros.d/macros.prov-req
+%{_rpmlibdir}/macros.d/macros.selinux
 %{_rpmlibdir}/macros.rpmbuild
-# compat wrappers
-%{_rpmlibdir}/macros.gstreamer
-%{_rpmlibdir}/macros.mono
 
 %attr(755,root,root) %{_rpmlibdir}/gstreamer.sh
 %attr(755,root,root) %{_rpmlibdir}/kmod-deps.sh
This page took 0.03842 seconds and 4 git commands to generate.