]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm.spec
- head poldek has distver on, so head rpm should too
[packages/rpm.git] / rpm.spec
index 32b1d6ac604eb2386a2403031f88899bbe63a45a..b73d17a8fb0b2c3bca4c1bd6e83b2a9664458b00 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -3,12 +3,11 @@
 # - consider using system libmagic not internal libfmagic
 #   (but internal has different method of passing output)
 # - after ac drop amd64 patch and make x86_64 generic arch + subarchs amd64 and ia32e
-# - ? make putting packages names in autogenerating dependacies as runtime option
 # 
 # Conditional build:
 %bcond_with    static  # build static rpmi (not supported at the moment)
+%bcond_without apidocs # don't generate documentation with doxygen
 %bcond_without pkgnameinautoreq        # don't put package name in autogenerated dependancy
-%bcond_without doc     # don't generate documentation with doxygen
 %bcond_without python  # don't build python bindings
 %bcond_without selinux # dont enable selinux support
 # force_cc             - force using __cc other than "%{_target_cpu}-pld-linux-gcc"
@@ -97,6 +96,8 @@ Patch41:      %{name}-file-readelf-fix.patch
 Patch43:       %{name}-perl_req-INC_dirs.patch
 Patch44:       %{name}-debuginfo.patch
 Patch45:       %{name}-beecrypt4.patch
+Patch46:       %{name}-doxygen_hack.patch
+Patch47:       %{name}-distver.patch
 Patch100:      %{name}-pl.po.patch
 URL:           http://www.rpm.org/
 Icon:          rpm.gif
@@ -105,7 +106,7 @@ BuildRequires:      automake
 BuildRequires: beecrypt-devel >= %{beecrypt_ver}
 BuildRequires: bzip2-devel >= 1.0.1
 BuildRequires: db-devel >= %{reqdb_ver}
-%{?with_doc:BuildRequires:     doxygen}
+%{?with_apidocs:BuildRequires: doxygen}
 BuildRequires: elfutils-devel
 BuildRequires: findutils
 BuildRequires: gettext-devel >= 0.11.4-2
@@ -493,7 +494,7 @@ Requires:   sh-utils
 Requires:      tar
 Requires:      textutils
 Provides:      rpmbuild(macros) = %{rpm_macros_rev}
-Provides:      rpmbuild(noauto) = 2
+Provides:      rpmbuild(noauto) = 3
 %ifarch amd64
 Conflicts:     automake < 1:1.7.9-2
 Conflicts:     libtool < 2:1.5-13
@@ -554,6 +555,21 @@ construir pacotes usando o RPM.
 ò¦ÚÎÏÍÁΦÔΦ ÄÏÐÏͦÖΦ ÓËÒÉÐÔÉ ÔÁ ÕÔÉ̦ÔÉ, Ñ˦ ×ÉËÏÒÉÓÔÏ×ÕÀÔØÓÑ ÄÌÑ
 ÐÏÂÕÄÏ×É RPM'¦×.
 
+%if %{with apidocs}
+%package       apidocs
+Summary:       rpm API documentation and guides
+Summary(pl):   Documentacja API rpm i przewodniki.
+Group:         Documentation   
+
+%description apidocs
+Documentation for rpm API and guides in html format generated
+from rpm sources by doxygen.
+
+%description apidocs -l pl
+Dokumentacja API rpm oraz przewodniki w formacie html generowana
+ze ¼rode³ rpm przez doxygen.
+%endif
+
 %prep
 %setup -q -n %{name}
 %patch1 -p1
@@ -612,6 +628,8 @@ cat %{SOURCE11} >> macros.in
 %patch43 -p0
 %patch44 -p1
 %patch45 -p1
+%patch46 -p1
+%patch47 -p1
 %patch100 -p1
 %patch3 -p1
 
@@ -667,7 +685,7 @@ mv -f macros.tmp macros.in
        CPP="%{__newcpp}" \
        --enable-shared \
        --enable-static \
-       %{?with_doc:--with-apidocs} \
+       %{?with_apidoc:--with-apidocs} \
        %{?with_pkgnameinautoreq:--enable-adding-packages-names-in-autogenerated-dependancies} \
        %{?with_python:--with-python=auto} \
        %{!?with_python:--without-python} \
@@ -685,10 +703,11 @@ mv -f macros.tmp macros.in
        debugedit_LDADD="\$(WITH_LIBELF_LIB) -lpopt"
 
 #      %{!?with_static:rpm_LDFLAGS="\$(myLDFLAGS)"} \
+%{?with_apidocs:%{__make} doxygen}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT/{%{_lib},/etc/sysconfig,%{_sysconfdir}/rpm}
+install -d $RPM_BUILD_ROOT{/%{_lib},/etc/sysconfig,%{_sysconfdir}/rpm}
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT \
@@ -795,7 +814,10 @@ cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqdep <<EOF
 ^libXxf86misc.so
 ^libXxf86rush.so
 ^libXxf86vm.so
+^libdps.so
+^libdpstk.so
 ^libfontenc.so
+^libpsres.so
 ^libxkbfile.so
 ^libxkbui.so
 EOF
@@ -974,15 +996,6 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 %attr(755,root,root) %{_rpmlibdir}/rpm2cpio.sh
 %attr(755,root,root) %{_rpmlibdir}/tgpg
 %attr(755,root,root) %{_rpmlibdir}/rpmdb_loadcvt
-
-%files utils-perl
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_rpmlibdir}/rpmdiff*
-# not here
-#%%{_rpmlibdir}/rpm.daily
-#%%{_rpmlibdir}/rpm.log
-#%%{_rpmlibdir}/rpm.xinetd
-
 %{_mandir}/man8/rpm2cpio.8*
 %{_mandir}/man8/rpmdeps.8*
 %{_mandir}/man8/rpmcache.8*
@@ -997,6 +1010,15 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 %lang(pl) %{_mandir}/pl/man8/rpmgraph.8*
 %lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
 
+%files utils-perl
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_rpmlibdir}/rpmdiff*
+# not here
+#%%{_rpmlibdir}/rpm.daily
+#%%{_rpmlibdir}/rpm.log
+#%%{_rpmlibdir}/rpm.xinetd
+
+
 %if %{with static}
 %files utils-static
 %defattr(644,root,root,755)
@@ -1036,3 +1058,9 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 %attr(755,root,root) %{_bindir}/builder
 %attr(755,root,root) %{_bindir}/adapter.awk
 %attr(755,root,root) %{_bindir}/pldnotify.awk
+
+%if %{with apidocs}
+%files apidocs
+%defattr(644,root,root,755)
+%doc apidocs
+%endif
This page took 0.075283 seconds and 4 git commands to generate.