]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm.spec
- replace 'cheating' bcond and patch with a macro to control this behavior
[packages/rpm.git] / rpm.spec
index 64096791f9afcc5c7b0d16d70db92f6599194858..ae387282c14356cb0af54e0878aaa22496ae440e 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -13,9 +13,9 @@
 %define                popt_ver        1.15
 %define                sover           9.1.0
 
- %if %{_ver_ge '%{_rpmversion}' '4.12'} && %{_ver_lt '%{_rpmversion}' '5.0'}
- %define       with_recommends_tags
- %endif
+%if "%{_rpmversion}" >= "4.12" && "%{_rpmversion}" < "5"
+%define        with_recommends_tags    1
+%endif
 
 Summary:       RPM Package Manager
 Summary(de.UTF-8):     RPM Packet-Manager
@@ -26,7 +26,7 @@ Summary(ru.UTF-8):    Менеджер пакетов от RPM
 Summary(uk.UTF-8):     Менеджер пакетів від RPM
 Name:          rpm
 Version:       4.16.0
-Release:       0.1
+Release:       0.5
 Epoch:         1
 License:       GPL v2 / LGPL v2.1
 Group:         Base
@@ -73,6 +73,8 @@ Patch18:      rpmversion.patch
 Patch19:       pkgconfig.patch
 Patch20:       uname-deps.patch
 Patch21:       aarch64.patch
+Patch22:       ix86-platforms.patch
+Patch23:       shortcircuited-deps.patch
 URL:           https://rpm.org/
 BuildRequires: acl-devel
 BuildRequires: db-devel >= %{db_ver}
@@ -102,6 +104,7 @@ BuildRequires:      python3-modules
 %if %{with python3}
 BuildRequires: python3-devel
 BuildRequires: rpm-pythonprov
+BuildRequires: rpmbuild(macros) >= 1.750
 %endif
 BuildRequires: sqlite3-devel >= 3.22.0
 BuildRequires: tcl
@@ -558,9 +561,9 @@ Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
 %patch18 -p1
 %patch19 -p1
 %patch20 -p1
-%ifarch aarch64
 %patch21 -p1
-%endif
+%patch22 -p1
+%patch23 -p1
 
 install %{SOURCE15} scripts/perl.prov.in
 
@@ -684,6 +687,14 @@ rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/s390*-linux/macros
 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/sh*-linux/macros
 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/sparc*-linux/macros
 
+cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
+%ifarch x32
+%{_target_cpu}-%{_target_vendor}-linux-gnux32
+%else
+%{_target_cpu}-%{_target_vendor}-linux
+%endif
+EOF
+
 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/find-lang.sh
 
 install -d $RPM_BUILD_ROOT%{_rpmlibdir}/pld
@@ -780,6 +791,8 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros.lang
+# this is ok to be replaced
+%config %verify(not md5 mtime size) %{_sysconfdir}/rpm/platform
 
 %{_mandir}/man8/rpm.8*
 %{_mandir}/man8/rpmdb.8*
This page took 0.027242 seconds and 4 git commands to generate.