]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm.spec
use libexec directory for private binaries - optional since FHS 3.0
[packages/rpm.git] / rpm.spec
index d3b73da9b220ee396dc80b2c3937add690367753..ac613f1eb474f537952b18287c27c27763755dde 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
 %bcond_with    system_lua      # use system lua
 %bcond_without system_pcre     # use system pcre
 %bcond_with    keyutils        # build with keyutils support
-# force_cc             - force using __cc other than "%{_target_cpu}-pld-linux-gcc"
-# force_cxx            - force using __cxx other than "%{_target_cpu}-pld-linux-g++"
-# force_cpp            - force using __cpp other than "%{_target_cpu}-pld-linux-gcc -E"
-#
 
 %if %{with sqlite}
 # Error: /lib64/librpmio-5.4.so: undefined symbol: sqlite3_enable_load_extension
@@ -51,7 +47,7 @@ Summary(ru.UTF-8):    Менеджер пакетов от RPM
 Summary(uk.UTF-8):     Менеджер пакетів від RPM
 Name:          rpm
 Version:       5.4.15
-Release:       17
+Release:       41
 License:       LGPL v2.1
 Group:         Base
 # http://rpm5.org/files/rpm/rpm-5.4/rpm-5.4.15-0.20140824.src.rpm
@@ -77,7 +73,7 @@ Source14:     %{name}-java-requires
 # http://svn.pld-linux.org/banner.sh/
 Source15:      banner.sh
 Source16:      ftp://ftp.pld-linux.org/dists/th/PLD-3.0-Th-GPG-key.asc
-# Source16-md5:        08b29584dd349aac9caa7610131a0a88
+# Source16-md5:        23914bb49fafe7153cee87126d966461
 Source17:      %{name}-mimetypedeps
 Source18:      macros.local
 Source19:      %{name}.noautocompressdoc
@@ -118,6 +114,7 @@ Patch22:    %{name}-sparc64.patch
 Patch23:       %{name}-gendiff.patch
 Patch24:       openmp.patch
 Patch25:       %{name}-URPM-build-fix.patch
+Patch26:       %{name}-semanage.patch
 Patch27:       %{name}-helperEVR-noassert.patch
 Patch28:       %{name}-unglobal.patch
 Patch29:       %{name}-builddir-readlink.patch
@@ -150,6 +147,7 @@ Patch55:    %{name}-disable-hmac-verify.patch
 Patch56:       %{name}-macros.patch
 Patch57:       %{name}-db5.2.patch
 Patch58:       %{name}-preserve-iterator.patch
+Patch59:       gcc6-stdlib.patch
 Patch60:       %{name}-python-sitescriptdir.patch
 Patch61:       %{name}-clean-docdir.patch
 Patch62:       %{name}-DB_CONFIG.patch
@@ -177,6 +175,12 @@ Patch87:   %{name}-file-output-for-ELF.patch
 Patch88:       %{name}-rpmtdnext.patch
 Patch89:       disable-header-verification.patch
 Patch90:       %{name}-cppcompat.patch
+Patch91:       py-disable-fetch.patch
+Patch92:       fast_python_deps.patch
+Patch93:       python2_explicit.patch
+Patch94:       do_not_write_before_macro_buffer.patch
+Patch95:       rpm-python-spec-header.patch
+Patch96:       skip-ldconfig-optimization.patch
 
 # Patches imported from Mandriva
 
@@ -358,6 +362,7 @@ BuildRequires:      popt-static >= %{reqpopt_ver}
 BuildRequires: zlib-static
 %endif
 Requires(posttrans):   coreutils
+Requires:      FHS >= 3.0-2
 Requires:      %{name}-base = %{version}-%{release}
 Requires:      %{name}-lib = %{version}-%{release}
 Requires:      beecrypt >= %{beecrypt_ver}
@@ -382,18 +387,6 @@ BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                ppc     ppc ppc7400 ppc7450
 %define                x8664   amd64 ia32e x86_64
 
-# stabilize new build environment
-%ifnarch x32
-%define                __newcc %{?force_cc}%{!?force_cc:%{_target_cpu}-pld-linux-gcc}
-%define                __newcxx %{?force_cxx}%{!?force_cxx:%{_target_cpu}-pld-linux-g++}
-%define                __newcpp %{?force_cpp}%{!?force_cpp:%{_target_cpu}-pld-linux-gcc -E}
-%else
-# x32 is a very special case
-%define                __newcc %{?force_cc}%{!?force_cc:x86_64-pld-linux-gnux32-gcc}
-%define                __newcxx %{?force_cxx}%{!?force_cxx:x86_64-pld-linux-gnux32-g++}
-%define                __newcpp %{?force_cpp}%{!?force_cpp:x86_64-pld-linux-gnux32-gcc -E}
-%endif
-
 %define                _rpmlibdir /usr/lib/rpm
 %define                _noautocompressdoc      RPM-GPG-KEY
 
@@ -673,7 +666,7 @@ Summary(uk.UTF-8):  Скрипти та утиліти, необхідні для
 Group:         Applications/File
 Requires(pretrans):    coreutils
 Requires(pretrans):    findutils
-Requires:      %{name}-build-macros >= 1.699
+Requires:      %{name}-build-macros >= 1.712
 Requires:      %{name}-utils = %{version}-%{release}
 Requires:      /bin/id
 Requires:      awk
@@ -774,7 +767,7 @@ Summary(pl.UTF-8):  Makra ułatwiające tworzenie pakietów RPM z programami napi
 Group:         Applications/File
 Requires:      %{name} = %{version}-%{release}
 Requires:      python
-Requires:      python-distribute
+Requires:      python-setuptools
 Requires:      python-modules
 
 %description pythonprov
@@ -904,6 +897,7 @@ cd -
 %patch23 -p1
 %patch24 -p1
 %patch25 -p1
+%patch26 -p1
 %patch27 -p1
 %patch28 -p1
 %patch29 -p1
@@ -936,6 +930,7 @@ cd -
 %patch56 -p1
 %{!?with_db61:%patch57 -p1}
 %patch58 -p1
+%patch59 -p1
 %patch60 -p1
 %patch61 -p1
 %patch62 -p1
@@ -962,6 +957,7 @@ cd -
 %patch88 -p1
 %patch89 -p1
 %patch90 -p1
+%patch91 -p1
 
 %patch1000 -p1
 %patch1001 -p1
@@ -1012,6 +1008,11 @@ cd -
 %patch1049 -p1
 
 %patch83 -p1
+%patch92 -p1
+%patch93 -p1
+%patch94 -p1
+%patch95 -p1
+%patch96 -p1
 
 %patch1050 -p1
 
@@ -1022,6 +1023,8 @@ install %{SOURCE11} scripts/perl.prov.in
 cp -p %{SOURCE30} scripts/rubygems.rb
 cp -p %{SOURCE31} scripts/gem_helper.rb
 
+rm scripts/find-php*
+
 %{__mv} -f scripts/perl.req{,.in}
 
 # generate Group translations to *.po
@@ -1050,11 +1053,7 @@ sed -i \
        macros/macros.in
 
 %{?with_system_lua:CPPFLAGS="-I/usr/include/lua51 %{rpmcppflags}"}
-# pass CC and CXX too in case of building with some older configure macro
 %configure \
-       CC="%{__newcc}" \
-       CXX="%{__newcxx}" \
-       CPP="%{__newcpp}" \
        WITH_PERL_VERSION=no \
        __GST_INSPECT=%{_bindir}/gst-inspect-1.0 \
        --disable-silent-rules \
@@ -1087,10 +1086,7 @@ sed -i \
        --with-xz=external \
        --with-zlib=external
 
-%{__make} -j1 \
-       CC="%{__cc}" \
-       CXX="%{__cxx}" \
-       CPP="%{__cpp}"
+%{__make} -j1
 
 %{?with_apidocs:%{__make} apidocs}
 
@@ -1269,7 +1265,6 @@ install %{SOURCE4} $RPM_BUILD_ROOT%{_rpmlibdir}/find-spec-bcond
 install %{SOURCE7} $RPM_BUILD_ROOT%{_rpmlibdir}/compress-doc
 install %{SOURCE12} $RPM_BUILD_ROOT%{_rpmlibdir}/user_group.sh
 install %{SOURCE14} $RPM_BUILD_ROOT%{_rpmlibdir}/java-find-requires
-install scripts/find-php*      $RPM_BUILD_ROOT%{_rpmlibdir}
 install scripts/php.{prov,req} $RPM_BUILD_ROOT%{_rpmlibdir}
 cp -p %{SOURCE25} $RPM_BUILD_ROOT%{_rpmlibdir}/php.req.php
 install %{SOURCE17} $RPM_BUILD_ROOT%{_rpmlibdir}/mimetypedeps.sh
@@ -1640,8 +1635,9 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 
 %files php-pearprov
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_rpmlibdir}/php*
-%attr(755,root,root) %{_rpmlibdir}/find-php*
+%attr(755,root,root) %{_rpmlibdir}/php.prov
+%attr(755,root,root) %{_rpmlibdir}/php.req
+%attr(755,root,root) %{_rpmlibdir}/php.req.php
 
 %if %{with python}
 %files -n python-rpm
This page took 0.067184 seconds and 4 git commands to generate.