]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm.spec
use libexec directory for private binaries - optional since FHS 3.0
[packages/rpm.git] / rpm.spec
index 086e21360cb1c73f9376162c76dd6f6e3cbf7e3e..ac613f1eb474f537952b18287c27c27763755dde 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
 %bcond_with    system_lua      # use system lua
 %bcond_without system_pcre     # use system pcre
 %bcond_with    keyutils        # build with keyutils support
-# force_cc             - force using __cc other than "%{_target_cpu}-pld-linux-gcc"
-# force_cxx            - force using __cxx other than "%{_target_cpu}-pld-linux-g++"
-# force_cpp            - force using __cpp other than "%{_target_cpu}-pld-linux-gcc -E"
-#
 
 %if %{with sqlite}
 # Error: /lib64/librpmio-5.4.so: undefined symbol: sqlite3_enable_load_extension
@@ -51,7 +47,7 @@ Summary(ru.UTF-8):    Менеджер пакетов от RPM
 Summary(uk.UTF-8):     Менеджер пакетів від RPM
 Name:          rpm
 Version:       5.4.15
-Release:       39
+Release:       41
 License:       LGPL v2.1
 Group:         Base
 # http://rpm5.org/files/rpm/rpm-5.4/rpm-5.4.15-0.20140824.src.rpm
@@ -151,6 +147,7 @@ Patch55:    %{name}-disable-hmac-verify.patch
 Patch56:       %{name}-macros.patch
 Patch57:       %{name}-db5.2.patch
 Patch58:       %{name}-preserve-iterator.patch
+Patch59:       gcc6-stdlib.patch
 Patch60:       %{name}-python-sitescriptdir.patch
 Patch61:       %{name}-clean-docdir.patch
 Patch62:       %{name}-DB_CONFIG.patch
@@ -365,6 +362,7 @@ BuildRequires:      popt-static >= %{reqpopt_ver}
 BuildRequires: zlib-static
 %endif
 Requires(posttrans):   coreutils
+Requires:      FHS >= 3.0-2
 Requires:      %{name}-base = %{version}-%{release}
 Requires:      %{name}-lib = %{version}-%{release}
 Requires:      beecrypt >= %{beecrypt_ver}
@@ -389,18 +387,6 @@ BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                ppc     ppc ppc7400 ppc7450
 %define                x8664   amd64 ia32e x86_64
 
-# stabilize new build environment
-%ifnarch x32
-%define                __newcc %{?force_cc}%{!?force_cc:%{_target_cpu}-pld-linux-gcc}
-%define                __newcxx %{?force_cxx}%{!?force_cxx:%{_target_cpu}-pld-linux-g++}
-%define                __newcpp %{?force_cpp}%{!?force_cpp:%{_target_cpu}-pld-linux-gcc -E}
-%else
-# x32 is a very special case
-%define                __newcc %{?force_cc}%{!?force_cc:x86_64-pld-linux-gnux32-gcc}
-%define                __newcxx %{?force_cxx}%{!?force_cxx:x86_64-pld-linux-gnux32-g++}
-%define                __newcpp %{?force_cpp}%{!?force_cpp:x86_64-pld-linux-gnux32-gcc -E}
-%endif
-
 %define                _rpmlibdir /usr/lib/rpm
 %define                _noautocompressdoc      RPM-GPG-KEY
 
@@ -944,6 +930,7 @@ cd -
 %patch56 -p1
 %{!?with_db61:%patch57 -p1}
 %patch58 -p1
+%patch59 -p1
 %patch60 -p1
 %patch61 -p1
 %patch62 -p1
@@ -1066,11 +1053,7 @@ sed -i \
        macros/macros.in
 
 %{?with_system_lua:CPPFLAGS="-I/usr/include/lua51 %{rpmcppflags}"}
-# pass CC and CXX too in case of building with some older configure macro
 %configure \
-       CC="%{__newcc}" \
-       CXX="%{__newcxx}" \
-       CPP="%{__newcpp}" \
        WITH_PERL_VERSION=no \
        __GST_INSPECT=%{_bindir}/gst-inspect-1.0 \
        --disable-silent-rules \
@@ -1103,10 +1086,7 @@ sed -i \
        --with-xz=external \
        --with-zlib=external
 
-%{__make} -j1 \
-       CC="%{__cc}" \
-       CXX="%{__cxx}" \
-       CPP="%{__cpp}"
+%{__make} -j1
 
 %{?with_apidocs:%{__make} apidocs}
 
This page took 0.032027 seconds and 4 git commands to generate.