]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm.spec
- perl -pi -e "s/^automake -a -c$/automake -a -c -f/"
[packages/rpm.git] / rpm.spec
index 74a605f133e4806e77f0c71b806d639f02984318..99d4e46980d756b0f2f3d82f918bfdfb741059ea 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -1,13 +1,13 @@
 # to build for athlon you need release at least 49
 
-Summary:       Red Hat (and now also PLD) Package Manager
-Summary(de):   Red Hat (und jetzt auch PLD) Packet-Manager
+Summary:       RPM Package Manager
+Summary(de):   RPM Packet-Manager
 Summary(es):   Gestor de paquetes RPM
-Summary(pl):   Aplikacja do zarz±dzania pakietami
+Summary(pl):   Aplikacja do zarz±dzania pakietami RPM
 Summary(pt_BR):        Gerenciador de pacotes RPM
 Name:          rpm
 Version:       4.0.2
-Release:       54
+Release:       60
 License:       GPL
 Group:         Base
 Source0:       ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.0.x/%{name}-%{version}.tar.gz
@@ -58,6 +58,7 @@ Patch30:      %{name}-athlon.patch
 Patch31:       %{name}-athlon-identify.patch
 Patch32:       %{name}-gettext-in-header.patch
 Patch33:       %{name}-perlprov-perl5.6.patch
+Patch34:       %{name}-groups-po.patch
 Patch37:        %{name}-short_circuit.patch
 Patch38:        %{name}-section_test.patch
 URL:           http://www.rpm.org/
@@ -70,14 +71,14 @@ BuildRequires:      db3-devel >= 3.1.17-9
 BuildRequires: gettext-devel >= 0.10.38-3
 BuildRequires: python-devel >= 2.2
 BuildRequires: python-modules >= 2.2
-BuildRequires: zlib-devel
+BuildRequires: python-devel >= 2.2.1
 BuildRequires: python-modules >= 2.2.1
 BuildRequires: zlib-devel >= 1.1.4
 %if %{!?_without_static:1}%{?_without_static:0}
 # Require static library only for static build
 BuildRequires: bzip2-static >= 1.0.1
 BuildRequires: db1-static >= 1.85
-BuildRequires: zlib-static
+BuildRequires: db3-static >= 3.1.17-9
 BuildRequires: glibc-static >= 2.2.0
 BuildRequires: zlib-static >= 1.1.4
 %endif
@@ -210,6 +211,7 @@ Summary:    Additional utilities for checking perl provides/requires in rpm package
 Summary(de):   Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
 Summary(pl):   Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów perla w pakietach rpm
 Group:         Applications/File
+Requires:      %{name} = %{version}
 Requires:      perl-modules
 Requires:      findutils
 
@@ -241,7 +243,7 @@ Pythonie.
 
 %package -n python-rpm
 Summary:       Python interface to RPM library
-Group:         Development/Languages/Python
+Summary(pl):   Pythonowy interfejs do biblioteki RPM-a
 Summary(pt_BR):        Módulo Python para aplicativos que manipulam pacotes RPM
 %requires_eq   python
 Requires:      %{name} = %{version}
@@ -296,6 +298,7 @@ Requires:   make
 Requires:      patch
 Requires:      popt >= 1.6.2-2
 Requires:      sed
+Requires:      sh-utils
 Requires:      tar
 Requires:      textutils
 
@@ -350,6 +353,7 @@ construir pacotes usando o RPM.
 %patch31 -p1
 %endif
 
+%patch32 -p1
 %patch35 -p1
 %patch36 -p1
 %patch37 -p1
@@ -372,7 +376,7 @@ awk -f %{SOURCE14} %{SOURCE1}
 
 cd popt
 autoconf
-automake -a -c
+automake -a -c -f
 aclocal
 autoheader
 automake -a -c -f
@@ -386,7 +390,7 @@ aclocal
 autoupdate
 autoheader || :
 %{__autoconf}
-automake -a -c
+automake -a -c -f
 sed -e 's#cpio.c $(DBLIBOBJS) depends.c#cpio.c depends.c#g' \
        lib/Makefile.am > lib/Makefile.am.new
 mv -f lib/Makefile.am.new lib/Makefile.am
@@ -453,6 +457,10 @@ rm -rf $RPM_BUILD_ROOT
 %post  -p /sbin/ldconfig
 %postun -p /sbin/ldconfig
 
+%files -f %{name}.lang
+%defattr(644,root,root,755)
+%doc RPM-PGP-KEY.gz CHANGES.gz doc/manual/*
+
 %attr(755,root,root) /bin/rpm
 %attr(755,root,root) %{_bindir}/rpmdb
 %attr(755,root,root) %{_bindir}/rpmquery
@@ -498,6 +506,10 @@ rm -rf $RPM_BUILD_ROOT
 %endif
 %ifarch ppc
 %{_libdir}/rpm/ppc*
+%endif
+
+
+%files build
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/rpmbuild
 %attr(755,root,root) %{_bindir}/rpme
@@ -534,7 +546,9 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/librpm*.so
 
 %files static
-%attr(755,root,root) %{_bindir}/*
+%defattr(644,root,root,755)
+%{_libdir}/librpm*.a
+
 %files utils
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/gendiff
@@ -559,7 +573,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %{_libdir}/rpm/macros.perl
 
-%defattr(644,root,root,755)
+%files pythonprov
 %defattr(644,root,root,755)
 %{_libdir}/rpm/macros.python
 
This page took 0.033766 seconds and 4 git commands to generate.