]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm.spec
- updated to 20041118 snap (not finished due to libtool problems)
[packages/rpm.git] / rpm.spec
index 5c3f96cefefcab1559702a97fe7e682f21b0e39e..88040816c72f8327aa79f691ee0d0a0730523abe 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -3,24 +3,24 @@
 # - consider using system libmagic not internal libfmagic
 #   (but internal has different method of passing output)
 # - after ac drop amd64 patch and make x86_64 generic arch + subarchs amd64 and ia32e
-# - ? make putting packages names in autogenerating dependacies as runtime option
 # 
 # Conditional build:
+%bcond_with    distver # build with distversion field
 %bcond_with    static  # build static rpmi (not supported at the moment)
-%bcond_without pkgnameinautoreq        # don't put package name in autogenerated dependancy
 %bcond_without apidocs # don't generate documentation with doxygen
+%bcond_without pkgnameinautoreq        # don't put package name in autogenerated dependancy
 %bcond_without python  # don't build python bindings
 %bcond_without selinux # dont enable selinux support
 # force_cc             - force using __cc other than "%{_target_cpu}-pld-linux-gcc"
 # force_cxx            - force using __cxx other than "%{_target_cpu}-pld-linux-g++"
 # force_cpp            - force using __cpp other than "%{_target_cpu}-pld-linux-gcc -E"
 
-%define        snap    20040614
+%define        snap    20041118
 # versions of required libraries
 %define        reqdb_ver       4.2.50-1
 %define        reqpopt_ver     1.9
-%define        beecrypt_ver    2:4.0.0
-%define        rpm_macros_rev  1.162
+%define        beecrypt_ver    2:4.1.0
+%define        rpm_macros_rev  1.167
 Summary:       RPM Package Manager
 Summary(de):   RPM Packet-Manager
 Summary(es):   Gestor de paquetes RPM
@@ -32,12 +32,12 @@ Name:               rpm
 %define        ver     4.4
 %define        sover   4.3
 Version:       %{ver}
-Release:       0.%{snap}.0.5
+Release:       0.%{snap}.0.1
 License:       GPL
 Group:         Base
 #Source0:      ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.2.x/%{name}-%{version}.%{snap}.tar.gz
 Source0:       ftp://distfiles.pld-linux.org/src/%{name}-%{version}.%{snap}.tar.bz2
-# Source0-md5: a91b8e17f6e69208b188d2876e80aef9
+# Source0-md5: 5033d2c69d8db97ab0886e48743e96c7
 Source1:       %{name}.groups
 Source2:       %{name}.platform
 Source3:       %{name}-install-tree
@@ -71,7 +71,6 @@ Patch14:      %{name}-bb-and-short-circuit.patch
 Patch15:       %{name}-etc_dir.patch
 Patch16:       %{name}-system_libs-more.patch
 Patch17:       %{name}-php-deps.patch
-Patch18:       %{name}-python-fix.patch
 Patch19:       %{name}-ldconfig-always.patch
 Patch20:       %{name}-perl_req.patch
 Patch21:       %{name}-no-bin-env.patch
@@ -86,18 +85,15 @@ Patch29:    %{name}-hack-norpmlibdep.patch
 Patch30:       %{name}-makefile-no_myLDADD_deps.patch
 Patch31:       %{name}-libdir64.patch
 Patch32:       %{name}-libdir-links.patch
-Patch33:       %{name}-context.patch
 Patch35:       %{name}-missing-prototypes.patch
 Patch36:       %{name}-pld-autodep.patch
 Patch37:       %{name}-rpmsq.patch
-Patch38:       %{name}-file-readelf.patch
-Patch39:       %{name}-no_version_check_in_obsoletes.patch
 Patch40:       %{name}-epoch0.patch
-Patch41:       %{name}-file-readelf-fix.patch
 Patch43:       %{name}-perl_req-INC_dirs.patch
 Patch44:       %{name}-debuginfo.patch
 Patch45:       %{name}-beecrypt4.patch
 Patch46:       %{name}-doxygen_hack.patch
+Patch47:       %{name}-distver.patch
 Patch100:      %{name}-pl.po.patch
 URL:           http://www.rpm.org/
 Icon:          rpm.gif
@@ -116,6 +112,7 @@ BuildRequires:      gettext-devel >= 0.11.4-2
 BuildRequires: libstdc++-devel
 BuildRequires: libtool
 BuildRequires: libxml2-devel
+BuildRequires: neon-devel
 BuildRequires: patch >= 2.2
 BuildRequires: popt-devel >= %{reqpopt_ver}
 %{?with_python:BuildRequires:  python-devel >= 2.2}
@@ -449,6 +446,7 @@ Summary(pl):        Biblioteki RPM-a
 Group:         Libraries
 Requires:      db >= %{reqdb_ver}
 Requires:      popt >= %{reqpopt_ver}
+%{?with_distver:Provides:      rpm-lib(distver)}
 # avoid SEGV caused by mixed db versions
 Conflicts:     poldek < 0.18.1-16
 
@@ -494,7 +492,7 @@ Requires:   sh-utils
 Requires:      tar
 Requires:      textutils
 Provides:      rpmbuild(macros) = %{rpm_macros_rev}
-Provides:      rpmbuild(noauto) = 2
+Provides:      rpmbuild(noauto) = 3
 %ifarch amd64
 Conflicts:     automake < 1:1.7.9-2
 Conflicts:     libtool < 2:1.5-13
@@ -556,12 +554,18 @@ construir pacotes usando o RPM.
 ÐÏÂÕÄÏ×É RPM'¦×.
 
 %if %{with apidocs}
-%package apidocs
-Summary: apidocs
-Group:  Documentation  
+%package       apidocs
+Summary:       rpm API documentation and guides
+Summary(pl):   Documentacja API rpm i przewodniki.
+Group:         Documentation   
 
 %description apidocs
-rpm apidocs generated by doxygen.
+Documentation for rpm API and guides in html format generated
+from rpm sources by doxygen.
+
+%description apidocs -l pl
+Dokumentacja API rpm oraz przewodniki w formacie html generowana
+ze ¼rode³ rpm przez doxygen.
 %endif
 
 %prep
@@ -584,7 +588,6 @@ rpm apidocs generated by doxygen.
 #%patch15 -p1
 %patch16 -p1
 %patch17 -p1
-%patch18 -p1
 %patch19 -p1
 %patch20 -p1
 %patch21 -p1
@@ -611,19 +614,19 @@ cat %{SOURCE11} >> macros.in
 %patch30 -p1
 %patch31 -p1
 %patch32 -p1
-%patch33 -p1
 %patch35 -p1
 %patch36 -p1
 %patch37 -p1
-%patch38 -p1
-%patch39 -p1
 %patch40 -p1
-%patch41 -p1
 %patch43 -p0
 %patch44 -p1
-%patch45 -p1
-%patch46 -p1
-%patch100 -p1
+# OBSOLETE
+#%patch45 -p1
+# NEEDS UPDATE
+# %patch46 -p1
+%{?with_distver:%patch47 -p1}
+# NEEDS UPDATE
+#%patch100 -p1
 %patch3 -p1
 
 cd scripts;
@@ -634,7 +637,7 @@ cd ..
 mv -f po/{no,nb}.po
 mv -f po/{sr,sr@Latn}.po
 
-rm -rf zlib libelf db db3 popt rpmdb/db.h
+rm -rf neon zlib libelf db db3 popt rpmdb/db.h
 
 # generate Group translations to *.po
 awk -f %{SOURCE6} %{SOURCE1}
@@ -700,7 +703,7 @@ mv -f macros.tmp macros.in
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT/{%{_lib},/etc/sysconfig,%{_sysconfdir}/rpm}
+install -d $RPM_BUILD_ROOT{/%{_lib},/etc/sysconfig,%{_sysconfdir}/rpm}
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT \
@@ -785,8 +788,13 @@ cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqdep <<EOF
 ^libXRes.so
 ^libXTrap.so
 ^libXaw.so
+^libXcomposite.so
 ^libXcursor.so
+^libXdamage.so
+^libXdmcp.so
+^libXevie.so
 ^libXext.so
+^libXfixes.so
 ^libXfont.so
 ^libXfontcache.so
 ^libXft.so
@@ -807,7 +815,10 @@ cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqdep <<EOF
 ^libXxf86misc.so
 ^libXxf86rush.so
 ^libXxf86vm.so
+^libdps.so
+^libdpstk.so
 ^libfontenc.so
+^libpsres.so
 ^libxkbfile.so
 ^libxkbui.so
 EOF
@@ -986,15 +997,6 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 %attr(755,root,root) %{_rpmlibdir}/rpm2cpio.sh
 %attr(755,root,root) %{_rpmlibdir}/tgpg
 %attr(755,root,root) %{_rpmlibdir}/rpmdb_loadcvt
-
-%files utils-perl
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_rpmlibdir}/rpmdiff*
-# not here
-#%%{_rpmlibdir}/rpm.daily
-#%%{_rpmlibdir}/rpm.log
-#%%{_rpmlibdir}/rpm.xinetd
-
 %{_mandir}/man8/rpm2cpio.8*
 %{_mandir}/man8/rpmdeps.8*
 %{_mandir}/man8/rpmcache.8*
@@ -1009,6 +1011,15 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 %lang(pl) %{_mandir}/pl/man8/rpmgraph.8*
 %lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
 
+%files utils-perl
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_rpmlibdir}/rpmdiff*
+# not here
+#%%{_rpmlibdir}/rpm.daily
+#%%{_rpmlibdir}/rpm.log
+#%%{_rpmlibdir}/rpm.xinetd
+
+
 %if %{with static}
 %files utils-static
 %defattr(644,root,root,755)
This page took 0.034359 seconds and 4 git commands to generate.