]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm.spec
- staring playing with rpm.org
[packages/rpm.git] / rpm.spec
index aac1eab5dc9f9ea77d546a5a09c94d28e8872460..82f7bf39355f477961eb1a1a3bfe041638d4777e 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
 %bcond_with    system_lua      # use system lua
 %bcond_without system_pcre     # use system pcre
 %bcond_with    keyutils        # build with keyutils support
-# force_cc             - force using __cc other than "%{_target_cpu}-pld-linux-gcc"
-# force_cxx            - force using __cxx other than "%{_target_cpu}-pld-linux-g++"
-# force_cpp            - force using __cpp other than "%{_target_cpu}-pld-linux-gcc -E"
-#
 
 %if %{with sqlite}
 # Error: /lib64/librpmio-5.4.so: undefined symbol: sqlite3_enable_load_extension
@@ -50,13 +46,12 @@ Summary(pt_BR.UTF-8):       Gerenciador de pacotes RPM
 Summary(ru.UTF-8):     Менеджер пакетов от RPM
 Summary(uk.UTF-8):     Менеджер пакетів від RPM
 Name:          rpm
-Version:       5.4.15
-Release:       18
-License:       LGPL v2.1
+Version:       4.14.2.1
+Release:       0.1
+License:       GPL v2 / LGPL v2.1
 Group:         Base
-# http://rpm5.org/files/rpm/rpm-5.4/rpm-5.4.15-0.20140824.src.rpm
-Source0:       %{name}-%{version}.tar.gz
-# Source0-md5: 4067f83ca8b5bf1a21e443c0cff3efa0
+Source0:       http://ftp.rpm.org/releases/rpm-4.14.x/%{name}-%{version}.tar.bz2
+# Source0-md5: fdb8b8857f103b087b6aed5b78dd9b4f
 # See README.cpu-os-macros how to update cpu-os-macros.a
 Source100:     cpu-os-macros.a
 Source101:     README.cpu-os-macros
@@ -77,7 +72,7 @@ Source14:     %{name}-java-requires
 # http://svn.pld-linux.org/banner.sh/
 Source15:      banner.sh
 Source16:      ftp://ftp.pld-linux.org/dists/th/PLD-3.0-Th-GPG-key.asc
-# Source16-md5:        08b29584dd349aac9caa7610131a0a88
+# Source16-md5:        23914bb49fafe7153cee87126d966461
 Source17:      %{name}-mimetypedeps
 Source18:      macros.local
 Source19:      %{name}.noautocompressdoc
@@ -118,6 +113,7 @@ Patch22:    %{name}-sparc64.patch
 Patch23:       %{name}-gendiff.patch
 Patch24:       openmp.patch
 Patch25:       %{name}-URPM-build-fix.patch
+Patch26:       %{name}-semanage.patch
 Patch27:       %{name}-helperEVR-noassert.patch
 Patch28:       %{name}-unglobal.patch
 Patch29:       %{name}-builddir-readlink.patch
@@ -150,6 +146,7 @@ Patch55:    %{name}-disable-hmac-verify.patch
 Patch56:       %{name}-macros.patch
 Patch57:       %{name}-db5.2.patch
 Patch58:       %{name}-preserve-iterator.patch
+Patch59:       gcc6-stdlib.patch
 Patch60:       %{name}-python-sitescriptdir.patch
 Patch61:       %{name}-clean-docdir.patch
 Patch62:       %{name}-DB_CONFIG.patch
@@ -158,6 +155,7 @@ Patch64:    %{name}-fix-compress-doc.patch
 Patch65:       %{name}-parseSpec-skip-empty-tags.patch
 Patch66:       %{name}-payload-use-hashed-inode.patch
 Patch67:       %{name}-repackage-dont-force-max-compression.patch
+Patch68:       rpm-bug-420.patch
 Patch70:       python-%{name}sense-missingok.patch
 Patch71:       %{name}-changelog-encoding.patch
 Patch72:       %{name}-preserve-tag-type.patch
@@ -177,126 +175,16 @@ Patch87: %{name}-file-output-for-ELF.patch
 Patch88:       %{name}-rpmtdnext.patch
 Patch89:       disable-header-verification.patch
 Patch90:       %{name}-cppcompat.patch
-
-# Patches imported from Mandriva
-
-# status: ready to merge, it's already been merged on HEAD, so commiting it to rpm-5_4
-# would basically just mean backporting it..
-Patch1000:     %{name}-5.4.4-add-_specfile-macro.patch
-# status: needs to be cleaned up and properly reviewed together with rest
-# of the patches related to dependency generation
-Patch1001:     %{name}-5.4.9-avoid-dependencies-on-self.patch
-# status: probably ready to merge
-Patch1002:     %{name}-5.4.4-pkgconfigdeps-check-path.patch
-# status: probably okay to merge, but discuss on rpm-devel first
-Patch1003:     %{name}-5.4.4-glob-wildcards-for-loading-macro-files.patch
-# status: needs to be discussed
-Patch1004:     %{name}-5.4.4-allow-installation-of-repackaged-rpms.patch
-# status: ready to merge
-Patch1005:     %{name}-5.4.8-dont-show-suggests-with-requires.patch
-# status: ready for merge
-Patch1006:     %{name}-5.4.9-strip-buildroot-away-from-duplicate-files-list.patch
-# status: probably okay to merge, but discuss on rpm-devel first
-Patch1007:     %{name}-5.4.10-duplicate_files_terminate_build.patch
-# status: same as above
-Patch1008:     %{name}-5.4.10-unpackaged_subdirs_terminate_build.patch
-# mdvbz#64898
-# status: uncertain, might be okay to merge, discuss on rpm-devel first
-Patch1009:     %{name}-5.4.4-rpmbuild-withoutclean.patch
-# no sense in having an additional dependency on 'pkgconfig' on all packages that
-# have a pkgconfig file, it's not needed for them to be made useful and anything
-# actuallly using pkgconfig for this purpose will pull it in as a dependency anyways...
-# status: might be okay to merge, but discuss on rpm-devel first
-Patch1010:     %{name}-5.4.4-drop-useless-auto-generated-pkgconfig-dependency.patch
-# status: ready for merge
-Patch1011:     %{name}-5.4.4-fix-rpmconstant-to-always-use-LC_CTYPE-C-for-case-conversion.patch
-# $RPM_BUILD_DIR isn't necessarily the same as $PWD, it's %%{_builddir}, not
-# %%{_builddir}/%%{?buildsubdir}, messing up paths in debug packages created..
-# status: needs to be discussed and investigated a bit better..
-Patch1012:     %{name}-5.4.4-pass-_builddir-properly-to-find-debuginfo.patch
-# status: probably okay to merge, but discuss on rpm-devel first
-Patch1013:     %{name}-5.4.10-files-listed-twice-terminates-build.patch
-# status: probably okay to merge
-Patch1014:     %{name}-5.4.9-ruby1.9-fixes.patch
-# status: keep locally
-Patch1015:     %{name}-5.4.9-keep-loading-script-macros.patch
-# status: same as for other dep gen patches
-Patch1016:     %{name}-5.4.9-update-rpmfc-when-removing-dependencies-on-self.patch
-# status: idem
-Patch1017:     %{name}-5.4.9-rpmfc-extract-dependencies-for-all-files.patch
-# status: probably okay to merge
-Patch1019:     %{name}-5.4.5-python-export-spec-macros.patch
-# status: idem
-Patch1020:     %{name}-5.4.9-font-provides.patch
-# stauus: idem
-Patch1021:     %{name}-5.4.7-kmod-dependencies.patch
-# status: probably okay to merge, discuss on rpm-devel first
-Patch1022:     %{name}-5.4.5-skip-dependencies-for-character-devices.patch
-# status: probably okay to merge
-Patch1024:     %{name}-5.4.5-rpmfc-apply-python-coloring-from-magic.patch
-# status: probably okay to merge
-Patch1026:     %{name}-5.4.10-dont-try-generate-rpmfc-dependencies-from-doc-files.patch
-# status: ready
-Patch1027:     %{name}-5.4.7-fix-generation-of-ruby-abi-provides.patch
-# crash reproducable with 'rpm -qa --triggers'
-# status: ready
-Patch1028:     %{name}-5.4.7-hdrfmt-fix-unitialized-argv-element.patch
-# status: same as for other dep gen patches
-Patch1029:     %{name}-5.4.7-dont-consider-trigger-dependencies-as-overlapping.patch
-# status: ready
-Patch1030:     %{name}-5.4.7-fix-minor-memleaks.patch
-# status: ready
-Patch1031:     %{name}-5.4.9-mire-fix-strings-lacking-null-terminator.patch
-# status: ready
-Patch1032:     %{name}-5.4.9-rpmpython-fix-input.patch
-# status: ready
-Patch1033:     %{name}-5.4.7-no-seqid_init-on-rdonly-database.patch
-# status: probably ready for merging
-Patch1034:     %{name}-5.4.9-avoid-double-slash-in-path-for-dirname-filetrigger-matching.patch
-# status: probably ready to merge, discuss on rpm-devel first
-Patch1035:     %{name}-5.4.9-fix-verify-segfault.patch
-# Due to rpmdav/neon being written in a different fashion than other rpmio clients,
-# the inconsistent behaviour affects code elsewhere which expects consistent behaviour,
-# with the result being that when unable to download files, neon will save error
-# page as the target file.
-# status: should go upstream, but uncertain about "correct" fix, ie. this is
-# more of a workaround, while rewriting rpmdav code to behave consistently
-# would be "the right thing to do". Yet I'm not fully able to grasp all of the
-# code and don't want to spend more time just to get the API..
-Patch1037:     %{name}-5.4.10-fix-neon-saving-error-pages-as-target-file.patch
-# As the transaction flags for ignoring arch & os are no longer used, there's
-# currently no way to ignore arch & os of packages anymore. This patch adds
-# support for doing this again by defining rpm variables and overriding
-# --ignorearch & --ignoreos to set these.
-# status: needs to be discussed upstream before thinking about merging
-Patch1038:     %{name}-5.4.10-support-ignore-arch-and-os-again.patch
-# status: ready for merge
-Patch1039:     %{name}-5.4.4-fix-same-package-with-epoch-possible-to-upgrade.patch
-# we want that patch too, a bit of builder infrastructure relies on NOSIGNATURES
-Patch1040:     %{name}-5.4.9-support-signatures-and-digest-disablers.patch
-# lack insight on actual functionality, which anyways seems broken, so let's
-# disable it to avoid errors from berkeley db..
-# status: keep locally
-Patch1041:     %{name}-5.4.9-disable-l10ndir.patch
-# status: ready for merge
-Patch1042:     %{name}-5.4.9-fix-rpm_qa-pattern.patch
-# warning: introduces memory leak
-Patch1043:     %{name}-5.4.12-copy-Value-string.patch
-Patch1044:     %{name}-5.4.12-fix-rpmlua-print.patch
-Patch1045:     %{name}-5.4.12-fix-rpmpython-module-import-init.patch
-Patch1046:     %{name}-5.4.12-truncate-output-buffer-after-use.patch
-Patch1047:     %{name}-5.4.13-perl-bindings-do-not-use-xmalloc.patch
-# proyvind:
-# there's a rpmdbchk tool I wrote a while back, which might help you. although
-# the incidents it's able to deal with is rather limited ATM... it might help
-# you out, if not and you'll be able to solve yer problem, you could take a
-# stab at adding support for fixing your specific problem to the util ;)
-# https://abf.io/openmandriva/rpm/raw/master/rpm-5.4.14-rpmdbchk.patch
-Patch1048:     %{name}-5.4.14-rpmdbchk.patch
-# https://abf.io/openmandriva/rpm/raw/master/rpm-5.4.14-no-assert-abort-with-broken-headers.patch
-Patch1049:     %{name}-5.4.14-no-assert-abort-with-broken-headers.patch
-
-Patch1050:     python-libx32.patch
+Patch91:       py-disable-fetch.patch
+Patch92:       fast_python_deps.patch
+Patch93:       python2_explicit.patch
+Patch94:       do_not_write_before_macro_buffer.patch
+Patch95:       rpm-python-spec-header.patch
+Patch96:       skip-ldconfig-optimization.patch
+Patch97:       glibc.patch
+Patch98:       extension-based-compression-detection.patch
+Patch99:       %{name}-gpg-pinentry.patch
+Patch100:      python-libx32.patch
 
 URL:           http://rpm5.org/
 BuildRequires: %{reqdb_pkg}-devel >= %{reqdb_pkgver}
@@ -358,6 +246,7 @@ BuildRequires:      popt-static >= %{reqpopt_ver}
 BuildRequires: zlib-static
 %endif
 Requires(posttrans):   coreutils
+Requires:      FHS >= 3.0-2
 Requires:      %{name}-base = %{version}-%{release}
 Requires:      %{name}-lib = %{version}-%{release}
 Requires:      beecrypt >= %{beecrypt_ver}
@@ -382,18 +271,6 @@ BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                ppc     ppc ppc7400 ppc7450
 %define                x8664   amd64 ia32e x86_64
 
-# stabilize new build environment
-%ifnarch x32
-%define                __newcc %{?force_cc}%{!?force_cc:%{_target_cpu}-pld-linux-gcc}
-%define                __newcxx %{?force_cxx}%{!?force_cxx:%{_target_cpu}-pld-linux-g++}
-%define                __newcpp %{?force_cpp}%{!?force_cpp:%{_target_cpu}-pld-linux-gcc -E}
-%else
-# x32 is a very special case
-%define                __newcc %{?force_cc}%{!?force_cc:x86_64-pld-linux-gnux32-gcc}
-%define                __newcxx %{?force_cxx}%{!?force_cxx:x86_64-pld-linux-gnux32-g++}
-%define                __newcpp %{?force_cpp}%{!?force_cpp:x86_64-pld-linux-gnux32-gcc -E}
-%endif
-
 %define                _rpmlibdir /usr/lib/rpm
 %define                _noautocompressdoc      RPM-GPG-KEY
 
@@ -673,7 +550,7 @@ Summary(uk.UTF-8):  Скрипти та утиліти, необхідні для
 Group:         Applications/File
 Requires(pretrans):    coreutils
 Requires(pretrans):    findutils
-Requires:      %{name}-build-macros >= 1.699
+Requires:      %{name}-build-macros >= 1.712
 Requires:      %{name}-utils = %{version}-%{release}
 Requires:      /bin/id
 Requires:      awk
@@ -904,6 +781,7 @@ cd -
 %patch23 -p1
 %patch24 -p1
 %patch25 -p1
+%patch26 -p1
 %patch27 -p1
 %patch28 -p1
 %patch29 -p1
@@ -936,6 +814,7 @@ cd -
 %patch56 -p1
 %{!?with_db61:%patch57 -p1}
 %patch58 -p1
+%patch59 -p1
 %patch60 -p1
 %patch61 -p1
 %patch62 -p1
@@ -944,6 +823,7 @@ cd -
 %patch65 -p1
 %patch66 -p1
 %patch67 -p1
+%patch68 -p1
 %patch70 -p1
 %patch71 -p1
 %patch72 -p1
@@ -962,58 +842,19 @@ cd -
 %patch88 -p1
 %patch89 -p1
 %patch90 -p1
-
-%patch1000 -p1
-%patch1001 -p1
-%patch1002 -p1
-%patch1003 -p1
-%patch1004 -p1
-%patch1005 -p1
-%patch1006 -p1
-%patch1007 -p1
-%patch1008 -p1
-%patch1009 -p1
-%patch1010 -p1
-%patch1011 -p1
-%patch1012 -p1
-%patch1013 -p1
-%patch1014 -p1
-%patch1015 -p1
-%patch1016 -p1
-%patch1017 -p1
-%patch1019 -p1
-%patch1020 -p1
-%patch1021 -p1
-%patch1022 -p1
-%patch1024 -p1
-%patch1026 -p1
-%patch1027 -p1
-%patch1028 -p1
-%patch1029 -p1
-%patch1030 -p1
-%patch1031 -p1
-%patch1032 -p1
-%patch1033 -p1
-%patch1034 -p1
-%patch1035 -p1
-%patch1037 -p1
-%patch1038 -p1
-%patch1039 -p1
-%patch1040 -p1
-# don't delete, may be usefull if jbj descides to enable this again
-#%patch1041 -p1
-%patch1042 -p1
-%patch1043 -p1
-%patch1044 -p1
-%patch1045 -p1
-%patch1046 -p1
-%patch1047 -p1
-%patch1048 -p1
-%patch1049 -p1
+%patch91 -p1
+%patch99 -p1
 
 %patch83 -p1
+%patch92 -p1
+%patch93 -p1
+%patch94 -p1
+%patch95 -p1
+%patch96 -p1
+%patch97 -p1
+%patch98 -p1
 
-%patch1050 -p1
+%patch100 -p1
 
 install %{SOURCE2} macros/pld.in
 install %{SOURCE8} scripts/php.prov.in
@@ -1022,6 +863,8 @@ install %{SOURCE11} scripts/perl.prov.in
 cp -p %{SOURCE30} scripts/rubygems.rb
 cp -p %{SOURCE31} scripts/gem_helper.rb
 
+rm scripts/find-php*
+
 %{__mv} -f scripts/perl.req{,.in}
 
 # generate Group translations to *.po
@@ -1050,13 +893,10 @@ sed -i \
        macros/macros.in
 
 %{?with_system_lua:CPPFLAGS="-I/usr/include/lua51 %{rpmcppflags}"}
-# pass CC and CXX too in case of building with some older configure macro
 %configure \
-       CC="%{__newcc}" \
-       CXX="%{__newcxx}" \
-       CPP="%{__newcpp}" \
        WITH_PERL_VERSION=no \
        __GST_INSPECT=%{_bindir}/gst-inspect-1.0 \
+       __GPG=%{_bindir}/gpg \
        --disable-silent-rules \
        --enable-shared \
        --enable-static \
@@ -1087,10 +927,7 @@ sed -i \
        --with-xz=external \
        --with-zlib=external
 
-%{__make} -j1 \
-       CC="%{__cc}" \
-       CXX="%{__cxx}" \
-       CPP="%{__cpp}"
+%{__make} -j1
 
 %{?with_apidocs:%{__make} apidocs}
 
@@ -1269,7 +1106,6 @@ install %{SOURCE4} $RPM_BUILD_ROOT%{_rpmlibdir}/find-spec-bcond
 install %{SOURCE7} $RPM_BUILD_ROOT%{_rpmlibdir}/compress-doc
 install %{SOURCE12} $RPM_BUILD_ROOT%{_rpmlibdir}/user_group.sh
 install %{SOURCE14} $RPM_BUILD_ROOT%{_rpmlibdir}/java-find-requires
-install scripts/find-php*      $RPM_BUILD_ROOT%{_rpmlibdir}
 install scripts/php.{prov,req} $RPM_BUILD_ROOT%{_rpmlibdir}
 cp -p %{SOURCE25} $RPM_BUILD_ROOT%{_rpmlibdir}/php.req.php
 install %{SOURCE17} $RPM_BUILD_ROOT%{_rpmlibdir}/mimetypedeps.sh
@@ -1640,8 +1476,9 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 
 %files php-pearprov
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_rpmlibdir}/php*
-%attr(755,root,root) %{_rpmlibdir}/find-php*
+%attr(755,root,root) %{_rpmlibdir}/php.prov
+%attr(755,root,root) %{_rpmlibdir}/php.req
+%attr(755,root,root) %{_rpmlibdir}/php.req.php
 
 %if %{with python}
 %files -n python-rpm
This page took 0.051249 seconds and 4 git commands to generate.