]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm.spec
- rel 1
[packages/rpm.git] / rpm.spec
index f327736d6baf582a0af0a016f62ef5ef1ca67533..7983ca9066ee6e66185f501402c143c6f42806e4 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
 
 # versions of required libraries
 %define                reqdb_pkg       db5.2
-%define                reqdb_ver       5.2.36.0-4
+%define                reqdb_ver       5.2
+%define                reqdb_pkgver    5.2.36.0-4
 %define                reqpopt_ver     1.15
-%define                beecrypt_ver    2:4.1.2-4
+%define                beecrypt_ver    2:4.2.0
 %define                sover           5.4
 
 Summary:       RPM Package Manager
@@ -41,13 +42,13 @@ Summary(pt_BR.UTF-8):       Gerenciador de pacotes RPM
 Summary(ru.UTF-8):     Менеджер пакетов от RPM
 Summary(uk.UTF-8):     Менеджер пакетів від RPM
 Name:          rpm
-Version:       5.4.10
-Release:       53
+Version:       5.4.13
+Release:       1
 License:       LGPL v2.1
 Group:         Base
-# http://rpm5.org/files/rpm/rpm-5.4/rpm-5.4.10-0.20120706.src.rpm
+# http://rpm5.org/files/rpm/rpm-5.4/rpm-5.4.13-0.20130819.src.rpm
 Source0:       %{name}-%{version}.tar.gz
-# Source0-md5: 5d099161bdd3203265ab32ffad3360b5
+# Source0-md5: 4ce4ab33a4d5f1fcb13afcc494c92c07
 Source100:     cpu-os-macros.tar.gz
 # Source100-md5:       928034a5bdceb398881bc14b5f29973b
 Source1:       %{name}.groups
@@ -74,7 +75,6 @@ Source19:     %{name}.noautocompressdoc
 Source20:      %{name}.noautoprov
 Source21:      %{name}.noautoprovfiles
 Source22:      %{name}.noautoreq
-Source23:      %{name}.noautoreqdep
 Source24:      %{name}.noautoreqfiles
 Source25:      %{name}-php-requires.php
 Source26:      %{name}db_checkversion.c
@@ -140,7 +140,6 @@ Patch55:    %{name}-disable-hmac-verify.patch
 Patch56:       %{name}-macros.patch
 Patch57:       %{name}-db5.2.patch
 Patch58:       %{name}-preserve-iterator.patch
-Patch59:       %{name}-triggerin-compat.patch
 Patch60:       %{name}-python-sitescriptdir.patch
 Patch61:       %{name}-clean-docdir.patch
 Patch62:       %{name}-DB_CONFIG.patch
@@ -154,6 +153,10 @@ Patch69:   rubyprov-abi-versioned.patch
 Patch70:       python-%{name}sense-missingok.patch
 Patch71:       %{name}-changelog-encoding.patch
 Patch72:       %{name}-preserve-tag-type.patch
+Patch73:       gem_helper-spec-arg.patch
+Patch74:       rpm-fix-internal-lua-build.patch
+Patch75:       rpm-double_check_file_deps.patch
+Patch76:       rpm-revert-debugedit-breakage.patch
 
 # Patches imported from Mandriva
 
@@ -215,8 +218,6 @@ Patch1022:  %{name}-5.4.5-skip-dependencies-for-character-devices.patch
 Patch1023:     %{name}-5.4.5-rpmfc-use-strlen-not-sizeof.patch
 # status: probably okay to merge
 Patch1024:     %{name}-5.4.5-rpmfc-apply-python-coloring-from-magic.patch
-# status: ready to merge
-Patch1025:     %{name}-5.4.7-rpmfc-fix-invalid-free-if-not-_defaultdocdir-set.patch
 # status: probably okay to merge
 Patch1026:     %{name}-5.4.10-dont-try-generate-rpmfc-dependencies-from-doc-files.patch
 # status: ready
@@ -265,13 +266,19 @@ Patch1040:        %{name}-5.4.9-support-signatures-and-digest-disablers.patch
 Patch1041:     %{name}-5.4.9-disable-l10ndir.patch
 # status: ready for merge
 Patch1042:     %{name}-5.4.9-fix-rpm_qa-pattern.patch
+# warning: introduces memory leak
+Patch1043:     %{name}-5.4.12-copy-Value-string.patch
+Patch1044:     %{name}-5.4.12-fix-rpmlua-print.patch
+Patch1045:     %{name}-5.4.12-fix-rpmpython-module-import-init.patch
+Patch1046:     %{name}-5.4.12-truncate-output-buffer-after-use.patch
+Patch1047:     %{name}-5.4.13-perl-bindings-do-not-use-xmalloc.patch
 
 URL:           http://rpm5.org/
-BuildRequires: %{reqdb_pkg}-devel >= %{reqdb_ver}
+BuildRequires: %{reqdb_pkg}-devel >= %{reqdb_pkgver}
 %if %{with sqlite}
 BuildRequires: sqlite3-devel
 %else
-BuildRequires: %{reqdb_pkg}-sql-devel >= %{reqdb_ver}
+BuildRequires: %{reqdb_pkg}-sql-devel >= %{reqdb_pkgver}
 %endif
 BuildRequires: autoconf >= 2.60
 BuildRequires: automake >= 1.4
@@ -294,7 +301,7 @@ BuildRequires:      libtool >= 1:1.4.2-9
 BuildRequires: libxml2-devel
 BuildRequires: neon-devel >= 0.25.5
 %endif
-%{?with_system_lua:BuildRequires:      lua51-devel >= 5.1.2}
+%{?with_system_lua:BuildRequires:      lua52-devel >= 5.2.2}
 BuildRequires: ossp-uuid-devel
 BuildRequires: patch >= 2.2
 BuildRequires: popt-devel >= %{reqpopt_ver}
@@ -312,7 +319,7 @@ BuildRequires:      tetex-pdftex
 %endif
 %if %{with static}
 # Require static library only for static build
-BuildRequires: %{reqdb_pkg}-static >= %{reqdb_ver}
+BuildRequires: %{reqdb_pkg}-static >= %{reqdb_pkgver}
 BuildRequires: beecrypt-static >= %{beecrypt_ver}
 BuildRequires: bzip2-static >= 1.0.2-17
 BuildRequires: elfutils-static
@@ -433,11 +440,11 @@ Zawiera on:
 Summary:       RPMs library
 Summary(pl.UTF-8):     Biblioteki RPM-a
 Group:         Libraries
-Requires:      %{reqdb_pkg} >= %{reqdb_ver}
+Requires:      %{reqdb_pkg} >= %{reqdb_pkgver}
 %if %{with sqlite}
 Requires:      sqlite3 >= %{sqlite_build_version}
 %else
-Requires:      %{reqdb_pkg}-sql >= %{reqdb_ver}
+Requires:      %{reqdb_pkg}-sql >= %{reqdb_pkgver}
 %endif
 Requires:      beecrypt >= %{beecrypt_ver}
 Requires:      libmagic >= 1.15-2
@@ -463,7 +470,7 @@ Summary(ru.UTF-8):  Хедеры и библиотеки для программ,
 Summary(uk.UTF-8):     Хедери та бібліотеки для програм, що працюють з пакетами rpm
 Group:         Development/Libraries
 Requires:      %{name}-lib = %{version}-%{release}
-Requires:      %{reqdb_pkg}-devel >= %{reqdb_ver}
+Requires:      %{reqdb_pkg}-devel >= %{reqdb_pkgver}
 Requires:      beecrypt-devel >= %{beecrypt_ver}
 Requires:      bzip2-devel
 Requires:      elfutils-devel
@@ -527,7 +534,7 @@ Summary(ru.UTF-8):  Статическая библиотека для прогр
 Summary(uk.UTF-8):     Статична бібліотека для програм, що працюють з пакетами rpm
 Group:         Development/Libraries
 Requires:      %{name}-devel = %{version}-%{release}
-Requires:      %{reqdb_pkg}-static >= %{reqdb_ver}
+Requires:      %{reqdb_pkg}-static >= %{reqdb_pkgver}
 Requires:      beecrypt-static >= %{beecrypt_ver}
 Requires:      bzip2-static
 Requires:      elfutils-static
@@ -759,6 +766,7 @@ Group:              Applications/File
 Requires:      %{name} = %{version}-%{release}
 Requires:      ruby
 Requires:      ruby-modules
+Requires:      ruby-rubygems
 
 %description rubyprov
 Ruby tools, which simplifies creation of RPM packages with Ruby
@@ -879,7 +887,6 @@ Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
 %patch56 -p1
 %patch57 -p1
 %patch58 -p1
-%patch59 -p1
 %patch60 -p1
 %patch61 -p1
 %patch62 -p1
@@ -891,6 +898,10 @@ Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
 %patch70 -p1
 %patch71 -p1
 %patch72 -p1
+%patch73 -p1
+%patch74 -p1
+%patch75 -p1
+%patch76 -p0
 
 %patch1000 -p1
 %patch1001 -p1
@@ -917,7 +928,6 @@ Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
 %patch1022 -p1
 %patch1023 -p1
 %patch1024 -p1
-%patch1025 -p1
 %patch1026 -p1
 %patch1027 -p1
 %patch1028 -p1
@@ -935,6 +945,11 @@ Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
 %patch1040 -p1
 %patch1041 -p1
 %patch1042 -p1
+%patch1043 -p1
+%patch1044 -p1
+%patch1045 -p1
+%patch1046 -p1
+%patch1047 -p1
 %patch68 -p1
 %patch69 -p1
 
@@ -951,6 +966,10 @@ awk -f %{SOURCE6} %{SOURCE1}
 install %{SOURCE26} tools/rpmdb_checkversion.c
 install %{SOURCE28} tools/rpmdb_reset.c
 
+for extlib in beecrypt neon pcre popt; do
+       [ -d $extlib ] && %{__rm} -r $extlib
+done
+
 %build
 %{__libtoolize}
 #%{__autopoint}
@@ -980,7 +999,7 @@ sed -i \
        %{?with_python:--with-python=%{py_ver} --with-python-lib-dir=%{py_sitedir}} \
        %{!?with_python:--without-python} \
        --with-selinux=%{!?with_selinux:no}%{?with_selinux:external} \
-       --with-sepol=%{!?with_selinux:not}%{?with_selinux:external} \
+       --with-sepol=%{!?with_selinux:no}%{?with_selinux:external} \
        --with-semanage=%{!?with_selinux:no}%{?with_selinux:external} \
        --with-libelf \
        --with-zlib=external \
@@ -1031,7 +1050,7 @@ install -d $RPM_BUILD_ROOT{/bin,/%{_lib},/etc/sysconfig,%{_sysconfdir}/rpm} \
 
 install %{SOURCE16} $RPM_BUILD_ROOT%{_sysconfdir}/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
 
-%{__make} install \
+%{__make} -j1 install \
        pkgconfigdir=%{_pkgconfigdir} \
        DESTDIR=$RPM_BUILD_ROOT
 
@@ -1179,7 +1198,6 @@ install %{SOURCE19} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautocompressdoc
 install %{SOURCE20} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprov
 install %{SOURCE21} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprovfiles
 install %{SOURCE22} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreq
-install %{SOURCE23} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqdep
 install %{SOURCE24} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqfiles
 
 touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Conflictname
@@ -1313,6 +1331,32 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 %dir %{_rpmlibdir}/macros.d
 %{_rpmlibdir}/macros.d/pld
 %{_rpmlibdir}/cpuinfo.yaml
+%{_rpmlibdir}/noarch-*
+%ifarch %{ix86}
+%{_rpmlibdir}/i?86*
+%{_rpmlibdir}/pentium*
+%{_rpmlibdir}/athlon*
+%endif
+%ifarch alpha
+%{_rpmlibdir}/alpha*
+%endif
+%ifarch ia64
+%{_rpmlibdir}/ia64*
+%endif
+%ifarch mips mipsel mips64 mips64el
+%{_rpmlibdir}/mips*
+%endif
+%ifarch %{ppc}
+%{_rpmlibdir}/ppc*
+%endif
+%ifarch sparc sparc64
+%{_rpmlibdir}/sparc*
+%endif
+%ifarch %{x8664}
+%{_rpmlibdir}/amd64*
+%{_rpmlibdir}/ia32e*
+%{_rpmlibdir}/x86_64*
+%endif
 
 %attr(755,root,root) %{_rpmlibdir}/hrmib-cache
 
@@ -1435,6 +1479,7 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 %attr(755,root,root) %{_rpmlibdir}/pkgconfigdeps.sh
 %attr(755,root,root) %{_rpmlibdir}/bin/api-sanity-autotest.pl
 %attr(755,root,root) %{_rpmlibdir}/bin/api-sanity-checker.pl
+%{!?with_sqlite:%attr(755,root,root) %{_rpmlibdir}/bin/dbsql}
 %attr(755,root,root) %{_rpmlibdir}/bin/install-sh
 %attr(755,root,root) %{_rpmlibdir}/bin/mkinstalldirs
 %attr(755,root,root) %{_rpmlibdir}/bin/pom2spec
@@ -1442,32 +1487,6 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 %attr(755,root,root) %{_rpmlibdir}/bin/sqlite3
 %attr(755,root,root) %{_rpmlibdir}/bin/wget
 %attr(755,root,root) %{_rpmlibdir}/vcheck
-%{_rpmlibdir}/noarch-*
-%ifarch %{ix86}
-%{_rpmlibdir}/i?86*
-%{_rpmlibdir}/pentium*
-%{_rpmlibdir}/athlon*
-%endif
-%ifarch alpha
-%{_rpmlibdir}/alpha*
-%endif
-%ifarch ia64
-%{_rpmlibdir}/ia64*
-%endif
-%ifarch mips mipsel mips64 mips64el
-%{_rpmlibdir}/mips*
-%endif
-%ifarch %{ppc}
-%{_rpmlibdir}/ppc*
-%endif
-%ifarch sparc sparc64
-%{_rpmlibdir}/sparc*
-%endif
-%ifarch %{x8664}
-%{_rpmlibdir}/amd64*
-%{_rpmlibdir}/ia32e*
-%{_rpmlibdir}/x86_64*
-%endif
 # not used yet ... these six depend on perl
 %attr(755,root,root) %{_rpmlibdir}/http.req
 # we always used scripts provided by mono-devel, maybe move them here
This page took 0.044665 seconds and 4 git commands to generate.