]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm.spec
- mention that rpm requires python-devel to be built
[packages/rpm.git] / rpm.spec
index 9168ac9ea8f885805e688c58be3e8f659f38eff5..66a8e04923ea724557696a55a72e01706482a7f7 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -3,7 +3,7 @@ Summary(de):    Red Hat (und jetzt auch PLD) Packet-Manager
 Summary(pl):   Aplikacja do zarz±dzania pakietami
 Name:          rpm
 Version:       4.0.2
-Release:       28
+Release:       35
 License:       GPL
 Group:         Base
 Group(de):     Gründsätzlich
@@ -35,11 +35,14 @@ Patch11:    %{name}-suggestions.patch
 Patch12:       %{name}-rh-lame.patch
 Patch13:       %{name}-glob.patch
 Patch14:       %{name}-header_h.patch  
-#Patch15:      %{name}-fast-alAddPackage.patch
+Patch15:       %{name}-fast-alAddPackage.patch
 Patch16:       %{name}-byKey.patch
 Patch17:       %{name}-perlprov.patch
 Patch18:       %{name}-noperldir.patch
 Patch19:       popt-cvs20010530.patch
+Patch20:       %{name}-noexpand.patch
+Patch21:       %{name}-scripts-closefds.patch
+Patch22:       %{name}-python-amfix.patch
 Patch37:        %{name}-short_circuit.patch
 Patch38:        %{name}-section_test.patch
 BuildRequires: gettext-devel >= 0.10.38-3
@@ -51,6 +54,7 @@ BuildRequires:        gettext-devel >= 0.10.38-3
 BuildRequires: libtool
 BuildRequires: automake
 BuildRequires: autoconf >= 2.50
+BuildRequires: python-devel
 BuildRequires: python-modules >= 2.2.1
 BuildRequires: zlib-devel >= 1.1.4
 # Require static library only for static build
@@ -66,6 +70,12 @@ Obsoletes:   rpm-libs
 %define __find_provides %{SOURCE4}
 %define _binary_payload w9.gzdio
 %define                __find_provides %{SOURCE4}
+%define python_prefix      %(echo `python -c "import sys; print sys.prefix"`)
+%define python_version     %(echo `python -c "import sys; print sys.version[:3]"`)
+%define python_includedir  %{_includedir}/python%{python_version}
+%define python_libdir      %{python_prefix}/lib/python%{python_version}
+%define python_sitedir     %{python_libdir}/site-packages
+%define                py_dyndir       %{py_libdir}/lib-dynload
 %define                pyrequires_eq() Requires:       %1 >= %py_ver %1 < %(echo `python -c "import sys; import string; ver=sys.version[:3].split('.'); ver[1]=str(int(ver[1])+1); print string.join(ver, '.')"`)
 
 %description
@@ -80,10 +90,10 @@ Installation, Anfrage, Verifizierung, Aktualisierung und
 Uninstallation individueller Softwarepakete. Ein Paket besteht aus
 einem Archiv Dateien und Paketinformation, inklusive Name, Version und
 nombre, versión y descripción.
-RPM jest doskona³ym menad¿erem pakietów. Dziêki niemu bêdziesz móg³
+
 %description -l pl
 RPM jest doskona³ym mened¿erem pakietów. Dziêki niemu bêdziesz móg³
-wchodz±cych w sk³ad pakietu, zale¿no¶ci od innych pakietów s±
+przebudowaæ, zainstalowaæ czy zweryfikowaæ dowolny pakiet. Informacje
 dotycz±ce ka¿dego pakietu, takie jak jego opis, lista plików
 wchodz±cych w sk³ad pakietu, zale¿no¶ci od innych pakietów, s±
 przechowywane w bazie danych i mo¿na je uzyskaæ za pomoc± opcji
@@ -104,13 +114,13 @@ Requires: popt-devel
 The RPM packaging system includes a C library that makes it easy to
 manipulate RPM packages and databases. It is intended to ease the
 creation of graphical package managers and other tools that need
-%description -l de devel
+intimate knowledge of RPM packages.
 
 %description devel -l de
 Der RPM-Packensystem enthält eine C-Library, die macht es einfach
 RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
 Vereinfachung des Schaffens grafischer Paket-Manager und anderer
-%description -l pl devel
+herramientas que necesiten un conocimiento profundo de paquetes RPM.
 Pliki nag³ówkowe i biblioteki statyczne.
 graficznych mened¿erów pakietów oraz innych narzêdzi, które wymagaj±
 ferramentas que precisem de conhecimento profundo de pacotes RPM.
@@ -126,10 +136,10 @@ Group:            Development/Libraries
 Requires:      %{name}-devel = %{version}
 
 %description static
-%description -l de static
+RPM static libraries.
 
 %description static -l de
-%description -l pl static
+RPMs statische Libraries.
 Biblioteki statyczne rpm-a.
 %description static -l pl
 Bibliotecas estáticas para desenvolvimento.
@@ -144,10 +154,10 @@ Group:            Applications/File
 Requires:      %{name} = %{version}
 
 %description utils
-%description -l de utils
+Additional utilities for managing rpm packages and database.
 
 %description utils -l de
-%description -l pl utils
+Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
 Dodatkowe narzêdzia do zarz±dzania baz± rpm-a i pakietami.
 %description utils -l pl
 Dodatkowe narzêdzia do zarz±dzania baz± RPM-a i pakietami.
@@ -164,13 +174,28 @@ Requires: findutils
 
 %description perlprov
 Additional utilities for checking perl provides/requires in rpm
-%description -l de perlprov
+packages.
 
 %description perlprov -l de
-%description -l pl perlprov
+Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
 Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci dla skryptów perl w
 %description perlprov -l pl
 Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów perla w
+%package python
+
+Group:         Development/Languages/Python
+Group(de):     Entwicklung/Sprachen/Python
+Group(pl):     Programowanie/Jêzyki/Python
+Summary(pt_BR):        Módulo Python para aplicativos que manipulam pacotes RPM
+%pyrequires_eq python
+%description python
+
+%description -n python-rpm
+The rpm-python package contains a module which permits applications
+written in the Python programming language to use the interface
+supplied by RPM (RPM Package Manager) libraries.
+
+This package should be installed if you want to develop Python
 Python para manipular pacotes e bancos de dados RPM.
 
 %package build
@@ -193,6 +218,8 @@ Requires:   libtool
 Requires:      glibc-devel
 Requires:      sed
 Requires:      sed
+Requires:      autoconf
+Requires:      automake
 Requires:      popt >= 1.6.2-2
 Requires:      tar
 Requires:      textutils
@@ -205,12 +232,12 @@ Requires: textutils
 Skrypty pomocnicze do budowania binarnych RPMów.
 %description build -l pl
 construir pacotes usando o RPM.
-%setup  -q
+%setup -q
 %prep
 %setup -q -a12
 %patch0 -p1
 %patch1 -p1
-%patch4 -p1 
+%patch2 -p1
 %patch3 -p1
 %patch4 -p1
 %patch5 -p1
@@ -221,26 +248,29 @@ construir pacotes usando o RPM.
 %patch12 -p0
 %patch11 -p0
 %patch12 -p0
-#%patch15 -p0
+%patch15 -p0
 %patch16 -p0
 %patch15 -p0
 %patch16 -p0
 %patch17 -p1
+%patch18 -p1
+%patch19 -p1
+%patch22 -p1
 %patch31 -p1
-install %{SOURCE2} macros.pld.in
+%patch36 -p1
+cp platform.in macros.pld.in
 %patch38 -p1
 sed -e 's/^/@pld@/' %{SOURCE2} >>platform.in
 cp -f platform.in macros.pld.in
 install %{SOURCE9} scripts/find-lang.sh
 install %{SOURCE13} macros.python.in
-(cd scripts; 
+install %{SOURCE6} scripts/find-perl-provides
 install %{SOURCE7} scripts/find-perl-requires
 install %{SOURCE9} scripts/find-lang.sh
 
 (cd scripts;
 mv -f perl.req perl.req.in
 mv -f perl.prov perl.prov.in)
-
 %build
 awk -f %{SOURCE14} %{SOURCE1}
 
@@ -263,9 +293,15 @@ automake -a -c
 sed -e 's#cpio.c depends.c#cpio.c $(DBLIBOBJS) depends.c#g' \
        lib/Makefile.in > lib/Makefile.in.new
 mv -f lib/Makefile.in.new lib/Makefile.in
-%configure \
+
+sed -e 's#python1.5#python%{python_version}#g' \
+       python/Makefile.in > python/Makefile.in.new
+mv -f python/Makefile.in.new python/Makefile.in
+
+sed -e 's|@host@|%{_target_cpu}-%{_target_vendor}-linux-gnu|' macros.in | \
        sed 's|@host_cpu@|%{_target_cpu}|' > macros.tmp
-       --enable-v1-packages
+       --enable-v1-packages \
+       --with-python
 %configure \
        --enable-v1-packages \
        --with-python
@@ -276,7 +312,6 @@ mv -f lib/Makefile.in.new lib/Makefile.in
        DESTDIR="$RPM_BUILD_ROOT" \
 rm -rf $RPM_BUILD_ROOT
 
-install macros.pld $RPM_BUILD_ROOT%{_libdir}/rpm/macros.pld
 %{__make} install \
        pkgbindir="%{_bindir}"
 
@@ -302,7 +337,7 @@ EOF
 
 %find_lang %{name}
 
-%post   -p /sbin/ldconfig
+gzip -9nf RPM-PGP-KEY CHANGES doc/manual/*
 
 %clean
 %clean
@@ -336,29 +371,16 @@ rm -rf $RPM_BUILD_ROOT
 %dir /var/lib/rpm
 %dir %{_libdir}/rpm
 
-%{_libdir}/rpm/macros.pld
 %{_libdir}/rpm/noarch-linux
 %{_libdir}/rpm/noarch-pld-linux
 %ifarch i386 i486 i586 i686
-%{_libdir}/rpm/i386-pld-linux
-%endif
-%ifarch i486 i586 i686
-%{_libdir}/rpm/i486-pld-linux
-%endif
-%ifarch i586 i686
-%{_libdir}/rpm/i586-pld-linux
-%endif
-%ifarch i686
-%{_libdir}/rpm/i686-pld-linux
+%{_libdir}/rpm/rpmpopt*
 %{_libdir}/rpm/noarch-linux
 %{_libdir}/rpm/noarch-pld-linux
-%{_libdir}/rpm/sparc-pld-linux
-%endif
-%ifarch sparc64
-%{_libdir}/rpm/sparc64-pld-linux
+%ifarch i386 i486 i586 i686 athlon
 %{_libdir}/rpm/i?86*
 %{_libdir}/rpm/athlon*
-%{_libdir}/rpm/alpha-pld-linux
+%endif
 %ifarch sparc sparc64
 %endif
 %ifarch ppc
@@ -417,6 +439,10 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/rpm/find-perl-*
 %attr(755,root,root) %{_libdir}/rpm/find-*.perl
 %attr(755,root,root) %{_libdir}/rpm/find-prov.pl
+%files python
+%defattr(644,root,root,755)
+%{python_sitedir}/*.so
+%{_libdir}/rpm/macros.python
 
 %files -n python-rpm
 * %{date} PLD Team <pld-list@pld.org.pl>
This page took 0.461655 seconds and 4 git commands to generate.