]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm.spec
- dwarf-4 debuginfo enabled in rpm-macros.patch, release 53.
[packages/rpm.git] / rpm.spec
index 92fd5853d613077138499d467b44580f1ad146d6..601261386a57985687169b0d5177b36fecf04622 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -12,6 +12,8 @@
 #   preserving payload format and compressor from original rpm, _not_ current settings
 #   /usr/bin/install: cannot stat `./it.gmo': No such file or directory
 #   /usr/bin/install: cannot stat `./sr@Latn.gmo': No such file or directory
+# - maybe? http://rpm.org/gitweb?p=rpm.git;a=commitdiff;h=cfcd1f9bd98d5d0fc46a84931984efec3b9d47e2
+# - fix linking, rpm is beeing linked against installed rpmio
 #
 # Conditional build:
 %bcond_with    static          # build static rpm+rpmi
@@ -55,7 +57,7 @@ Summary(ru.UTF-8):    Менеджер пакетов от RPM
 Summary(uk.UTF-8):     Менеджер пакетів від RPM
 Name:          rpm
 Version:       4.5
-Release:       32
+Release:       53
 License:       LGPL
 Group:         Base
 Source0:       %{name}-%{version}.tar.gz
@@ -100,6 +102,7 @@ Patch12:    %{name}-system_libs.patch
 Patch13:       %{name}-unglobal.patch
 Patch14:       %{name}-etc_dir.patch
 Patch15:       %{name}-system_libs-more.patch
+Patch16:       %{name}-libmagic-locale.patch
 Patch17:       %{name}-ldconfig-always.patch
 Patch18:       %{name}-macros-ac.patch
 Patch19:       %{name}-macros-th.patch
@@ -174,6 +177,11 @@ Patch96:   %{name}-disable-hkp.patch
 Patch97:       %{name}-sigpad.patch
 Patch98:       %{name}-debugdir.patch
 Patch99:       %{name}-pkgconfig.patch
+Patch100:      %{name}-rpm5-debugedit.patch
+Patch101:      %{name}-builddir-readlink.patch
+Patch102:      pythondeps-speedup.patch
+Patch103:      %{name}-lua-exit-chroot-correctly.patch
+Patch104:      %{name}-glob.patch
 URL:           http://rpm5.org/
 BuildRequires: autoconf >= 2.57
 BuildRequires: automake >= 1.4
@@ -333,7 +341,7 @@ Requires:   ossp-uuid >= 1.6.2-4
 Requires:      popt >= %{reqpopt_ver}
 %{?with_internal_db:%{?with_nptl:Requires:     uname(release) >= 2.6.0}}
 Requires:      zlib >= 1.2.3.3
-%{?with_suggest_tags:Suggests: lzma}
+%{?with_suggest_tags:Suggests: xz}
 Obsoletes:     rpm-libs
 # avoid installing with incompatible (non-tukaani) lzma
 # avoid incompatible (-M0 not supported) lzma
@@ -364,6 +372,7 @@ Requires:   elfutils-devel
 Requires:      keyutils-devel
 %{?with_system_libmagic:Requires:      libmagic-devel}
 %{?with_selinux:Requires:      libselinux-devel}
+Requires:      ossp-uuid-devel >= 1.6.2-6
 Requires:      popt-devel >= %{reqpopt_ver}
 Requires:      zlib-devel >= 1.2.3.3
 
@@ -544,13 +553,13 @@ Requires: gcc >= 5:3.4
 Requires:      glibc-devel
 Requires:      grep
 Requires:      gzip
-Requires:      lzma
 Requires:      make
 Requires:      patch
 Requires:      sed
 Requires:      sh-utils
 Requires:      tar
 Requires:      textutils
+Requires:      xz
 Provides:      rpmbuild(monoautodeps)
 Provides:      rpmbuild(noauto) = 3
 %ifarch %{x8664}
@@ -710,6 +719,7 @@ Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
 %patch12 -p1
 %patch13 -p1
 %patch14 -p1
+%patch16 -p1
 %patch17 -p1
 sed -e 's/^/@pld@/' %{SOURCE2} >>platform.in
 echo '%%define __perl_provides %%{__perl} /usr/lib/rpm/perl.prov' > macros.perl
@@ -799,6 +809,11 @@ install %{SOURCE13} scripts/perl.prov
 %patch98 -p1
 %patch99 -p1
 %patch53 -p1
+%patch100 -p1
+%patch101 -p1
+%patch102 -p1
+%patch103 -p1
+%patch104 -p1
 
 mv -f po/{sr,sr@Latn}.po
 rm -rf sqlite zlib popt
@@ -872,7 +887,7 @@ sed -i \
 
 # pass CC and CXX too in case of building with some older configure macro
 # disable perl-RPM2 build, we have it in separate spec
-CPPFLAGS=-I/usr/include/oosp-uuid
+CPPFLAGS="%{rpmcppflags} -I/usr/include/ossp-uuid"
 %configure \
        CC="%{__newcc}" \
        CXX="%{__newcxx}" \
@@ -985,16 +1000,28 @@ s390-[^-]*-[Ll]inux(-gnu)?
 
 %ifarch sparc64
 sparc64-[^-]*-[Ll]inux(-gnu)?
-sparcv8-[^-]*-[Ll]inux(-gnu)?
-sparcv9-[^-]*-[Ll]inux(-gnu)?
 %endif
-%ifarch sparcv9
-sparcv8-[^-]*-[Ll]inux(-gnu)?
+%ifarch sparcv9 sparc64
 sparcv9-[^-]*-[Ll]inux(-gnu)?
 %endif
 %ifarch sparc sparcv9 sparc64
 sparc-[^-]*-[Ll]inux(-gnu)?
 %endif
+%ifarch armv5tel
+armv5tel-[^-]*-[Ll]inux(-gnu)?
+%endif
+%ifarch armv4t armv5tel
+armv4t-[^-]*-[Ll]inux(-gnu)?
+%endif
+%ifarch armv3t armv4t armv5tel
+armv3t-[^-]*-[Ll]inux(-gnu)?
+%endif
+%ifarch armv5teb
+armv5teb-[^-]*-[Ll]inux(-gnu)?
+%endif
+%ifarch armv4b armv5teb
+armv4b-[^-]*-[Ll]inux(-gnu)?
+%endif
 
 # noarch
 noarch-[^-]*-.*
@@ -1006,31 +1033,29 @@ rm $RPM_BUILD_ROOT%{_rpmlibdir}/find-{provides,requires}.perl
 rm $RPM_BUILD_ROOT%{_rpmlibdir}/find-lang.sh
 
 # not installed since 4.4.8 (-tools-perl subpackage)
-install scripts/rpmdiff scripts/rpmdiff.cgi $RPM_BUILD_ROOT%{_rpmlibdir}
-
-install macros.perl    $RPM_BUILD_ROOT%{_rpmlibdir}/macros.perl
-install macros.python  $RPM_BUILD_ROOT%{_rpmlibdir}/macros.python
-install macros.php     $RPM_BUILD_ROOT%{_rpmlibdir}/macros.php
-install macros.mono    $RPM_BUILD_ROOT%{_rpmlibdir}/macros.mono
-install %{SOURCE16}    $RPM_BUILD_ROOT%{_rpmlibdir}/macros.java
-install %{SOURCE19}    $RPM_BUILD_ROOT%{_rpmlibdir}/macros.gstreamer
-
-install %{SOURCE1} doc/manual/groups
-install %{SOURCE3} $RPM_BUILD_ROOT%{_rpmlibdir}/install-build-tree
-install %{SOURCE4} $RPM_BUILD_ROOT%{_rpmlibdir}/find-spec-bcond
-install %{SOURCE7} $RPM_BUILD_ROOT%{_rpmlibdir}/compress-doc
-install %{SOURCE14} $RPM_BUILD_ROOT%{_rpmlibdir}/user_group.sh
-install %{SOURCE17} $RPM_BUILD_ROOT%{_rpmlibdir}/java-find-requires
-install scripts/php.{prov,req} $RPM_BUILD_ROOT%{_rpmlibdir}
-install %{SOURCE5} $RPM_BUILD_ROOT%{_rpmlibdir}/hrmib-cache
-install %{SOURCE15} $RPM_BUILD_ROOT/etc/sysconfig/rpm
-
-install %{SOURCE18} $RPM_BUILD_ROOT%{_bindir}/banner.sh
+install -p scripts/rpmdiff scripts/rpmdiff.cgi $RPM_BUILD_ROOT%{_rpmlibdir}
+
+cp -a macros.perl      $RPM_BUILD_ROOT%{_rpmlibdir}/macros.perl
+cp -a macros.python    $RPM_BUILD_ROOT%{_rpmlibdir}/macros.python
+cp -a macros.php       $RPM_BUILD_ROOT%{_rpmlibdir}/macros.php
+cp -a macros.mono      $RPM_BUILD_ROOT%{_rpmlibdir}/macros.mono
+cp -a %{SOURCE16}      $RPM_BUILD_ROOT%{_rpmlibdir}/macros.java
+cp -a %{SOURCE19}      $RPM_BUILD_ROOT%{_rpmlibdir}/macros.gstreamer
+
+install -p %{SOURCE3} $RPM_BUILD_ROOT%{_rpmlibdir}/install-build-tree
+install -p %{SOURCE4} $RPM_BUILD_ROOT%{_rpmlibdir}/find-spec-bcond
+install -p %{SOURCE7} $RPM_BUILD_ROOT%{_rpmlibdir}/compress-doc
+install -p %{SOURCE14} $RPM_BUILD_ROOT%{_rpmlibdir}/user_group.sh
+install -p %{SOURCE17} $RPM_BUILD_ROOT%{_rpmlibdir}/java-find-requires
+install -p scripts/php.{prov,req}      $RPM_BUILD_ROOT%{_rpmlibdir}
+install -p %{SOURCE5} $RPM_BUILD_ROOT%{_rpmlibdir}/hrmib-cache
+install -p %{SOURCE18} $RPM_BUILD_ROOT%{_bindir}/banner.sh
+cp -a %{SOURCE15} $RPM_BUILD_ROOT/etc/sysconfig/rpm
 
 install -d $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo
 touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Conflictname
 touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Dirnames
-install %{SOURCE12} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Filelinktos
+cp -a %{SOURCE12} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Filelinktos
 touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Obsoletename
 touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Providename
 touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Requirename
@@ -1050,10 +1075,10 @@ cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros <<EOF
 %%_verify_file_context_path    %%{nil}
 
 # If non-zero, all erasures will be automagically repackaged.
-#%%_repackage_all_erasures     1
+#%%_repackage_all_erasures     0
 
 # If non-zero, create debuginfo packages
-#%%_enable_debug_packages      1
+#%%_enable_debug_packages      0
 
 # Boolean (i.e. 1 == "yes", 0 == "no") that controls whether files
 # marked as %doc should be installed.
@@ -1190,6 +1215,7 @@ rm -f $RPM_BUILD_ROOT%{py_sitedir}/rpm/*.{la,a,py}
 
 rm -rf manual
 cp -a doc/manual manual
+cp -a %{SOURCE1} manual/groups
 rm -f manual/Makefile*
 
 %clean
@@ -1212,6 +1238,9 @@ if [ -d /vservers ]; then
        rm -f /etc/vservers/*/apps/pkgmgmt/base/rpm/state/__*
 fi
 echo >&2 "You should rebuild your rpmdb: rpm --rebuilddb to avoid random rpmdb errors"
+%if "%{pld_release}" == "th"
+echo >&2 "You probably want to remove db4.5 package now"
+%endif
 
 %triggerpostun -- %{name} < 4.4.9-44
 %{_rpmlibdir}/hrmib-cache
@@ -1386,6 +1415,9 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 %{_rpmlibdir}/ia32e*
 %{_rpmlibdir}/x86_64*
 %endif
+%ifarch armv5tel armv4t armv3t armv5teb armv4b
+%{_rpmlibdir}/arm*
+%endif
 # must be here for "Requires: rpm-*prov" to work
 %{_rpmlibdir}/macros.gstreamer
 %{_rpmlibdir}/macros.java
This page took 0.133776 seconds and 4 git commands to generate.