]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm.spec
- conflict for automake and libtool versions without amd64 support in rpm-build for...
[packages/rpm.git] / rpm.spec
index ff9fa51c38021bddec84be5adbb41b748f5c21b3..5eeeef40f964be4a3ffa00453e81495fef8096f2 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -2,20 +2,24 @@
 # TODO:
 # - learn find-perl-provides to use the __perl macro instead
 #   of /usr/bin/perl
+#   NOTE: there is no find-perl* now, only perl.{prov,req}
 # - use system libmagic not internal libfmagic
 #
 # Conditional build:
-# _without_static      - build shared /bin/rpm (doesn't work at the moment)
+%bcond_without static  # - build shared /bin/rpm (doesn't work at the moment)
+%bcond_without docs    # - don't generate documentation with doxygen
+%bcond_without python  # - don't build python bindings
 # force_cc             - force using __cc other than "%{_target_cpu}-pld-linux-gcc"
 # force_cxx            - force using __cxx other than "%{_target_cpu}-pld-linux-g++"
 # force_cpp            - force using __cpp other than "%{_target_cpu}-pld-linux-gcc -E"
-#
-%include        /usr/lib/rpm/macros.python
-%define snap   20030515
+
+%include        /usr/%{_lib}/rpm/macros.python
+%define snap   20030610
 # versions of required libraries
-%define        reqdb_ver       4.1.25-1
+%define        reqdb_ver       4.2.50-1
 %define        reqpopt_ver     1.9
-%define        beecrypt_ver    3.0.0
+%define        beecrypt_ver    3.0.0-0.20030610.1
+%define rpm_macros_rev 1.133
 Summary:       RPM Package Manager
 Summary(de):   RPM Packet-Manager
 Summary(es):   Gestor de paquetes RPM
@@ -26,56 +30,75 @@ Summary(uk):        
 Name:          rpm
 %define        ver     4.3
 Version:       %{ver}
-%define        rel     0.4
-Release:       %{rel}
+Release:       0.%{snap}.32
 License:       GPL
 Group:         Base
-Source0:       ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.2.x/%{name}-%{version}.%{snap}.tar.gz
+#Source0:      ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.2.x/%{name}-%{version}.%{snap}.tar.gz
+Source0:       ftp://distfiles.pld-linux.org/src/%{name}-%{version}.%{snap}.tar.gz
+# Source0-md5: f923fe5ca8f0803868ae7bcc0fabe9bb
 Source1:       %{name}.groups
 Source2:       %{name}.platform
 Source3:       %{name}-install-tree
-Source4:       %{name}-find-%{name}-provides
-Source5:       %{name}-macros.perl
-Source8:       %{name}-find-spec-bcond
-Source9:       %{name}-find-lang
-Source10:      %{name}-find-provides
-Source11:      %{name}-find-requires
-Source14:      %{name}-groups-po.awk
-Source15:      %{name}-compress-doc
-Source16:      %{name}-check-files
-Source17:      %{name}-php-provides
-Source18:      %{name}-php-requires
-Source20:      %{name}.macros
+Source4:       %{name}-find-rpm-provides
+Source5:       %{name}-find-spec-bcond
+Source6:       %{name}-find-lang
+Source7:       %{name}-find-provides
+Source8:       %{name}-find-requires
+Source9:       %{name}-groups-po.awk
+Source10:      %{name}-compress-doc
+Source11:      %{name}-check-files
+Source12:      %{name}-php-provides
+Source13:      %{name}-php-requires
+Source14:      %{name}.macros
+Source15:      %{name}-find-provides-wrapper
+Source16:      %{name}-find-requires-wrapper
 Source30:      builder
 Source31:      adapter.awk
 Source32:      pldnotify.awk
 Source33:      perl.prov
 Patch0:                %{name}-pl.po.patch
-Patch1:                %{name}-%{name}rc.patch
+Patch1:                %{name}-rpmrc.patch
 Patch2:                %{name}-arch.patch
-Patch3:                %{name}-%{name}popt.patch
+Patch3:                %{name}-rpmpopt.patch
 Patch4:                %{name}-perl-macros.patch
 Patch5:                %{name}-perl-req-perlfile.patch
-Patch7:                %{name}-glob.patch
-Patch11:       %{name}-noexpand.patch
-Patch12:       %{name}-scripts-closefds.patch
-Patch13:       %{name}-python-macros.patch
-Patch16:       %{name}-drop-legacy-CLI.patch
-Patch18:       %{name}-gettext-in-header.patch
-Patch19:       %{name}-compress-doc.patch
-Patch20:       %{name}-lt14d.patch
-Patch21:       %{name}-gettext0.11.patch
-Patch22:       %{name}-build.patch
-Patch24:       %{name}-system_libs.patch
-Patch25:       %{name}-bb-and-short-circuit.patch
-Patch30:       %{name}-etc_dir.patch
-Patch31:       %{name}-system_libs-more.patch
-Patch32:       %{name}-php-deps.patch
-Patch33:       %{name}-python-fix.patch
-Patch34:       %{name}-spec-prep-pre.patch
-Patch35:       %{name}-perl_req.patch
-Patch36:       %{name}-system_libs_more.patch
-Patch37:       %{name}-python_2_3.patch
+Patch6:                %{name}-glob.patch
+Patch7:                %{name}-noexpand.patch
+Patch8:                %{name}-scripts-closefds.patch
+Patch9:                %{name}-python-macros.patch
+Patch10:       %{name}-gettext-in-header.patch
+Patch11:       %{name}-compress-doc.patch
+Patch12:       %{name}-gettext0.11.patch
+Patch13:       %{name}-build.patch
+Patch14:       %{name}-system_libs.patch
+Patch15:       %{name}-bb-and-short-circuit.patch
+Patch16:       %{name}-etc_dir.patch
+Patch17:       %{name}-system_libs-more.patch
+Patch18:       %{name}-php-deps.patch
+Patch19:       %{name}-python-fix.patch
+Patch20:       %{name}-ldconfig-always.patch
+Patch21:       %{name}-perl_req.patch
+Patch22:       %{name}-system_libs_more.patch
+Patch23:       %{name}-python_2_3.patch
+Patch24:       %{name}-no-bin-env.patch
+Patch25:       %{name}-specflags.patch
+Patch26:       %{name}-magic-usesystem.patch
+Patch27:       %{name}-dontneedutils.patch
+Patch28:       %{name}-python-beecrypt.patch
+Patch29:       %{name}-man-typos.patch
+Patch30:       %{name}-man-pl.patch
+Patch31:       %{name}-fdClose-typo.patch
+Patch32:       %{name}-userpmdepswrappers.patch
+Patch33:       %{name}-provides-dont-obsolete.patch
+Patch34:       %{name}-examplesaredoc.patch
+Patch35:       %{name}-po.patch
+Patch36:       %{name}-amd64.patch
+Patch37:       %{name}-notsc.patch
+Patch38:       %{name}-hack-norpmlibdep.patch
+Patch39:       %{name}-db42.patch
+Patch40:       %{name}-makefile-no_myLDADD_deps.patch
+Patch41:       %{name}-libdir64.patch
+Patch42:       %{name}-no-gnu.patch
 URL:           http://www.rpm.org/
 Icon:          rpm.gif
 BuildRequires: autoconf >= 2.52
@@ -83,19 +106,19 @@ BuildRequires:     automake
 BuildRequires: beecrypt-devel >= %{beecrypt_ver}
 BuildRequires: bzip2-devel >= 1.0.1
 BuildRequires: db-devel >= %{reqdb_ver}
-BuildRequires: doxygen
+%{?with_docs:BuildRequires:    doxygen}
 BuildRequires: gettext-devel >= 0.11.4-2
 BuildRequires: elfutils-devel
 #BuildRequires:        libmagic-devel
 BuildRequires: libtool
 BuildRequires: patch >= 2.2
-BuildRequires: python-devel >= 2.2
+BuildRequires: popt-devel >= %{reqpopt_ver}
+%{?with_python:BuildRequires:  python-devel >= 2.2}
 BuildRequires: python-modules >= 2.2
 BuildRequires: rpm-perlprov
 BuildRequires: rpm-pythonprov
 BuildRequires: zlib-devel
-BuildRequires: popt-devel >= %{reqpopt_ver}
-%if %{!?_without_static:1}0
+%if %{with static}
 # Require static library only for static build
 BuildRequires: beecrypt-static >= %{beecrypt_ver}
 BuildRequires: bzip2-static >= 1.0.2-5
@@ -103,14 +126,19 @@ BuildRequires:    db-static >= %{reqdb_ver}
 BuildRequires: glibc-static >= 2.2.94
 BuildRequires: elfutils-static
 #BuildRequires:        libmagic-static
-BuildRequires: zlib-static
 BuildRequires: popt-static >= %{reqpopt_ver}
+BuildRequires: zlib-static
 %endif
-BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 Requires:      popt >= %{reqpopt_ver}
+Requires:      %{name}-lib = %{version}-%{release}
 Conflicts:     glibc < 2.2.92
+# avoid SEGV caused by mixed db versions
+Conflicts:     poldek < 0.18.1-16
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                __find_provides %{SOURCE4}
+# not needed now (rpm processes rpmlib(*) deps internally) and didn't work
+# anyway (broken: uses obsolete find-provides script, pgrep(??? typo???))
+##define       __find_provides %{SOURCE4}
 %define                _binary_payload w9.gzdio
 %define                _noPayloadPrefix 1
 
@@ -172,15 +200,15 @@ RPM - 
 ¦ÎÆÏÒÍÁæÀ ÐÒÏ ÐÁËÅÔ.
 
 %package devel
-Summary:       Header files and libraries
-Summary(de):   Header-Dateien uns Libraries
+Summary:       Header files for rpm libraries
+Summary(de):   Header-Dateien für rpm Libraries
 Summary(es):   Archivos de inclusión y bibliotecas para programas de manipulación de paquetes rpm
-Summary(pl):   Pliki nag³ówkowe i biblioteki statyczne
+Summary(pl):   Pliki nag³ówkowe bibliotek rpm
 Summary(pt_BR):        Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
 Summary(ru):   èÅÄÅÒÙ É ÂÉÂÌÉÏÔÅËÉ ÄÌÑ ÐÒÏÇÒÁÍÍ, ÒÁÂÏÔÁÀÝÉÈ Ó rpm-ÐÁËÅÔÁÍÉ
 Summary(uk):   èÅÄÅÒÉ ÔÁ Â¦Â̦ÏÔÅËÉ ÄÌÑ ÐÒÏÇÒÁÍ, ÝÏ ÐÒÁÃÀÀÔØ Ú ÐÁËÅÔÁÍÉ rpm
 Group:         Development/Libraries
-Requires:      %{name}-lib = %{version}
+Requires:      %{name}-lib = %{version}-%{release}
 Requires:      beecrypt-devel >= %{beecrypt_ver}
 Requires:      bzip2-devel
 Requires:      db-devel
@@ -189,10 +217,11 @@ Requires: popt-devel >= %{reqpopt_ver}
 Requires:      zlib-devel
 
 %description devel
-The RPM packaging system includes a C library that makes it easy to
-manipulate RPM packages and databases. It is intended to ease the
+The RPM packaging system includes C libraries that make it easy to
+manipulate RPM packages and databases. They are intended to ease the
 creation of graphical package managers and other tools that need
-intimate knowledge of RPM packages.
+intimate knowledge of RPM packages. This package contains header files
+for these libraries.
 
 %description devel -l de
 Der RPM-Packensystem enthält eine C-Library, die macht es einfach
@@ -207,10 +236,11 @@ facilitar la creaci
 herramientas que necesiten un conocimiento profundo de paquetes RPM.
 
 %description devel -l pl
-System RPM zawiera bibliotekê C, która u³atwia manipulowanie pakietami
-RPM oraz bazami danych. W zamiarze ma to upro¶ciæ tworzenie
+System RPM zawiera biblioteki C, które u³atwiaj± manipulowanie
+pakietami RPM oraz bazami danych. W zamiarze ma to upro¶ciæ tworzenie
 graficznych programów zarz±dzaj±cych pakietami oraz innych narzêdzi,
-które wymagaj± szczegó³owej wiedzy na temat pakietów RPM.
+które wymagaj± szczegó³owej wiedzy na temat pakietów RPM. Ten pakiet
+zawiera pliki nag³ówkowe wspomnianych bibliotek.
 
 %description devel -l pt_BR
 O sistema de empacotamento RPM inclui uma biblioteca C que torna fácil
@@ -239,7 +269,7 @@ Summary(pt_BR):     Bibliotecas est
 Summary(ru):   óÔÁÔÉÞÅÓËÁÑ ÂÉÂÌÉÏÔÅËÁ ÄÌÑ ÐÒÏÇÒÁÍÍ, ÒÁÂÏÔÁÀÝÉÈ Ó rpm-ÐÁËÅÔÁÍÉ
 Summary(uk):   óÔÁÔÉÞÎÁ Â¦Â̦ÏÔÅËÁ ÄÌÑ ÐÒÏÇÒÁÍ, ÝÏ ÐÒÁÃÀÀÔØ Ú ÐÁËÅÔÁÍÉ rpm
 Group:         Development/Libraries
-Requires:      %{name}-devel = %{version}
+Requires:      %{name}-devel = %{version}-%{release}
 Requires:      beecrypt-static >= %{beecrypt_ver}
 Requires:      bzip2-static
 Requires:      db-static
@@ -274,7 +304,7 @@ Summary:    Additional utilities for managing rpm packages and database
 Summary(de):   Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
 Summary(pl):   Dodatkowe narzêdzia do zarz±dzania baz± RPM-a i pakietami
 Group:         Applications/File
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{version}-%{release}
 Requires:      popt >= %{reqpopt_ver}
 
 %description utils
@@ -286,12 +316,48 @@ Zusatzwerkzeuge f
 %description utils -l pl
 Dodatkowe narzêdzia do zarz±dzania baz± RPM-a i pakietami.
 
+%package utils-perl
+Summary:       Additional utilities for managing rpm packages and database
+Summary(de):   Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
+Summary(pl):   Dodatkowe narzêdzia do zarz±dzania baz± RPM-a i pakietami
+Group:         Applications/File
+Requires:      %{name}-utils = %{version}-%{release}
+Requires:      popt >= %{reqpopt_ver}
+
+%description utils-perl
+Additional utilities for managing rpm packages and database.
+
+%description utils-perl -l de
+Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
+
+%description utils-perl -l pl
+Dodatkowe narzêdzia do zarz±dzania baz± RPM-a i pakietami.
+
+%package utils-static
+Summary:       Static rpm utilities
+Summary(pl):   Statyczne narzêdzia rpm
+Group:         Applications/System
+Requires:      %{name} = %{version}-%{release}
+
+%description utils-static
+Static rpm utilities for repairing system in case something with
+shared libraries used by rpm become broken. Currently it contains rpmi
+binary, which can be used to install/upgrade/remove packages without
+using shared libraries (well, in fact with exception of NSS modules).
+
+%description utils-static -l pl
+Statyczne narzêdzia rpm do naprawy systemu w przypadku zepsucia czego¶
+zwi±zanego z bibliotekami wspó³dzielonymi u¿ywanymi przez rpm-a.
+Aktualnie pakiet zawiera binarkê rpmi, któr± mo¿na u¿yæ do instalacji,
+uaktualniania lub usuwania pakietów bez udzia³u bibliotek statycznych
+(z wyj±tkiem modu³ów NSS).
+
 %package perlprov
 Summary:       Additional utilities for checking perl provides/requires in rpm packages
 Summary(de):   Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
 Summary(pl):   Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów perla w pakietach rpm
 Group:         Applications/File
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{version}-%{release}
 Requires:      perl-devel
 Requires:      perl-modules
 
@@ -310,7 +376,7 @@ pakietach rpm.
 Summary:       Python macros, which simplifies creation of rpm packages with Python software
 Summary(pl):   Makra u³atwiaj±ce tworzenie pakietów rpm z programami napisanymi w Pythonie
 Group:         Applications/File
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{version}-%{release}
 Requires:      python-modules
 
 %description pythonprov
@@ -325,7 +391,7 @@ Pythonie.
 Summary:       Additional utilities for managing rpm packages and database
 Summary(pl):   Dodatkowe narzêdzia do sprawdzania zale¿no¶ci skryptów php w rpm
 Group:         Applications/File
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{version}-%{release}
 
 %description php-pearprov
 Additional utilities for checking php pear provides/requires in rpm
@@ -340,7 +406,7 @@ Summary:    Python interface to RPM library
 Summary(pl):   Pythonowy interfejs do biblioteki RPM-a
 Summary(pt_BR):        Módulo Python para aplicativos que manipulam pacotes RPM
 Group:         Development/Languages/Python
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{version}-%{release}
 %pyrequires_eq python
 Obsoletes:     rpm-python
 
@@ -373,6 +439,8 @@ Summary(pl):        Biblioteki RPM-a
 Group:         Libraries
 Requires:      db >= %{reqdb_ver}
 Requires:      popt >= %{reqpopt_ver}
+# avoid SEGV caused by mixed db versions
+Conflicts:     poldek < 0.18.1-16
 
 %description lib
 RPMs library.
@@ -389,13 +457,13 @@ Summary(ru):      
 Summary(uk):   óËÒÉÐÔÉ ÔÁ ÕÔÉ̦ÔÉ, ÎÅÏÂȦÄΦ ÄÌÑ ÐÏÂÕÄÏ×É ÐÁËÅÔ¦×
 Group:         Applications/File
 Requires(pre): findutils
-Requires:      %{name} = %{version}
-Requires:      %{name}-utils = %{version}
+Requires:      %{name}-utils = %{version}-%{release}
 Requires:      /bin/id
 Requires:      awk
 Requires:      binutils
+Requires:      chrpath
 Requires:      diffutils
-Requires:      file >= 3.31
+Requires:      file >= 4.01
 Requires:      fileutils
 Requires:      findutils
 %ifarch athlon
@@ -403,6 +471,10 @@ Requires:  gcc >= 3.0.3
 %else
 Requires:      gcc
 %endif
+%ifarch amd64
+Conflicts:     automake < 1:1.7.9-2
+Conflicts:     libtool < 2:1.5-13
+%endif
 Requires:      glibc-devel
 Requires:      grep
 Requires:      gzip
@@ -413,6 +485,7 @@ Requires:   sed
 Requires:      sh-utils
 Requires:      tar
 Requires:      textutils
+Provides:      rpmbuild(macros) = %{rpm_macros_rev}
 
 %description build
 Scripts for building binary RPM packages.
@@ -443,10 +516,10 @@ Summary(pt_BR):   Scripts e programas execut
 Summary(ru):   óËÒÉÐÔÙ É ÕÔÉÌÉÔÙ, ÎÅÏÂÈÏÄÉÍÙÅ ÄÌÑ ÓÂÏÒËÉ ÐÁËÅÔÏ×
 Summary(uk):   óËÒÉÐÔÉ ÔÁ ÕÔÉ̦ÔÉ, ÎÅÏÂȦÄΦ ÄÌÑ ÐÏÂÕÄÏ×É ÐÁËÅÔ¦×
 Group:         Applications/File
-Requires:      %{name}-build = %{version}
+Requires:      %{name}-build = %{version}-%{release}
 # these are optional
 #Requires:     cvs
-#Requires:     wget
+Requires:      wget
 
 %description build-tools
 Scripts for managing .spec files and building RPM packages.
@@ -471,47 +544,60 @@ construir pacotes usando o RPM.
 
 %prep
 %setup -q
-# need update
-#%%patch0 -p1
+%patch0 -p1
 %patch1 -p1
 %patch2 -p1
-# find-spec-bcond need update
-# po/pl.po need update
 %patch3 -p1
 %patch4 -p1
 %patch5 -p1
+%patch6 -p1
 %patch7 -p1
+%patch8 -p1
+%patch9 -p1
+%patch10 -p1
 %patch11 -p1
 %patch12 -p1
 %patch13 -p1
+%patch14 -p1
+%patch15 -p1
 %patch16 -p1
+%patch17 -p1
 %patch18 -p1
 %patch19 -p1
 %patch20 -p1
 %patch21 -p1
 %patch22 -p1
+%patch23 -p1
 %patch24 -p1
+
+sed -e 's/^/@pld@/' %{SOURCE2} >>platform.in
+cp -f platform.in macros.pld.in
+echo '%%define _perl_deps      1' > macros.perl
+echo '# obsoleted file' > macros.python
+echo '%%define _php_deps       1' > macros.php
+install %{SOURCE6} scripts/find-lang.sh
+install %{SOURCE12} scripts/php.prov.in
+install %{SOURCE13} scripts/php.req.in
+install %{SOURCE33} scripts/perl.prov
+cat %{SOURCE14} >> macros.in
 %patch25 -p1
+%patch26 -p1
+%patch27 -p1
+%patch28 -p1
+%patch29 -p1
 %patch30 -p1
 %patch31 -p1
 %patch32 -p1
-%patch33 -p1 -b .wiget
-# patch34 -- look down
+%patch33 -p1
+%patch34 -p1
 %patch35 -p1
 %patch36 -p1
 %patch37 -p1
-
-sed -e 's/^/@pld@/' %{SOURCE2} >>platform.in
-cp -f platform.in macros.pld.in
-echo '# obsoleted file' > macros.perl
-echo '# obsoleted file' > macros.python
-echo '# obsoleted file' > macros.php
-install %{SOURCE9} scripts/find-lang.sh
-install %{SOURCE17} scripts/php.prov.in
-install %{SOURCE18} scripts/php.req.in
-install %{SOURCE33} scripts/perl.prov
-cat %{SOURCE20} >> macros.in
-%patch34 -p1
+%patch38 -p1
+%patch39 -p1
+%patch40 -p1
+%patch41 -p1
+%patch42 -p1
 
 cd scripts;
 mv -f perl.req perl.req.in
@@ -522,7 +608,13 @@ chmod +x %{SOURCE4}
 rm -rf zlib libelf db db3 popt rpmdb/db.h
 
 # generate Group translations to *.po
-awk -f %{SOURCE14} %{SOURCE1}
+awk -f %{SOURCE9} %{SOURCE1}
+
+# update macros paths
+for f in doc{,/ja,/pl}/rpm.8 doc{,/ja,/pl}/rpmbuild.8 ; do
+       sed -e 's@lib/rpm/redhat@lib/rpm/pld@g' $f > ${f}.tmp
+       mv -f ${f}.tmp $f
+done
 
 %build
 cd file
@@ -553,17 +645,18 @@ mv -f macros.tmp macros.in
        CC="%{__cc}" CXX="%{__cxx}" CPP="%{__cpp}" \
        --enable-shared \
        --enable-static \
-       --with-apidocs \
-       --with-python=auto \
+       %{?with_docs:--with-apidocs} \
+       %{?with_python:--with-python=auto} \
+       %{!?with_python:--without-python} \
        --without-db
 
 %{__make} \
-       %{?_without_static:rpm_LDFLAGS="\$(myLDFLAGS)"} \
+       %{!?with_static:rpm_LDFLAGS="\$(myLDFLAGS)"} \
        myLDFLAGS="%{rpmldflags}"
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT/lib
+install -d $RPM_BUILD_ROOT/%{_lib}
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT \
@@ -576,13 +669,18 @@ install macros.php        $RPM_BUILD_ROOT%{_libdir}/rpm/macros.php
 install %{SOURCE1} doc/manual/groups
 install %{SOURCE3} $RPM_BUILD_ROOT%{_libdir}/rpm/install-build-tree
 install %{SOURCE4} $RPM_BUILD_ROOT%{_libdir}/rpm/find-rpm-provides
-install %{SOURCE8} $RPM_BUILD_ROOT%{_libdir}/rpm/find-spec-bcond
-install %{SOURCE10} $RPM_BUILD_ROOT%{_libdir}/rpm/find-provides
-install %{SOURCE11} $RPM_BUILD_ROOT%{_libdir}/rpm/find-requires
-install %{SOURCE15} $RPM_BUILD_ROOT%{_libdir}/rpm/compress-doc
-install %{SOURCE16} $RPM_BUILD_ROOT%{_libdir}/rpm/check-files
-install scripts/find-php*      $RPM_BUILD_ROOT%{_libdir}/rpm/
-install scripts/php.{prov,req} $RPM_BUILD_ROOT%{_libdir}/rpm/
+install %{SOURCE5} $RPM_BUILD_ROOT%{_libdir}/rpm/find-spec-bcond
+# 2 following files - to be removed or changed to find-elf-*
+# (to generate only ELF dependencies using objdump)???
+# WARNING: don't even try to use, currently broken by some 64-bit experiments
+install %{SOURCE7} $RPM_BUILD_ROOT%{_libdir}/rpm/find-provides
+install %{SOURCE8} $RPM_BUILD_ROOT%{_libdir}/rpm/find-requires
+install %{SOURCE10} $RPM_BUILD_ROOT%{_libdir}/rpm/compress-doc
+install %{SOURCE11} $RPM_BUILD_ROOT%{_libdir}/rpm/check-files
+install %{SOURCE15} $RPM_BUILD_ROOT%{_libdir}/rpm/find-provides-wrapper
+install %{SOURCE16} $RPM_BUILD_ROOT%{_libdir}/rpm/find-requires-wrapper
+install scripts/find-php*      $RPM_BUILD_ROOT%{_libdir}/rpm
+install scripts/php.{prov,req} $RPM_BUILD_ROOT%{_libdir}/rpm
 
 install %{SOURCE30} $RPM_BUILD_ROOT%{_bindir}/builder
 install %{SOURCE31} $RPM_BUILD_ROOT%{_bindir}/adapter.awk
@@ -598,15 +696,47 @@ cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros <<EOF
 %%distribution PLD
 EOF
 
+cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprovfiles <<EOF
+# global list of files (name regexps) which don't generate Provides
+EOF
+cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprov <<EOF
+# global list of capabilities (regexps) not to be used in Provides
+EOF
+cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqfiles <<EOF
+# global list of files (name regexps) which don't generate Requires
+/usr/src/examples/.*
+/usr/share/doc/.*
+EOF
+cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreq <<EOF
+# global list of capabilities (regexps) not to be used in Requires
+EOF
+cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqdep <<EOF
+# global list of capabilities (SONAME, perl(module), php(module) regexps)
+# which don't generate dependencies on package NAMES
+libGL.so.1
+libGLU.so.1
+libOSMesa.so.4
+libglide3.so.3
+libgtkmozembed.so
+libgtksuperwin.so
+libxpcom.so
+EOF
+cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautocompressdoc <<EOF
+# global list of file masks not to be compressed in DOCDIR
+EOF
+
 # for rpm -e|-U --repackage
 install -d $RPM_BUILD_ROOT/var/spool/repackage
 
 # move libs to /lib
 for a in librpm-%{ver}.so librpmdb-%{ver}.so librpmio-%{ver}.so ; do
-       mv -f $RPM_BUILD_ROOT/%{_libdir}/$a $RPM_BUILD_ROOT/lib/
-       ln -s /lib/$a $RPM_BUILD_ROOT/%{_libdir}/$a
+       mv -f $RPM_BUILD_ROOT%{_libdir}/$a $RPM_BUILD_ROOT/%{_lib}
+       ln -s /%{_lib}/$a $RPM_BUILD_ROOT%{_libdir}/$a
 done
 
+for f in $RPM_BUILD_ROOT%{_datadir}/locale/{en_RN,eu_ES,gl,hu,ro,wa,zh,zh_CN.GB2312}/LC_MESSAGES/rpm.mo ; do
+       [ "`file $f | sed -e 's/.*,//' -e 's/message.*//'`" -le 1 ] && rm -f $f
+done
 %find_lang %{name}
 
 rm -rf manual
@@ -618,17 +748,19 @@ rm -rf $RPM_BUILD_ROOT
 
 %post  lib -p /sbin/ldconfig
 %postun lib -p /sbin/ldconfig
-%post   -n beecrypt -p /sbin/ldconfig
-%postun -n beecrypt -p /sbin/ldconfig
 
 %pre build
-find /usr/lib/rpm -name '*-linux' -type l | xargs rm -f
+find %{_libdir}/rpm -name '*-linux' -type l | xargs rm -f
 
 %files -f %{name}.lang
 %defattr(644,root,root,755)
 %doc RPM-PGP-KEY CHANGES manual
 
 %attr(755,root,root) /bin/rpm
+#%attr(755,root,root) %{_bindir}/rpmdb
+#%attr(755,root,root) %{_bindir}/rpmquery
+#%attr(755,root,root) %{_bindir}/rpmsign
+#%attr(755,root,root) %{_bindir}/rpmverify
 
 %dir %{_sysconfdir}/rpm
 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/rpm/macros
@@ -644,6 +776,9 @@ find /usr/lib/rpm -name '*-linux' -type l | xargs rm -f
 %dir /var/lib/rpm
 %dir %attr(700,root,root) /var/spool/repackage
 %dir %{_libdir}/rpm
+#%attr(755,root,root) %{_libdir}/rpm/rpmd
+#%attr(755,root,root) %{_libdir}/rpm/rpmk
+#%attr(755,root,root) %{_libdir}/rpm/rpm[qv]
 
 %doc %attr(755,root,root) %{_libdir}/rpm/convertrpmrc.sh
 
@@ -653,15 +788,18 @@ find /usr/lib/rpm -name '*-linux' -type l | xargs rm -f
 
 %files lib
 %defattr(644,root,root,755)
-%attr(755,root,root) /lib/librpm*-*.so
+%attr(755,root,root) /%{_lib}/librpm*-*.so
 %attr(755,root,root) %{_libdir}/librpm*-*.so
 
 %files build
 %defattr(644,root,root,755)
+%config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/rpm/noauto*
 %attr(755,root,root) %{_libdir}/rpm/compress-doc
 %attr(755,root,root) %{_libdir}/rpm/cross-build
-%attr(755,root,root) %{_libdir}/rpm/find-requires
 %attr(755,root,root) %{_libdir}/rpm/find-provides
+%attr(755,root,root) %{_libdir}/rpm/find-provides-wrapper
+%attr(755,root,root) %{_libdir}/rpm/find-requires
+%attr(755,root,root) %{_libdir}/rpm/find-requires-wrapper
 %attr(755,root,root) %{_libdir}/rpm/find-rpm-provides
 %attr(755,root,root) %{_libdir}/rpm/find-spec-bcond
 %attr(755,root,root) %{_libdir}/rpm/find-lang.sh
@@ -676,7 +814,8 @@ find /usr/lib/rpm -name '*-linux' -type l | xargs rm -f
 #%attr(755,root,root) %{_libdir}/rpm/cpanflute2
 #%attr(755,root,root) %{_libdir}/rpm/Specfile.pm
 %attr(755,root,root) %{_libdir}/rpm/http.req
-%attr(755,root,root) %{_libdir}/rpm/magic.*
+%attr(755,root,root) %{_libdir}/rpm/magic.prov
+%attr(755,root,root) %{_libdir}/rpm/magic.req
 %attr(755,root,root) %{_libdir}/rpm/u_pkg.sh
 %attr(755,root,root) %{_libdir}/rpm/vpkg-provides.sh
 %attr(755,root,root) %{_libdir}/rpm/vpkg-provides2.sh
@@ -696,6 +835,9 @@ find /usr/lib/rpm -name '*-linux' -type l | xargs rm -f
 %ifarch ppc
 %{_libdir}/rpm/ppc*
 %endif
+# must be here for "Requires: rpm-*prov" to work
+%{_libdir}/rpm/macros.perl
+%{_libdir}/rpm/macros.php
 # not used yet ...
 %{_libdir}/rpm/sql.prov
 %{_libdir}/rpm/sql.req
@@ -706,8 +848,11 @@ find /usr/lib/rpm -name '*-linux' -type l | xargs rm -f
 %attr(755,root,root) %{_bindir}/gendiff
 %attr(755,root,root) %{_bindir}/rpmbuild
 
-%{_mandir}/man1/*
+%{_mandir}/man1/gendiff.1*
 %{_mandir}/man8/rpmbuild.8*
+%lang(ja) %{_mandir}/ja/man8/rpmbuild.8*
+%lang(pl) %{_mandir}/pl/man1/gendiff.1*
+%lang(pl) %{_mandir}/pl/man8/rpmbuild.8*
 
 %files devel
 %defattr(644,root,root,755)
@@ -730,33 +875,37 @@ find /usr/lib/rpm -name '*-linux' -type l | xargs rm -f
 %attr(755,root,root) %{_bindir}/rpmdeps
 %attr(755,root,root) %{_bindir}/rpmgraph
 %attr(755,root,root) %{_bindir}/rpmfile
-#%attr(755,root,root) %{_bindir}/striptofile
-#%attr(755,root,root) %{_bindir}/unstripfile
 %attr(755,root,root) %{_libdir}/rpm/find-debuginfo.sh
 %attr(755,root,root) %{_libdir}/rpm/rpm2cpio.sh
-%attr(755,root,root) %{_libdir}/rpm/rpmd
-%attr(755,root,root) %{_libdir}/rpm/rpmdiff*
-%attr(755,root,root) %{_libdir}/rpm/rpmi
-%attr(755,root,root) %{_libdir}/rpm/rpmk
-%attr(755,root,root) %{_libdir}/rpm/rpmq
-%attr(755,root,root) %{_libdir}/rpm/rpmv
 %attr(755,root,root) %{_libdir}/rpm/tgpg
 %attr(755,root,root) %{_libdir}/rpm/rpmdb_loadcvt
-%{_libdir}/rpm/magic
 
+%files utils-perl
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/rpm/rpmdiff*
 # not here
 #%%{_libdir}/rpm/rpm.daily
 #%%{_libdir}/rpm/rpm.log
 #%%{_libdir}/rpm/rpm.xinetd
 
 %{_mandir}/man8/rpm2cpio.8*
+%{_mandir}/man8/rpmdeps.8*
+%{_mandir}/man8/rpmcache.8*
+%{_mandir}/man8/rpmgraph.8*
 %lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
+%lang(ja) %{_mandir}/ja/man8/rpmcache.8*
+%lang(ja) %{_mandir}/ja/man8/rpmgraph.8*
 %lang(ko) %{_mandir}/ko/man8/rpm2cpio.8*
 %lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
+%lang(pl) %{_mandir}/pl/man8/rpmdeps.8*
+%lang(pl) %{_mandir}/pl/man8/rpmcache.8*
+%lang(pl) %{_mandir}/pl/man8/rpmgraph.8*
 %lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
-%{_mandir}/man8/rpmdeps.8*
-%{_mandir}/man8/rpmcache.8*
-%{_mandir}/man8/rpmgraph.8*
+
+%files utils-static
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/rpm[ieu]
+%attr(755,root,root) %{_libdir}/rpm/rpm[ieu]
 
 %files perlprov
 %defattr(644,root,root,755)
@@ -768,8 +917,6 @@ find /usr/lib/rpm -name '*-linux' -type l | xargs rm -f
 %attr(755,root,root) %{_libdir}/rpm/find-req.pl
 %attr(755,root,root) %{_libdir}/rpm/get_magic.pl
 
-%{_libdir}/rpm/macros.perl
-
 %files pythonprov
 %defattr(644,root,root,755)
 %{_libdir}/rpm/macros.python
@@ -778,13 +925,14 @@ find /usr/lib/rpm -name '*-linux' -type l | xargs rm -f
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/rpm/php*
 %attr(755,root,root) %{_libdir}/rpm/find-php*
-%{_libdir}/rpm/macros.php
 
+%if %{with python}
 %files -n python-rpm
 %defattr(644,root,root,755)
 %attr(755,root,root) %{py_sitedir}/*.so
 %attr(755,root,root) %{py_sitedir}/rpmdb/*.so
 %{py_sitedir}/rpmdb/*.py*
+%endif
 
 %files build-tools
 %defattr(644,root,root,755)
This page took 0.216589 seconds and 4 git commands to generate.