]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm.spec
- added short_circuit patch
[packages/rpm.git] / rpm.spec
index 99d4e46980d756b0f2f3d82f918bfdfb741059ea..58fe2ae0ab9c3e9adb277400485ccf341d3b4a37 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -7,7 +7,7 @@ Summary(pl):    Aplikacja do zarz
 Summary(pt_BR):        Gerenciador de pacotes RPM
 Name:          rpm
 Version:       4.0.2
-Release:       60
+Release:       72
 License:       GPL
 Group:         Base
 Source0:       ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.0.x/%{name}-%{version}.tar.gz
@@ -24,6 +24,8 @@ Source10:     %{name}-find-provides
 Source11:      %{name}-find-requires
 Source12:      %{name}-non-english-man-pages.tar.bz2
 Source13:      %{name}-macros.python
+Source14:      %{name}-groups-po.awk
+Source15:      %{name}-compress-doc
 Patch0:                %{name}-rpmrc.patch
 Patch1:                %{name}-macros.patch
 Patch2:                %{name}-arch.patch
@@ -58,7 +60,9 @@ Patch30:      %{name}-athlon.patch
 Patch31:       %{name}-athlon-identify.patch
 Patch32:       %{name}-gettext-in-header.patch
 Patch33:       %{name}-perlprov-perl5.6.patch
-Patch34:       %{name}-groups-po.patch
+Patch34:       %{name}-ac25x.patch
+Patch35:        %{name}-signverify-fix.patch
+Patch36:        %{name}-compress-doc.patch
 Patch37:        %{name}-short_circuit.patch
 Patch38:        %{name}-section_test.patch
 URL:           http://www.rpm.org/
@@ -69,8 +73,8 @@ BuildRequires:        bzip2-devel >= 1.0.1
 BuildRequires: db1-devel >= 1.85
 BuildRequires: db3-devel >= 3.1.17-9
 BuildRequires: gettext-devel >= 0.10.38-3
-BuildRequires: python-devel >= 2.2
-BuildRequires: python-modules >= 2.2
+BuildRequires: libtool
+BuildRequires: patch >= 2.2
 BuildRequires: python-devel >= 2.2.1
 BuildRequires: python-modules >= 2.2.1
 BuildRequires: zlib-devel >= 1.1.4
@@ -92,6 +96,7 @@ Conflicts:    glibc < 2.2
 %define                py_ver          %(echo `python -c "import sys; print sys.version[:3]"`)
 %define                py_prefix       %(echo `python -c "import sys; print sys.prefix"`)
 %define                py_libdir       %{py_prefix}/lib/python%{py_ver}
+%define                py_sitedir      %{py_libdir}/site-packages
 %define                py_dyndir       %{py_libdir}/lib-dynload
 %define                pyrequires_eq() Requires:       %1 >= %py_ver %1 < %(echo `python -c "import sys; import string; ver=sys.version[:3].split('.'); ver[1]=str(int(ver[1])+1); print string.join(ver, '.')"`)
 
@@ -245,7 +250,7 @@ Pythonie.
 Summary:       Python interface to RPM library
 Summary(pl):   Pythonowy interfejs do biblioteki RPM-a
 Summary(pt_BR):        Módulo Python para aplicativos que manipulam pacotes RPM
-%requires_eq   python
+Group:         Libraries/Python
 Requires:      %{name} = %{version}
 %pyrequires_eq python
 Obsoletes:     rpm-python
@@ -291,6 +296,7 @@ Requires:   findutils
 Requires:      gcc >= 3.0.3
 %else
 Requires:      gcc
+%endif
 Requires:      glibc-devel
 Requires:      grep
 Requires:      gzip
@@ -354,6 +360,8 @@ construir pacotes usando o RPM.
 %endif
 
 %patch32 -p1
+%patch33 -p1
+%patch34 -p1
 %patch35 -p1
 %patch36 -p1
 %patch37 -p1
@@ -370,27 +378,30 @@ install %{SOURCE9} scripts/find-lang.sh
 (cd scripts;
 mv -f perl.req perl.req.in
 mv -f perl.prov perl.prov.in)
+
+chmod +x %{SOURCE4}
+
 %build
 # generate Group translations to *.po
 awk -f %{SOURCE14} %{SOURCE1}
 
 cd popt
-autoconf
-automake -a -c -f
+rm -f missing
+libtoolize --force --copy
 aclocal
 autoheader
-automake -a -c -f
+%{__autoconf}
 %{__automake}
 cd ..
 
 rm -f missing
 libtoolize --force --copy
-autoconf
+gettextize --copy --force
 aclocal
 autoupdate
 autoheader || :
 %{__autoconf}
-automake -a -c -f
+# ugly workaround for automake
 sed -e 's#cpio.c $(DBLIBOBJS) depends.c#cpio.c depends.c#g' \
        lib/Makefile.am > lib/Makefile.am.new
 mv -f lib/Makefile.am.new lib/Makefile.am
@@ -429,6 +440,7 @@ install macros.python $RPM_BUILD_ROOT%{_libdir}/rpm/macros.python
 
 install %{SOURCE1} doc/manual/groups
 install %{SOURCE3} $RPM_BUILD_ROOT%{_libdir}/rpm/install-build-tree
+install %{SOURCE4} $RPM_BUILD_ROOT%{_libdir}/rpm/find-rpm-provides
 install %{SOURCE8} $RPM_BUILD_ROOT%{_libdir}/rpm/find-spec-bcond
 install %{SOURCE10} $RPM_BUILD_ROOT%{_libdir}/rpm/find-provides
 install %{SOURCE11} $RPM_BUILD_ROOT%{_libdir}/rpm/find-requires
@@ -486,7 +498,6 @@ rm -rf $RPM_BUILD_ROOT
 %dir /var/lib/rpm
 %dir %{_libdir}/rpm
 
-%{_libdir}/rpm/macros.python
 %doc %attr(755,root,root) %{_libdir}/rpm/convertrpmrc.sh
 
 %{_libdir}/rpm/rpmrc
@@ -521,6 +532,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/rpm/find-spec-bcond
 %attr(755,root,root) %{_libdir}/rpm/find-lang.sh
 %attr(755,root,root) %{_libdir}/rpm/mkinstalldirs
+%attr(755,root,root) %{_libdir}/rpm/config.*
 %attr(755,root,root) %{_libdir}/rpm/getpo.sh
 %attr(755,root,root) %{_libdir}/rpm/install-build-tree
 %attr(755,root,root) %{_libdir}/rpm/brp-*
This page took 0.103554 seconds and 4 git commands to generate.