]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm.spec
make -lib depend on elfutils-libs instead of elfutils; rel 7
[packages/rpm.git] / rpm.spec
index d46290ccafa9eb5f5e87d43b3e66a07d4ce7d05d..4ebca67171db31f2dc25967808a5c42105df38b3 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -14,7 +14,7 @@
 %bcond_without fsverity        # fsverity plugin
 
 %define                popt_ver        1.15
-%define                sover           9.2.0
+%define                sover           9.3.0
 
 %if "%{_rpmversion}" >= "4.12" && "%{_rpmversion}" < "5"
 %define        with_recommends_tags    1
@@ -33,13 +33,13 @@ Summary(pt_BR.UTF-8):       Gerenciador de pacotes RPM
 Summary(ru.UTF-8):     Менеджер пакетов от RPM
 Summary(uk.UTF-8):     Менеджер пакетів від RPM
 Name:          rpm
-Version:       4.17.0
-Release:       0.1
+Version:       4.17.1.1
+Release:       7
 Epoch:         1
 License:       GPL v2 / LGPL v2.1
 Group:         Base
 Source0:       http://ftp.rpm.org/releases/rpm-4.17.x/%{name}-%{version}.tar.bz2
-# Source0-md5: ba23b5d2403fd2f9163dfd0dadce1820
+# Source0-md5: 30e5806bdcb06a17cabf23d8f07b6b0f
 Source1:       ftp://ftp.pld-linux.org/dists/th/PLD-3.0-Th-GPG-key.asc
 # Source1-md5: 23914bb49fafe7153cee87126d966461
 Source2:       macros.local
@@ -92,6 +92,10 @@ Patch32:     noexpand.patch
 Patch34:       skip-symlinks.patch
 Patch35:       pl-po.patch
 Patch36:       build-locale.patch
+Patch37:       no-exe-for-elf-req.patch
+Patch38:       gem-in-package-builddir.patch
+Patch39:       sqlite-log-crash.patch
+Patch40:       perl-heredoc-matching.patch
 URL:           https://rpm.org/
 BuildRequires: acl-devel
 %{?with_audit:BuildRequires:   audit-libs-devel}
@@ -99,8 +103,7 @@ BuildRequires:       autoconf >= 2.63
 BuildRequires: automake >= 1:1.10
 BuildRequires: bzip2-devel >= 1.0.2-17
 %{?with_plugins:BuildRequires: dbus-devel >= 1.3}
-BuildRequires: elfutils-devel >= 0.108
-%{?with_fsverity:BuildRequires:        fsverity-utils-devel}
+BuildRequires: elfutils-devel >= 0.159
 BuildRequires: gettext-tools >= 0.19.2
 %{?with_imaevm:BuildRequires:  ima-evm-utils-devel >= 1.0}
 BuildRequires: libarchive-devel
@@ -112,7 +115,7 @@ BuildRequires:      libmagic-devel
 # needed only for AM_PROG_CXX used for CXX substitution in rpm.macros
 BuildRequires: libstdc++-devel
 BuildRequires: libtool >= 1:1.4.2-9
-BuildRequires: lua-devel >= 5.2
+BuildRequires: lua-devel >= 5.3
 BuildRequires: patch >= 2.2
 BuildRequires: pkgconfig
 BuildRequires: popt-devel >= %{popt_ver}
@@ -126,8 +129,8 @@ BuildRequires:      rpm-build >= 4.6
 BuildRequires: sqlite3-devel >= 3.22.0
 BuildRequires: tcl
 BuildRequires: xz-devel
-BuildRequires: zlib-devel
-BuildRequires: zstd-devel
+BuildRequires: zlib-devel >= 1.0.5
+BuildRequires: zstd-devel >= 1.3.8
 %if %{with apidocs}
 BuildRequires: doxygen
 BuildRequires: ghostscript
@@ -241,9 +244,12 @@ Zawiera on:
 Summary:       RPMs library
 Summary(pl.UTF-8):     Biblioteki RPM-a
 Group:         Libraries
+Requires:      elfutils-libs >= 0.159
 Requires:      libmagic >= 1.15-2
 Requires:      popt >= %{popt_ver}
 Requires:      sqlite3-libs >= 3.22.0
+Requires:      zlib >= 1.0.5
+Requires:      zstd >= 1.3.8
 Obsoletes:     rpm-libs < 4.0.2-4
 # avoid SEGV caused by mixed db versions
 Conflicts:     poldek < 0.18.1-16
@@ -264,17 +270,25 @@ Summary(ru.UTF-8):        Хедеры и библиотеки для программ,
 Summary(uk.UTF-8):     Хедери та бібліотеки для програм, що працюють з пакетами rpm
 Group:         Development/Libraries
 Requires:      %{name}-lib = %{epoch}:%{version}-%{release}
+Requires:      acl-devel
+%{?with_audit:Requires:        audit-libs-devel}
 Requires:      bzip2-devel
-Requires:      elfutils-devel
+Requires:      elfutils-devel >= 0.159
+Requires:      libcap-devel
 Requires:      libgcrypt-devel
+Requires:      libgomp-devel >= 6:4.5
 Requires:      libmagic-devel
 %if %{with selinux}
 Requires:      libselinux-devel
 Requires:      libsemanage-devel
 Requires:      libsepol-devel
 %endif
+Requires:      lua-devel >= 5.3
 Requires:      popt-devel >= %{popt_ver}
-Requires:      zlib-devel
+Requires:      sqlite3-devel >= 3.22.0
+Requires:      xz-devel
+Requires:      zlib-devel >= 1.0.5
+Requires:      zstd-devel >= 1.3.8
 Obsoletes:     rpm-static < 1:4.15
 
 %description devel
@@ -360,6 +374,7 @@ Requires:   awk
 Requires:      bzip2
 Requires:      chrpath >= 0.10-4
 Requires:      cpio
+Requires:      debugedit
 Requires:      diffutils
 Requires:      elfutils
 Requires:      file >= 4.17
@@ -430,23 +445,6 @@ Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
 Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w
 pakietach RPM.
 
-%package pythonprov
-Summary:       Python macros, which simplifies creation of RPM packages with Python software
-Summary(pl.UTF-8):     Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w Pythonie
-Group:         Applications/File
-Requires:      %{name} = %{epoch}:%{version}-%{release}
-Requires:      python3
-Requires:      python3-modules
-Requires:      python3-setuptools
-
-%description pythonprov
-Python macros, which simplifies creation of RPM packages with Python
-software.
-
-%description pythonprov -l pl.UTF-8
-Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w
-Pythonie.
-
 %package -n python3-rpm
 Summary:       Python 3 interface to RPM library
 Summary(pl.UTF-8):     Interfejs Pythona 3 do biblioteki RPM-a
@@ -566,14 +564,19 @@ Wtyczka do funkcjonalności SELinux.
 
 %package plugin-fsverity
 Summary:       Plugin for fsverity file signatures
+Summary(pl.UTF-8):     Wtyczka do sygnatur plików fsverity
 Group:         Base
 Requires:      %{name}-lib = %{epoch}:%{version}-%{release}
 
 %description plugin-fsverity
 Plugin for fsverity file signatures.
 
+%description plugin-fsverity -l pl.UTF-8
+Wtyczka do sygnatur plików fsverity.
+
 %package plugin-fapolicyd
 Summary:       Plugin for fapolicyd support
+Summary(pl.UTF-8):     Wtyczka do obsługi fapolicyd
 Group:         Base
 Requires:      %{name}-lib = %{epoch}:%{version}-%{release}
 
@@ -583,8 +586,15 @@ Plugin for fapolicyd support.
 See https://people.redhat.com/sgrubb/fapolicyd/ for information about
 the fapolicyd daemon.
 
+%description plugin-fapolicyd -l pl.UTF-8
+Wtyczka do obsługi fapolicyd.
+
+Informacje na temat demona fapolicyd można znaleźć pod adresem
+<https://people.redhat.com/sgrubb/fapolicyd/>.
+
 %package plugin-dbus-announce
 Summary:       Plugin for announcing transactions on the DBUS
+Summary(pl.UTF-8):     Wtyczka ogłaszająca transakcje przez DBUS
 Group:         Base
 Requires:      %{name}-lib = %{epoch}:%{version}-%{release}
 
@@ -594,6 +604,12 @@ system DBUS - like packages installed or removed. Other programs can
 subscribe to the signals to get notified when packages on the system
 change.
 
+%description plugin-dbus-announce -l pl.UTF-8
+Ta wtyczka ogłasza przez podstawowe szynę systemową DBUS informacje o
+transakcjach RPM-a, takie jak pakiety, które są instalowane lub
+usuwane. Inne programy mogą zasubskrybować sygnały powiadamiające o
+zmianach w pakietach systemowych.
+
 %package sign
 Summary:       Package signing support
 Summary(pl.UTF-8):     Obsługa podpisywania pakietów
@@ -656,6 +672,10 @@ Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
 %patch34 -p1
 %patch35 -p1
 %patch36 -p1
+%patch37 -p1
+%patch38 -p1
+%patch39 -p1
+%patch40 -p1
 
 %{__rm} po/*.gmo
 
@@ -666,8 +686,6 @@ install %{SOURCE15} scripts/perl.prov.in
 # generate Group translations to *.po
 awk -f %{SOURCE6} %{SOURCE5}
 
-#%{__sed} -i -e '1s,/usr/bin/python,%{__python3},' scripts/pythondistdeps.py
-
 %build
 %{__libtoolize}
 %{__aclocal}
@@ -687,7 +705,6 @@ awk -f %{SOURCE6} %{SOURCE5}
        WITH_PERL_VERSION=no \
        __GST_INSPECT=%{_bindir}/gst-inspect-1.0 \
        __GPG=%{_bindir}/gpg \
-       --enable-bdb \
        --enable-bdb-ro \
        --enable-ndb \
        %{!?with_plugins:--disable-plugins} \
@@ -701,7 +718,6 @@ awk -f %{SOURCE6} %{SOURCE5}
        --with-cap \
        --with-fapolicyd \
        %{?with_imaevm:--with-imaevm} \
-       --with-lua \
        %{?with_python3:--enable-python} \
        --with-selinux%{!?with_selinux:=no} \
        --with-vendor=pld
@@ -1024,19 +1040,7 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 # needs hacked pkg-config to return anything
 %attr(755,root,root) %{_rpmlibdir}/pkgconfigdeps.sh
 %attr(755,root,root) %{_rpmlibdir}/mkinstalldirs
-
 %attr(755,root,root) %{_rpmlibdir}/fontconfig.prov
-# must be here for "Requires: rpm-*prov" to work
-#%{_rpmlibdir}/macros.d/cmake
-#%{_rpmlibdir}/macros.d/gstreamer
-#%{_rpmlibdir}/macros.d/libtool
-#%{_rpmlibdir}/macros.d/perl
-#%{_rpmlibdir}/macros.d/pkgconfig
-#%{_rpmlibdir}/macros.d/python
-#%{_rpmlibdir}/macros.d/selinux
-#%{_rpmlibdir}/macros.d/tcl
-#%{_rpmlibdir}/macros.rpmbuild
-
 %attr(755,root,root) %{_rpmlibdir}/check-buildroot
 %attr(755,root,root) %{_rpmlibdir}/check-prereqs
 %attr(755,root,root) %{_rpmlibdir}/check-rpaths
@@ -1054,8 +1058,6 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 %{_rpmlibdir}/fileattrs/libtool.attr
 %{_rpmlibdir}/fileattrs/metainfo.attr
 %{_rpmlibdir}/fileattrs/ocaml.attr
-%{_rpmlibdir}/fileattrs/perl.attr
-%{_rpmlibdir}/fileattrs/perllib.attr
 %{_rpmlibdir}/fileattrs/pkgconfig.attr
 %{_rpmlibdir}/fileattrs/script.attr
 
@@ -1072,12 +1074,10 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 
 %files perlprov
 %defattr(644,root,root,755)
+%{_rpmlibdir}/fileattrs/perl.attr
+%{_rpmlibdir}/fileattrs/perllib.attr
 %attr(755,root,root) %{_rpmlibdir}/perl.*
 
-%files pythonprov
-%defattr(644,root,root,755)
-#%attr(755,root,root) %{_rpmlibdir}/pythondistdeps.py
-
 %if %{with python3}
 %files -n python3-rpm
 %defattr(644,root,root,755)
@@ -1132,12 +1132,14 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 %attr(755,root,root) %{_libdir}/rpm-plugins/fapolicyd.so
 %{_mandir}/man8/rpm-plugin-fapolicyd.8*
 
+%if %{with systemd}
 %files plugin-dbus-announce
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/rpm-plugins/dbus_announce.so
 %{_mandir}/man8/rpm-plugin-dbus-announce.8*
 %{_sysconfdir}/dbus-1/system.d/org.rpm.conf
 %endif
+%endif
 
 %files sign
 %defattr(644,root,root,755)
This page took 0.06046 seconds and 4 git commands to generate.