]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm.spec
make -lib depend on elfutils-libs instead of elfutils; rel 7
[packages/rpm.git] / rpm.spec
index 060b5c5618ae979c555080c52610c821963255d5..4ebca67171db31f2dc25967808a5c42105df38b3 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -14,7 +14,7 @@
 %bcond_without fsverity        # fsverity plugin
 
 %define                popt_ver        1.15
-%define                sover           9.2.0
+%define                sover           9.3.0
 
 %if "%{_rpmversion}" >= "4.12" && "%{_rpmversion}" < "5"
 %define        with_recommends_tags    1
@@ -33,13 +33,13 @@ Summary(pt_BR.UTF-8):       Gerenciador de pacotes RPM
 Summary(ru.UTF-8):     Менеджер пакетов от RPM
 Summary(uk.UTF-8):     Менеджер пакетів від RPM
 Name:          rpm
-Version:       4.17.0
-Release:       4
+Version:       4.17.1.1
+Release:       7
 Epoch:         1
 License:       GPL v2 / LGPL v2.1
 Group:         Base
 Source0:       http://ftp.rpm.org/releases/rpm-4.17.x/%{name}-%{version}.tar.bz2
-# Source0-md5: ba23b5d2403fd2f9163dfd0dadce1820
+# Source0-md5: 30e5806bdcb06a17cabf23d8f07b6b0f
 Source1:       ftp://ftp.pld-linux.org/dists/th/PLD-3.0-Th-GPG-key.asc
 # Source1-md5: 23914bb49fafe7153cee87126d966461
 Source2:       macros.local
@@ -94,6 +94,8 @@ Patch35:      pl-po.patch
 Patch36:       build-locale.patch
 Patch37:       no-exe-for-elf-req.patch
 Patch38:       gem-in-package-builddir.patch
+Patch39:       sqlite-log-crash.patch
+Patch40:       perl-heredoc-matching.patch
 URL:           https://rpm.org/
 BuildRequires: acl-devel
 %{?with_audit:BuildRequires:   audit-libs-devel}
@@ -242,8 +244,7 @@ Zawiera on:
 Summary:       RPMs library
 Summary(pl.UTF-8):     Biblioteki RPM-a
 Group:         Libraries
-Requires:      elfutils >= 0.159
-Requires:      elfutils-libelf >= 0.159
+Requires:      elfutils-libs >= 0.159
 Requires:      libmagic >= 1.15-2
 Requires:      popt >= %{popt_ver}
 Requires:      sqlite3-libs >= 3.22.0
@@ -275,6 +276,7 @@ Requires:   bzip2-devel
 Requires:      elfutils-devel >= 0.159
 Requires:      libcap-devel
 Requires:      libgcrypt-devel
+Requires:      libgomp-devel >= 6:4.5
 Requires:      libmagic-devel
 %if %{with selinux}
 Requires:      libselinux-devel
@@ -562,14 +564,19 @@ Wtyczka do funkcjonalności SELinux.
 
 %package plugin-fsverity
 Summary:       Plugin for fsverity file signatures
+Summary(pl.UTF-8):     Wtyczka do sygnatur plików fsverity
 Group:         Base
 Requires:      %{name}-lib = %{epoch}:%{version}-%{release}
 
 %description plugin-fsverity
 Plugin for fsverity file signatures.
 
+%description plugin-fsverity -l pl.UTF-8
+Wtyczka do sygnatur plików fsverity.
+
 %package plugin-fapolicyd
 Summary:       Plugin for fapolicyd support
+Summary(pl.UTF-8):     Wtyczka do obsługi fapolicyd
 Group:         Base
 Requires:      %{name}-lib = %{epoch}:%{version}-%{release}
 
@@ -579,8 +586,15 @@ Plugin for fapolicyd support.
 See https://people.redhat.com/sgrubb/fapolicyd/ for information about
 the fapolicyd daemon.
 
+%description plugin-fapolicyd -l pl.UTF-8
+Wtyczka do obsługi fapolicyd.
+
+Informacje na temat demona fapolicyd można znaleźć pod adresem
+<https://people.redhat.com/sgrubb/fapolicyd/>.
+
 %package plugin-dbus-announce
 Summary:       Plugin for announcing transactions on the DBUS
+Summary(pl.UTF-8):     Wtyczka ogłaszająca transakcje przez DBUS
 Group:         Base
 Requires:      %{name}-lib = %{epoch}:%{version}-%{release}
 
@@ -590,6 +604,12 @@ system DBUS - like packages installed or removed. Other programs can
 subscribe to the signals to get notified when packages on the system
 change.
 
+%description plugin-dbus-announce -l pl.UTF-8
+Ta wtyczka ogłasza przez podstawowe szynę systemową DBUS informacje o
+transakcjach RPM-a, takie jak pakiety, które są instalowane lub
+usuwane. Inne programy mogą zasubskrybować sygnały powiadamiające o
+zmianach w pakietach systemowych.
+
 %package sign
 Summary:       Package signing support
 Summary(pl.UTF-8):     Obsługa podpisywania pakietów
@@ -654,6 +674,8 @@ Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
 %patch36 -p1
 %patch37 -p1
 %patch38 -p1
+%patch39 -p1
+%patch40 -p1
 
 %{__rm} po/*.gmo
 
@@ -1018,19 +1040,7 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 # needs hacked pkg-config to return anything
 %attr(755,root,root) %{_rpmlibdir}/pkgconfigdeps.sh
 %attr(755,root,root) %{_rpmlibdir}/mkinstalldirs
-
 %attr(755,root,root) %{_rpmlibdir}/fontconfig.prov
-# must be here for "Requires: rpm-*prov" to work
-#%{_rpmlibdir}/macros.d/cmake
-#%{_rpmlibdir}/macros.d/gstreamer
-#%{_rpmlibdir}/macros.d/libtool
-#%{_rpmlibdir}/macros.d/perl
-#%{_rpmlibdir}/macros.d/pkgconfig
-#%{_rpmlibdir}/macros.d/python
-#%{_rpmlibdir}/macros.d/selinux
-#%{_rpmlibdir}/macros.d/tcl
-#%{_rpmlibdir}/macros.rpmbuild
-
 %attr(755,root,root) %{_rpmlibdir}/check-buildroot
 %attr(755,root,root) %{_rpmlibdir}/check-prereqs
 %attr(755,root,root) %{_rpmlibdir}/check-rpaths
@@ -1122,12 +1132,14 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 %attr(755,root,root) %{_libdir}/rpm-plugins/fapolicyd.so
 %{_mandir}/man8/rpm-plugin-fapolicyd.8*
 
+%if %{with systemd}
 %files plugin-dbus-announce
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/rpm-plugins/dbus_announce.so
 %{_mandir}/man8/rpm-plugin-dbus-announce.8*
 %{_sysconfdir}/dbus-1/system.d/org.rpm.conf
 %endif
+%endif
 
 %files sign
 %defattr(644,root,root,755)
This page took 0.04823 seconds and 4 git commands to generate.