]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm.spec
- updated to 4.4.5
[packages/rpm.git] / rpm.spec
index d2a1814b954f4a8a01fee6c10d8e5e0888d36c7c..3f74429c9c53206d181cce8b8123e4b1906ddbf4 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -16,8 +16,8 @@
 # force_cpp            - force using __cpp other than "%{_target_cpu}-pld-linux-gcc -E"
 
 # versions of required libraries
-%define        reqdb_ver       4.4.16
-%define        reqpopt_ver     1.10.4
+%define        reqdb_ver       4.4.20
+%define        reqpopt_ver     1.10.5
 %define        beecrypt_ver    2:4.1.2-4
 Summary:       RPM Package Manager
 Summary(de):   RPM Packet-Manager
@@ -28,12 +28,12 @@ Summary(ru):        
 Summary(uk):   íÅÎÅÄÖÅÒ ÐÁËÅԦנצĠRPM
 Name:          rpm
 %define        sover   4.4
-Version:       4.4.4
-Release:       0.3
+Version:       4.4.5
+Release:       0.1
 License:       GPL
 Group:         Base
 Source0:       ftp://jbj.org/pub/rpm-4.4.x/%{name}-%{version}.tar.gz
-# Source0-md5: d6cba56ec786915c3bf340c310a0bc44
+# Source0-md5: d5f434789c0c56d05d77be6f4262a561
 Source1:       %{name}.groups
 Source2:       %{name}.platform
 Source3:       %{name}-install-tree
@@ -106,6 +106,7 @@ Patch48:    %{name}-requireseq.patch
 Patch49:       %{name}-p4.patch
 Patch50:       %{name}-macros.patch
 Patch51:       %{name}-cleanlibdirs.patch
+Patch52:       %{name}-morearchs.patch
 URL:           http://wraptastic.org/
 BuildRequires: autoconf >= 2.52
 BuildRequires: automake
@@ -123,13 +124,12 @@ BuildRequires:    libstdc++-devel
 BuildRequires: libtool
 %if %{with neon}
 BuildRequires: libxml2-devel
-BuildRequires: neon-devel >= 0.24.7-3
+BuildRequires: neon-devel >= 0.25.5
 %endif
 BuildRequires: patch >= 2.2
 BuildRequires: popt-devel >= %{reqpopt_ver}
 %{?with_python:BuildRequires:  python-devel >= 1:2.3}
 BuildRequires: python-modules >= 1:2.3
-BuildRequires: readline-devel
 BuildRequires: rpm-perlprov
 %{?with_python:BuildRequires:  rpm-pythonprov}
 BuildRequires: zlib-devel
@@ -161,6 +161,7 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 # don't require very fresh rpm.macros to build
 %define                __gettextize gettextize --copy --force --intl ; cp -f po/Makevars{.template,}
 %define                ix86    i386 i486 i586 i686 athlon pentium3 pentium4
+%define                ppc     ppc ppc7400 ppc7450
 %define                x8664   amd64 ia32e x86_64
 
 # stabilize new build environment
@@ -225,7 +226,6 @@ RPM - 
 Summary:       RPM base package - scripts used by rpm packages themselves
 Summary(pl):   Podstawowy pakiet RPM - skrypty u¿ywane przez same pakiety rpm
 Group:         Base
-Requires:      sed
 Obsoletes:     vserver-rpm
 
 %description base
@@ -425,7 +425,7 @@ Summary(ru):        
 Summary(uk):   óËÒÉÐÔÉ ÔÁ ÕÔÉ̦ÔÉ, ÎÅÏÂȦÄΦ ÄÌÑ ÐÏÂÕÄÏ×É ÐÁËÅÔ¦×
 Group:         Applications/File
 Requires(pre): findutils
-Requires:      %{name}-build-macros
+Requires:      %{name}-build-macros >= 1.284
 Requires:      %{name}-utils = %{version}-%{release}
 Requires:      /bin/id
 Requires:      awk
@@ -680,6 +680,7 @@ install %{SOURCE12} scripts/perl.prov
 %patch49 -p1
 %patch50 -p1
 %patch51 -p1
+%patch52 -p1
 
 cd scripts
 mv -f perl.req perl.req.in
@@ -767,6 +768,11 @@ install -d $RPM_BUILD_ROOT{/%{_lib},/etc/sysconfig,%{_sysconfdir}/rpm,/var/lib/b
        pylibdir=%{py_libdir} \
        pkgbindir="%{_bindir}"
 
+%ifarch %{ppc}
+sed -e '/_target_platform/s/[%]{_target_cpu}/ppc/' \
+       -i $RPM_BUILD_ROOT%{_rpmlibdir}/ppc74[05]0-linux/macros
+%endif
+
 rm $RPM_BUILD_ROOT%{_rpmlibdir}/vpkg-provides*
 rm $RPM_BUILD_ROOT%{_rpmlibdir}/find-{prov,req}.pl
 rm $RPM_BUILD_ROOT%{_rpmlibdir}/find-{provides,requires}.perl
@@ -931,7 +937,7 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 
 %files -f %{name}.lang
 %defattr(644,root,root,755)
-%doc RPM-PGP-KEY CHANGES manual
+%doc RPM-PGP-KEY CHANGES manual/*
 
 %attr(755,root,root) /bin/rpm
 #%attr(755,root,root) %{_bindir}/rpmdb
@@ -1070,7 +1076,7 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 %ifarch mips mipsel mips64 mips64el
 %{_rpmlibdir}/mips*
 %endif
-%ifarch ppc
+%ifarch %{ppc}
 %{_rpmlibdir}/ppc*
 %endif
 %ifarch sparc sparc64
This page took 0.038273 seconds and 4 git commands to generate.