]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm.spec
- updated to 4.4.5
[packages/rpm.git] / rpm.spec
index a827529d8c286997b5876f11be258890c4825425..3f74429c9c53206d181cce8b8123e4b1906ddbf4 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -16,8 +16,8 @@
 # force_cpp            - force using __cpp other than "%{_target_cpu}-pld-linux-gcc -E"
 
 # versions of required libraries
-%define        reqdb_ver       4.4.16
-%define        reqpopt_ver     1.10.4
+%define        reqdb_ver       4.4.20
+%define        reqpopt_ver     1.10.5
 %define        beecrypt_ver    2:4.1.2-4
 Summary:       RPM Package Manager
 Summary(de):   RPM Packet-Manager
@@ -28,12 +28,12 @@ Summary(ru):        
 Summary(uk):   íÅÎÅÄÖÅÒ ÐÁËÅԦנצĠRPM
 Name:          rpm
 %define        sover   4.4
-Version:       4.4.4
-Release:       0.3
+Version:       4.4.5
+Release:       0.1
 License:       GPL
 Group:         Base
 Source0:       ftp://jbj.org/pub/rpm-4.4.x/%{name}-%{version}.tar.gz
-# Source0-md5: d6cba56ec786915c3bf340c310a0bc44
+# Source0-md5: d5f434789c0c56d05d77be6f4262a561
 Source1:       %{name}.groups
 Source2:       %{name}.platform
 Source3:       %{name}-install-tree
@@ -124,13 +124,12 @@ BuildRequires:    libstdc++-devel
 BuildRequires: libtool
 %if %{with neon}
 BuildRequires: libxml2-devel
-BuildRequires: neon-devel >= 0.24.7-3
+BuildRequires: neon-devel >= 0.25.5
 %endif
 BuildRequires: patch >= 2.2
 BuildRequires: popt-devel >= %{reqpopt_ver}
 %{?with_python:BuildRequires:  python-devel >= 1:2.3}
 BuildRequires: python-modules >= 1:2.3
-BuildRequires: readline-devel
 BuildRequires: rpm-perlprov
 %{?with_python:BuildRequires:  rpm-pythonprov}
 BuildRequires: zlib-devel
@@ -426,7 +425,7 @@ Summary(ru):        
 Summary(uk):   óËÒÉÐÔÉ ÔÁ ÕÔÉ̦ÔÉ, ÎÅÏÂȦÄΦ ÄÌÑ ÐÏÂÕÄÏ×É ÐÁËÅÔ¦×
 Group:         Applications/File
 Requires(pre): findutils
-Requires:      %{name}-build-macros
+Requires:      %{name}-build-macros >= 1.284
 Requires:      %{name}-utils = %{version}-%{release}
 Requires:      /bin/id
 Requires:      awk
@@ -724,14 +723,8 @@ cd ..
 
 # config.guess doesn't handle athlon, so we have to change it by hand.
 # rpm checks for CPU type at runtime, but it looks better
-%ifarch %{ppc}
-TARG=$( echo %{_target_cpu} | sed 's/ppc//' )
-sed -e "s|@host@|ppc-%{_target_vendor}-linux-gnu|" \
-       -e "s|@host_cpu@|%{_target_cpu}|" macros.in > macros.tmp
-%else
 sed -e 's|@host@|%{_target_cpu}-%{_target_vendor}-linux-gnu|' \
        -e 's|@host_cpu@|%{_target_cpu}|' macros.in > macros.tmp
-%endif
 mv -f macros.tmp macros.in
 
 CPPFLAGS="-Dglob=rpm_glob -Dglobfree=rpm_globfree"; export CPPFLAGS
@@ -775,6 +768,11 @@ install -d $RPM_BUILD_ROOT{/%{_lib},/etc/sysconfig,%{_sysconfdir}/rpm,/var/lib/b
        pylibdir=%{py_libdir} \
        pkgbindir="%{_bindir}"
 
+%ifarch %{ppc}
+sed -e '/_target_platform/s/[%]{_target_cpu}/ppc/' \
+       -i $RPM_BUILD_ROOT%{_rpmlibdir}/ppc74[05]0-linux/macros
+%endif
+
 rm $RPM_BUILD_ROOT%{_rpmlibdir}/vpkg-provides*
 rm $RPM_BUILD_ROOT%{_rpmlibdir}/find-{prov,req}.pl
 rm $RPM_BUILD_ROOT%{_rpmlibdir}/find-{provides,requires}.perl
This page took 0.039874 seconds and 4 git commands to generate.