]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm.spec
- updated to 4.4.5
[packages/rpm.git] / rpm.spec
index 5eb242303ff52a23193cf88caec86def885feaee..3f74429c9c53206d181cce8b8123e4b1906ddbf4 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -16,8 +16,8 @@
 # force_cpp            - force using __cpp other than "%{_target_cpu}-pld-linux-gcc -E"
 
 # versions of required libraries
-%define        reqdb_ver       4.3.29
-%define        reqpopt_ver     1.10.3
+%define        reqdb_ver       4.4.20
+%define        reqpopt_ver     1.10.5
 %define        beecrypt_ver    2:4.1.2-4
 Summary:       RPM Package Manager
 Summary(de):   RPM Packet-Manager
@@ -28,12 +28,12 @@ Summary(ru):        
 Summary(uk):   íÅÎÅÄÖÅÒ ÐÁËÅԦנצĠRPM
 Name:          rpm
 %define        sover   4.4
-Version:       4.4.3
+Version:       4.4.5
 Release:       0.1
 License:       GPL
 Group:         Base
 Source0:       ftp://jbj.org/pub/rpm-4.4.x/%{name}-%{version}.tar.gz
-# Source0-md5: 12ffef41c0f0ff565d2f6a89ad6c0598
+# Source0-md5: d5f434789c0c56d05d77be6f4262a561
 Source1:       %{name}.groups
 Source2:       %{name}.platform
 Source3:       %{name}-install-tree
@@ -65,7 +65,7 @@ Patch7:               %{name}-scripts-closefds.patch
 Patch8:                %{name}-python-macros.patch
 Patch9:                %{name}-gettext-in-header.patch
 Patch10:       %{name}-compress-doc.patch
-
+Patch11:       %{name}-rpmdeps-segv.patch
 Patch12:       %{name}-system_libs.patch
 Patch13:       %{name}-bb-and-short-circuit.patch
 Patch14:       %{name}-etc_dir.patch
@@ -73,7 +73,7 @@ Patch15:      %{name}-system_libs-more.patch
 Patch16:       %{name}-php-deps.patch
 Patch17:       %{name}-ldconfig-always.patch
 Patch18:       %{name}-perl_req.patch
-
+Patch19:       %{name}-link.patch
 Patch20:       %{name}-magic-usesystem.patch
 Patch21:       %{name}-dontneedutils.patch
 Patch22:       %{name}-provides-dont-obsolete.patch
@@ -92,11 +92,11 @@ Patch34:    %{name}-epoch0.patch
 Patch35:       %{name}-perl_req-INC_dirs.patch
 Patch36:       %{name}-debuginfo.patch
 Patch37:       %{name}-doxygen_hack.patch
-
+Patch38:       %{name}-empty-rpmlock-path.patch
 Patch39:       %{name}-pythondeps.patch
 Patch40:       %{name}-print-requires.patch
 Patch41:       %{name}-reduce-stack-usage.patch
-
+Patch42:       %{name}-old-fileconflicts-behaviour.patch
 Patch43:       %{name}-patch-quote.patch
 Patch44:       %{name}-no-neon.patch
 Patch45:       %{name}-no-sqlite.patch
@@ -106,8 +106,8 @@ Patch48:    %{name}-requireseq.patch
 Patch49:       %{name}-p4.patch
 Patch50:       %{name}-macros.patch
 Patch51:       %{name}-cleanlibdirs.patch
+Patch52:       %{name}-morearchs.patch
 URL:           http://wraptastic.org/
-Icon:          rpm.gif
 BuildRequires: autoconf >= 2.52
 BuildRequires: automake
 BuildRequires: beecrypt-devel >= %{beecrypt_ver}
@@ -124,13 +124,12 @@ BuildRequires:    libstdc++-devel
 BuildRequires: libtool
 %if %{with neon}
 BuildRequires: libxml2-devel
-BuildRequires: neon-devel >= 0.24.7-3
+BuildRequires: neon-devel >= 0.25.5
 %endif
 BuildRequires: patch >= 2.2
 BuildRequires: popt-devel >= %{reqpopt_ver}
 %{?with_python:BuildRequires:  python-devel >= 1:2.3}
 BuildRequires: python-modules >= 1:2.3
-BuildRequires: readline-devel
 BuildRequires: rpm-perlprov
 %{?with_python:BuildRequires:  rpm-pythonprov}
 BuildRequires: zlib-devel
@@ -162,6 +161,7 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 # don't require very fresh rpm.macros to build
 %define                __gettextize gettextize --copy --force --intl ; cp -f po/Makevars{.template,}
 %define                ix86    i386 i486 i586 i686 athlon pentium3 pentium4
+%define                ppc     ppc ppc7400 ppc7450
 %define                x8664   amd64 ia32e x86_64
 
 # stabilize new build environment
@@ -171,6 +171,8 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _rpmlibdir /usr/lib/rpm
 
+%define                specflags       -fno-strict-aliasing
+
 %description
 RPM is a powerful package manager, which can be used to build,
 install, query, verify, update, and uninstall individual software
@@ -224,7 +226,6 @@ RPM - 
 Summary:       RPM base package - scripts used by rpm packages themselves
 Summary(pl):   Podstawowy pakiet RPM - skrypty u¿ywane przez same pakiety rpm
 Group:         Base
-Requires:      sed
 Obsoletes:     vserver-rpm
 
 %description base
@@ -424,7 +425,7 @@ Summary(ru):        
 Summary(uk):   óËÒÉÐÔÉ ÔÁ ÕÔÉ̦ÔÉ, ÎÅÏÂȦÄΦ ÄÌÑ ÐÏÂÕÄÏ×É ÐÁËÅÔ¦×
 Group:         Applications/File
 Requires(pre): findutils
-Requires:      %{name}-build-macros
+Requires:      %{name}-build-macros >= 1.284
 Requires:      %{name}-utils = %{version}-%{release}
 Requires:      /bin/id
 Requires:      awk
@@ -443,7 +444,6 @@ Requires:   grep
 Requires:      gzip
 Requires:      make
 Requires:      patch
-Requires:      popt >= 1.7
 Requires:      sed
 Requires:      sh-utils
 Requires:      tar
@@ -627,6 +627,7 @@ ze 
 %patch8 -p1
 %patch9 -p1
 %patch10 -p1
+%patch11 -p1
 %patch12 -p1
 %patch13 -p1
 %patch14 -p1
@@ -646,6 +647,7 @@ install %{SOURCE5} scripts/find-lang.sh
 install %{SOURCE9} scripts/php.prov.in
 install %{SOURCE10} scripts/php.req.in
 install %{SOURCE12} scripts/perl.prov
+%patch19 -p1
 %patch20 -p1
 %patch21 -p1
 %patch22 -p1
@@ -664,17 +666,21 @@ install %{SOURCE12} scripts/perl.prov
 %patch35 -p0
 %patch36 -p1
 %patch37 -p1
+%patch38 -p1
 %patch39 -p1
 %patch40 -p1
 %patch41 -p1
+%patch42 -p1
 %patch43 -p1
 %{!?with_neon:%patch44 -p1}
 %patch45 -p1
 %patch46 -p1
+
 %patch48 -p1
 %patch49 -p1
 %patch50 -p1
 %patch51 -p1
+%patch52 -p1
 
 cd scripts
 mv -f perl.req perl.req.in
@@ -758,9 +764,15 @@ install -d $RPM_BUILD_ROOT{/%{_lib},/etc/sysconfig,%{_sysconfdir}/rpm,/var/lib/b
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT \
+       staticLDFLAGS=%{?with_static:-all-static} \
        pylibdir=%{py_libdir} \
        pkgbindir="%{_bindir}"
 
+%ifarch %{ppc}
+sed -e '/_target_platform/s/[%]{_target_cpu}/ppc/' \
+       -i $RPM_BUILD_ROOT%{_rpmlibdir}/ppc74[05]0-linux/macros
+%endif
+
 rm $RPM_BUILD_ROOT%{_rpmlibdir}/vpkg-provides*
 rm $RPM_BUILD_ROOT%{_rpmlibdir}/find-{prov,req}.pl
 rm $RPM_BUILD_ROOT%{_rpmlibdir}/find-{provides,requires}.perl
@@ -925,7 +937,7 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 
 %files -f %{name}.lang
 %defattr(644,root,root,755)
-%doc RPM-PGP-KEY CHANGES manual
+%doc RPM-PGP-KEY CHANGES manual/*
 
 %attr(755,root,root) /bin/rpm
 #%attr(755,root,root) %{_bindir}/rpmdb
@@ -1064,7 +1076,7 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 %ifarch mips mipsel mips64 mips64el
 %{_rpmlibdir}/mips*
 %endif
-%ifarch ppc
+%ifarch %{ppc}
 %{_rpmlibdir}/ppc*
 %endif
 %ifarch sparc sparc64
This page took 0.033035 seconds and 4 git commands to generate.