]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm.spec
- requires lua 5.3
[packages/rpm.git] / rpm.spec
index 9b0d65d2285e1492fb9823c8b197374adaec0bc1..3c079d92e6e7c6b47a7d67e8c54e4e1b384fc62e 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
 %bcond_without python          # don't build python bindings
 %bcond_without selinux         # build without selinux support
 %bcond_without suggest_tags    # build without Suggest tag (bootstrapping)
-%bcond_with    db61            # use DB 6.1 instead of 5.2
+%bcond_with    db61            # use DB 6.1 instead of 5.3
 %bcond_with    neon            # build with HTTP/WebDAV support (neon library)
 %bcond_with    sqlite          # build with SQLite support
-%bcond_with    system_lua      # use system lua
 %bcond_without system_pcre     # use system pcre
 %bcond_with    keyutils        # build with keyutils support
-# force_cc             - force using __cc other than "%{_target_cpu}-pld-linux-gcc"
-# force_cxx            - force using __cxx other than "%{_target_cpu}-pld-linux-g++"
-# force_cpp            - force using __cpp other than "%{_target_cpu}-pld-linux-gcc -E"
-#
 
 %if %{with sqlite}
 # Error: /lib64/librpmio-5.4.so: undefined symbol: sqlite3_enable_load_extension
 %define                reqdb_ver       6.1
 %define                reqdb_pkgver    6.1.19
 %else
-%define                reqdb_pkg       db5.2
-%define                reqdb_ver       5.2
-%define                reqdb_pkgver    5.2.36.0-4
+%define                reqdb_pkg       db5.3
+%define                reqdb_ver       5.3
+%define                reqdb_pkgver    5.3.28.0
 %endif
 %define                reqpopt_ver     1.15
-%define                beecrypt_ver    2:4.2.0
+%define                openssl_ver     1.1.1d
 %define                sover           5.4
 
 Summary:       RPM Package Manager
@@ -50,13 +45,12 @@ Summary(pt_BR.UTF-8):       Gerenciador de pacotes RPM
 Summary(ru.UTF-8):     Менеджер пакетов от RPM
 Summary(uk.UTF-8):     Менеджер пакетів від RPM
 Name:          rpm
-Version:       5.4.15
-Release:       36
-License:       LGPL v2.1
+Version:       4.15.1
+Release:       0.1
+License:       GPL v2 / LGPL v2.1
 Group:         Base
-# http://rpm5.org/files/rpm/rpm-5.4/rpm-5.4.15-0.20140824.src.rpm
-Source0:       %{name}-%{version}.tar.gz
-# Source0-md5: 4067f83ca8b5bf1a21e443c0cff3efa0
+Source0:       http://ftp.rpm.org/releases/rpm-4.15.x/%{name}-%{version}.tar.bz2
+# Source0-md5: ed72147451a5ed93b2a48e2f8f5413c3
 # See README.cpu-os-macros how to update cpu-os-macros.a
 Source100:     cpu-os-macros.a
 Source101:     README.cpu-os-macros
@@ -95,214 +89,25 @@ Source31:  gem_helper.rb
 Patch0:                %{name}-branch.patch
 Patch1:                %{name}-man_pl.patch
 Patch2:                %{name}-popt-aliases.patch
-Patch3:                %{name}-nosetproctitle.patch
 Patch4:                %{name}-perl-macros.patch
 Patch5:                %{name}-perl-req-perlfile.patch
 Patch6:                %{name}-scripts-closefds.patch
 Patch7:                %{name}-php-macros.patch
-Patch8:                %{name}-gettext-in-header.patch
 Patch9:                %{name}-lua.patch
-Patch10:       %{name}-php-deps.patch
-Patch11:       %{name}-notsc.patch
-Patch12:       %{name}-hack-norpmlibdep.patch
-Patch13:       %{name}-dont-copy-descriptive-tags.patch
 Patch14:       %{name}-perl_req-INC_dirs.patch
 Patch15:       %{name}-debuginfo.patch
 Patch16:       vendor-pld.patch
-Patch17:       %{name}-old-fileconflicts-behaviour.patch
 Patch18:       %{name}-javadeps.patch
-Patch19:       %{name}-truncate-cvslog.patch
 Patch20:       %{name}-libtool-deps.patch
-Patch21:       %{name}-mimetype.patch
-Patch22:       %{name}-sparc64.patch
-Patch23:       %{name}-gendiff.patch
-Patch24:       openmp.patch
-Patch25:       %{name}-URPM-build-fix.patch
-Patch27:       %{name}-helperEVR-noassert.patch
-Patch28:       %{name}-unglobal.patch
 Patch29:       %{name}-builddir-readlink.patch
 Patch30:       %{name}-changelog_order_check_nonfatal.patch
-Patch31:       %{name}-cleanbody.patch
-Patch32:       %{name}-dirdeps-macro.patch
-Patch33:       %{name}-installbeforeerase.patch
-Patch34:       %{name}-libmagic-locale.patch
 Patch35:       %{name}-namespace-compare.patch
-Patch36:       %{name}-popt-coreutils.patch
 Patch37:       %{name}-postun-nofail.patch
-Patch38:       %{name}-silence-RPM_CHAR_TYPE.patch
-Patch39:       %{name}-fix-missing-types-in-headers.patch
-Patch40:       %{name}-fix--p-interpreter-and-empty-script.patch
-Patch41:       %{name}-db_buffer_small.patch
-Patch42:       %{name}-pattern_Release.patch
-Patch43:       %{name}-fix-___build_pre-macro.patch
-Patch44:       %{name}-missing-patch-file-fails-build.patch
-Patch45:       %{name}-remove-misleading-missing-patch-message.patch
-Patch46:       %{name}-file-magic-can-be-mixed-case.patch
-Patch47:       %{name}-query-always-noisy.patch
-Patch48:       %{name}-verify-ghosts-broken-logic.patch
-Patch49:       %{name}-python-enable-compat-RPMSENSE.patch
-Patch50:       %{name}-dont-treat-gstreamer-modules-as-font.patch
-Patch51:       %{name}-gst-inspect-typo.patch
-Patch52:       %{name}-null-term-ascii-digest.patch
-Patch53:       %{name}-lua-enable-extra-libs.patch
-Patch54:       %{name}-fix-filedigests-verify.patch
-Patch55:       %{name}-disable-hmac-verify.patch
-Patch56:       %{name}-macros.patch
-Patch57:       %{name}-db5.2.patch
-Patch58:       %{name}-preserve-iterator.patch
-Patch60:       %{name}-python-sitescriptdir.patch
 Patch61:       %{name}-clean-docdir.patch
-Patch62:       %{name}-DB_CONFIG.patch
-Patch63:       %{name}-pythoneggs.patch
 Patch64:       %{name}-fix-compress-doc.patch
-Patch65:       %{name}-parseSpec-skip-empty-tags.patch
-Patch66:       %{name}-payload-use-hashed-inode.patch
-Patch67:       %{name}-repackage-dont-force-max-compression.patch
-Patch70:       python-%{name}sense-missingok.patch
-Patch71:       %{name}-changelog-encoding.patch
-Patch72:       %{name}-preserve-tag-type.patch
-Patch74:       %{name}-fix-internal-lua-build.patch
-Patch75:       %{name}-double_check_file_deps.patch
-Patch77:       %{name}-lua-expat.patch
-Patch78:       %{name}-double_check_unpackaged_subdirs.patch
-Patch79:       %{name}-rpmspec.patch
-Patch80:       %{name}-revert-gpg-argv-parsing.patch
 Patch81:       %{name}-perl-magic.patch
-Patch82:       %{name}-5.4.15-use-DSA-sig.patch
 Patch83:       %{name}-ignore-missing-macro-files.patch
 Patch84:       x32.patch
-Patch85:       rpm-CVE-2013-6435.patch
-Patch86:       rpm-CVE-2014-8118.patch
-Patch87:       %{name}-file-output-for-ELF.patch
-Patch88:       %{name}-rpmtdnext.patch
-Patch89:       disable-header-verification.patch
-Patch90:       %{name}-cppcompat.patch
-Patch91:       py-disable-fetch.patch
-Patch92:       fast_python_deps.patch
-Patch93:       python2_explicit.patch
-Patch94:       do_not_write_before_macro_buffer.patch
-Patch95:       rpm-python-spec-header.patch
-Patch96:       skip-ldconfig-optimization.patch
-
-# Patches imported from Mandriva
-
-# status: ready to merge, it's already been merged on HEAD, so commiting it to rpm-5_4
-# would basically just mean backporting it..
-Patch1000:     %{name}-5.4.4-add-_specfile-macro.patch
-# status: needs to be cleaned up and properly reviewed together with rest
-# of the patches related to dependency generation
-Patch1001:     %{name}-5.4.9-avoid-dependencies-on-self.patch
-# status: probably ready to merge
-Patch1002:     %{name}-5.4.4-pkgconfigdeps-check-path.patch
-# status: probably okay to merge, but discuss on rpm-devel first
-Patch1003:     %{name}-5.4.4-glob-wildcards-for-loading-macro-files.patch
-# status: needs to be discussed
-Patch1004:     %{name}-5.4.4-allow-installation-of-repackaged-rpms.patch
-# status: ready to merge
-Patch1005:     %{name}-5.4.8-dont-show-suggests-with-requires.patch
-# status: ready for merge
-Patch1006:     %{name}-5.4.9-strip-buildroot-away-from-duplicate-files-list.patch
-# status: probably okay to merge, but discuss on rpm-devel first
-Patch1007:     %{name}-5.4.10-duplicate_files_terminate_build.patch
-# status: same as above
-Patch1008:     %{name}-5.4.10-unpackaged_subdirs_terminate_build.patch
-# mdvbz#64898
-# status: uncertain, might be okay to merge, discuss on rpm-devel first
-Patch1009:     %{name}-5.4.4-rpmbuild-withoutclean.patch
-# no sense in having an additional dependency on 'pkgconfig' on all packages that
-# have a pkgconfig file, it's not needed for them to be made useful and anything
-# actuallly using pkgconfig for this purpose will pull it in as a dependency anyways...
-# status: might be okay to merge, but discuss on rpm-devel first
-Patch1010:     %{name}-5.4.4-drop-useless-auto-generated-pkgconfig-dependency.patch
-# status: ready for merge
-Patch1011:     %{name}-5.4.4-fix-rpmconstant-to-always-use-LC_CTYPE-C-for-case-conversion.patch
-# $RPM_BUILD_DIR isn't necessarily the same as $PWD, it's %%{_builddir}, not
-# %%{_builddir}/%%{?buildsubdir}, messing up paths in debug packages created..
-# status: needs to be discussed and investigated a bit better..
-Patch1012:     %{name}-5.4.4-pass-_builddir-properly-to-find-debuginfo.patch
-# status: probably okay to merge, but discuss on rpm-devel first
-Patch1013:     %{name}-5.4.10-files-listed-twice-terminates-build.patch
-# status: probably okay to merge
-Patch1014:     %{name}-5.4.9-ruby1.9-fixes.patch
-# status: keep locally
-Patch1015:     %{name}-5.4.9-keep-loading-script-macros.patch
-# status: same as for other dep gen patches
-Patch1016:     %{name}-5.4.9-update-rpmfc-when-removing-dependencies-on-self.patch
-# status: idem
-Patch1017:     %{name}-5.4.9-rpmfc-extract-dependencies-for-all-files.patch
-# status: probably okay to merge
-Patch1019:     %{name}-5.4.5-python-export-spec-macros.patch
-# status: idem
-Patch1020:     %{name}-5.4.9-font-provides.patch
-# stauus: idem
-Patch1021:     %{name}-5.4.7-kmod-dependencies.patch
-# status: probably okay to merge, discuss on rpm-devel first
-Patch1022:     %{name}-5.4.5-skip-dependencies-for-character-devices.patch
-# status: probably okay to merge
-Patch1024:     %{name}-5.4.5-rpmfc-apply-python-coloring-from-magic.patch
-# status: probably okay to merge
-Patch1026:     %{name}-5.4.10-dont-try-generate-rpmfc-dependencies-from-doc-files.patch
-# status: ready
-Patch1027:     %{name}-5.4.7-fix-generation-of-ruby-abi-provides.patch
-# crash reproducable with 'rpm -qa --triggers'
-# status: ready
-Patch1028:     %{name}-5.4.7-hdrfmt-fix-unitialized-argv-element.patch
-# status: same as for other dep gen patches
-Patch1029:     %{name}-5.4.7-dont-consider-trigger-dependencies-as-overlapping.patch
-# status: ready
-Patch1030:     %{name}-5.4.7-fix-minor-memleaks.patch
-# status: ready
-Patch1031:     %{name}-5.4.9-mire-fix-strings-lacking-null-terminator.patch
-# status: ready
-Patch1032:     %{name}-5.4.9-rpmpython-fix-input.patch
-# status: ready
-Patch1033:     %{name}-5.4.7-no-seqid_init-on-rdonly-database.patch
-# status: probably ready for merging
-Patch1034:     %{name}-5.4.9-avoid-double-slash-in-path-for-dirname-filetrigger-matching.patch
-# status: probably ready to merge, discuss on rpm-devel first
-Patch1035:     %{name}-5.4.9-fix-verify-segfault.patch
-# Due to rpmdav/neon being written in a different fashion than other rpmio clients,
-# the inconsistent behaviour affects code elsewhere which expects consistent behaviour,
-# with the result being that when unable to download files, neon will save error
-# page as the target file.
-# status: should go upstream, but uncertain about "correct" fix, ie. this is
-# more of a workaround, while rewriting rpmdav code to behave consistently
-# would be "the right thing to do". Yet I'm not fully able to grasp all of the
-# code and don't want to spend more time just to get the API..
-Patch1037:     %{name}-5.4.10-fix-neon-saving-error-pages-as-target-file.patch
-# As the transaction flags for ignoring arch & os are no longer used, there's
-# currently no way to ignore arch & os of packages anymore. This patch adds
-# support for doing this again by defining rpm variables and overriding
-# --ignorearch & --ignoreos to set these.
-# status: needs to be discussed upstream before thinking about merging
-Patch1038:     %{name}-5.4.10-support-ignore-arch-and-os-again.patch
-# status: ready for merge
-Patch1039:     %{name}-5.4.4-fix-same-package-with-epoch-possible-to-upgrade.patch
-# we want that patch too, a bit of builder infrastructure relies on NOSIGNATURES
-Patch1040:     %{name}-5.4.9-support-signatures-and-digest-disablers.patch
-# lack insight on actual functionality, which anyways seems broken, so let's
-# disable it to avoid errors from berkeley db..
-# status: keep locally
-Patch1041:     %{name}-5.4.9-disable-l10ndir.patch
-# status: ready for merge
-Patch1042:     %{name}-5.4.9-fix-rpm_qa-pattern.patch
-# warning: introduces memory leak
-Patch1043:     %{name}-5.4.12-copy-Value-string.patch
-Patch1044:     %{name}-5.4.12-fix-rpmlua-print.patch
-Patch1045:     %{name}-5.4.12-fix-rpmpython-module-import-init.patch
-Patch1046:     %{name}-5.4.12-truncate-output-buffer-after-use.patch
-Patch1047:     %{name}-5.4.13-perl-bindings-do-not-use-xmalloc.patch
-# proyvind:
-# there's a rpmdbchk tool I wrote a while back, which might help you. although
-# the incidents it's able to deal with is rather limited ATM... it might help
-# you out, if not and you'll be able to solve yer problem, you could take a
-# stab at adding support for fixing your specific problem to the util ;)
-# https://abf.io/openmandriva/rpm/raw/master/rpm-5.4.14-rpmdbchk.patch
-Patch1048:     %{name}-5.4.14-rpmdbchk.patch
-# https://abf.io/openmandriva/rpm/raw/master/rpm-5.4.14-no-assert-abort-with-broken-headers.patch
-Patch1049:     %{name}-5.4.14-no-assert-abort-with-broken-headers.patch
-
-Patch1050:     python-libx32.patch
 
 URL:           http://rpm5.org/
 BuildRequires: %{reqdb_pkg}-devel >= %{reqdb_pkgver}
@@ -313,7 +118,7 @@ BuildRequires:      %{reqdb_pkg}-sql-devel >= %{reqdb_pkgver}
 %endif
 BuildRequires: autoconf >= 2.63
 BuildRequires: automake >= 1.4
-BuildRequires: beecrypt-devel >= %{beecrypt_ver}
+BuildRequires: openssl-devel >= %{openssl_ver}
 BuildRequires: bzip2-devel >= 1.0.2-17
 BuildRequires: elfutils-devel >= 0.108
 BuildRequires: gettext-tools >= 0.19.2
@@ -331,7 +136,7 @@ BuildRequires:      libtool >= 1:1.4.2-9
 BuildRequires: libxml2-devel
 BuildRequires: neon-devel >= 0.25.5
 %endif
-%{?with_system_lua:BuildRequires:      lua52-devel >= 5.2.2}
+BuildRequires: lua53-devel >= 5.3.5
 BuildRequires: ossp-uuid-devel
 BuildRequires: patch >= 2.2
 BuildRequires: popt-devel >= %{reqpopt_ver}
@@ -350,7 +155,7 @@ BuildRequires:      tetex-pdftex
 %if %{with static}
 # Require static library only for static build
 BuildRequires: %{reqdb_pkg}-static >= %{reqdb_pkgver}
-BuildRequires: beecrypt-static >= %{beecrypt_ver}
+BuildRequires: openssl-static >= %{openssl_ver}
 BuildRequires: bzip2-static >= 1.0.2-17
 BuildRequires: elfutils-static
 BuildRequires: glibc-static >= 2.2.94
@@ -364,9 +169,10 @@ BuildRequires:     popt-static >= %{reqpopt_ver}
 BuildRequires: zlib-static
 %endif
 Requires(posttrans):   coreutils
+Requires:      FHS >= 3.0-2
 Requires:      %{name}-base = %{version}-%{release}
 Requires:      %{name}-lib = %{version}-%{release}
-Requires:      beecrypt >= %{beecrypt_ver}
+Requires:      openssl >= %{openssl_ver}
 Requires:      popt >= %{reqpopt_ver}
 Provides:      rpm-db-ver = %{reqdb_ver}
 Obsoletes:     rpm-getdeps
@@ -388,18 +194,6 @@ BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                ppc     ppc ppc7400 ppc7450
 %define                x8664   amd64 ia32e x86_64
 
-# stabilize new build environment
-%ifnarch x32
-%define                __newcc %{?force_cc}%{!?force_cc:%{_target_cpu}-pld-linux-gcc}
-%define                __newcxx %{?force_cxx}%{!?force_cxx:%{_target_cpu}-pld-linux-g++}
-%define                __newcpp %{?force_cpp}%{!?force_cpp:%{_target_cpu}-pld-linux-gcc -E}
-%else
-# x32 is a very special case
-%define                __newcc %{?force_cc}%{!?force_cc:x86_64-pld-linux-gnux32-gcc}
-%define                __newcxx %{?force_cxx}%{!?force_cxx:x86_64-pld-linux-gnux32-g++}
-%define                __newcpp %{?force_cpp}%{!?force_cpp:x86_64-pld-linux-gnux32-gcc -E}
-%endif
-
 %define                _rpmlibdir /usr/lib/rpm
 %define                _noautocompressdoc      RPM-GPG-KEY
 
@@ -483,7 +277,7 @@ Requires:   sqlite3 >= %{sqlite_build_version}
 %else
 Requires:      %{reqdb_pkg}-sql >= %{reqdb_pkgver}
 %endif
-Requires:      beecrypt >= %{beecrypt_ver}
+Requires:      openssl >= %{openssl_ver}
 Requires:      libmagic >= 1.15-2
 %{?with_selinux:Requires:      libselinux >= 2.1.0}
 Requires:      popt >= %{reqpopt_ver}
@@ -508,7 +302,7 @@ Summary(uk.UTF-8):  Хедери та бібліотеки для програм,
 Group:         Development/Libraries
 Requires:      %{name}-lib = %{version}-%{release}
 Requires:      %{reqdb_pkg}-devel >= %{reqdb_pkgver}
-Requires:      beecrypt-devel >= %{beecrypt_ver}
+Requires:      openssl-devel >= %{openssl_ver}
 Requires:      bzip2-devel
 Requires:      elfutils-devel
 %{?with_keyutils:Requires:     keyutils-devel}
@@ -576,7 +370,7 @@ Summary(uk.UTF-8):  Статична бібліотека для програм,
 Group:         Development/Libraries
 Requires:      %{name}-devel = %{version}-%{release}
 Requires:      %{reqdb_pkg}-static >= %{reqdb_pkgver}
-Requires:      beecrypt-static >= %{beecrypt_ver}
+Requires:      openssl-static >= %{openssl_ver}
 Requires:      bzip2-static
 Requires:      elfutils-static
 %{?with_keyutils:Requires:     keyutils-static}
@@ -882,160 +676,33 @@ cd -
 #patch0 -p1
 %patch1 -p1
 %patch2 -p1
-%patch3 -p1
 %patch4 -p1
 %patch5 -p1
 %patch6 -p1
-%patch7 -p1
-%patch8 -p1
-%{?with_system_lua:%patch9 -p1}
-%patch10 -p1
-%ifnarch i386 i486
-# enable TSC for capable archs
-%patch11 -p1
-%endif
-%patch12 -p1
-%patch13 -p1
+#%patch7 -p1
+%patch9 -p1
 %patch14 -p0
 %patch15 -p1
-%patch16 -p1
-%patch17 -p1
-%patch18 -p1
-%patch19 -p1
+#%patch16 -p1
+#%patch18 -p1
 %patch20 -p1
-%patch21 -p1
-%ifarch sparc64
-%patch22 -p1
-%endif
-%patch23 -p1
-%patch24 -p1
-%patch25 -p1
-%patch27 -p1
-%patch28 -p1
 %patch29 -p1
 %patch30 -p1
-%patch31 -p1
-%patch32 -p1
-%patch33 -p1
-%patch34 -p1
-%patch35 -p1
-%patch36 -p1
+#%patch35 -p1
 %patch37 -p1
-%patch38 -p1
-%patch39 -p1
-%patch40 -p1
-%{?with_db61:%patch41 -p1}
-%patch42 -p1
-%patch43 -p1
-%patch44 -p1
-%patch45 -p1
-%patch46 -p1
-%patch47 -p1
-%patch48 -p1
-%patch49 -p1
-%patch50 -p1
-%patch51 -p1
-%patch52 -p0
-%patch53 -p1
-%patch54 -p1
-%patch55 -p1
-%patch56 -p1
-%{!?with_db61:%patch57 -p1}
-%patch58 -p1
-%patch60 -p1
 %patch61 -p1
-%patch62 -p1
-%patch63 -p1
-%patch64 -p1
-%patch65 -p1
-%patch66 -p1
-%patch67 -p1
-%patch70 -p1
-%patch71 -p1
-%patch72 -p1
-%patch74 -p1
-%patch75 -p1
-%patch77 -p0
-%patch78 -p1
-%patch79 -p1
-%patch80 -p1
-%patch81 -p0
-%patch82 -p1
-%patch84 -p1
-%patch85 -p1
-%patch86 -p1
-%patch87 -p1
-%patch88 -p1
-%patch89 -p1
-%patch90 -p1
-%patch91 -p1
-
-%patch1000 -p1
-%patch1001 -p1
-%patch1002 -p1
-%patch1003 -p1
-%patch1004 -p1
-%patch1005 -p1
-%patch1006 -p1
-%patch1007 -p1
-%patch1008 -p1
-%patch1009 -p1
-%patch1010 -p1
-%patch1011 -p1
-%patch1012 -p1
-%patch1013 -p1
-%patch1014 -p1
-%patch1015 -p1
-%patch1016 -p1
-%patch1017 -p1
-%patch1019 -p1
-%patch1020 -p1
-%patch1021 -p1
-%patch1022 -p1
-%patch1024 -p1
-%patch1026 -p1
-%patch1027 -p1
-%patch1028 -p1
-%patch1029 -p1
-%patch1030 -p1
-%patch1031 -p1
-%patch1032 -p1
-%patch1033 -p1
-%patch1034 -p1
-%patch1035 -p1
-%patch1037 -p1
-%patch1038 -p1
-%patch1039 -p1
-%patch1040 -p1
-# don't delete, may be usefull if jbj descides to enable this again
-#%patch1041 -p1
-%patch1042 -p1
-%patch1043 -p1
-%patch1044 -p1
-%patch1045 -p1
-%patch1046 -p1
-%patch1047 -p1
-%patch1048 -p1
-%patch1049 -p1
-
+#%patch64 -p1
+%patch81 -p1
 %patch83 -p1
-%patch92 -p1
-%patch93 -p1
-%patch94 -p1
-%patch95 -p1
-%patch96 -p1
-
-%patch1050 -p1
+#%patch84 -p1
 
-install %{SOURCE2} macros/pld.in
-install %{SOURCE8} scripts/php.prov.in
-install %{SOURCE9} scripts/php.req.in
+install %{SOURCE2} pld.in
+#install %{SOURCE8} scripts/php.prov.in
+#install %{SOURCE9} scripts/php.req.in
 install %{SOURCE11} scripts/perl.prov.in
 cp -p %{SOURCE30} scripts/rubygems.rb
 cp -p %{SOURCE31} scripts/gem_helper.rb
 
-rm scripts/find-php*
-
 %{__mv} -f scripts/perl.req{,.in}
 
 # generate Group translations to *.po
@@ -1044,7 +711,7 @@ awk -f %{SOURCE6} %{SOURCE1}
 install %{SOURCE26} tools/rpmdb_checkversion.c
 install %{SOURCE28} tools/rpmdb_reset.c
 
-for extlib in beecrypt neon %{?with_system_pcre:pcre} popt; do
+for extlib in openssl neon %{?with_system_pcre:pcre} popt; do
        [ -d $extlib ] && %{__rm} -r $extlib
 done
 
@@ -1061,21 +728,18 @@ sed -i \
        -e 's|@host@|%{_target_cpu}-%{_target_vendor}-%{_target_os}|' \
        -e 's|@host_cpu@|%{_target_cpu}|' \
        -e 's|@host_os@|%{_target_os}|' \
-       macros/macros.in
+       macros.in
 
-%{?with_system_lua:CPPFLAGS="-I/usr/include/lua51 %{rpmcppflags}"}
-# pass CC and CXX too in case of building with some older configure macro
+CPPFLAGS="-I/usr/include/lua53 %{rpmcppflags}"
 %configure \
-       CC="%{__newcc}" \
-       CXX="%{__newcxx}" \
-       CPP="%{__newcpp}" \
        WITH_PERL_VERSION=no \
        __GST_INSPECT=%{_bindir}/gst-inspect-1.0 \
+       __GPG=%{_bindir}/gpg \
        --disable-silent-rules \
        --enable-shared \
        --enable-static \
        %{!?with_apidocs:--without-apidocs} \
-       --with-beecrypt=external \
+       --with-crypto=openssl \
        --with-bugreport="http://bugs.pld-linux.org/" \
        --with-bzip2=external \
        --with-db=external \
@@ -1083,7 +747,7 @@ sed -i \
        --with-file=external \
        --with-keyutils=%{?with_keyutils:external}%{!?with_keyutils:no} \
        --with-libelf \
-       --with-lua=%{!?with_system_lua:internal}%{?with_system_lua:external} \
+       --with-lua \
        --with-lzma=external \
        --with-neon=%{?with_neon:external}%{!?with_neon:no} \
        --with-path-macros='%{_rpmlibdir}/macros:%{_rpmlibdir}/macros.d/pld:%{_rpmlibdir}/%%{_target}/macros:%{_rpmlibdir}/macros.build:%{_sysconfdir}/rpm/macros.*:%{_sysconfdir}/rpm/macros:%{_sysconfdir}/rpm/%%{_target}/macros:%{_sysconfdir}/rpm/macros.d/*.macros:~/etc/.rpmmacros:~/.rpmmacros' \
@@ -1092,7 +756,7 @@ sed -i \
        --with-popt=external \
        %{?with_python:--with-python=%{py_ver} --with-python-lib-dir=%{py_sitedir}} \
        %{!?with_python:--without-python} \
-       --with-selinux=%{!?with_selinux:no}%{?with_selinux:external} \
+       --with-selinux=%{!?with_selinux:no}%{?with_selinux:yes} \
        --with-semanage=%{!?with_selinux:no}%{?with_selinux:external} \
        --with-sepol=%{!?with_selinux:no}%{?with_selinux:external} \
        --with-sqlite=%{?with_sqlite:yes}%{!?with_sqlite:no} \
@@ -1101,12 +765,7 @@ sed -i \
        --with-xz=external \
        --with-zlib=external
 
-%{__make} -j1 \
-       CC="%{__cc}" \
-       CXX="%{__cxx}" \
-       CPP="%{__cpp}"
-
-%{?with_apidocs:%{__make} apidocs}
+%{__make}
 
 %{__cc} %{rpmcflags} -I/usr/include/db%{reqdb_ver} tools/rpmdb_checkversion.c \
        -o tools/rpmdb_checkversion -ldb-%{reqdb_ver}
@@ -1265,7 +924,6 @@ EOF
 # Squash Extra Blank Lines
 %{__sed} -i -e '/./,/^$/!d' $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
 
-%{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/vpkg-provides*
 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/find-{prov,req}.pl
 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/find-{provides,requires}.perl
 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/find-lang.sh
@@ -1530,12 +1188,6 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 %attr(755,root,root) %{_rpmlibdir}/bin/semodule
 %attr(755,root,root) %{_rpmlibdir}/bin/spooktool
 %endif
-%if %{without system_lua}
-%attr(755,root,root) %{_rpmlibdir}/bin/lua
-%attr(755,root,root) %{_rpmlibdir}/bin/luac
-%attr(755,root,root) %{_rpmlibdir}/bin/rpmlua
-%attr(755,root,root) %{_rpmlibdir}/bin/rpmluac
-%endif
 %{?with_keyutils:%attr(755,root,root) %{_rpmlibdir}/bin/rpmkey}
 %attr(755,root,root) %{_rpmlibdir}/bin/rpmrepo
 %{_mandir}/man8/rpm2cpio.8*
This page took 0.062095 seconds and 4 git commands to generate.