]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm.spec
- merged with branch NEW_PEAR_REQUIRES (new rpm pear req/prov scripts)
[packages/rpm.git] / rpm.spec
index 60d5ece9b2cf69b564561d460a7b723610b6122c..393e8cc846caba15519b1d342c1e9ada06c7f14f 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -1,13 +1,15 @@
 # to build for athlon you need release at least 49
 
-Summary:       Red Hat (and now also PLD) Package Manager
-Summary(de):   Red Hat (und jetzt auch PLD) Packet-Manager
+Summary:       RPM Package Manager
+Summary(de):   RPM Packet-Manager
 Summary(es):   Gestor de paquetes RPM
-Summary(pl):   Aplikacja do zarz±dzania pakietami
+Summary(pl):   Aplikacja do zarz±dzania pakietami RPM
 Summary(pt_BR):        Gerenciador de pacotes RPM
+Summary(ru):   íÅÎÅÄÖÅÒ ÐÁËÅÔÏ× ÏÔ Red Hat
+Summary(uk):   íÅÎÅÄÖÅÒ ÐÁËÅԦנצĠRed Hat
 Name:          rpm
 Version:       4.0.2
-Release:       53
+Release:       98
 License:       GPL
 Group:         Base
 Source0:       ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.0.x/%{name}-%{version}.tar.gz
@@ -24,6 +26,17 @@ Source10:    %{name}-find-provides
 Source11:      %{name}-find-requires
 Source12:      %{name}-non-english-man-pages.tar.bz2
 Source13:      %{name}-macros.python
+Source14:      %{name}-groups-po.awk
+Source15:      %{name}-compress-doc
+Source16:      %{name}-check-files
+Source17:      %{name}-php-provides
+Source18:      %{name}-php-requires
+Source19:      %{name}-find-php-provides
+Source20:      %{name}-find-php-requires
+Source21:      %{name}-macros.php
+Source30:      builder
+Source31:      adapter.awk
+Source32:      pldnotify.awk
 Patch0:                %{name}-rpmrc.patch
 Patch1:                %{name}-macros.patch
 Patch2:                %{name}-arch.patch
@@ -43,7 +56,7 @@ Patch15:      %{name}-fast-alAddPackage.patch
 Patch16:       %{name}-byKey.patch
 Patch17:       %{name}-perlprov.patch
 Patch18:       %{name}-noperldir.patch
-Patch19:       popt-cvs20010530.patch
+Patch19:       %{name}-popt-cvs20010530.patch
 Patch20:       %{name}-noexpand.patch
 Patch21:       %{name}-scripts-closefds.patch
 Patch22:       %{name}-python-amfix.patch
@@ -57,8 +70,16 @@ Patch29:     %{name}-cxx.patch
 Patch30:       %{name}-athlon.patch
 Patch31:       %{name}-athlon-identify.patch
 Patch32:       %{name}-gettext-in-header.patch
-Patch37:        %{name}-short_circuit.patch
-Patch38:        %{name}-section_test.patch
+Patch33:       %{name}-perlprov-perl5.6.patch
+Patch34:       %{name}-ac25x.patch
+Patch35:       %{name}-signverify-fix.patch
+Patch36:       %{name}-compress-doc.patch
+Patch37:       %{name}-short_circuit.patch
+Patch38:       %{name}-test_stage.patch
+Patch39:       %{name}-exclude.patch
+Patch40:       %{name}-check_files.patch
+Patch41:       %{name}-choke-on-evil-doc.patch
+Patch42:       %{name}-rpmlog-fix.patch
 URL:           http://www.rpm.org/
 Icon:          rpm.gif
 BuildRequires: autoconf >= 2.50
@@ -67,19 +88,20 @@ BuildRequires:      bzip2-devel >= 1.0.1
 BuildRequires: db1-devel >= 1.85
 BuildRequires: db3-devel >= 3.1.17-9
 BuildRequires: gettext-devel >= 0.10.38-3
-BuildRequires: python-devel >= 2.2
-BuildRequires: python-modules >= 2.2
-BuildRequires: zlib-devel
+BuildRequires: libtool
+BuildRequires: patch >= 2.2
+BuildRequires: python-devel >= 2.2.1
 BuildRequires: python-modules >= 2.2.1
 BuildRequires: zlib-devel >= 1.1.4
 %if %{!?_without_static:1}%{?_without_static:0}
 # Require static library only for static build
 BuildRequires: bzip2-static >= 1.0.1
 BuildRequires: db1-static >= 1.85
-BuildRequires: zlib-static
+BuildRequires: db3-static >= 3.1.17-9
 BuildRequires: glibc-static >= 2.2.0
 BuildRequires: zlib-static >= 1.1.4
 %endif
+Requires:      zlib >= 1.1.4
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 Obsoletes:     rpm-libs
 Conflicts:     glibc < 2.2
@@ -90,6 +112,7 @@ Conflicts:   glibc < 2.2
 %define                py_ver          %(echo `python -c "import sys; print sys.version[:3]"`)
 %define                py_prefix       %(echo `python -c "import sys; print sys.prefix"`)
 %define                py_libdir       %{py_prefix}/lib/python%{py_ver}
+%define                py_sitedir      %{py_libdir}/site-packages
 %define                py_dyndir       %{py_libdir}/lib-dynload
 %define                pyrequires_eq() Requires:       %1 >= %py_ver %1 < %(echo `python -c "import sys; import string; ver=sys.version[:3].split('.'); ver[1]=str(int(ver[1])+1); print string.join(ver, '.')"`)
 
@@ -128,12 +151,28 @@ pacotes individuais de software. Um pacote consiste de um conjunto de
 arquivos e informações adicionais, incluindo nome, versão e descrição
 do pacote, permissões dos arquivos, etc.
 
+%description -l ru
+RPM - ÜÔÏ ÍÏÝÎÙÊ ÍÅÎÅÄÖÅÒ ÐÁËÅÔÏ×, ËÏÔÏÒÙÊ ÍÏÖÅÔ ÂÙÔØ ÉÓÐÏÌØÚÏ×ÁΠÄÌÑ
+ÓÏÚÄÁÎÉÑ, ÉÎÓÔÁÌÌÑÃÉÉ, ÚÁÐÒÏÓÏ× (query), ÐÒÏ×ÅÒËÉ, ÏÂÎÏ×ÌÅÎÉÑ É
+ÕÄÁÌÅÎÉÑ ÐÒÏÇÒÁÍÍÎÙÈ ÐÁËÅÔÏ×. ðÁËÅÔ ÓÏÓÔÏÉÔ ÉÚ ÆÁÊÌÏ×ÏÇÏ ÁÒÈÉ×Á É
+ÓÌÕÖÅÂÎÏÊ ÉÎÆÏÒÍÁÃÉÉ, ×ËÌÀÞÁÀÝÅÊ ÎÁÚ×ÁÎÉÅ, ×ÅÒÓÉÀ, ÏÐÉÓÁÎÉÅ É ÄÒÕÇÉÅ
+ÄÁÎÎÙÅ Ï ÐÁËÅÔÅ.
+
+%description -l uk
+RPM - ÃÅ ÐÏÔÕÖÎÉÊ ÍÅÎÅÄÖÅÒ ÐÁËÅÔ¦×, ÝÏ ÍÏÖÅ ÂÕÔÉ ×ÉËÏÒÉÓÔÁÎÉÊ ÄÌÑ
+ÓÔ×ÏÒÅÎÎÑ, ¦ÎÓÔÁÌÑæ§, ÚÁÐÉԦנ(query), ÐÅÒÅצÒËÉ, ÐÏÎÏ×ÌÅÎÎÑ ÔÁ
+×ÉÄÁÌÅÎÎÑ ÐÒÏÇÒÁÍÎÉÈ ÐÁËÅÔ¦×. ðÁËÅÔ ÓËÌÁÄÁ¤ÔØÓÑ Ú ÆÁÊÌÏ×ÏÇÏ ÁÒȦ×Õ ÔÁ
+ÓÌÕÖÂÏ×ϧ ¦ÎÆÏÒÍÁæ§, ÝϠͦÓÔÉÔØ ÎÁÚ×Õ, ×ÅÒÓ¦À, ÏÐÉÓ ÔÁ ¦ÎÛÕ
+¦ÎÆÏÒÍÁæÀ ÐÒÏ ÐÁËÅÔ.
+
 %package devel
 Summary:       Header files and libraries
 Summary(de):   Header-Dateien uns Libraries
 Summary(es):   Archivos de inclusión y bibliotecas para programas de manipulación de paquetes rpm
 Summary(pl):   Pliki nag³ówkowe i biblioteki statyczne
 Summary(pt_BR):        Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
+Summary(ru):   èÅÄÅÒÙ É ÂÉÂÌÉÏÔÅËÉ ÄÌÑ ÐÒÏÇÒÁÍÍ, ÒÁÂÏÔÁÀÝÉÈ Ó rpm-ÐÁËÅÔÁÍÉ.
+Summary(uk):   èÅÄÅÒÉ ÔÁ Â¦Â̦ÏÔÅËÉ ÄÌÑ ÐÒÏÇÒÁÍ, ÝÏ ÐÒÁÃÀÀÔØ Ú ÐÁËÅÔÁÍÉ rpm
 Group:         Development/Libraries
 Requires:      %{name} = %{version}
 Requires:      popt-devel
@@ -168,11 +207,26 @@ a manipula
 facilitar a criação de gerenciadores gráficos de pacotes e outras
 ferramentas que precisem de conhecimento profundo de pacotes RPM.
 
+%description devel -l ru
+óÉÓÔÅÍÁ ÕÐÒÁ×ÌÅÎÉÑ ÐÁËÅÔÁÍÉ RPM ÓÏÄÅÒÖÉÔ ÂÉÂÌÉÏÔÅËÕ C, ËÏÔÏÒÁÑ
+ÕÐÒÏÝÁÅÔ ÍÁÎÉÐÕÌÑÃÉÀ ÐÁËÅÔÁÍÉ RPM É ÓÏÏÔ×ÅÔÓÔ×ÕÀÝÉÍÉ ÂÁÚÁÍÉ ÄÁÎÎÙÈ.
+üÔÁ ÂÉÂÌÉÏÔÅËÁ ÐÒÅÄÎÁÚÎÁÞÅÎÁ ÄÌÑ ÏÂÌÅÇÞÅÎÉÑ ÓÏÚÄÁÎÉÑ ÇÒÁÆÉÞÅÓËÉÈ
+ÐÁËÅÔÎÙÈ ÍÅÎÅÄÖÅÒÏ× É ÄÒÕÇÉÈ ÕÔÉÌÉÔ, ËÏÔÏÒÙÍ ÎÅÏÂÈÏÄÉÍÏ ÒÁÂÏÔÁÔØ Ó
+ÐÁËÅÔÁÍÉ RPM.
+
+%description devel -l uk
+óÉÓÔÅÍÁ ËÅÒÕ×ÁÎÎÑ ÐÁËÅÔÁÍÉ RPM Í¦ÓÔÉÔؠ¦Â̦ÏÔÅËÕ C, ËÏÔÒÁ ÓÐÒÏÝÕ¤
+ÒÏÂÏÔÕ Ú ÐÁËÅÔÁÍÉ RPM ÔÁ ×¦ÄÐÏצÄÎÉÍÉ ÂÁÚÁÍÉ ÄÁÎÉÈ. ãѠ¦Â̦ÏÔÅËÁ
+ÐÒÉÚÎÁÞÅÎÁ ÄÌÑ ÐÏÌÅÇÛÅÎÎÑ ÓÔ×ÏÒÅÎÎÑ ÇÒÁƦÞÎÉÈ ÐÁËÅÔÎÉÈ ÍÅÎÅÄÖÅҦנÔÁ
+¦ÎÛÉÈ ÕÔÉ̦Ô, ÝÏ ÐÒÁÃÀÀÔØ Ú ÐÁËÅÔÁÍÉ RPM.
+
 %package static
 Summary:       RPM static libraries
 Summary(de):   RPMs statische Libraries
 Summary(pl):   Biblioteki statyczne RPM-a
 Summary(pt_BR):        Bibliotecas estáticas para o desenvolvimento de aplicações RPM
+Summary(ru):   óÔÁÔÉÞÅÓËÁÑ ÂÉÂÌÉÏÔÅËÁ ÄÌÑ ÐÒÏÇÒÁÍÍ, ÒÁÂÏÔÁÀÝÉÈ Ó rpm-ÐÁËÅÔÁÍÉ.
+Summary(uk):   óÔÁÔÉÞÎÁ Â¦Â̦ÏÔÅËÁ ÄÌÑ ÐÒÏÇÒÁÍ, ÝÏ ÐÒÁÃÀÀÔØ Ú ÐÁËÅÔÁÍÉ rpm
 Group:         Development/Libraries
 Requires:      %{name}-devel = %{version}
 
@@ -188,6 +242,16 @@ Biblioteki statyczne RPM-a.
 %description static -l pt_BR
 Bibliotecas estáticas para desenvolvimento.
 
+%description static -l ru
+óÉÓÔÅÍÁ ÕÐÒÁ×ÌÅÎÉÑ ÐÁËÅÔÁÍÉ RPM ÓÏÄÅÒÖÉÔ ÂÉÂÌÉÏÔÅËÕ C, ËÏÔÏÒÁÑ
+ÕÐÒÏÝÁÅÔ ÍÁÎÉÐÕÌÑÃÉÀ ÐÁËÅÔÁÍÉ RPM É ÓÏÏÔ×ÅÔÓÔ×ÕÀÝÉÍÉ ÂÁÚÁÍÉ ÄÁÎÎÙÈ.
+üÔÏ ÓÔÁÔÉÞÅÓËÁÑ ÂÉÂÌÉÏÔÅËÁ RPM.
+
+%description static -l uk
+óÉÓÔÅÍÁ ËÅÒÕ×ÁÎÎÑ ÐÁËÅÔÁÍÉ RPM Í¦ÓÔÉÔؠ¦Â̦ÏÔÅËÕ C, ËÏÔÒÁ ÓÐÒÏÝÕ¤
+ÒÏÂÏÔÕ Ú ÐÁËÅÔÁÍÉ RPM ÔÁ ×¦ÄÐÏצÄÎÉÍÉ ÂÁÚÁÍÉ ÄÁÎÉÈ. ãÅ ÓÔÁÔÉÞÎÁ
+¦Â̦ÏÔÅËÁ RPM.
+
 %package utils
 Summary:       Additional utilities for managing rpm packages and database
 Summary(de):   Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
@@ -209,6 +273,7 @@ Summary:    Additional utilities for checking perl provides/requires in rpm package
 Summary(de):   Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
 Summary(pl):   Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów perla w pakietach rpm
 Group:         Applications/File
+Requires:      %{name} = %{version}
 Requires:      perl-modules
 Requires:      findutils
 
@@ -238,11 +303,25 @@ software.
 Makra u³atwiaj±ce tworzenie pakietów rpm z programami napisanymi w
 Pythonie.
 
+%package php-pearprov
+Summary:       Additional utilities for managing rpm packages and database
+Summary(pl):   Dodatkowe narzêdzia do sprawdzania zale¿no¶ci skryptów php w rpm.
+Group:         Applications/File
+Requires:      %{name} = %{version}
+
+%description php-pearprov
+Additional utilities for checking php pear provides/requires in rpm
+packages.
+
+%description php-pearprov -l pl
+Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów php pear w
+pakietach rpm.
+
 %package -n python-rpm
 Summary:       Python interface to RPM library
-Group:         Development/Languages/Python
+Summary(pl):   Pythonowy interfejs do biblioteki RPM-a
 Summary(pt_BR):        Módulo Python para aplicativos que manipulam pacotes RPM
-%requires_eq   python
+Group:         Libraries/Python
 Requires:      %{name} = %{version}
 %pyrequires_eq python
 Obsoletes:     rpm-python
@@ -275,11 +354,14 @@ Summary:  Scripts for building binary RPM packages
 Summary(de):   Scripts fürs Bauen binärer RPM-Pakete
 Summary(pl):   Skrypty pomocnicze do budowania binarnych RPM-ów
 Summary(pt_BR):        Scripts e programas executáveis usados para construir pacotes
+Summary(ru):   óËÒÉÐÔÙ É ÕÔÉÌÉÔÙ, ÎÅÏÂÈÏÄÉÍÙÅ ÄÌÑ ÓÂÏÒËÉ ÐÁËÅÔÏ×
+Summary(uk):   óËÒÉÐÔÉ ÔÁ ÕÔÉ̦ÔÉ, ÎÅÏÂȦÄΦ ÄÌÑ ÐÏÂÕÄÏ×É ÐÁËÅÔ¦×
 Group:         Applications/File
 Requires:      %{name} = %{version}
 Requires:      /bin/id
 Requires:      awk
 Requires:      binutils
+Requires:      chrpath
 Requires:      diffutils
 Requires:      file >= 3.31
 Requires:      fileutils
@@ -288,6 +370,7 @@ Requires:   findutils
 Requires:      gcc >= 3.0.3
 %else
 Requires:      gcc
+%endif
 Requires:      glibc-devel
 Requires:      grep
 Requires:      gzip
@@ -295,6 +378,7 @@ Requires:   make
 Requires:      patch
 Requires:      popt >= 1.6.2-2
 Requires:      sed
+Requires:      sh-utils
 Requires:      tar
 Requires:      textutils
 
@@ -311,6 +395,48 @@ Skrypty pomocnicze do budowania binarnych RPM-
 Este pacote contém scripts e programas executáveis que são usados para
 construir pacotes usando o RPM.
 
+%description build -l ru
+òÁÚÌÉÞÎÙÅ ×ÓÐÏÍÏÇÁÔÅÌØÎÙÅ ÓËÒÉÐÔÙ É ÉÓÐÏÌÎÑÅÍÙÅ ÐÒÏÇÒÁÍÍÙ, ËÏÔÏÒÙÅ
+ÉÓÐÏÌØÚÕÀÔÓÑ ÄÌÑ ÓÂÏÒËÉ RPM'Ï×.
+
+%description build -l uk
+ò¦ÚÎÏÍÁΦÔΦ ÄÏÐÏͦÖΦ ÓËÒÉÐÔÉ ÔÁ ÕÔÉ̦ÔÉ, Ñ˦ ×ÉËÏÒÉÓÔÏ×ÕÀÔØÓÑ ÄÌÑ
+ÐÏÂÕÄÏ×É RPM'¦×.
+
+%package build-tools
+Summary:       Scripts for managing .spec files and building RPM packages
+Summary(de):   Scripts fürs Bauen binärer RPM-Pakete
+Summary(pl):   Skrypty pomocnicze do zarz±dznia plikami .spec i budowania RPM-ów
+Summary(pt_BR):        Scripts e programas executáveis usados para construir pacotes
+Summary(ru):   óËÒÉÐÔÙ É ÕÔÉÌÉÔÙ, ÎÅÏÂÈÏÄÉÍÙÅ ÄÌÑ ÓÂÏÒËÉ ÐÁËÅÔÏ×
+Summary(uk):   óËÒÉÐÔÉ ÔÁ ÕÔÉ̦ÔÉ, ÎÅÏÂȦÄΦ ÄÌÑ ÐÏÂÕÄÏ×É ÐÁËÅÔ¦×
+Group:         Applications/File
+Requires:      %{name}-build = %{version}
+# these are optional
+#Requires:     cvs
+#Requires:     wget
+
+%description build-tools
+Scripts for managing .spec files and building RPM packages.
+
+%description build-tools -l de
+Scripts fürs Bauen RPM-Pakete.
+
+%description build-tools -l pl
+Skrypty pomocnicze do zarz±dznia plikami .spec i do budowania RPM-ów.
+
+%description build-tools -l pt_BR
+Este pacote contém scripts e programas executáveis que são usados para
+construir pacotes usando o RPM.
+
+%description build-tools -l ru
+òÁÚÌÉÞÎÙÅ ×ÓÐÏÍÏÇÁÔÅÌØÎÙÅ ÓËÒÉÐÔÙ É ÉÓÐÏÌÎÑÅÍÙÅ ÐÒÏÇÒÁÍÍÙ, ËÏÔÏÒÙÅ
+ÉÓÐÏÌØÚÕÀÔÓÑ ÄÌÑ ÓÂÏÒËÉ RPM'Ï×.
+
+%description build-tools -l uk
+ò¦ÚÎÏÍÁΦÔΦ ÄÏÐÏͦÖΦ ÓËÒÉÐÔÉ ÔÁ ÕÔÉ̦ÔÉ, Ñ˦ ×ÉËÏÒÉÓÔÏ×ÕÀÔØÓÑ ÄÌÑ
+ÐÏÂÕÄÏ×É RPM'¦×.
+
 %prep
 %setup -q -a12
 %patch0 -p1
@@ -348,43 +474,60 @@ construir pacotes usando o RPM.
 %ifarch athlon
 %patch31 -p1
 %endif
+
+%patch32 -p1
+%patch33 -p1
+%patch34 -p1
 %patch35 -p1
 %patch36 -p1
 %patch37 -p1
 %patch38 -p1
+%patch39 -p1
+%patch40 -p1
+%patch41 -p1
+%patch42 -p1
 
 sed -e 's/^/@pld@/' %{SOURCE2} >>platform.in
 cp -f platform.in macros.pld.in
 install %{SOURCE5} macros.perl.in
 install %{SOURCE13} macros.python.in
+install %{SOURCE21} macros.php.in
 install %{SOURCE6} scripts/find-perl-provides
 install %{SOURCE7} scripts/find-perl-requires
 install %{SOURCE9} scripts/find-lang.sh
+install %{SOURCE17} scripts/php.prov.in
+install %{SOURCE18} scripts/php.req.in
+install %{SOURCE19} scripts/find-php-provides
+install %{SOURCE20} scripts/find-php-requires
+
 
 (cd scripts;
 mv -f perl.req perl.req.in
 mv -f perl.prov perl.prov.in)
+
+chmod +x %{SOURCE4}
+
 %build
 # generate Group translations to *.po
 awk -f %{SOURCE14} %{SOURCE1}
 
 cd popt
-autoconf
-automake -a -c
-aclocal
-autoheader
-automake -a -c -f
+rm -f missing
+%{__libtoolize}
+%{__aclocal}
+%{__autoheader}
+%{__autoconf}
 %{__automake}
 cd ..
 
 rm -f missing
-libtoolize --force --copy
-autoconf
-aclocal
+%{__libtoolize}
+%{__gettextize}
+%{__aclocal}
 autoupdate
-autoheader || :
+%{__autoheader} || :
 %{__autoconf}
-automake -a -c
+# ugly workaround for automake
 sed -e 's#cpio.c $(DBLIBOBJS) depends.c#cpio.c depends.c#g' \
        lib/Makefile.am > lib/Makefile.am.new
 mv -f lib/Makefile.am.new lib/Makefile.am
@@ -408,7 +551,6 @@ mv -f macros.tmp macros.in
        --enable-v1-packages \
        --with-python
 
-
 %{__make} %{?_without_static:rpm_LDFLAGS="\\$(myLDFLAGS)"}
 
 %install
@@ -418,15 +560,24 @@ rm -rf $RPM_BUILD_ROOT
        DESTDIR=$RPM_BUILD_ROOT \
        pkgbindir="%{_bindir}"
 
-install macros.perl $RPM_BUILD_ROOT%{_libdir}/rpm/macros.perl
-install macros.python $RPM_BUILD_ROOT%{_libdir}/rpm/macros.python
+install macros.perl    $RPM_BUILD_ROOT%{_libdir}/rpm/macros.perl
+install macros.python  $RPM_BUILD_ROOT%{_libdir}/rpm/macros.python
+install macros.php     $RPM_BUILD_ROOT%{_libdir}/rpm/macros.php
 
 install %{SOURCE1} doc/manual/groups
 install %{SOURCE3} $RPM_BUILD_ROOT%{_libdir}/rpm/install-build-tree
+install %{SOURCE4} $RPM_BUILD_ROOT%{_libdir}/rpm/find-rpm-provides
 install %{SOURCE8} $RPM_BUILD_ROOT%{_libdir}/rpm/find-spec-bcond
 install %{SOURCE10} $RPM_BUILD_ROOT%{_libdir}/rpm/find-provides
 install %{SOURCE11} $RPM_BUILD_ROOT%{_libdir}/rpm/find-requires
 install %{SOURCE15} $RPM_BUILD_ROOT%{_libdir}/rpm/compress-doc
+install %{SOURCE16} $RPM_BUILD_ROOT%{_libdir}/rpm/check-files
+install scripts/find-php*      $RPM_BUILD_ROOT%{_libdir}/rpm/
+install scripts/php.{prov,req} $RPM_BUILD_ROOT%{_libdir}/rpm/
+
+install %{SOURCE30} $RPM_BUILD_ROOT%{_bindir}/builder
+install %{SOURCE31} $RPM_BUILD_ROOT%{_bindir}/adapter.awk
+install %{SOURCE32} $RPM_BUILD_ROOT%{_bindir}/pldnotify.awk
 
 install rpmio/ugid.h $RPM_BUILD_ROOT%{_includedir}/rpm
 
@@ -440,17 +591,16 @@ EOF
 
 %find_lang %{name}
 
-# DON'T BREAK BUILD TREE!!!
-# rm -f doc/manual/Makefile*
-
-gzip -9nf RPM-PGP-KEY CHANGES doc/manual/*
-
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %post  -p /sbin/ldconfig
 %postun -p /sbin/ldconfig
 
+%files -f %{name}.lang
+%defattr(644,root,root,755)
+%doc RPM-PGP-KEY CHANGES doc/manual/[a-z]*
+
 %attr(755,root,root) /bin/rpm
 %attr(755,root,root) %{_bindir}/rpmdb
 %attr(755,root,root) %{_bindir}/rpmquery
@@ -476,7 +626,6 @@ rm -rf $RPM_BUILD_ROOT
 %dir /var/lib/rpm
 %dir %{_libdir}/rpm
 
-%{_libdir}/rpm/macros.python
 %doc %attr(755,root,root) %{_libdir}/rpm/convertrpmrc.sh
 
 %{_libdir}/rpm/rpmrc
@@ -496,6 +645,9 @@ rm -rf $RPM_BUILD_ROOT
 %endif
 %ifarch ppc
 %{_libdir}/rpm/ppc*
+%endif
+
+%files build
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/rpmbuild
 %attr(755,root,root) %{_bindir}/rpme
@@ -507,10 +659,12 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/rpm/find-spec-bcond
 %attr(755,root,root) %{_libdir}/rpm/find-lang.sh
 %attr(755,root,root) %{_libdir}/rpm/mkinstalldirs
+%attr(755,root,root) %{_libdir}/rpm/config.*
 %attr(755,root,root) %{_libdir}/rpm/getpo.sh
 %attr(755,root,root) %{_libdir}/rpm/install-build-tree
 %attr(755,root,root) %{_libdir}/rpm/brp-*
 %attr(755,root,root) %{_libdir}/rpm/check-prereqs
+%attr(755,root,root) %{_libdir}/rpm/check-files
 %attr(755,root,root) %{_libdir}/rpm/compress-doc
 %attr(755,root,root) %{_libdir}/rpm/cpanflute
 %attr(755,root,root) %{_libdir}/rpm/http.req
@@ -525,6 +679,12 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/rpm/rpme
 %attr(755,root,root) %{_libdir}/rpm/rpmu
 
+%files build-tools
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/builder
+%attr(755,root,root) %{_bindir}/adapter.awk
+%attr(755,root,root) %{_bindir}/pldnotify.awk
+
 %files devel
 %defattr(644,root,root,755)
 %{_includedir}/rpm
@@ -532,7 +692,9 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/librpm*.so
 
 %files static
-%attr(755,root,root) %{_bindir}/*
+%defattr(644,root,root,755)
+%{_libdir}/librpm*.a
+
 %files utils
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/gendiff
@@ -557,10 +719,16 @@ rm -rf $RPM_BUILD_ROOT
 
 %{_libdir}/rpm/macros.perl
 
-%defattr(644,root,root,755)
+%files pythonprov
 %defattr(644,root,root,755)
 %{_libdir}/rpm/macros.python
 
+%files php-pearprov
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/rpm/php*
+%attr(755,root,root) %{_libdir}/rpm/find-php*
+%{_libdir}/rpm/macros.php
+
 %files -n python-rpm
-%defattr(755,root,root,755)
-%{py_sitedir}/*.so
+%defattr(644,root,root,755)
+%attr(755,root,root) %{py_sitedir}/*.so
This page took 0.244104 seconds and 4 git commands to generate.