]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm.spec
- rel 45; define _GNU_SOURCE in rpmio.h
[packages/rpm.git] / rpm.spec
index 3e40f7acc5bc8af56f299b0b85ac28294cd43fdf..242b4d20cbaf072bd2fa9f115487cfc49370847d 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
 %bcond_with    system_lua      # use system lua
 %bcond_without system_pcre     # use system pcre
 %bcond_with    keyutils        # build with keyutils support
-# force_cc             - force using __cc other than "%{_target_cpu}-pld-linux-gcc"
-# force_cxx            - force using __cxx other than "%{_target_cpu}-pld-linux-g++"
-# force_cpp            - force using __cpp other than "%{_target_cpu}-pld-linux-gcc -E"
-#
 
 %if %{with sqlite}
 # Error: /lib64/librpmio-5.4.so: undefined symbol: sqlite3_enable_load_extension
@@ -51,7 +47,7 @@ Summary(ru.UTF-8):    Менеджер пакетов от RPM
 Summary(uk.UTF-8):     Менеджер пакетів від RPM
 Name:          rpm
 Version:       5.4.15
-Release:       37
+Release:       45
 License:       LGPL v2.1
 Group:         Base
 # http://rpm5.org/files/rpm/rpm-5.4/rpm-5.4.15-0.20140824.src.rpm
@@ -118,6 +114,7 @@ Patch22:    %{name}-sparc64.patch
 Patch23:       %{name}-gendiff.patch
 Patch24:       openmp.patch
 Patch25:       %{name}-URPM-build-fix.patch
+Patch26:       %{name}-semanage.patch
 Patch27:       %{name}-helperEVR-noassert.patch
 Patch28:       %{name}-unglobal.patch
 Patch29:       %{name}-builddir-readlink.patch
@@ -150,6 +147,7 @@ Patch55:    %{name}-disable-hmac-verify.patch
 Patch56:       %{name}-macros.patch
 Patch57:       %{name}-db5.2.patch
 Patch58:       %{name}-preserve-iterator.patch
+Patch59:       gcc6-stdlib.patch
 Patch60:       %{name}-python-sitescriptdir.patch
 Patch61:       %{name}-clean-docdir.patch
 Patch62:       %{name}-DB_CONFIG.patch
@@ -183,6 +181,9 @@ Patch93:    python2_explicit.patch
 Patch94:       do_not_write_before_macro_buffer.patch
 Patch95:       rpm-python-spec-header.patch
 Patch96:       skip-ldconfig-optimization.patch
+Patch97:       glibc.patch
+Patch98:       extension-based-compression-detection.patch
+Patch99:       %{name}-gpg-pinentry.patch
 
 # Patches imported from Mandriva
 
@@ -364,6 +365,7 @@ BuildRequires:      popt-static >= %{reqpopt_ver}
 BuildRequires: zlib-static
 %endif
 Requires(posttrans):   coreutils
+Requires:      FHS >= 3.0-2
 Requires:      %{name}-base = %{version}-%{release}
 Requires:      %{name}-lib = %{version}-%{release}
 Requires:      beecrypt >= %{beecrypt_ver}
@@ -388,18 +390,6 @@ BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                ppc     ppc ppc7400 ppc7450
 %define                x8664   amd64 ia32e x86_64
 
-# stabilize new build environment
-%ifnarch x32
-%define                __newcc %{?force_cc}%{!?force_cc:%{_target_cpu}-pld-linux-gcc}
-%define                __newcxx %{?force_cxx}%{!?force_cxx:%{_target_cpu}-pld-linux-g++}
-%define                __newcpp %{?force_cpp}%{!?force_cpp:%{_target_cpu}-pld-linux-gcc -E}
-%else
-# x32 is a very special case
-%define                __newcc %{?force_cc}%{!?force_cc:x86_64-pld-linux-gnux32-gcc}
-%define                __newcxx %{?force_cxx}%{!?force_cxx:x86_64-pld-linux-gnux32-g++}
-%define                __newcpp %{?force_cpp}%{!?force_cpp:x86_64-pld-linux-gnux32-gcc -E}
-%endif
-
 %define                _rpmlibdir /usr/lib/rpm
 %define                _noautocompressdoc      RPM-GPG-KEY
 
@@ -910,6 +900,7 @@ cd -
 %patch23 -p1
 %patch24 -p1
 %patch25 -p1
+%patch26 -p1
 %patch27 -p1
 %patch28 -p1
 %patch29 -p1
@@ -942,6 +933,7 @@ cd -
 %patch56 -p1
 %{!?with_db61:%patch57 -p1}
 %patch58 -p1
+%patch59 -p1
 %patch60 -p1
 %patch61 -p1
 %patch62 -p1
@@ -969,6 +961,7 @@ cd -
 %patch89 -p1
 %patch90 -p1
 %patch91 -p1
+%patch99 -p1
 
 %patch1000 -p1
 %patch1001 -p1
@@ -1024,6 +1017,8 @@ cd -
 %patch94 -p1
 %patch95 -p1
 %patch96 -p1
+%patch97 -p1
+%patch98 -p1
 
 %patch1050 -p1
 
@@ -1064,13 +1059,10 @@ sed -i \
        macros/macros.in
 
 %{?with_system_lua:CPPFLAGS="-I/usr/include/lua51 %{rpmcppflags}"}
-# pass CC and CXX too in case of building with some older configure macro
 %configure \
-       CC="%{__newcc}" \
-       CXX="%{__newcxx}" \
-       CPP="%{__newcpp}" \
        WITH_PERL_VERSION=no \
        __GST_INSPECT=%{_bindir}/gst-inspect-1.0 \
+       __GPG=%{_bindir}/gpg \
        --disable-silent-rules \
        --enable-shared \
        --enable-static \
@@ -1101,10 +1093,7 @@ sed -i \
        --with-xz=external \
        --with-zlib=external
 
-%{__make} -j1 \
-       CC="%{__cc}" \
-       CXX="%{__cxx}" \
-       CPP="%{__cpp}"
+%{__make} -j1
 
 %{?with_apidocs:%{__make} apidocs}
 
This page took 0.067343 seconds and 4 git commands to generate.