]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm.spec
- added explicit "rpmlib(VersionedDependencies) <= 3.0.3-1" cap
[packages/rpm.git] / rpm.spec
index 21add7d75c0cbbccf5ae93ed50beb154ad602ff9..242328bc49d6cf487ad3a217770fb5e8d2bf4b40 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -1,15 +1,15 @@
 Summary:       Red Hat & PLD Package Manager
 Summary(pl):   Aplikacja do zarz±dzania pakietami
 Name:          rpm
-Version:       3.0.4
-Release:       7
+Version:       3.0.5
+Release:       11
 Group:         Base
 Group(pl):     Podstawowe
 License:       GPL
 Source0:       ftp://ftp.rpm.org/pub/rpm/dist/rpm-3.0.x/%{name}-%{version}.tar.gz
 Source1:       rpm.groups
 Source2:       rpm.macros
-Source3:       rpm-find-requires
+Source3:       rpm-remove-unneeded-elf-sections
 Source5:       rpm-install-tree
 Patch0:                rpm-rpmrc.patch
 Patch1:                rpm-find-requires.patch
@@ -19,9 +19,15 @@ Patch4:              rpm-rpmpopt.patch
 Patch5:                rpm-find-provides.patch
 Patch6:                rpm-perl-macros.patch
 Patch7:                rpm-find-lang-all-name.patch
+Patch8:                rpm-file3.31.patch
+Patch9:                rpm-find-lang-name-matching.patch
+Patch10:       rpm-exclude-examples-doc.patch
+Patch11:       rpm-db3.patch
 Patch37:        %{name}-short_circuit.patch
 Patch38:        %{name}-section_test.patch
-BuildRequires: bzip2-static >= 1.0.0
+Provides:      rpmlib(VersionedDependencies) <= 3.0.3-1
+Requires:      glibc >= 2.1
+BuildRequires: bzip2-static >= 1.0.1
 BuildRequires: gdbm-static
 BuildRequires: zlib-static
 BuildRequires: gettext-devel >= 0.10.38-3
@@ -29,7 +35,7 @@ BuildRequires:        libtool
 BuildRequires: automake
 BuildRequires: autoconf >= 2.13-8
 BuildRequires: gettext-devel
-Requires:      glibc >= 2.1
+BuildRequires: db3-static >= 3.1.14
 BuildRequires: zlib-static >= 1.1.4
 Obsoletes:     rpm-libs
 %define                pyrequires_eq() Requires:       %1 >= %py_ver %1 < %(echo `python -c "import sys; import string; ver=sys.version[:3].split('.'); ver[1]=str(int(ver[1])+1); print string.join(ver, '.')"`)
@@ -40,9 +46,11 @@ name, version, and description.
 packages. A package consists of an archive of files, and package
 nombre, versión y descripción.
 RPM jest doskona³ym menad¿erem pakietów. Dziêki niemu bêdziesz móg³ przebudowaæ,
-zainstalowaæ czy zweryfikowaæ dowolny pakiet. Informacje dotycz±ce ka¿dego 
-pakietu s± przechowywane w bazie danych i dostêpne tylko dla administratora 
-systemu.
+zainstalowaæ czy zweryfikowaæ dowolny pakiet. 
+Informacje dotycz±ce ka¿dego pakietu, takie jak jego opis, lista plików
+wchodz±cych w sk³ad pakietu, zalezno¶ci od innych pakietów
+s± przechowywane s± w bazie danych i mo¿na je uzyskaæ za pomoc± opcji
+wchodz±cych w sk³ad pakietu, zale¿no¶ci od innych pakietów, s±
 przechowywane w bazie danych i mo¿na je uzyskaæ za pomoc± opcji
 %package libs
 Summary:       RPM shared libraries
@@ -121,6 +129,13 @@ Group(pl): Narz
 Summary(pt_BR):        Scripts e programas executáveis usados para construir pacotes
 Group:         Applications/File
 Requires:      sh-utils
+Requires:      binutils
+Requires:      patch
+Requires:      texinfo
+Requires:      file >= 3.31
+Requires:      binutils
+Requires:      gcc >= 3.0.3
+Requires:      gcc
 Requires:      tar
 Requires:      textutils
 
@@ -138,6 +153,10 @@ construir pacotes usando o RPM.
 %patch5 -p1
 %patch6 -p1 
 %patch7 -p1 
+%patch8 -p1
+%patch7 -p1
+%patch10 -p1
+%patch11 -p1
 %patch31 -p1
 install %{SOURCE2} macros.pld.in
 install %{SOURCE13} macros.python.in
@@ -163,7 +182,7 @@ autoconf
 %configure \
        --enable-shared
 %configure \
-make
+%{__make}
        --with-python
 
 
@@ -171,23 +190,22 @@ make
 install -d $RPM_BUILD_ROOT/var/lib/rpm \
        $RPM_BUILD_ROOT%{_mandir}/{ru,pl}/man8
 
-make DESTDIR="$RPM_BUILD_ROOT" pkgbindir="%{_bindir}" install
+%{__make} DESTDIR="$RPM_BUILD_ROOT" pkgbindir="%{_bindir}" install
 
 install macros.pld $RPM_BUILD_ROOT%{_libdir}/rpm/macros.pld
 %{__make} install \
+install %{SOURCE3} $RPM_BUILD_ROOT%{_libdir}/rpm/remove-unneeded-elf-sections
 install %{SOURCE5} $RPM_BUILD_ROOT%{_libdir}/rpm/install-build-tree
        pkgbindir="%{_bindir}"
 
 install %{SOURCE8} $RPM_BUILD_ROOT%{_libdir}/rpm/find-spec-bcond
-install %{SOURCE3} $RPM_BUILD_ROOT%{_libdir}/rpm/find-requires
-
 strip --strip-unneeded $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*
 
 #%%_install_langs pl_PL:en_US
 %%distribution PLD
 EOF
 
-gzip -9fn $RPM_BUILD_ROOT%{_mandir}/{{ru,pl}/man8/*,man8/*} \
+gzip -9fn $RPM_BUILD_ROOT%{_mandir}/{{ja,ru,pl}/man8/*,man8/*} \
        RPM-PGP-KEY CHANGES doc/manual/*
 
 %pre
@@ -227,6 +245,9 @@ if [ ! -f /var/lib/rpm/packages.rpm ]; then
        /bin/rpm --initdb
 fi
 
+%post libs -p /sbin/ldconfig
+%postun libs -p /sbin/ldconfig
+%clean
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -260,6 +281,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/rpm/find-provides
 %attr(755,root,root) %{_libdir}/rpm/find-rpm-provides
 %attr(755,root,root) %{_libdir}/rpm/find-spec-bcond
+%attr(755,root,root) %{_libdir}/rpm/remove-unneeded-elf-sections
 %attr(755,root,root) %{_libdir}/rpm/rpmb
 %attr(755,root,root) %{_libdir}/rpm/rpmi
 %attr(755,root,root) %{_libdir}/rpm/rpmt
@@ -278,7 +300,6 @@ rm -rf $RPM_BUILD_ROOT
 
 %files static
 %attr(755,root,root) %{_bindir}/*
-%attr(755,root,root) %{_libdir}/rpm/freshen.sh
 %files utils
 %defattr(644,root,root,755)
 %{_mandir}/man8/rpm2cpio.8*
This page took 0.202397 seconds and 4 git commands to generate.